]> git.pld-linux.org Git - packages/mysql.git/blob - mysql.spec
- use %service macro for mysql server
[packages/mysql.git] / mysql.spec
1 # TODO:
2 # - trigger that prepares system from pre-cluster into cluster
3 # - trigger /etc/mysqld.conf into /etc/mysql/mysqld.conf. Solve possible
4 #   conflict with /var/lib/mysql/mysqld.conf
5 #
6 # Conditional build:
7 %bcond_with     bdb     # Berkeley DB support
8 %bcond_without  innodb  # Without InnoDB support
9 %bcond_without  isam    # Without ISAM table format (used in mysql 3.22)
10 %bcond_without  raid    # Without raid
11 %bcond_without  ssl     # Without OpenSSL
12 %bcond_without  tcpd    # Without libwrap (tcp_wrappers) support
13 %bcond_with             big_tables      # enable '--with-big-tables', some performance loss on 32bit arch, but can do >= 4GB database tables.
14 #
15 %include        /usr/lib/rpm/macros.perl
16 Summary:        MySQL: a very fast and reliable SQL database engine
17 Summary(fr):    MySQL: un serveur SQL rapide et fiable
18 Summary(pl):    MySQL: bardzo szybka i niezawodna baza danych (SQL)
19 Summary(de):    MySQL: ist eine SQL-Datenbank
20 Summary(pt_BR): MySQL: Um servidor SQL rápido e confiável
21 Summary(ru):    MySQL - ÂÙÓÔÒÙÊ SQL-ÓÅÒ×ÅÒ
22 Summary(uk):    MySQL - Û×ÉÄËÉÊ SQL-ÓÅÒ×ÅÒ
23 Summary(zh_CN): MySQLÊý¾Ý¿â·þÎñÆ÷
24 Name:           mysql
25 Group:          Applications/Databases
26 Version:        4.1.13
27 Release:        1
28 License:        GPL + MySQL FLOSS Exception
29 Source0:        http://mysql.dataphone.se/Downloads/MySQL-4.1/%{name}-%{version}.tar.gz
30 # Source0-md5:  49d7a7314a2c9cf49e34777e73e66562
31 Source1:        %{name}.init
32 Source2:        %{name}.sysconfig
33 Source3:        %{name}.logrotate
34 Source4:        %{name}d.conf
35 Source5:        %{name}-clusters.conf
36 Source6:        %{name}.monitrc
37 Source7:        %{name}-ndb.init
38 Source8:        %{name}-ndb.sysconfig
39 Source9:        %{name}-ndb-mgm.init
40 Source10:       %{name}-ndb-mgm.sysconfig
41 Source11:       %{name}-ndb-cpc.init
42 Source12:       %{name}-ndb-cpc.sysconfig
43 Source13:       %{name}-client.conf
44 Patch0:         %{name}-libs.patch
45 Patch1:         %{name}-libwrap.patch
46 Patch2:         %{name}-c++.patch
47 Patch3:         %{name}-info.patch
48 Patch4:         %{name}-sql-cxx-pic.patch
49 Patch5:         %{name}-noproc.patch
50 Patch6:         %{name}-fix_privilege_tables.patch
51 Patch7:         %{name}-align.patch
52 Patch8:         %{name}-client-config.patch
53 Icon:           mysql.gif
54 URL:            http://www.mysql.com/
55 #BuildRequires: ORBit-devel
56 BuildRequires:  autoconf
57 BuildRequires:  automake
58 %{?with_bdb:BuildRequires:      db3-devel}
59 BuildRequires:  libstdc++-devel >= 5:3.0
60 BuildRequires:  libtool
61 %{?with_tcpd:BuildRequires:     libwrap-devel}
62 BuildRequires:  ncurses-devel >= 4.2
63 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
64 BuildRequires:  perl-DBI
65 BuildRequires:  perl-devel >= 1:5.6.1
66 BuildRequires:  readline-devel >= 4.2
67 BuildRequires:  rpm-perlprov >= 4.1-13
68 BuildRequires:  rpmbuild(macros) >= 1.228
69 BuildRequires:  texinfo
70 BuildRequires:  zlib-devel
71 PreReq:         rc-scripts >= 0.2.0
72 Requires(pre):  /usr/bin/getgid
73 Requires(pre):  /bin/id
74 Requires(pre):  /usr/sbin/groupadd
75 Requires(pre):  /usr/sbin/useradd
76 Requires(postun):       /usr/sbin/userdel
77 Requires(postun):       /usr/sbin/groupdel
78 Requires(post,preun):   /sbin/chkconfig
79 Requires(triggerpostun):        sed >= 4.0
80 Requires:       %{name}-libs = %{version}-%{release}
81 Requires:       /usr/bin/setsid
82 Provides:       MySQL-server
83 Provides:       group(mysql)
84 Provides:       msqlormysql
85 Provides:       user(mysql)
86 Obsoletes:      MySQL
87 Obsoletes:      mysql-server
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _libexecdir     %{_sbindir}
91 %define         _localstatedir  /var/lib/mysql
92 %define         _mysqlhome      /home/services/mysql
93
94 %define         _noautoreqdep   'perl(DBD::mysql)'
95
96 %description
97 MySQL is a true multi-user, multi-threaded SQL (Structured Query
98 Language) database server. SQL is the most popular database language
99 in the world. MySQL is a client/server implementation that consists of
100 a server daemon mysqld and many different client programs/libraries.
101
102 The main goals of MySQL are speed, robustness and easy to use. MySQL
103 was originally developed because we at Tcx needed a SQL server that
104 could handle very big databases with magnitude higher speed than what
105 any database vendor could offer to us. We have now been using MySQL
106 since 1996 in a environment with more than 40 databases, 10,000
107 tables, of which more than 500 have more than 7 million rows. This is
108 about 50G of mission critical data.
109
110 The base upon which MySQL is built is a set of routines that have been
111 used in a highly demanding production environment for many years.
112 While MySQL is still in development, it already offers a rich and
113 highly useful function set.
114
115 %description -l fr
116 MySQL est un serveur de bases de donnees SQL vraiment multi-usagers et
117 multi-taches. Le langage SQL est le langage de bases de donnees le
118 plus populaire au monde. MySQL est une implementation client/serveur
119 qui consiste en un serveur (mysqld) et differents
120 programmes/bibliotheques clientes.
121
122 Les objectifs principaux de MySQL sont: vitesse, robustesse et
123 facilite d'utilisation. MySQL fut originalement developpe parce que
124 nous, chez Tcx, avions besoin d'un serveur SQL qui pouvait gerer de
125 tres grandes bases de donnees avec une vitesse d'un ordre de magnitude
126 superieur a ce que n'importe quel vendeur pouvait nous offrir. Nous
127 utilisons MySQL depuis 1996 dans un environnement avec plus de 40
128 bases de donnees, 10000 tables, desquelles plus de 500 ont plus de 7
129 millions de lignes. Ceci represente environ 50G de donnees critiques.
130
131 A la base de la conception de MySQL, on retrouve une serie de routines
132 qui ont ete utilisees dans un environnement de production pendant
133 plusieurs annees. Meme si MySQL est encore en developpement, il offre
134 deja une riche et utile serie de fonctions.
135
136 %description -l pl
137 MySQL to prawdziwie wielou¿ytkownikowy, wielow±tkowy serwer baz danych
138 SQL. SQL jest najpopularniejszym na ¶wiecie jêzykiem u¿ywanym do baz
139 danych. MySQL to implementacja klient/serwer sk³adaj±ca siê z demona
140 mysqld i wielu ró¿nych programów i bibliotek klienckich.
141
142 G³ównymi celami MySQL-a s± szybko¶æ, potêga i ³atwo¶æ u¿ytkowania.
143 MySQL oryginalnie by³ tworzony, poniewa¿ autorzy w Tcx potrzebowali
144 serwera SQL do obs³ugi bardzo du¿ych baz danych z szybko¶ci± o wiele
145 wiêksz±, ni¿ mogli zaoferowaæ inni producenci baz danych. U¿ywaj± go
146 od 1996 roku w ¶rodowisku z ponad 40 bazami danych, 10 000 tabel, z
147 których ponad 500 zawiera ponad 7 milionów rekordów - w sumie oko³o
148 50GB krytycznych danych.
149
150 Baza, na której oparty jest MySQL, sk³ada siê ze zbioru procedur,
151 które by³y u¿ywane w bardzo wymagaj±cym ¶rodowisku produkcyjnym przez
152 wiele lat. Pomimo, ¿e MySQL jest ci±gle rozwijany, ju¿ oferuje bogaty
153 i u¿yteczny zbiór funkcji.
154
155 %description -l de
156 MySQL ist eine SQL-Datenbank. Allerdings ist sie im Gegensatz zu
157 Oracle, DB2 oder PostgreSQL keine relationale Datenbank. Die Daten
158 werden zwar in zweidimensionalen Tabellen gespeichert und können mit
159 einem Primärschlüssel versehen werden. Es ist aber keine Definition
160 eines Fremdschlüssels möglich. Der Benutzer ist somit bei einer
161 MySQL-Datenbank völlig allein für die (referenzielle) Integrität der
162 Daten verantwortlich. Allein durch die Nutzung externer
163 Tabellenformate, wie InnoDB bzw Berkeley DB wird eine Relationalität
164 ermöglicht. Diese Projekte sind aber getrennt von MySQL zu betrachten.
165
166 %description -l pt_BR
167 O MySQL é um servidor de banco de dados SQL realmente multiusuário e
168 multi-tarefa. A linguagem SQL é a mais popular linguagem para banco de
169 dados no mundo. O MySQL é uma implementação cliente/servidor que
170 consiste de um servidor chamado mysqld e diversos
171 programas/bibliotecas clientes. Os principais objetivos do MySQL são:
172 velocidade, robustez e facilidade de uso. O MySQL foi originalmente
173 desenvolvido porque nós na Tcx precisávamos de um servidor SQL que
174 pudesse lidar com grandes bases de dados e com uma velocidade muito
175 maior do que a que qualquer vendedor podia nos oferecer. Estamos
176 usando o MySQL desde 1996 em um ambiente com mais de 40 bases de dados
177 com 10.000 tabelas, das quais mais de 500 têm mais de 7 milhões de
178 linhas. Isto é o equivalente a aproximadamente 50G de dados críticos.
179 A base da construção do MySQL é uma série de rotinas que foram usadas
180 em um ambiente de produção com alta demanda por muitos anos. Mesmo o
181 MySQL estando ainda em desenvolvimento, ele já oferece um conjunto de
182 funções muito ricas e úteis. Veja a documentação para maiores
183 informações.
184
185 %description -l ru
186 MySQL - ÜÔÏ SQL (Structured Query Language) ÓÅÒ×ÅÒ ÂÁÚÙ ÄÁÎÎÙÈ. MySQL
187 ÂÙÌÁ ÎÁÐÉÓÁÎÁ Michael'ÏÍ (monty) Widenius'ÏÍ. óÍ. ÆÁÊÌ CREDITS ×
188 ÄÉÓÔÒÉÂÕÔÉ×Å ÎÁ ÐÒÅÄÍÅÔ ÄÒÕÇÉÈ ÕÞÁÓÔÎÉËÏ× ÐÒÏÅËÔÁ É ÐÒÏÞÅÊ ÉÎÆÏÒÍÁÃÉÉ
189 Ï MySQL.
190
191 %description -l uk
192 MySQL - ÃÅ SQL (Structured Query Language) ÓÅÒ×ÅÒ ÂÁÚÉ ÄÁÎÉÈ. MySQL
193 ÂÕÌÏ ÎÁÐÉÓÁÎÏ Michael'ÏÍ (monty) Widenius'ÏÍ. äÉ×. ÆÁÊÌ CREDITS ×
194 ÄÉÓÔÒÉÂÕÔÉצ ÄÌÑ ¦ÎÆÏÒÍÁ槠ÐÒÏ ¦ÎÛÉÈ ÕÞÁÓÎÉ˦נÐÒÏÅËÔÕ ÔÁ ¦ÎÛϧ
195 ¦ÎÆÏÒÍÁæ§.
196
197 %package extras
198 Summary:        MySQL additional utilities
199 Summary(pl):    Dodatkowe narzêdzia do MySQL
200 Group:          Applications/Databases
201 Requires:       %{name}-libs = %{version}-%{release}
202
203 %description extras
204 MySQL additional utilities except Perl scripts (they may be found in
205 %{name}-extras-perl package).
206
207 %description extras -l pl
208 Dodatkowe narzêdzia do MySQL - z wyj±tkiem skryptów Perla (które s± w
209 pakiecie %{name}-extras-perl).
210
211 %package extras-perl
212 Summary:        MySQL additional utilities written in Perl
213 Summary(pl):    Dodatkowe narzêdzia do MySQL napisane w Perlu
214 Group:          Applications/Databases
215 Requires:       %{name}-extras = %{version}-%{release}
216 Requires:       perl(DBD::mysql)
217
218 %description extras-perl
219 MySQL additional utilities written in Perl.
220
221 %description extras-perl -l pl
222 Dodatkowe narzêdzia do MySQL napisane w Perlu.
223
224 %package client
225 Summary:        MySQL - Client
226 Summary(pl):    MySQL - Klient
227 Summary(pt):    MySQL - Cliente
228 Summary(ru):    MySQL ËÌÉÅÎÔ
229 Summary(uk):    MySQL Ë̦¤ÎÔ
230 Group:          Applications/Databases
231 Requires:       %{name}-libs = %{version}-%{release}
232 Obsoletes:      MySQL-client
233
234 %description client
235 This package contains the standard MySQL clients.
236
237 %description client -l fr
238 Ce package contient les clients MySQL standards.
239
240 %description client -l pl
241 Standardowe programy klienckie MySQL.
242
243 %description client -l pt_BR
244 Este pacote contém os clientes padrão para o MySQL.
245
246 %description client -l ru
247 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÔÏÌØËÏ ËÌÉÅÎÔ MySQL.
248
249 %description client -l uk
250 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ Ô¦ÌØËÉ Ë̦¤ÎÔÁ MySQL.
251
252 %package libs
253 Summary:        Shared libraries for MySQL
254 Summary(pl):    Biblioteki dzielone MySQL
255 Group:          Applications/Databases
256 Obsoletes:      libmysql10
257 Obsoletes:      mysql-doc < 4.1.12
258
259 %description libs
260 Shared libraries for MySQL.
261
262 %description libs -l pl
263 Biblioteki dzielone MySQL.
264
265 %package devel
266 Summary:        MySQL - Development header files and libraries
267 Summary(pl):    MySQL - Pliki nag³ówkowe i biblioteki dla programistów
268 Summary(pt):    MySQL - Medições de desempenho
269 Summary(ru):    MySQL - ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ
270 Summary(uk):    MySQL - ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ
271 Group:          Development/Libraries
272 Requires:       %{name}-libs = %{version}-%{release}
273 %{?with_ssl:Requires:   openssl-devel}
274 Requires:       zlib-devel
275 Obsoletes:      MySQL-devel
276 Obsoletes:      libmysql10-devel
277
278 %description devel
279 This package contains the development header files and libraries
280 necessary to develop MySQL client applications.
281
282 %description devel -l fr
283 Ce package contient les fichiers entetes et les librairies de
284 developpement necessaires pour developper des applications clientes
285 MySQL.
286
287 %description devel -l pl
288 Pliki nag³ówkowe i biblioteki konieczne do kompilacji aplikacji
289 klienckich MySQL.
290
291 %description devel -l pt_BR
292 Este pacote contém os arquivos de cabeçalho (header files) e
293 bibliotecas necessárias para desenvolver aplicações clientes do MySQL.
294
295 %description devel -l ru
296 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ
297 ÒÁÚÒÁÂÏÔËÉ ËÌÉÅÎÔÓËÉÈ ÐÒÉÌÏÖÅÎÉÊ.
298
299 %description devel -l uk
300 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ, ÎÅÏÂȦÄΦ ÄÌÑ
301 ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ-Ë̦¤ÎÔ¦×.
302
303 %package static
304 Summary:        MySQL static libraries
305 Summary(pl):    Biblioteki statyczne MySQL
306 Summary(ru):    MySQL - ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ
307 Summary(uk):    MySQL - ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ
308 Group:          Development/Libraries
309 Requires:       %{name}-devel = %{version}-%{release}
310 Obsoletes:      MySQL-static
311
312 %description static
313 MySQL static libraries.
314
315 %description static -l pl
316 Biblioteki statyczne MySQL.
317
318 %description static -l ru
319 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ, ÎÅÏÂÈÏÄÉÍÙÅ
320 ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ËÌÉÅÎÔÓËÉÈ ÐÒÉÌÏÖÅÎÉÊ.
321
322 %description static -l uk
323 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ, ÎÅÏÂȦÄΦ ÄÌÑ
324 ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ-Ë̦¤ÎÔ¦×.
325
326 %package bench
327 Summary:        MySQL - Benchmarks
328 Summary(pl):    MySQL - Programy testuj±ce szybko¶æ dzia³ania bazy
329 Summary(pt):    MySQL - Medições de desempenho
330 Summary(ru):    MySQL - ÂÅÎÞÍÁÒËÉ
331 Summary(uk):    MySQL - ÂÅÎÞÍÁÒËÉ
332 Group:          Applications/Databases
333 Requires:       %{name} = %{version}-%{release}
334 Requires:       %{name}-client
335 Requires:       perl(DBD::mysql)
336 Obsoletes:      MySQL-bench
337
338 %description bench
339 This package contains MySQL benchmark scripts and data.
340
341 %description bench -l pl
342 Programy testuj±ce szybko¶æ serwera MySQL.
343
344 %description bench -l pt_BR
345 Este pacote contém medições de desempenho de scripts e dados do MySQL.
346
347 %description bench -l ru
348 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓËÒÉÐÔÙ É ÄÁÎÎÙÅ ÄÌÑ ÏÃÅÎËÉ ÐÒÏÉÚ×ÏÄÉÔÅÌØÎÏÓÔÉ
349 MySQL.
350
351 %description bench -l uk
352 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓËÒÉÐÔÉ ÔÁ ÄÁΦ ÄÌÑ ÏæÎËÉ ÐÒÏÄÕËÔÉ×ÎÏÓÔ¦ MySQL.
353
354 %package doc
355 Summary:        MySQL manual
356 Summary(pl):    Podrêcznik u¿ytkownika MySQL
357 Group:          Applications/Databases
358
359 %description doc
360 This package contains manual in HTML format.
361
362 %description doc -l pl
363 Podrêcznik MySQL-a w formacie HTML.
364
365 %package ndb
366 Summary:        MySQL - NDB Storage Engine Daemon
367 Summary(pl):    MySQL - demon silnika przechowywania danych NDB
368 Group:          Applications/Databases
369 Requires:       %{name}-libs = %{version}-%{release}
370
371 %description ndb
372 This package contains the standard MySQL NDB Storage Engine Daemon.
373
374 %description ndb -l pl
375 Ten pakiet zawiera standardowego demona silnika przechowywania danych
376 NDB.
377
378 %package ndb-client
379 Summary:        MySQL - NDB Clients
380 Summary(pl):    MySQL - programy klienckie NDB
381 Group:          Applications/Databases
382 Requires:       %{name}-libs = %{version}-%{release}
383
384 %description ndb-client
385 This package contains the standard MySQL NDB Clients.
386
387 %description ndb-client -l pl
388 Ten pakiet zawiera standardowe programy klienckie MySQL NDB.
389
390 %package ndb-mgm
391 Summary:        MySQL - NDB Management Daemon
392 Summary(pl):    MySQL - demon zarz±dzaj±cy NDB
393 Group:          Applications/Databases
394 Requires:       %{name}-libs = %{version}-%{release}
395
396 %description ndb-mgm
397 This package contains the standard MySQL NDB Management Daemon.
398
399 %description ndb-mgm -l pl
400 Ten pakiet zawiera standardowego demona zarz±dzaj±cego MySQL NDB.
401
402 %package ndb-cpc
403 Summary:        MySQL - NDB CPC Daemon
404 Summary(pl):    MySQL - demon NDB CPC
405 Group:          Applications/Databases
406 Requires:       %{name}-libs = %{version}-%{release}
407
408 %description ndb-cpc
409 This package contains the standard MySQL NDB CPC Daemon.
410
411 %description ndb-cpc -l pl
412 Ten pakiet zawiera standardowego demona MySQL NDB CPC.
413
414 %prep
415 %setup -q
416 %patch0 -p1
417 %{?with_tcpd:%patch1 -p1}
418 %patch2 -p1
419 %patch3 -p1
420 %ifarch alpha
421 # this is strange: mysqld functions for UDF modules are not explicitly defined,
422 # so -rdynamic is used; in such case gcc3+ld on alpha doesn't like C++ vtables
423 # in objects compiled without -fPIC
424 %patch4 -p1
425 %endif
426 %patch5 -p1
427 %patch6 -p1
428 %patch7 -p1
429 %patch8 -p1
430
431 %{__perl} -pi -e 's@(ndb_bin_am_ldflags)="-static"@$1=""@' configure.in
432
433 %build
434 %{__libtoolize}
435 %{__aclocal}
436 %{__automake}
437 %{__autoconf}
438 # The compiler flags are as per their "official" spec ;)
439 CXXFLAGS="%{rpmcflags} -felide-constructors -fno-rtti -fno-exceptions %{!?debug:-fomit-frame-pointer}"
440 CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
441
442 # NOTE: the PS, FIND_PROC, KILL, CHECK_PID are not used by PLD Linux
443 # and therefore do not add BR on these. These are here just to satisfy
444 # configure.
445 %configure \
446         PS='/bin/ps' \
447         FIND_PROC='/bin/ps p $$PID' \
448         KILL='/bin/kill' \
449         CHECK_PID='/bin/kill -0 $$PID' \
450         --enable-assembler \
451         --enable-shared \
452         --enable-static \
453         --enable-thread-safe-client \
454         --with%{!?with_bdb:out}-berkeley-db \
455         --with%{!?with_innodb:out}-innodb \
456         --with%{!?with_isam:out}-isam \
457         --with%{!?with_raid:out}-raid \
458         --with%{!?with_ssl:out}-openssl \
459         --with%{!?with_tcpd:out}-libwrap \
460         %{?with_big_tables:--with-big-tables} \
461         --with-comment="PLD Linux Distribution MySQL RPM" \
462         --with%{!?debug:out}-debug \
463         --with-embedded-server \
464         --with-extra-charsets=all \
465         --with-low-memory \
466         --with-mysqld-user=mysql \
467         --with-named-curses-libs="-lncurses" \
468         --with-named-thread-libs="-lpthread" \
469         --with-unix-socket-path=/var/lib/mysql/mysql.sock \
470         --with-vio \
471         --with-ndbcluster \
472         --without-readline \
473         --without-libedit \
474         --without-docs
475 #       --with-mysqlfs
476 #       --with-ndb-test --with-ndb-docs
477
478 # NOTE that /var/lib/mysql/mysql.sock is symlink to real sock file
479 # (it defaults to first cluster but user may change it to whatever
480 # cluster it wants)
481
482 echo -e "all:\ninstall:\nclean:\nlink_sources:\n" > libmysqld/examples/Makefile
483
484 %{__make} \
485         benchdir=$RPM_BUILD_ROOT%{_datadir}/sql-bench
486
487 %{__make} -C Docs mysql.info
488
489 %install
490 rm -rf $RPM_BUILD_ROOT
491 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,mysql,monit} \
492            $RPM_BUILD_ROOT/var/{log/{archiv,}/mysql,lib/mysql} \
493            $RPM_BUILD_ROOT{%{_infodir},%{_mysqlhome}}
494
495 %if %{with bdb}
496 install -d $RPM_BUILD_ROOT/var/lib/mysql/bdb/{log,tmp}
497 %endif
498
499 # Make install
500 %{__make} install \
501         DESTDIR=$RPM_BUILD_ROOT \
502         benchdir=%{_datadir}/sql-bench \
503         libsdir=/tmp
504 # libsdir is to avoid installing innodb static libs in $RPM_BUILD_ROOT../libs
505
506 install Docs/mysql.info $RPM_BUILD_ROOT%{_infodir}
507
508 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql
509 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/mysql
510 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mysql
511 # This is template for configuration file which is created after 'service mysql init'
512 install %{SOURCE4} mysqld.conf
513 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/mysql/clusters.conf
514 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/monit
515 touch $RPM_BUILD_ROOT/var/log/mysql/{err,log,update,isamlog.log}
516
517 # remove innodb directives from mysqld.conf if mysqld is configured without
518 %if %{without innodb}
519         cp mysqld.conf mysqld.tmp
520         awk 'BEGIN { RS="\n\n" } !/innodb/ { printf("%s\n\n", $0) }' < mysqld.tmp > mysqld.conf
521 %endif
522
523 # remove berkeley-db directives from mysqld.conf if mysqld is configured without
524 %if %{without bdb}
525         cp mysqld.conf mysqld.tmp
526         awk 'BEGIN { RS="\n\n" } !/bdb/ { printf("%s\n\n", $0) }' < mysqld.tmp > mysqld.conf
527 %endif
528
529 install mysqld.conf $RPM_BUILD_ROOT%{_datadir}/mysql/mysqld.conf
530 install %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/mysql/mysql-client.conf
531
532 # NDB
533 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb
534 install %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb
535 install %{SOURCE9} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb-mgm
536 install %{SOURCE10} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb-mgm
537 install %{SOURCE11} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb-cpc
538 install %{SOURCE12} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb-cpc
539
540 # remove .txt variants for .sys messages
541 rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*/*.txt
542
543 mv -f $RPM_BUILD_ROOT%{_libdir}/mysql/lib* $RPM_BUILD_ROOT%{_libdir}
544 %{__perl} -pi -e 's,%{_libdir}/mysql,%{_libdir},;' $RPM_BUILD_ROOT%{_libdir}/libmysqlclient.la
545
546 # remove known unpackaged files
547 rm -rf $RPM_BUILD_ROOT%{_prefix}/mysql-test
548
549 # rename not to be so generic name
550 mv $RPM_BUILD_ROOT%{_bindir}/{,mysql_}comp_err
551 mv $RPM_BUILD_ROOT%{_bindir}/{,mysql_}resolve_stack_dump
552
553 # not our OS
554 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/*.plist
555 # unuseful stuff
556 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/*.spec
557
558 # functionality in initscript / rpm
559 rm $RPM_BUILD_ROOT%{_bindir}/mysql_create_system_tables
560 rm $RPM_BUILD_ROOT%{_bindir}/mysql_install_db
561 rm $RPM_BUILD_ROOT%{_bindir}/mysqld_safe
562 rm $RPM_BUILD_ROOT%{_bindir}/mysqld_multi
563 rm $RPM_BUILD_ROOT%{_mandir}/man1/mysqld_{multi,safe}*
564 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/fill_help_tables.sql
565 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/mysql-log-rotate
566 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/mysql.server
567 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{pre,post}install
568 rm $RPM_BUILD_ROOT%{_bindir}/mysql_waitpid
569
570 # in %doc
571 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/*.{ini,cnf}
572
573 %clean
574 rm -rf $RPM_BUILD_ROOT
575
576 %pre
577 %groupadd -g 89 mysql
578 %useradd -u 89 -d %{_mysqlhome} -s /bin/sh -g mysql -c "MySQL Server" mysql
579
580 %post
581 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
582 /sbin/chkconfig --add mysql
583 %service mysql restart
584
585 %preun
586 if [ "$1" = "0" ]; then
587         %service -q mysql stop
588         /sbin/chkconfig --del mysql
589 fi
590
591 %postun
592 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
593 if [ "$1" = "0" ]; then
594         %userremove mysql
595         %groupremove mysql
596 fi
597
598 %post ndb
599 /sbin/chkconfig --add mysql-ndb
600 if [ -f /var/lock/subsys/mysql-ndb ]; then
601         /etc/rc.d/init.d/mysql-ndb restart >&2
602 else
603         echo "Run \"/etc/rc.d/init.d/mysql-ndb start\" to start mysql NDB engine." >&2
604 fi
605
606 %preun ndb
607 if [ "$1" = "0" ]; then
608         if [ -f /var/lock/subsys/mysql-ndb ]; then
609                 /etc/rc.d/init.d/mysql-ndb stop
610         fi
611         /sbin/chkconfig --del mysql-ndb
612 fi
613
614 %post ndb-mgm
615 /sbin/chkconfig --add mysql-ndb-mgm
616 if [ -f /var/lock/subsys/mysql-ndb-mgm ]; then
617         /etc/rc.d/init.d/mysql-ndb-mgm restart >&2
618 else
619         echo "Run \"/etc/rc.d/init.d/mysql-ndb-mgm start\" to start mysql NDB management node." >&2
620 fi
621
622 %preun ndb-mgm
623 if [ "$1" = "0" ]; then
624         if [ -f /var/lock/subsys/mysql-ndb-mgm ]; then
625                 /etc/rc.d/init.d/mysql-ndb-mgm stop
626         fi
627         /sbin/chkconfig --del mysql-ndb-mgm
628 fi
629
630 %post ndb-cpc
631 /sbin/chkconfig --add mysql-ndb-cpc
632 if [ -f /var/lock/subsys/mysql-ndb-cpc ]; then
633         /etc/rc.d/init.d/mysql-ndb-cpc restart >&2
634 else
635         echo "Run \"/etc/rc.d/init.d/mysql-ndb-cpc start\" to start mysql NDB CPC." >&2
636 fi
637
638 %preun ndb-cpc
639 if [ "$1" = "0" ]; then
640         if [ -f /var/lock/subsys/mysql-ndb-cpc ]; then
641                 /etc/rc.d/init.d/mysql-ndb-cpc stop
642         fi
643         /sbin/chkconfig --del mysql-ndb-cpc
644 fi
645
646 %post   libs -p /sbin/ldconfig
647 %postun libs -p /sbin/ldconfig
648
649 %triggerpostun -- mysql <= 4.0.20-2
650 # For clusters in /etc/mysql/clusters.conf
651 if [ -f "/etc/sysconfig/mysql" ]; then
652         . /etc/sysconfig/mysql
653         if [ -n "$MYSQL_DB_CLUSTERS" ]; then
654                 for i in "$MYSQL_DB_CLUSTERS"; do
655                         echo "$i/mysqld.conf=$i" >> /etc/mysql/clusters.conf
656                 done
657                 echo "# Do not use **obsolete** option MYSQL_DB_CLUSTERS" >> /etc/sysconfig/mysql
658                 echo "# USE /etc/mysql/clusters.conf instead" >> /etc/sysconfig/mysql
659                 echo "Converted clusters from MYSQL_DB_CLUSTERS to /etc/mysql/clusters.conf."
660                 echo "You NEED to fix your /etc/sysconfig/mysql and verify /etc/mysql/clusters.conf."
661         fi
662 fi
663
664 %triggerpostun -- mysql <= 4.1.1
665 # For better compatibility with prevoius versions:
666 for config in $(awk -F= '!/^#/ && /=/{print $1}' /etc/mysql/clusters.conf); do
667         if echo "$config" | grep -q '^/'; then
668                 config_file="$config"
669         elif [ -f "/etc/mysql/$config" ]; then
670                 config_file=/etc/mysql/$config
671         else
672                 clusterdir=$(awk -F= "/^$config/{print \$2}" /etc/mysql/clusters.conf)
673                 if [ -z "$clusterdir" ]; then
674                         echo >&2 "Can't find cluster dir for $config!"
675                         echo >&2 "Please remove extra (leading) spaces from /etc/mysql/clusters.conf"
676                         exit 1
677                 fi
678                 config_file="$clusterdir/mysqld.conf"
679         fi
680
681         if [ ! -f "$config_file" ]; then
682                         echo >&2 "Lost myself! Please report this (with above errors, if any) to http://bugs.pld-linux.org/"
683                         exit 1
684         fi
685         echo "Adding option old-passwords to config: $config_file"
686         echo "If you want to use new, better passwords - remove it"
687
688         # sed magic to add 'old-passwords' to [mysqld] section
689         sed -i -e '/./{H;$!d;};x;/\[mysqld\]/{
690                 a
691                 a; Compatibility options:
692                 aold-passwords
693         }
694         ' $config_file
695 done
696
697 %files
698 %defattr(644,root,root,755)
699 %doc support-files/*.cnf support-files/*.ini scripts/fill_help_tables.sql
700 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/mysql
701 %attr(754,root,root) /etc/rc.d/init.d/mysql
702 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql
703 %attr(640,root,mysql) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mysql/clusters.conf
704 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/monit/*.monitrc
705 %attr(755,root,root) %{_bindir}/isamchk
706 %attr(755,root,root) %{_bindir}/isamlog
707 %attr(755,root,root) %{_bindir}/myisamchk
708 %attr(755,root,root) %{_bindir}/myisamlog
709 %attr(755,root,root) %{_bindir}/myisampack
710 %attr(755,root,root) %{_bindir}/mysql_fix_privilege_tables
711 %attr(755,root,root) %{_bindir}/pack_isam
712 %attr(755,root,root) %{_bindir}/my_print_defaults
713 %attr(755,root,root) %{_sbindir}/mysqld
714 %{_mandir}/man1/isamchk.1*
715 %{_mandir}/man1/isamlog.1*
716 %{_mandir}/man1/mysql_fix_privilege_tables.1*
717 %{_mandir}/man1/mysqld.1*
718
719 %attr(700,mysql,mysql) %{_mysqlhome}
720 # root:root is proper here for AC mysql.rpm while mysql:mysql is potential security hole
721 %attr(751,root,root) /var/lib/mysql
722 %attr(750,mysql,mysql) %dir /var/log/mysql
723 %attr(750,mysql,mysql) %dir /var/log/archiv/mysql
724 %attr(640,mysql,mysql) %ghost /var/log/mysql/*
725
726 %{_infodir}/mysql.info*
727 %dir %{_datadir}/mysql
728 # This is template for configuration file which is created after 'service mysql init'
729 %{_datadir}/mysql/mysqld.conf
730 %{_datadir}/mysql/charsets
731 %{_datadir}/mysql/english
732 %{_datadir}/mysql/mysql_fix_privilege_tables.sql
733 %lang(cs) %{_datadir}/mysql/czech
734 %lang(da) %{_datadir}/mysql/danish
735 %lang(de) %{_datadir}/mysql/german
736 %lang(el) %{_datadir}/mysql/greek
737 %lang(es) %{_datadir}/mysql/spanish
738 %lang(et) %{_datadir}/mysql/estonian
739 %lang(fr) %{_datadir}/mysql/french
740 %lang(hu) %{_datadir}/mysql/hungarian
741 %lang(it) %{_datadir}/mysql/italian
742 %lang(ja) %{_datadir}/mysql/japanese
743 %lang(ja) %{_datadir}/mysql/japanese-sjis
744 %lang(ko) %{_datadir}/mysql/korean
745 %lang(nl) %{_datadir}/mysql/dutch
746 %lang(nb) %{_datadir}/mysql/norwegian
747 %lang(nn) %{_datadir}/mysql/norwegian-ny
748 %lang(pl) %{_datadir}/mysql/polish
749 %lang(pt) %{_datadir}/mysql/portuguese
750 %lang(ro) %{_datadir}/mysql/romanian
751 %lang(ru) %{_datadir}/mysql/russian
752 %lang(sr) %{_datadir}/mysql/serbian
753 %lang(sk) %{_datadir}/mysql/slovak
754 %lang(sv) %{_datadir}/mysql/swedish
755 %lang(uk) %{_datadir}/mysql/ukrainian
756
757 %files extras
758 %defattr(644,root,root,755)
759 %attr(755,root,root) %{_bindir}/msql2mysql
760 %attr(755,root,root) %{_bindir}/perror
761 %attr(755,root,root) %{_bindir}/replace
762 %attr(755,root,root) %{_bindir}/resolveip
763 %attr(755,root,root) %{_bindir}/myisam_ftdump
764 %attr(755,root,root) %{_bindir}/mysql_secure_installation
765 %attr(755,root,root) %{_bindir}/mysql_tzinfo_to_sql
766 %attr(755,root,root) %{_bindir}/mysqlcheck
767 %{_mandir}/man1/perror.1*
768 %{_mandir}/man1/replace.1*
769
770 %files extras-perl
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_bindir}/mysql_convert_table_format
773 %attr(755,root,root) %{_bindir}/mysqldumpslow
774 %attr(755,root,root) %{_bindir}/mysqlhotcopy
775 %attr(755,root,root) %{_bindir}/mysql_setpermission
776 %attr(755,root,root) %{_bindir}/mysql_zap
777 %attr(755,root,root) %{_bindir}/mysql_find_rows
778 %attr(755,root,root) %{_bindir}/mysqlaccess
779 %attr(755,root,root) %{_bindir}/mysql_fix_extensions
780 %attr(755,root,root) %{_bindir}/mysql_explain_log
781 %attr(755,root,root) %{_bindir}/mysql_tableinfo
782 %{_mandir}/man1/mysql_zap.1*
783 %{_mandir}/man1/mysqlaccess.1*
784
785 %files client
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_bindir}/mysql
788 %attr(755,root,root) %{_bindir}/mysqlbug
789 %attr(755,root,root) %{_bindir}/mysqldump
790 %attr(755,root,root) %{_bindir}/mysqlimport
791 %attr(755,root,root) %{_bindir}/mysqlmanager*
792 %attr(755,root,root) %{_bindir}/mysqlshow
793 %attr(755,root,root) %{_bindir}/mysqlbinlog
794 %attr(755,root,root) %{_bindir}/mysqladmin
795 %{_mandir}/man1/mysql.1*
796 %{_mandir}/man1/mysqladmin.1*
797 %{_mandir}/man1/mysqldump.1*
798 %{_mandir}/man1/mysqlshow.1*
799
800 %files libs
801 %defattr(644,root,root,755)
802 %doc EXCEPTIONS-CLIENT
803 %attr(755,root,root) %{_libdir}/lib*.so.*.*
804 %attr(751,root,root) %dir %{_sysconfdir}/mysql
805 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mysql/mysql-client.conf
806
807 %files devel
808 %defattr(644,root,root,755)
809 %attr(755,root,root) %{_bindir}/mysql_config
810 %attr(755,root,root) %{_libdir}/lib*.so
811 %attr(755,root,root) %{_bindir}/*comp_err
812 %attr(755,root,root) %{_bindir}/*resolve_stack_dump
813 %{_libdir}/lib*.la
814 %{_libdir}/lib*[!tr].a
815 %{_includedir}/mysql
816
817 %files static
818 %defattr(644,root,root,755)
819 %{_libdir}/lib*[tr].a
820
821 %files bench
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_bindir}/mysqltest
824 %attr(755,root,root) %{_bindir}/mysql_client_test
825 %dir %{_datadir}/sql-bench
826 %{_datadir}/sql-bench/[CDRl]*
827 %attr(755,root,root) %{_datadir}/sql-bench/[bcgirst]*
828 # wrong dir?
829 %{_datadir}/mysql/mi_test_all.res
830 %attr(755,root,root) %{_datadir}/mysql/mi_test_all
831
832 #%files doc
833 #%defattr(644,root,root,755)
834 #%doc Docs/manual.html Docs/manual_toc.html
835
836 %files ndb
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_sbindir}/ndbd
839 %attr(754,root,root) /etc/rc.d/init.d/mysql-ndb
840 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql-ndb
841
842 %files ndb-client
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_bindir}/ndb_*
845
846 %files ndb-mgm
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_sbindir}/ndb_mgmd
849 %attr(754,root,root) /etc/rc.d/init.d/mysql-ndb-mgm
850 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql-ndb-mgm
851
852 %files ndb-cpc
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_sbindir}/ndb_cpcd
855 %attr(754,root,root) /etc/rc.d/init.d/mysql-ndb-cpc
856 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mysql-ndb-cpc
This page took 0.095983 seconds and 4 git commands to generate.