]> git.pld-linux.org Git - packages/mysql.git/blob - mysql.spec
- updated to newest version: 4.1.8a
[packages/mysql.git] / mysql.spec
1 # TODO:
2 # - init/sysconfig for NDB subpackages
3 #
4 # - trigger that prepares system from pre-cluster into cluster
5 # - trigger /etc/mysqld.conf into /etc/mysql/mysqld.conf. Solve possible
6 #   conflict with /var/lib/mysql/mysqld.conf
7 #
8 # Conditional build:
9 %bcond_with     bdb     # Berkeley DB support
10 #
11 %include        /usr/lib/rpm/macros.perl
12 Summary:        MySQL: a very fast and reliable SQL database engine
13 Summary(fr):    MySQL: un serveur SQL rapide et fiable
14 Summary(pl):    MySQL: bardzo szybka i niezawodna baza danych (SQL)
15 Summary(pt_BR): MySQL: Um servidor SQL rápido e confiável
16 Summary(ru):    MySQL - ÂÙÓÔÒÙÊ SQL-ÓÅÒ×ÅÒ
17 Summary(uk):    MySQL - Û×ÉÄËÉÊ SQL-ÓÅÒ×ÅÒ
18 Summary(zh_CN): MySQLÊý¾Ý¿â·þÎñÆ÷
19 Name:           mysql
20 Group:          Applications/Databases
21 Version:        4.1.8a
22 Release:        0.1
23 License:        GPL + MySQL FLOSS Exception
24 Source0:        http://mysql.mirror.anlx.net/Downloads/MySQL-4.1/mysql-%{version}.tar.gz
25 # Source0-md5:  2886edbe5cc826727fbb79a79d41145c
26 Source1:        %{name}.init
27 Source2:        %{name}.sysconfig
28 Source3:        %{name}.logrotate
29 Source4:        %{name}d.conf
30 Source5:        %{name}-clusters.conf
31 Source6:        %{name}.monitrc
32 Source7:        %{name}-ndb.init
33 Source8:        %{name}-ndb.sysconfig
34 Source9:        %{name}-ndb-mgm.init
35 Source10:       %{name}-ndb-mgm.sysconfig
36 Source11:       %{name}-ndb-cpc.init
37 Source12:       %{name}-ndb-cpc.sysconfig
38 Patch0:         %{name}-libs.patch
39 Patch1:         %{name}-libwrap.patch
40 Patch2:         %{name}-c++.patch
41 Patch3:         %{name}-_r-link.patch
42 Patch4:         %{name}-info.patch
43 Patch5:         %{name}-sql-cxx-pic.patch
44 Patch6:         %{name}-noproc.patch
45 Patch7:         %{name}-fix_privilege_tables.patch
46 Patch8:         %{name}-nptl.patch
47 Icon:           mysql.gif
48 URL:            http://www.mysql.com/
49 #BuildRequires: ORBit-devel
50 BuildRequires:  /bin/ps
51 BuildRequires:  autoconf
52 BuildRequires:  automake
53 %{?with_bdb:BuildRequires:      db3-devel}
54 BuildRequires:  libstdc++-devel >= 5:3.0
55 BuildRequires:  libtool
56 BuildRequires:  libwrap-devel
57 BuildRequires:  ncurses-devel >= 4.2
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  perl-DBI
60 BuildRequires:  perl-devel >= 1:5.6.1
61 BuildRequires:  readline-devel >= 4.2
62 BuildRequires:  rpm-perlprov >= 4.1-13
63 BuildRequires:  rpmbuild(macros) >= 1.159
64 BuildRequires:  texinfo
65 BuildRequires:  zlib-devel
66 PreReq:         rc-scripts >= 0.2.0
67 Requires(pre):  /usr/bin/getgid
68 Requires(pre):  /bin/id
69 Requires(pre):  /usr/sbin/groupadd
70 Requires(pre):  /usr/sbin/useradd
71 Requires(postun):       /usr/sbin/userdel
72 Requires(postun):       /usr/sbin/groupdel
73 Requires(post,preun):   /sbin/chkconfig
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       /usr/bin/setsid
76 Provides:       MySQL-server
77 Provides:       group(mysql)
78 Provides:       msqlormysql
79 Provides:       user(mysql)
80 Obsoletes:      MySQL
81 Obsoletes:      mysql-server
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _libexecdir     %{_sbindir}
85 %define         _localstatedir  /var/lib/mysql
86 %define         _mysqlhome      /home/services/mysql
87
88 %define         _noautoreqdep   'perl(DBD::mysql)'
89 # workaround for buggy gcc 3.3.1
90 %define         specflags_alpha  -mno-explicit-relocs
91
92 %description
93 MySQL is a true multi-user, multi-threaded SQL (Structured Query
94 Language) database server. SQL is the most popular database language
95 in the world. MySQL is a client/server implementation that consists of
96 a server daemon mysqld and many different client programs/libraries.
97
98 The main goals of MySQL are speed, robustness and easy to use. MySQL
99 was originally developed because we at Tcx needed a SQL server that
100 could handle very big databases with magnitude higher speed than what
101 any database vendor could offer to us. We have now been using MySQL
102 since 1996 in a environment with more than 40 databases, 10,000
103 tables, of which more than 500 have more than 7 million rows. This is
104 about 50G of mission critical data.
105
106 The base upon which MySQL is built is a set of routines that have been
107 used in a highly demanding production environment for many years.
108 While MySQL is still in development, it already offers a rich and
109 highly useful function set.
110
111 %description -l fr
112 MySQL est un serveur de bases de donnees SQL vraiment multi-usagers et
113 multi-taches. Le langage SQL est le langage de bases de donnees le
114 plus populaire au monde. MySQL est une implementation client/serveur
115 qui consiste en un serveur (mysqld) et differents
116 programmes/bibliotheques clientes.
117
118 Les objectifs principaux de MySQL sont: vitesse, robustesse et
119 facilite d'utilisation. MySQL fut originalement developpe parce que
120 nous, chez Tcx, avions besoin d'un serveur SQL qui pouvait gerer de
121 tres grandes bases de donnees avec une vitesse d'un ordre de magnitude
122 superieur a ce que n'importe quel vendeur pouvait nous offrir. Nous
123 utilisons MySQL depuis 1996 dans un environnement avec plus de 40
124 bases de donnees, 10000 tables, desquelles plus de 500 ont plus de 7
125 millions de lignes. Ceci represente environ 50G de donnees critiques.
126
127 A la base de la conception de MySQL, on retrouve une serie de routines
128 qui ont ete utilisees dans un environnement de production pendant
129 plusieurs annees. Meme si MySQL est encore en developpement, il offre
130 deja une riche et utile serie de fonctions.
131
132 %description -l pl
133 MySQL to prawdziwie wielou¿ytkownikowy, wielow±tkowy serwer baz danych
134 SQL. SQL jest najpopularniejszym na ¶wiecie jêzykiem u¿ywanym do baz
135 danych. MySQL to implementacja klient/serwer sk³adaj±ca siê z demona
136 mysqld i wielu ró¿nych programów i bibliotek klienckich.
137
138 G³ównymi celami MySQL-a s± szybko¶æ, potêga i ³atwo¶æ u¿ytkowania.
139 MySQL oryginalnie by³ tworzony, poniewa¿ autorzy w Tcx potrzebowali
140 serwera SQL do obs³ugi bardzo du¿ych baz danych z szybko¶ci± o wiele
141 wiêksz±, ni¿ mogli zaoferowaæ inni producenci baz danych. U¿ywaj± go
142 od 1996 roku w ¶rodowisku z ponad 40 bazami danych, 10 000 tabel,
143 z których ponad 500 zawiera ponad 7 milionów rekordów - w sumie oko³o
144 50GB krytycznych danych.
145
146 Baza, na której oparty jest MySQL, sk³ada siê ze zbioru procedur,
147 które by³y u¿ywane w bardzo wymagaj±cym ¶rodowisku produkcyjnym przez
148 wiele lat. Pomimo, ¿e MySQL jest ci±gle rozwijany, ju¿ oferuje bogaty
149 i u¿yteczny zbiór funkcji.
150
151 %description -l pt_BR
152 O MySQL é um servidor de banco de dados SQL realmente multiusuário e
153 multi-tarefa. A linguagem SQL é a mais popular linguagem para banco de
154 dados no mundo. O MySQL é uma implementação cliente/servidor que
155 consiste de um servidor chamado mysqld e diversos
156 programas/bibliotecas clientes. Os principais objetivos do MySQL são:
157 velocidade, robustez e facilidade de uso. O MySQL foi originalmente
158 desenvolvido porque nós na Tcx precisávamos de um servidor SQL que
159 pudesse lidar com grandes bases de dados e com uma velocidade muito
160 maior do que a que qualquer vendedor podia nos oferecer. Estamos
161 usando o MySQL desde 1996 em um ambiente com mais de 40 bases de dados
162 com 10.000 tabelas, das quais mais de 500 têm mais de 7 milhões de
163 linhas. Isto é o equivalente a aproximadamente 50G de dados críticos.
164 A base da construção do MySQL é uma série de rotinas que foram usadas
165 em um ambiente de produção com alta demanda por muitos anos. Mesmo o
166 MySQL estando ainda em desenvolvimento, ele já oferece um conjunto de
167 funções muito ricas e úteis. Veja a documentação para maiores
168 informações.
169
170 %description -l ru
171 MySQL - ÜÔÏ SQL (Structured Query Language) ÓÅÒ×ÅÒ ÂÁÚÙ ÄÁÎÎÙÈ. MySQL
172 ÂÙÌÁ ÎÁÐÉÓÁÎÁ Michael'ÏÍ (monty) Widenius'ÏÍ. óÍ. ÆÁÊÌ CREDITS ×
173 ÄÉÓÔÒÉÂÕÔÉ×Å ÎÁ ÐÒÅÄÍÅÔ ÄÒÕÇÉÈ ÕÞÁÓÔÎÉËÏ× ÐÒÏÅËÔÁ É ÐÒÏÞÅÊ ÉÎÆÏÒÍÁÃÉÉ
174 Ï MySQL.
175
176 %description -l uk
177 MySQL - ÃÅ SQL (Structured Query Language) ÓÅÒ×ÅÒ ÂÁÚÉ ÄÁÎÉÈ. MySQL
178 ÂÕÌÏ ÎÁÐÉÓÁÎÏ Michael'ÏÍ (monty) Widenius'ÏÍ. äÉ×. ÆÁÊÌ CREDITS ×
179 ÄÉÓÔÒÉÂÕÔÉצ ÄÌÑ ¦ÎÆÏÒÍÁ槠ÐÒÏ ¦ÎÛÉÈ ÕÞÁÓÎÉ˦נÐÒÏÅËÔÕ ÔÁ ¦ÎÛϧ
180 ¦ÎÆÏÒÍÁæ§.
181
182 %package extras
183 Summary:        MySQL additional utilities
184 Summary(pl):    Dodatkowe narzêdzia do MySQL
185 Group:          Applications/Databases
186 Requires:       %{name}-libs = %{version}-%{release}
187
188 %description extras
189 MySQL additional utilities except Perl scripts (they may be found in
190 %{name}-extras-perl package).
191
192 %description extras -l pl
193 Dodatkowe narzêdzia do MySQL - z wyj±tkiem skryptów Perla (które s± w
194 pakiecie %{name}-extras-perl).
195
196 %package extras-perl
197 Summary:        MySQL additional utilities written in Perl
198 Summary(pl):    Dodatkowe narzêdzia do MySQL napisane w Perlu
199 Group:          Applications/Databases
200 Requires:       %{name}-extras = %{version}-%{release}
201 Requires:       perl(DBD::mysql)
202
203 %description extras-perl
204 MySQL additional utilities written in Perl.
205
206 %description extras-perl -l pl
207 Dodatkowe narzêdzia do MySQL napisane w Perlu.
208
209 %package client
210 Summary:        MySQL - Client
211 Summary(pl):    MySQL - Klient
212 Summary(pt):    MySQL - Cliente
213 Summary(ru):    MySQL ËÌÉÅÎÔ
214 Summary(uk):    MySQL Ë̦¤ÎÔ
215 Group:          Applications/Databases
216 Requires:       %{name}-libs = %{version}-%{release}
217 Obsoletes:      MySQL-client
218
219 %description client
220 This package contains the standard MySQL clients.
221
222 %description client -l fr
223 Ce package contient les clients MySQL standards.
224
225 %description client -l pl
226 Standardowe programy klienckie MySQL.
227
228 %description client -l pt_BR
229 Este pacote contém os clientes padrão para o MySQL.
230
231 %description client -l ru
232 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÔÏÌØËÏ ËÌÉÅÎÔ MySQL.
233
234 %description client -l uk
235 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ Ô¦ÌØËÉ Ë̦¤ÎÔÁ MySQL.
236
237 %package libs
238 Summary:        Shared libraries for MySQL
239 Summary(pl):    Biblioteki dzielone MySQL
240 Group:          Applications/Databases
241 Obsoletes:      libmysql10
242
243 %description libs
244 Shared libraries for MySQL.
245
246 %description libs -l pl
247 Biblioteki dzielone MySQL.
248
249 %package devel
250 Summary:        MySQL - Development header files and libraries
251 Summary(pl):    MySQL - Pliki nag³ówkowe i biblioteki dla programistów
252 Summary(pt):    MySQL - Medições de desempenho
253 Summary(ru):    MySQL - ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ
254 Summary(uk):    MySQL - ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ
255 Group:          Development/Libraries
256 Requires:       %{name}-libs = %{version}-%{release}
257 Requires:       openssl-devel
258 Requires:       zlib-devel
259 Obsoletes:      MySQL-devel
260 Obsoletes:      libmysql10-devel
261
262 %description devel
263 This package contains the development header files and libraries
264 necessary to develop MySQL client applications.
265
266 %description devel -l fr
267 Ce package contient les fichiers entetes et les librairies de
268 developpement necessaires pour developper des applications clientes
269 MySQL.
270
271 %description devel -l pl
272 Pliki nag³ówkowe i biblioteki konieczne do kompilacji aplikacji
273 klienckich MySQL.
274
275 %description devel -l pt_BR
276 Este pacote contém os arquivos de cabeçalho (header files) e
277 bibliotecas necessárias para desenvolver aplicações clientes do MySQL.
278
279 %description devel -l ru
280 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÈÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ
281 ÒÁÚÒÁÂÏÔËÉ ËÌÉÅÎÔÓËÉÈ ÐÒÉÌÏÖÅÎÉÊ.
282
283 %description devel -l uk
284 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÈÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ, ÎÅÏÂȦÄΦ ÄÌÑ
285 ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ-Ë̦¤ÎÔ¦×.
286
287 %package static
288 Summary:        MySQL static libraries
289 Summary(pl):    Biblioteki statyczne MySQL
290 Summary(ru):    MySQL - ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ
291 Summary(uk):    MySQL - ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ
292 Group:          Development/Libraries
293 Requires:       %{name}-devel = %{version}-%{release}
294 Obsoletes:      MySQL-static
295
296 %description static
297 MySQL static libraries.
298
299 %description static -l pl
300 Biblioteki statyczne MySQL.
301
302 %description static -l ru
303 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÒÁÚÒÁÂÏÔÞÉËÁ, ÎÅÏÂÈÏÄÉÍÙÅ
304 ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ËÌÉÅÎÔÓËÉÈ ÐÒÉÌÏÖÅÎÉÊ.
305
306 %description static -l uk
307 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÐÒÏÇÒÁͦÓÔÁ, ÎÅÏÂȦÄΦ ÄÌÑ
308 ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ-Ë̦¤ÎÔ¦×.
309
310 %package bench
311 Summary:        MySQL - Benchmarks
312 Summary(pl):    MySQL - Programy testuj±ce szybko¶æ dzia³ania bazy
313 Summary(pt):    MySQL - Medições de desempenho
314 Summary(ru):    MySQL - ÂÅÎÞÍÁÒËÉ
315 Summary(uk):    MySQL - ÂÅÎÞÍÁÒËÉ
316 Group:          Applications/Databases
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       %{name}-client
319 Requires:       perl(DBD::mysql)
320 Obsoletes:      MySQL-bench
321
322 %description bench
323 This package contains MySQL benchmark scripts and data.
324
325 %description bench -l pl
326 Programy testuj±ce szybko¶æ serwera MySQL.
327
328 %description bench -l pt_BR
329 Este pacote contém medições de desempenho de scripts e dados do MySQL.
330
331 %description bench -l ru
332 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓËÒÉÐÔÙ É ÄÁÎÎÙÅ ÄÌÑ ÏÃÅÎËÉ ÐÒÏÉÚ×ÏÄÉÔÅÌØÎÏÓÔÉ
333 MySQL.
334
335 %description bench -l uk
336 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓËÒÉÐÔÉ ÔÁ ÄÁΦ ÄÌÑ ÏæÎËÉ ÐÒÏÄÕËÔÉ×ÎÏÓÔ¦ MySQL.
337
338 %package doc
339 Summary:        MySQL manual
340 Summary(pl):    Podrêcznik u¿ytkownika MySQL
341 Group:          Applications/Databases
342
343 %description doc
344 This package contains manual in HTML format.
345
346 %description doc -l pl
347 Podrêcznik MySQL-a w formacie HTML.
348
349 %package ndb
350 Summary:        MySQL - NDB Storage Engine Daemon
351 Summary(pl):    MySQL - demon silnika przechowywania danych NDB
352 Group:          Applications/Databases
353 Requires:       %{name}-libs = %{version}-%{release}
354
355 %description ndb
356 This package contains the standard MySQL NDB Storage Engine Daemon.
357
358 %description ndb -l pl
359 Ten pakiet zawiera standardowego demona silnika przechowywania
360 danych NDB.
361
362 %package ndb-client
363 Summary:        MySQL - NDB Clients
364 Summary(pl):    MySQL - programy klienckie NDB
365 Group:          Applications/Databases
366 Requires:       %{name}-libs = %{version}-%{release}
367
368 %description ndb-client
369 This package contains the standard MySQL NDB Clients.
370
371 %description ndb-client -l pl
372 Ten pakiet zawiera standardowe programy klienckie MySQL NDB.
373
374 %package ndb-mgm
375 Summary:        MySQL - NDB Management Daemon
376 Summary(pl):    MySQL - demon zarz±dzaj±cy NDB
377 Group:          Applications/Databases
378 Requires:       %{name}-libs = %{version}-%{release}
379
380 %description ndb-mgm
381 This package contains the standard MySQL NDB Management Daemon.
382
383 %description ndb-mgm -l pl
384 Ten pakiet zawiera standardowego demona zarz±dzaj±cego MySQL NDB.
385
386 %package ndb-cpc
387 Summary:        MySQL - NDB CPC Daemon
388 Summary(pl):    MySQL - demon NDB CPC
389 Group:          Applications/Databases
390 Requires:       %{name}-libs = %{version}-%{release}
391
392 %description ndb-cpc
393 This package contains the standard MySQL NDB CPC Daemon.
394
395 %description ndb-cpc -l pl
396 Ten pakiet zawiera standardowego demona MySQL NDB CPC.
397
398 %prep
399 %setup -q
400 %patch0 -p1
401 %patch1 -p1
402 %patch2 -p1
403 %patch3 -p1
404 %patch4 -p1
405 %ifarch alpha
406 # this is strange: mysqld functions for UDF modules are not explicitly defined,
407 # so -rdynamic is used; in such case gcc3+ld on alpha doesn't like C++ vtables
408 # in objects compiled without -fPIC
409 %patch5 -p1
410 %endif
411 %patch6 -p1
412 %patch7 -p1
413 %patch8 -p1
414
415 %{__perl} -pi -e 's@(ndb_bin_am_ldflags)="-static"@$1=""@' configure.in
416
417 %build
418 %{__libtoolize}
419 %{__aclocal}
420 %{__automake}
421 %{__autoconf}
422 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions %{!?debug:-fomit-frame-pointer}"
423 CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
424 %configure \
425         PS='/bin/ps' \
426         FIND_PROC='/bin/ps p $$PID' \
427         KILL='/bin/kill' \
428         CHECK_PID='/bin/kill -0 $$PID' \
429         --enable-assembler \
430         --enable-shared \
431         --enable-static \
432         --enable-thread-safe-client \
433         %{?with_bdb:--with-berkeley-db} \
434         --with-comment="PLD Linux Distribution MySQL RPM" \
435         --with%{!?debug:out}-debug \
436         --with-embedded-server \
437         --with-extra-charsets=all \
438         --with-libwrap \
439         --with-low-memory \
440         --with-mysqld-user=mysql \
441         --with-named-curses-libs="-lncurses" \
442         --with-openssl \
443         --with-pthread \
444         --with-raid \
445         --with-unix-socket-path=/var/lib/mysql/mysql.sock \
446         --with-vio \
447         --with-ndbcluster \
448         --without-readline \
449         --without-docs
450 #       --with-mysqlfs
451
452 # NOTE that /var/lib/mysql/mysql.sock is symlink to real sock file
453 # (it defaults to first cluster but user may change it to whatever
454 #  cluster it wants)
455
456 echo -e "all:\ninstall:\nclean:\nlink_sources:\n" > libmysqld/examples/Makefile
457
458 %{__make} \
459         benchdir=$RPM_BUILD_ROOT%{_datadir}/sql-bench
460
461 %{__make} -C Docs mysql.info
462
463 %install
464 rm -rf $RPM_BUILD_ROOT
465 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,mysql,monit} \
466            $RPM_BUILD_ROOT/var/{log/{archiv,}/mysql,lib/mysql} \
467            $RPM_BUILD_ROOT{%{_infodir},%{_mysqlhome}}
468
469 %if %{with bdb}
470 install -d $RPM_BUILD_ROOT/var/lib/mysql/bdb/{log,tmp}
471 %endif
472
473 # Make install
474 %{__make} install \
475         DESTDIR=$RPM_BUILD_ROOT \
476         benchdir=%{_datadir}/sql-bench \
477         libsdir=/tmp
478 # libsdir is to avoid installing innodb static libs in $RPM_BUILD_ROOT../libs
479
480 install Docs/mysql.info $RPM_BUILD_ROOT%{_infodir}
481
482 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql
483 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/mysql
484 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/mysql
485 # This is template for configuration file which is created after 'service mysql init'
486 install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/mysql/mysqld.conf
487 install %{SOURCE5} $RPM_BUILD_ROOT/etc/mysql/clusters.conf
488 install %{SOURCE6} $RPM_BUILD_ROOT/etc/monit
489 touch $RPM_BUILD_ROOT/var/log/mysql/{err,log,update,isamlog.log}
490
491 # NDB
492 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb
493 install %{SOURCE8} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb
494 install %{SOURCE9} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb-mgm
495 install %{SOURCE10} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb-mgm
496 install %{SOURCE11} $RPM_BUILD_ROOT/etc/rc.d/init.d/mysql-ndb-cpc
497 install %{SOURCE12} $RPM_BUILD_ROOT/etc/sysconfig/mysql-ndb-cpc
498
499 # remove mysqld's *.po files
500 find . $RPM_BUILD_ROOT%{_datadir}/%{name} -name \*.txt | xargs -n 100 rm -f
501 mv -f $RPM_BUILD_ROOT%{_libdir}/mysql/lib* $RPM_BUILD_ROOT%{_libdir}
502 %{__perl} -pi -e 's,%{_libdir}/mysql,%{_libdir},;' $RPM_BUILD_ROOT%{_libdir}/libmysqlclient.la
503
504 rm -rf $RPM_BUILD_ROOT%{_prefix}/mysql-test
505
506 %clean
507 rm -rf $RPM_BUILD_ROOT
508
509 %pre
510 if [ -n "`/usr/bin/getgid mysql`" ]; then
511         if [ "`/usr/bin/getgid mysql`" != "89" ]; then
512                 echo "Error: group mysql doesn't have gid=89. Correct this before installing mysql." 1>&2
513                 exit 1
514         fi
515 else
516         /usr/sbin/groupadd -g 89 mysql
517 fi
518 if [ -n "`/bin/id -u mysql 2>/dev/null`" ]; then
519         if [ "`/bin/id -u mysql`" != "89" ]; then
520                 echo "Error: user mysql doesn't have uid=89. Correct this before installing mysql." 1>&2
521                 exit 1
522         fi
523 else
524         /usr/sbin/useradd -u 89 \
525                         -d %{_mysqlhome} -s /bin/sh -g mysql \
526                         -c "MySQL Server" mysql 1>&2
527 fi
528
529 %post
530 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
531 /sbin/chkconfig --add mysql
532 if [ -f /var/lock/subsys/mysql ]; then
533         /etc/rc.d/init.d/mysql restart >&2
534 else
535         echo "Run \"/etc/rc.d/init.d/mysql start\" to start mysql." >&2
536 fi
537
538 %preun
539 if [ "$1" = "0" ]; then
540         if [ -f /var/lock/subsys/mysql ]; then
541                 /etc/rc.d/init.d/mysql stop
542         fi
543         /sbin/chkconfig --del mysql
544 fi
545
546 %postun
547 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
548 if [ "$1" = "0" ]; then
549         %userremove mysql
550         %groupremove mysql
551 fi
552
553 %post ndb
554 /sbin/chkconfig --add mysql-ndb
555 if [ -f /var/lock/subsys/mysql-ndb ]; then
556         /etc/rc.d/init.d/mysql-ndb restart >&2
557 else
558         echo "Run \"/etc/rc.d/init.d/mysql-ndb start\" to start mysql NDB engine." >&2
559 fi
560
561 %preun ndb
562 if [ "$1" = "0" ]; then
563         if [ -f /var/lock/subsys/mysql-ndb ]; then
564                 /etc/rc.d/init.d/mysql-ndb stop
565         fi
566         /sbin/chkconfig --del mysql-ndb
567 fi
568
569 %post ndb-mgm
570 /sbin/chkconfig --add mysql-ndb-mgm
571 if [ -f /var/lock/subsys/mysql-ndb-mgm ]; then
572         /etc/rc.d/init.d/mysql-ndb-mgm restart >&2
573 else
574         echo "Run \"/etc/rc.d/init.d/mysql-ndb-mgm start\" to start mysql NDB management node." >&2
575 fi
576
577 %preun ndb-mgm
578 if [ "$1" = "0" ]; then
579         if [ -f /var/lock/subsys/mysql-ndb-mgm ]; then
580                 /etc/rc.d/init.d/mysql-ndb-mgm stop
581         fi
582         /sbin/chkconfig --del mysql-ndb-mgm
583 fi
584
585 %post ndb-cpc
586 /sbin/chkconfig --add mysql-ndb-cpc
587 if [ -f /var/lock/subsys/mysql-ndb-cpc ]; then
588         /etc/rc.d/init.d/mysql-ndb-cpc restart >&2
589 else
590         echo "Run \"/etc/rc.d/init.d/mysql-ndb-cpc start\" to start mysql NDB CPC." >&2
591 fi
592
593 %preun ndb-cpc
594 if [ "$1" = "0" ]; then
595         if [ -f /var/lock/subsys/mysql-ndb-cpc ]; then
596                 /etc/rc.d/init.d/mysql-ndb-cpc stop
597         fi
598         /sbin/chkconfig --del mysql-ndb-cpc
599 fi
600
601 %post   libs -p /sbin/ldconfig
602 %postun libs -p /sbin/ldconfig
603
604 %triggerpostun -- mysql <= 4.0.20-2
605 # For clusters in /etc/mysql/clusters.conf
606 if [ -f "/etc/sysconfig/mysql" ]; then
607         . /etc/sysconfig/mysql
608         if [ -n "$MYSQL_DB_CLUSTERS" ]; then
609                 for i in "$MYSQL_DB_CLUSTERS"; do
610                         echo "$i/mysqld.conf=$i" >> /etc/mysql/clusters.conf
611                 done
612                 echo "# Do not use **obsolete** option MYSQL_DB_CLUSTERS" >> /etc/sysconfig/mysql
613                 echo "# USE /etc/mysql/clusters.conf instead" >> /etc/sysconfig/mysql
614                 echo "Converted clusters from MYSQL_DB_CLUSTERS to /etc/mysql/clusters.conf."
615                 echo "You NEED to fix your /etc/sysconfig/mysql and verify /etc/mysql/clusters.conf."
616         fi
617 fi
618
619 %files
620 %defattr(644,root,root,755)
621 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/logrotate.d/mysql
622 %attr(754,root,root) /etc/rc.d/init.d/mysql
623 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/mysql
624 %attr(751,root,root) %dir /etc/mysql
625 %attr(640,root,mysql) %config(noreplace) %verify(not md5 size mtime) /etc/mysql/clusters.conf
626 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/monit/*.monitrc
627 %attr(755,root,root) %{_bindir}/isamchk
628 %attr(755,root,root) %{_bindir}/isamlog
629 %attr(755,root,root) %{_bindir}/myisamchk
630 %attr(755,root,root) %{_bindir}/myisamlog
631 %attr(755,root,root) %{_bindir}/myisampack
632 %attr(755,root,root) %{_bindir}/mysql_fix_privilege_tables
633 %attr(755,root,root) %{_bindir}/pack_isam
634 %attr(755,root,root) %{_sbindir}/mysqld
635 %{_mandir}/man1/isamchk.1*
636 %{_mandir}/man1/isamlog.1*
637 %{_mandir}/man1/mysql_fix_privilege_tables.1*
638 %{_mandir}/man1/mysqld.1*
639
640 %attr(700,mysql,mysql) %{_mysqlhome}
641 # root:root is proper here for AC mysql.rpm while mysql:mysql is potential security hole
642 %attr(751,root,root) /var/lib/mysql
643 %attr(750,mysql,mysql) %dir /var/log/mysql
644 %attr(750,mysql,mysql) %dir /var/log/archiv/mysql
645 %attr(640,mysql,mysql) %config(noreplace) %verify(not md5 size mtime) /var/log/mysql/*
646
647 %{_infodir}/mysql.info*
648 %dir %{_datadir}/mysql
649 # This is template for configuration file which is created after 'service mysql init'
650 %{_datadir}/mysql/mysqld.conf
651 %{_datadir}/mysql/charsets
652 %{_datadir}/mysql/english
653 %{_datadir}/mysql/mysql_fix_privilege_tables.sql
654 %lang(cs) %{_datadir}/mysql/czech
655 %lang(da) %{_datadir}/mysql/danish
656 %lang(de) %{_datadir}/mysql/german
657 %lang(el) %{_datadir}/mysql/greek
658 %lang(es) %{_datadir}/mysql/spanish
659 %lang(et) %{_datadir}/mysql/estonian
660 %lang(fr) %{_datadir}/mysql/french
661 %lang(hu) %{_datadir}/mysql/hungarian
662 %lang(it) %{_datadir}/mysql/italian
663 %lang(ja) %{_datadir}/mysql/japanese
664 %lang(ko) %{_datadir}/mysql/korean
665 %lang(nl) %{_datadir}/mysql/dutch
666 %lang(nb) %{_datadir}/mysql/norwegian
667 %lang(nn) %{_datadir}/mysql/norwegian-ny
668 %lang(pl) %{_datadir}/mysql/polish
669 %lang(pt) %{_datadir}/mysql/portuguese
670 %lang(ro) %{_datadir}/mysql/romanian
671 %lang(ru) %{_datadir}/mysql/russian
672 %lang(sr) %{_datadir}/mysql/serbian
673 %lang(sk) %{_datadir}/mysql/slovak
674 %lang(sv) %{_datadir}/mysql/swedish
675 %lang(uk) %{_datadir}/mysql/ukrainian
676
677 %files extras
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/msql2mysql
680 %attr(755,root,root) %{_bindir}/perror
681 %attr(755,root,root) %{_bindir}/my_print_defaults
682 %attr(755,root,root) %{_bindir}/replace
683 %attr(755,root,root) %{_bindir}/resolveip
684 %{_mandir}/man1/perror.1*
685 %{_mandir}/man1/replace.1*
686
687 %files extras-perl
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_bindir}/mysql_convert_table_format
690 %attr(755,root,root) %{_bindir}/mysqldumpslow
691 %attr(755,root,root) %{_bindir}/mysqlhotcopy
692 %attr(755,root,root) %{_bindir}/mysql_setpermission
693 %attr(755,root,root) %{_bindir}/mysql_zap
694 %attr(755,root,root) %{_bindir}/mysql_find_rows
695 %attr(755,root,root) %{_bindir}/mysqlaccess
696 %{_mandir}/man1/mysql_zap.1*
697 %{_mandir}/man1/mysqlaccess.1*
698
699 %files client
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_bindir}/mysql
702 %attr(755,root,root) %{_bindir}/mysqlbug
703 %attr(755,root,root) %{_bindir}/mysqldump
704 %attr(755,root,root) %{_bindir}/mysqlimport
705 %attr(755,root,root) %{_bindir}/mysqlmanager*
706 %attr(755,root,root) %{_bindir}/mysqlshow
707 %attr(755,root,root) %{_bindir}/mysqlbinlog
708 %attr(755,root,root) %{_bindir}/mysqladmin
709 %attr(755,root,root) %{_bindir}/mysqltest
710 %{_mandir}/man1/mysql.1*
711 %{_mandir}/man1/mysqladmin.1*
712 %{_mandir}/man1/mysqldump.1*
713 %{_mandir}/man1/mysqlshow.1*
714
715 %files libs
716 %defattr(644,root,root,755)
717 %doc EXCEPTIONS-CLIENT
718 %attr(755,root,root) %{_libdir}/lib*.so.*.*
719
720 %files devel
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_bindir}/mysql_config
723 %attr(755,root,root) %{_libdir}/lib*.so
724 %{_libdir}/lib*.la
725 %{_libdir}/lib*[!tr].a
726 %{_includedir}/mysql
727
728 %files static
729 %defattr(644,root,root,755)
730 %{_libdir}/lib*[tr].a
731
732 %files bench
733 %defattr(644,root,root,755)
734 %dir %{_datadir}/sql-bench
735 %{_datadir}/sql-bench/[CDRl]*
736 %attr(755,root,root) %{_datadir}/sql-bench/[bcgrst]*
737
738 %files doc
739 %defattr(644,root,root,755)
740 %doc Docs/manual.html Docs/manual_toc.html
741
742 %files ndb
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_sbindir}/ndbd
745 %attr(754,root,root) /etc/rc.d/init.d/mysql-ndb
746 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/mysql-ndb
747
748 %files ndb-client
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_bindir}/ndb_*
751
752 %files ndb-mgm
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_sbindir}/ndb_mgmd
755 %attr(754,root,root) /etc/rc.d/init.d/mysql-ndb-mgm
756 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/mysql-ndb-mgm
757
758
759 %files ndb-cpc
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_sbindir}/ndb_cpcd
762 %attr(754,root,root) /etc/rc.d/init.d/mysql-ndb-cpc
763 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/mysql-ndb-cpc
This page took 0.088936 seconds and 4 git commands to generate.