]> git.pld-linux.org Git - packages/mplayer.git/blob - mplayer.spec
- release 13 (by relup.sh)
[packages/mplayer.git] / mplayer.spec
1 #
2 # Conditional build:
3 # - CPU optimization:
4 %bcond_without  altivec         # PPC altivec support
5 %bcond_without  ssse3           # SSSE3 optimizations (needs binutils >= 2.16.92)
6 %bcond_without  runtime         # disable runtime cpu detection, just detect CPU
7                                 #  in compile time (advertised by mplayer authors as working faster); in this case
8                                 #  mplayer may not work on machine other then where it was compiled
9 %bcond_without  hidden_visibility       # no gcc hidden visibility
10 %bcond_without  verbose         # disable verbose build
11 # - general features:
12 %bcond_without  bluray          # Blu-ray support
13 %bcond_without  cdio            # libcdio support
14 %bcond_without  cdparanoia      # cdparanoia support (when libcdio not enabled)
15 %bcond_without  doc             # don't build docs (slow)
16 %bcond_without  dvdnav          # dvdnav support
17 %bcond_without  system_dvdcss   # system libdvdcss library (instead of internal copy)
18 %bcond_without  system_dvdread  # system libdvdread library (instead of internal copy)
19 %bcond_without  enca            # disable using ENCA charset oracle library
20 %bcond_without  gui             # without GTK+ GUI
21 %bcond_without  joystick        # joystick support
22 %bcond_without  lirc            # lirc support
23 %bcond_without  live            # LIVE555 Streaming Media support
24 %bcond_without  mencoder        # mencoder (a/v encoder) compilation
25 %bcond_without  nemesi          # NeMeSi Streaming Media support
26 %bcond_without  osd             # osd menu support
27 %bcond_without  rtmp            # RTMPDump Streaming Media support
28 %bcond_with     shared          # experimental libmplayer.so support
29 %bcond_without  smb             # Samba (SMB) input support
30 %bcond_without  vstream         # TiVo vstream client support
31 # - codecs:
32 %bcond_without  amr             # Adaptive Multi Rate (AMR) speech codec support
33 %bcond_without  bs2b            # BS2B audio filter support
34 %bcond_without  crystalhd       # CrystalHD support
35 %bcond_without  faad            # FAAD2 (AAC) support
36 %bcond_without  gif             # GIF support
37 %bcond_without  ladspa          # LADSPA plugin support
38 %bcond_without  libdts          # libdts support
39 %bcond_without  libdv           # libdv en/decoding support
40 %bcond_without  lzo             # LZO support (requires lzo 2.x)
41 %bcond_without  mad             # mad (audio MPEG) support
42 %bcond_without  mpg123          # libmpg123 MP3 decoding support
43 %bcond_with     musepack        # libmpcdec support (deprecated in favour of libavcodec)
44 %bcond_without  openjpeg        # OpenJPEG (JPEG2000) input/output support
45 %bcond_without  quicktime       # binary quicktime dll support
46 %bcond_without  real            # Real* 8/9 codecs support
47 %bcond_without  vorbis          # Ogg Vorbis audio support (both tremor and libvorbis)
48 %bcond_with     tremor          # use tremor instead of libvorbis
49 %bcond_without  theora          # Ogg Theora video support
50 %bcond_without  win32           # Win32 codecs support
51 %bcond_without  x264            # x264 support
52 %bcond_with     xmms            # XMMS inputplugin support
53 %bcond_without  xvid            # XviD codec
54 %bcond_with     system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
55 %bcond_with     system_ffmpeg   # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
56 # - video output:
57 %bcond_without  aalib           # aalib video output
58 %bcond_without  caca            # libcaca video output
59 %bcond_with     directfb        # DirectFB video output
60 %bcond_with     dxr2            # DXR2 (hardware MPEG decoder) video output
61 %bcond_with     dxr3            # DXR3/H+ (hardware MPEG decoder) video output
62 %bcond_with     ggi             # GGI video output
63 %bcond_without  sdl             # SDL video output
64 %bcond_with     svga            # svgalib video output
65 %bcond_without  vdpau           # VDPAU acceleration
66 %bcond_without  vidix           # VIDIX video drivers
67 %bcond_with     zr              # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
68 %bcond_with     gnomess         # controling gnome screensaver [patch not updated]
69 # - audio output:
70 %bcond_without  alsa            # ALSA audio output
71 %bcond_with     arts            # aRts audio output
72 %bcond_with     esd             # EsounD sound support
73 %bcond_without  jack            # JACKD support
74 %bcond_with     nas             # NAS audio output
75 %bcond_without  pulseaudio      # pulseaudio output
76 %bcond_without  select          # audio select() support (required e.g. for ALSA or Vortex2 driver)
77
78 %if %{with alsa}
79 %undefine       with_select
80 %endif
81 %if %{without vorbis}
82 %undefine       with_tremor
83 %endif
84
85 %ifnarch %{ix86}
86 %undefine       with_win32
87 %undefine       with_quicktime
88 %undefine       with_vidix
89 %endif
90 %ifnarch %{ix86} %{x8664} ppc ppc64
91 %undefine       with_runtime
92 %endif
93 %ifnarch %{ix86} %{x8664}
94 %undefine       with_vdpau
95 %endif
96 %ifnarch ppc
97 %undefine       with_altivec
98 %endif
99 %ifnarch i686 pentium4 athlon %{x8664}
100 %undefine       with_crystalhd
101 %endif
102
103 %if %{_lib} != "lib"
104 %define         binsuf  %(lib=%{_lib} ; echo ${lib#lib})
105 %else
106 %ifarch %{ix86} ppc sparc sparcv9 s390
107 %define         binsuf  32
108 %else
109 %define         binsuf  %{nil}
110 %endif
111 %endif
112
113 %if 0
114 # date from directory inside of tarball (like mplayer-export-2014-04-29)
115 %define snap    2018-05-22
116 %define ssnap   %(echo %{snap} | tr -d -)
117 %define rel     13
118 %endif
119 Summary:        MPlayer - THE Movie Player for UN*X
120 Summary(de.UTF-8):      MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
121 Summary(es.UTF-8):      Otro reproductor de películas
122 Summary(ko.UTF-8):      리눅스용 미디어플레이어
123 Summary(pl.UTF-8):      Odtwarzacz filmów dla systemów uniksowych
124 Summary(pt_BR.UTF-8):   Reprodutor de filmes
125 Name:           mplayer
126 Version:        1.4
127 Release:        1
128 # DO NOT increase epoch unless it's really neccessary!
129 # especially such changes like pre7->pre7try2, increase Release instead!
130 # PS: $ rpmvercmp pre7try2 pre7
131 # pre7try2 > pre7
132 Epoch:          3
133 License:        GPL
134 Group:          Applications/Multimedia
135 # Source0:      http://mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
136 Source0:        http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
137 # Source0-md5:  58d39f72bf7f3ddaa9e019224bffcb74
138 %if 0
139 Source1:        http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
140 # Source1-md5:  b1b71cc56b15da49cee1ede9a7b8134e
141 %endif
142 Source2:        http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
143 # Source2-md5:  1ecd31d17b51f16332b1fcc7da36b312
144 Source3:        http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
145 # Source3-md5:  7b47904a925cf58ea546ca15f3df160c
146 Source4:        http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-7.tar.bz2
147 # Source4-md5:  956a9d9ea51970e057f0deb7b2e25889
148 Source5:        g%{name}.desktop
149 Source7:        %{name}.png
150 Source8:        %{name}.desktop
151
152 # build (configure / Makefile) related:
153 Patch10:        %{name}-ldflags.patch
154 Patch11:        %{name}-altivec.patch
155 Patch12:        %{name}-check-byteswap.patch
156 Patch13:        %{name}-visibility-hidden-fix.patch
157 Patch14:        cflags.patch
158 Patch15:        %{name}-live555-async.patch
159
160 Patch17:        %{name}-gsm.patch
161
162 Patch19:        %{name}-shared.patch
163 Patch20:        %{name}-vstream.patch
164
165 # codecs, outputs, demuxers:
166 Patch21:        %{name}-auto-expand.patch
167 Patch22:        %{name}-release_directfb.patch
168
169 # goodies:
170 Patch30:        %{name}-cp1250-fontdesc.patch
171 Patch31:        %{name}-350.patch
172 # update, hard to fix right now because of gnome bug 579430:
173 # https://bugzilla.gnome.org/show_bug.cgi?id=579430
174 #Patch32:       %{name}-gnome-screensaver.patch
175
176 Patch101:       %{name}-link.patch
177
178 URL:            http://www.mplayerhq.hu/
179 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
180 BuildRequires:  EGL-devel
181 BuildRequires:  OpenAL-devel
182 BuildRequires:  OpenGL-GLX-devel
183 %{?with_sdl:BuildRequires:      SDL-devel >= 1.1.7}
184 # checked, but seems actually not used
185 #%{?with_sdl:BuildRequires:     SDL_image-devel}
186 BuildRequires:  a52dec-libs-devel
187 %{?with_aalib:BuildRequires:    aalib-devel}
188 %{?with_alsa:BuildRequires:     alsa-lib-devel}
189 %{?with_arts:BuildRequires:     artsc-devel}
190 BuildRequires:  binutils >= 2.10.1
191 %{?with_ssse3:BuildRequires:    binutils >= 3:2.16.92}
192 BuildRequires:  bzip2-devel
193 #%{?with_cdparanoia:BuildRequires:      cdparanoia-III-devel}
194 %{?with_gnomess:BuildRequires:  dbus-glib-devel}
195 %{?with_doc:BuildRequires:      docbook-dtd45-xml}
196 %{?with_doc:BuildRequires:      docbook-style-xsl}
197 %{?with_dxr2:BuildRequires:     dxr2-driver-devel}
198 %{?with_dxr3:BuildRequires:     em8300-devel}
199 %{?with_enca:BuildRequires:     enca-devel}
200 %{?with_esd:BuildRequires:      esound-devel}
201 BuildRequires:  faac-devel
202 %{?with_faad:BuildRequires:     faad2-devel >= 2.0}
203 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 4.1}
204 BuildRequires:  fontconfig-devel >= 1:2.4.2
205 BuildRequires:  freetype-devel >= 1:2.2.1
206 BuildRequires:  fribidi-devel
207 %{?with_altivec:BuildRequires:  gcc >= 5:4.1}
208 %{?with_gif:BuildRequires:      giflib-devel}
209 %{?with_gui:BuildRequires:      glib2-devel >= 1:2.6.0}
210 BuildRequires:  gnutls-devel
211 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
212 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
213 %{?with_ladspa:BuildRequires:   ladspa-devel}
214 BuildRequires:  lame-libs-devel
215 BuildRequires:  libass-devel >= 0.9.10
216 %{?with_bluray:BuildRequires:   libbluray-devel}
217 %{?with_bs2b:BuildRequires:     libbs2b-devel >= 3.0.0}
218 %{?with_caca:BuildRequires:     libcaca-devel}
219 %{?with_cdio:BuildRequires:     libcdio-paranoia-devel}
220 %{?with_crystalhd:BuildRequires:        libcrystalhd-devel}
221 %{?with_libdts:BuildRequires:   libdts-devel}
222 %{?with_libdv:BuildRequires:    libdv-devel > 0.9.5}
223 #%{?with_system_dvdcss:BuildRequires:   libdvdcss-devel}
224 %{?with_dvdnav:BuildRequires:   libdvdnav-devel >= 4.1.3}
225 %{?with_system_dvdread:BuildRequires:   libdvdread-devel >= 4.1}
226 %{?with_ggi:BuildRequires:      libggi-devel}
227 %{?with_ggi:BuildRequires:      libggiwmh-devel}
228 BuildRequires:  libgsm-devel
229 BuildRequires:  libjpeg-devel
230 %{?with_mad:BuildRequires:      libmad-devel}
231 BuildRequires:  libmng-devel
232 %{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
233 %{?with_system_libmpeg2:BuildRequires:  libmpeg2-devel}
234 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
235 %{?with_nemesi:BuildRequires:   libnemesi-devel >= 0.6.3}
236 BuildRequires:  libnut-devel
237 BuildRequires:  libpng-devel
238 %{?with_rtmp:BuildRequires:     librtmp-devel}
239 %{?with_smb:BuildRequires:      libsmbclient-devel}
240 %{?with_theora:BuildRequires:   libtheora-devel}
241 %{?with_vdpau:BuildRequires:    libvdpau-devel}
242 %if %{with vorbis} && %{without tremor}
243 BuildRequires:  libvorbis-devel
244 %endif
245 BuildRequires:  libvpx-devel
246 # build >= 118
247 %{?with_x264:BuildRequires:     libx264-devel >= 0.1.3}
248 BuildRequires:  libxslt-progs
249 # with v4l2 headers
250 BuildRequires:  linux-libc-headers >= 7:2.6.22
251 %{?with_lirc:BuildRequires:     lirc-devel}
252 %{?with_live:BuildRequires:     live-devel >= 2:2011.01.10}
253 %{?with_lzo:BuildRequires:      lzo-devel >= 2.0}
254 %{?with_nas:BuildRequires:      nas-devel}
255 BuildRequires:  ncurses-devel
256 %{?with_amr:BuildRequires:      opencore-amr-devel}
257 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
258 BuildRequires:  opus-devel
259 BuildRequires:  pkgconfig
260 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9}
261 BuildRequires:  rpm >= 4.4.9-56
262 BuildRequires:  rpmbuild(macros) >= 1.527
263 BuildRequires:  speex-devel >= 1.1
264 %{?with_svga:BuildRequires:     svgalib-devel}
265 BuildRequires:  tar >= 1:1.22
266 %{?with_tremor:BuildRequires:   tremor-devel}
267 BuildRequires:  twolame-devel
268 %{?with_vidix:BuildRequires:    vidix-devel}
269 %{?with_vstream:BuildRequires:  vstream-client-devel}
270 BuildRequires:  webrtc-libilbc-devel
271 %{?with_xmms:BuildRequires:     xmms-devel}
272 BuildRequires:  xorg-lib-libX11-devel
273 BuildRequires:  xorg-lib-libXScrnSaver-devel
274 BuildRequires:  xorg-lib-libXext-devel
275 BuildRequires:  xorg-lib-libXinerama-devel
276 BuildRequires:  xorg-lib-libXv-devel
277 BuildRequires:  xorg-lib-libXvMC-devel
278 BuildRequires:  xorg-lib-libXxf86dga-devel
279 BuildRequires:  xorg-lib-libXxf86vm-devel
280 %{?with_xvid:BuildRequires:     xvid-devel >= 1:0.9.0}
281 BuildRequires:  xz
282 %ifarch %{ix86} %{x8664}
283 BuildRequires:  yasm
284 %endif
285 BuildRequires:  zlib-devel
286 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
287 %{?with_openjpeg:Requires:      openjpeg2 >= 2.1.0}
288 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
289
290 %define         specflags_ia32  -fomit-frame-pointer
291 %if %{with altivec}
292 %define         specflags_ppc   -maltivec
293 %endif
294
295 %description
296 Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
297 AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
298 MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
299 MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
300 devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
301 optionally with SHM extension, X11 using overlays with the Xvideo
302 extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
303 Voodoo2/3 hardware, SDL v1.1.7 driver etc.
304
305 If you want to use win32 codecs install w32codec package.
306
307 %description -l de.UTF-8
308 MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
309 Kennzeichnend ist die herausragende Format- und
310 Plattform-Kompatibilität.
311
312 Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
313 plattformexklusive, wodurch etwa Windows Media auch außerhalb von
314 Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
315 Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
316 ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
317 Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
318 installierte Codecs nicht mit MPlayer kollidieren können.
319
320 %description -l es.UTF-8
321 Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
322 MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
323 (uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
324 de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
325 Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
326 G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
327 overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
328 G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
329 v1.1.7 etc.
330
331 Si quiere usar codecs Win32, instale el paquete w32codec.
332
333 %description -l ko.UTF-8
334 MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
335 파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
336 MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
337 Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
338 (Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
339 수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
340 크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
341 있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
342 부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
343
344 %description -l pl.UTF-8
345 Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
346 RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
347 (nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
348 Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
349 Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
350 rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
351 G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
352
353 Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
354
355 %description -l pt_BR.UTF-8
356 MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
357 áudio. Diferentes mecanismos de reprodução podem também ser
358 escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
359
360 %package -n gmplayer
361 Summary:        MPlayer with GTK+ GUI interface
362 Summary(pl.UTF-8):      MPlayer z graficznym interfejsem GTK+
363 Group:          X11/Applications/Multimedia
364 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
365 Requires:       %{name}-skin
366
367 %description -n gmplayer
368 MPlayer with GUI GTK+ interface.
369
370 %description -n gmplayer -l pl.UTF-8
371 MPlayer z graficznym interfejsem GTK+.
372
373 %package common
374 Summary:        Configuration files and documentation for MPlayer
375 Summary(pl.UTF-8):      Pliki konfiguracyjne i dokumentacja dla MPlayera
376 Group:          Applications/Multimedia
377 Suggests:       unrar
378 Obsoletes:      mplayer-vidix
379
380 %description common
381 Configuration files, man page and HTML documentation for MPlayer.
382
383 %description common -l pl.UTF-8
384 Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
385
386 %package doc
387 Summary:        HTML documentation for MPlayer
388 Summary(pl.UTF-8):      Dokumentacja do MPlayera w formacie HTML
389 Group:          Documentation
390
391 %description doc
392 HTML Documentation for MPlayer.
393
394 %description doc -l pl.UTF-8
395 Dokumentacja do MPlayera w formacie HTML.
396
397 %package -n mencoder
398 Summary:        MEncoder - a movie encoder for Linux
399 Summary(pl.UTF-8):      MEncoder - koder filmów dla Linuksa
400 Group:          Applications/Multimedia
401 Requires:       %{name}-common = %{epoch}:%{version}-%{release}
402
403 %description -n mencoder
404 MEncoder is a movie encoder for Linux and is a part of the MPlayer
405 package.
406
407 %description -n mencoder -l pl.UTF-8
408 MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
409
410 %prep
411 %if 0%{?snap:1}
412 %setup -q -n %{name}-export-%{snap} -a1 -a2 -a3 -a4
413 %else
414 %setup -q -n MPlayer-%{version} -a2 -a3 -a4
415 %endif
416 cp -f etc/codecs.conf etc/codecs.win32.conf
417
418 # build (configure / Makefile) related:
419 %patch10 -p1
420 %patch11 -p1
421 %patch12 -p1
422 %patch13 -p1
423 %patch14 -p1
424 %patch15 -p1
425
426 %patch17 -p1
427
428 %{?with_shared:%patch19 -p1}
429 %patch20 -p1
430
431 # codecs, outputs, demuxers:
432 %patch21 -p1
433 %patch22 -p1
434
435 # goodies:
436 %patch30 -p0
437 %patch31 -p1
438 #%{with_gnomess:%patch32 -p1}
439
440 %patch101 -p1
441
442 cat etc/example.conf > etc/mplayer.conf
443 cat <<'CONFIGADD' >> etc/mplayer.conf
444
445 ######################
446 # PLD Linux Defaults #
447 ######################
448 [default]
449
450 # alternate solution for CP1250-encoded subtitles
451 fontconfig = yes
452 subcp = cp1250
453
454 # ...or if you prefer native bitmap fonts shipped with mplayer
455 #fontconfig = no
456 #subcp = iso-8859-1
457
458 # Standard location
459 unrarexec = "%{_bindir}/unrar"
460
461 # Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
462 joystick=no
463
464 CONFIGADD
465
466 %if %{with system_ffmpeg}
467 # using external ffmpeg, but mplayer adds these to includepath
468 %{__rm} -rf ffmpeg
469 %endif
470
471 %build
472 CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
473 CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb: %{_includedir}/directfb} -DHAVE_GSM_H=1"
474
475 # NOTE:
476 # - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
477 # - toolame is obsolete predecessor of twolame
478 # - libcdio-paranoia is preferred over cdparanoia-III libs
479 build() {
480         set -x
481
482         ./configure \
483         %{?debug:--enable-debug=3} \
484         --prefix=%{_prefix} \
485         --codecsdir=%{_libdir}/codecs \
486         --confdir=%{_sysconfdir}/mplayer \
487         --cc="%{__cc}" \
488         --extra-cflags="$CFLAGS" \
489         --real-ldflags="%{rpmldflags}" \
490         --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
491         --language=all \
492 %if %{with system_ffmpeg}
493         --disable-ffmpeg_a \
494 %endif
495 %ifnarch %{ix86} %{x8664}
496         --disable-3dnow \
497         --disable-3dnowext \
498         --disable-fastmemcpy \
499         --disable-mmx \
500         --disable-mmxext \
501         --disable-sse \
502         --disable-sse2 \
503 %endif
504         %{__disable ssse3} \
505 %ifarch ppc
506         %{__disable altivec} \
507 %endif
508         %{__disable aalib aa} \
509         %{__enable_disable alsa} \
510         %{__disable arts} \
511         %{__disable bluray} \
512         %{__disable caca} \
513         %{__disable cdparanoia} \
514         --enable-dga1 \
515         --enable-dga2 \
516         %{__enable_disable directfb} \
517         %{__enable_disable dvdnav} \
518         %{__disable system_dvdread dvdread-internal} \
519         %{__disable dxr2} \
520         %{__disable dxr3} \
521         --enable-dynamic-plugins \
522         %{__disable enca} \
523         %{__disable esd} \
524         %{__disable faad} \
525         --enable-fbdev \
526         %{__disable gif} \
527         --enable-gl \
528         %{__disable ggi} \
529         %{__disable jack} \
530         %{__enable joystick} \
531         %{__disable cdio libcdio} \
532         %{__disable ladspa} \
533         %{__disable bs2b libbs2b} \
534         %{__disable libdts libdca} \
535         %{__disable libdv} \
536         %{__disable system_dvdcss libdvdcss-internal} \
537         %{__disable lzo liblzo} \
538         %{__disable system_libmpeg2 libmpeg2-internal} \
539         %{__disable nemesi} \
540         %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
541         %{__disable openjpeg} \
542         %{__disable rtmp librtmp} \
543         %{__disable vorbis libvorbis} \
544         %{__enable_disable lirc} \
545         --disable-lircc \
546         %{__disable live} \
547         %{__disable mad} \
548         %{__disable mencoder} \
549         %{__enable osd menu} \
550         --enable-mga \
551         %{__disable mpg123} \
552         %{__enable musepack} \
553         %{__disable nas} \
554         %{__disable pulseaudio pulse} \
555         %{__disable quicktime qtx} \
556         --enable-radio \
557         --enable-radio-capture \
558         %{__disable real} \
559         %{__enable_disable runtime runtime-cpudetection} \
560         %{__enable_disable sdl} \
561         %{__disable select} \
562         --enable-s3fb \
563         %{__disable smb} \
564         %{__disable svga} \
565         --enable-tdfxfb \
566         --enable-tdfxvid \
567         %{__disable theora} \
568         --disable-toolame \
569         %{!?with_tremor:--disable-tremor} \
570         --enable-unrarexec \
571         %{__disable vdpau} \
572         %{__disable vidix} \
573         %{__disable vstream} \
574         --enable-vm \
575 %ifarch ppc
576         --enable-wii \
577 %endif
578         %{__disable win32 win32dll} \
579         --enable-x11 \
580         %{__disable x264} \
581         --enable-xmga \
582         %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
583         --enable-xv \
584         %{__disable xvid} \
585         --enable-xvmc --with-xvmclib=XvMCW \
586         %{__enable_disable zr} \
587         "$@"
588
589         %{__make} %{?with_verbose:V=1}
590 }
591
592 %if %{with gui}
593 # build GUI version
594 build --enable-gui --disable-mencoder
595 %{__mv} mplayer gmplayer
596 %{__make} distclean
597 %endif
598
599 # now build regular version
600 build --disable-gui
601
602 %if %{with doc}
603 %{__make} -j1 doc
604 %endif
605
606 %install
607 rm -rf $RPM_BUILD_ROOT
608 install -d \
609         $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
610         $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
611         $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
612         $RPM_BUILD_ROOT%{_desktopdir}
613
614 # default config files
615 install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
616
617 # executables
618 for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
619 install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
620 %if "%{binsuf}" != ""
621 ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
622 %endif
623 done
624
625 %if %{with shared}
626 install -d $RPM_BUILD_ROOT%{_libdir}
627 install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
628 %endif
629
630 # fonts
631 cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
632 ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
633
634 %if %{with gui}
635 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
636 %endif
637 touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
638 install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
639 install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
640
641 # man pages
642 install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
643 install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
644 install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
645 install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
646 install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
647 install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
648 install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
649 install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
650 install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
651 #install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
652 install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
653
654 %clean
655 rm -rf $RPM_BUILD_ROOT
656
657 %post -n gmplayer
658 umask 022
659 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
660
661 %postun -n gmplayer
662 umask 022
663 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
664
665 %files
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/mplayer*
668
669 %if %{with gui}
670 %files -n gmplayer
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/gmplayer*
673 %{_desktopdir}/gmplayer.desktop
674 %endif
675
676 %if %{with mencoder}
677 %files -n mencoder
678 %defattr(644,root,root,755)
679 %doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
680 %doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
681 %doc DOCS/tech/colorspaces.txt
682 %attr(755,root,root) %{_bindir}/mencoder*
683 %endif
684
685 %if %{with doc}
686 %files doc
687 %defattr(644,root,root,755)
688 %doc DOCS/tech
689 # HTML and XML-generated docs
690 %doc DOCS/HTML/en
691 %lang(cs) %doc DOCS/HTML/cs
692 %lang(de) %doc DOCS/HTML/de
693 %lang(es) %doc DOCS/HTML/es
694 %lang(fr) %doc DOCS/HTML/fr
695 %lang(hu) %doc DOCS/HTML/hu
696 %lang(it) %doc DOCS/HTML/it
697 %lang(pl) %doc DOCS/HTML/pl
698 %lang(ru) %doc DOCS/HTML/ru
699 %lang(zh_CN) %doc DOCS/HTML/zh_CN
700 %endif
701
702 %files common
703 %defattr(644,root,root,755)
704 %doc AUTHORS README
705 %{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
706 %if %{with win32}
707 %doc etc/codecs.win32.conf
708 %endif
709
710 %dir %{_sysconfdir}/%{name}
711 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
712 %{_mandir}/man1/mplayer.1*
713 %lang(cs) %{_mandir}/cs/man1/mplayer.1*
714 %lang(de) %{_mandir}/de/man1/mplayer.1*
715 %lang(es) %{_mandir}/es/man1/mplayer.1*
716 %lang(fr) %{_mandir}/fr/man1/mplayer.1*
717 %lang(hu) %{_mandir}/hu/man1/mplayer.1*
718 %lang(it) %{_mandir}/it/man1/mplayer.1*
719 %lang(pl) %{_mandir}/pl/man1/mplayer.1*
720 %lang(ru) %{_mandir}/ru/man1/mplayer.1*
721 #%lang(sv) %{_mandir}/sv/man1/mplayer.1*
722 %lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
723 %{_desktopdir}/mplayer.desktop
724 %{_pixmapsdir}/mplayer.png
725 %dir %{_datadir}/%{name}
726 %{_datadir}/%{name}/font*
727 %dir %{_datadir}/%{name}/skins
728 %ghost %{_datadir}/%{name}/skins/default
This page took 0.107451 seconds and 4 git commands to generate.