]> git.pld-linux.org Git - packages/mplayer.git/blame - mplayer.spec
- release 13 (by relup.sh)
[packages/mplayer.git] / mplayer.spec
CommitLineData
37050656 1#
94cb018b 2# Conditional build:
62ba71a7 3# - CPU optimization:
63bba7db 4%bcond_without altivec # PPC altivec support
62ba71a7
JB
5%bcond_without ssse3 # SSSE3 optimizations (needs binutils >= 2.16.92)
6%bcond_without runtime # disable runtime cpu detection, just detect CPU
7 # in compile time (advertised by mplayer authors as working faster); in this case
8 # mplayer may not work on machine other then where it was compiled
62ba71a7 9%bcond_without hidden_visibility # no gcc hidden visibility
d53c9a42 10%bcond_without verbose # disable verbose build
62ba71a7
JB
11# - general features:
12%bcond_without bluray # Blu-ray support
63bba7db
JB
13%bcond_without cdio # libcdio support
14%bcond_without cdparanoia # cdparanoia support (when libcdio not enabled)
62ba71a7 15%bcond_without doc # don't build docs (slow)
63bba7db
JB
16%bcond_without dvdnav # dvdnav support
17%bcond_without system_dvdcss # system libdvdcss library (instead of internal copy)
18%bcond_without system_dvdread # system libdvdread library (instead of internal copy)
3c3fdfcc 19%bcond_without enca # disable using ENCA charset oracle library
8d7378f8 20%bcond_without gui # without GTK+ GUI
63bba7db 21%bcond_without joystick # joystick support
62ba71a7
JB
22%bcond_without lirc # lirc support
23%bcond_without live # LIVE555 Streaming Media support
24%bcond_without mencoder # mencoder (a/v encoder) compilation
10a6d1a6 25%bcond_without nemesi # NeMeSi Streaming Media support
62ba71a7
JB
26%bcond_without osd # osd menu support
27%bcond_without rtmp # RTMPDump Streaming Media support
28%bcond_with shared # experimental libmplayer.so support
29%bcond_without smb # Samba (SMB) input support
10a6d1a6 30%bcond_without vstream # TiVo vstream client support
62ba71a7
JB
31# - codecs:
32%bcond_without amr # Adaptive Multi Rate (AMR) speech codec support
10a6d1a6 33%bcond_without bs2b # BS2B audio filter support
62ba71a7
JB
34%bcond_without crystalhd # CrystalHD support
35%bcond_without faad # FAAD2 (AAC) support
36%bcond_without gif # GIF support
63bba7db
JB
37%bcond_without ladspa # LADSPA plugin support
38%bcond_without libdts # libdts support
39%bcond_without libdv # libdv en/decoding support
63bba7db
JB
40%bcond_without lzo # LZO support (requires lzo 2.x)
41%bcond_without mad # mad (audio MPEG) support
42%bcond_without mpg123 # libmpg123 MP3 decoding support
44d571a0 43%bcond_with musepack # libmpcdec support (deprecated in favour of libavcodec)
63bba7db 44%bcond_without openjpeg # OpenJPEG (JPEG2000) input/output support
63bba7db
JB
45%bcond_without quicktime # binary quicktime dll support
46%bcond_without real # Real* 8/9 codecs support
63bba7db 47%bcond_without vorbis # Ogg Vorbis audio support (both tremor and libvorbis)
44d571a0 48%bcond_with tremor # use tremor instead of libvorbis
62ba71a7
JB
49%bcond_without theora # Ogg Theora video support
50%bcond_without win32 # Win32 codecs support
51%bcond_without x264 # x264 support
52%bcond_with xmms # XMMS inputplugin support
63bba7db 53%bcond_without xvid # XviD codec
62ba71a7 54%bcond_with system_libmpeg2 # system libmpeg2 library (instead of internal copy with some quantizer modifications)
759ef2d3 55%bcond_with system_ffmpeg # use ffmpeg-devel, rather bundled sources (likely needs ffmpeg from same svn revision than mplayer)
62ba71a7
JB
56# - video output:
57%bcond_without aalib # aalib video output
58%bcond_without caca # libcaca video output
59%bcond_with directfb # DirectFB video output
10a6d1a6
JB
60%bcond_with dxr2 # DXR2 (hardware MPEG decoder) video output
61%bcond_with dxr3 # DXR3/H+ (hardware MPEG decoder) video output
62ba71a7
JB
62%bcond_with ggi # GGI video output
63%bcond_without sdl # SDL video output
64%bcond_with svga # svgalib video output
65%bcond_without vdpau # VDPAU acceleration
66%bcond_without vidix # VIDIX video drivers
63bba7db 67%bcond_with zr # ZR360[56]7/ZR36060 video output (needs deprecated V4L1 linux headers)
62ba71a7
JB
68%bcond_with gnomess # controling gnome screensaver [patch not updated]
69# - audio output:
70%bcond_without alsa # ALSA audio output
71%bcond_with arts # aRts audio output
72%bcond_with esd # EsounD sound support
73%bcond_without jack # JACKD support
74%bcond_with nas # NAS audio output
75%bcond_without pulseaudio # pulseaudio output
76%bcond_without select # audio select() support (required e.g. for ALSA or Vortex2 driver)
2dfabf36 77
9accd5e5 78%if %{with alsa}
79%undefine with_select
80%endif
d1f72115 81%if %{without vorbis}
44d571a0 82%undefine with_tremor
d1f72115 83%endif
84
94cb018b
JB
85%ifnarch %{ix86}
86%undefine with_win32
7a82c266 87%undefine with_quicktime
1087e996 88%undefine with_vidix
94cb018b 89%endif
38c74592 90%ifnarch %{ix86} %{x8664} ppc ppc64
906bf13b
JB
91%undefine with_runtime
92%endif
ca278bdf
ER
93%ifnarch %{ix86} %{x8664}
94%undefine with_vdpau
95%endif
3d17ae18
ER
96%ifnarch ppc
97%undefine with_altivec
98%endif
810f3f3d
ER
99%ifnarch i686 pentium4 athlon %{x8664}
100%undefine with_crystalhd
101%endif
3d17ae18 102
40ce9ce9
JB
103%if %{_lib} != "lib"
104%define binsuf %(lib=%{_lib} ; echo ${lib#lib})
1a8df7bd 105%else
40ce9ce9 106%ifarch %{ix86} ppc sparc sparcv9 s390
e2b12b5a 107%define binsuf 32
40ce9ce9
JB
108%else
109%define binsuf %{nil}
110%endif
1a8df7bd 111%endif
112
b1e29978 113%if 0
0cd1ec52 114# date from directory inside of tarball (like mplayer-export-2014-04-29)
b13d3bd9 115%define snap 2018-05-22
0cd1ec52 116%define ssnap %(echo %{snap} | tr -d -)
aa751f83 117%define rel 13
b1e29978 118%endif
906bf13b 119Summary: MPlayer - THE Movie Player for UN*X
eeb91a66
ER
120Summary(de.UTF-8): MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player
121Summary(es.UTF-8): Otro reproductor de películas
122Summary(ko.UTF-8): 리눅스용 미디어플레이어
123Summary(pl.UTF-8): Odtwarzacz filmów dla systemów uniksowych
124Summary(pt_BR.UTF-8): Reprodutor de filmes
2adea73e 125Name: mplayer
b1e29978
JB
126Version: 1.4
127Release: 1
1f85fd72
ER
128# DO NOT increase epoch unless it's really neccessary!
129# especially such changes like pre7->pre7try2, increase Release instead!
130# PS: $ rpmvercmp pre7try2 pre7
131# pre7try2 > pre7
59476b48 132Epoch: 3
bc426a7f 133License: GPL
906bf13b 134Group: Applications/Multimedia
b1e29978
JB
135# Source0: http://mplayerhq.hu/MPlayer/releases/mplayer-export-snapshot.tar.bz2
136Source0: http://mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
137# Source0-md5: 58d39f72bf7f3ddaa9e019224bffcb74
138%if 0
0cd1ec52 139Source1: http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
dea0f5a7 140# Source1-md5: b1b71cc56b15da49cee1ede9a7b8134e
b1e29978
JB
141%endif
142Source2: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-1.tar.bz2
143# Source2-md5: 1ecd31d17b51f16332b1fcc7da36b312
144Source3: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-2.tar.bz2
0a38bda8 145# Source3-md5: 7b47904a925cf58ea546ca15f3df160c
b1e29978
JB
146Source4: http://mplayerhq.hu/MPlayer/releases/fonts/font-arial-iso-8859-7.tar.bz2
147# Source4-md5: 956a9d9ea51970e057f0deb7b2e25889
e601cd91 148Source5: g%{name}.desktop
11b89ef7 149Source7: %{name}.png
24481cd2 150Source8: %{name}.desktop
79907b07 151
152# build (configure / Makefile) related:
153Patch10: %{name}-ldflags.patch
154Patch11: %{name}-altivec.patch
155Patch12: %{name}-check-byteswap.patch
c2bf8f19 156Patch13: %{name}-visibility-hidden-fix.patch
2bb2f3d6 157Patch14: cflags.patch
1ee1ef52 158Patch15: %{name}-live555-async.patch
e156db0d 159
63bba7db 160Patch17: %{name}-gsm.patch
7eb1aa3e 161
63bba7db 162Patch19: %{name}-shared.patch
990687b2 163Patch20: %{name}-vstream.patch
79907b07 164
165# codecs, outputs, demuxers:
990687b2
JB
166Patch21: %{name}-auto-expand.patch
167Patch22: %{name}-release_directfb.patch
79907b07 168
169# goodies:
170Patch30: %{name}-cp1250-fontdesc.patch
2833f81f 171Patch31: %{name}-350.patch
d1f72115 172# update, hard to fix right now because of gnome bug 579430:
173# https://bugzilla.gnome.org/show_bug.cgi?id=579430
2833f81f 174#Patch32: %{name}-gnome-screensaver.patch
79907b07 175
b252aa8a 176Patch101: %{name}-link.patch
79907b07 177
c5b97685 178URL: http://www.mplayerhq.hu/
44d571a0
JB
179%{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.22}
180BuildRequires: EGL-devel
aeb67db6 181BuildRequires: OpenAL-devel
44d571a0 182BuildRequires: OpenGL-GLX-devel
11421384 183%{?with_sdl:BuildRequires: SDL-devel >= 1.1.7}
44d571a0
JB
184# checked, but seems actually not used
185#%{?with_sdl:BuildRequires: SDL_image-devel}
63bba7db 186BuildRequires: a52dec-libs-devel
dd6c659c
JB
187%{?with_aalib:BuildRequires: aalib-devel}
188%{?with_alsa:BuildRequires: alsa-lib-devel}
189%{?with_arts:BuildRequires: artsc-devel}
44d571a0 190BuildRequires: binutils >= 2.10.1
841cb995 191%{?with_ssse3:BuildRequires: binutils >= 3:2.16.92}
0431b837 192BuildRequires: bzip2-devel
364125e7 193#%{?with_cdparanoia:BuildRequires: cdparanoia-III-devel}
df52db46 194%{?with_gnomess:BuildRequires: dbus-glib-devel}
d6da6cb0 195%{?with_doc:BuildRequires: docbook-dtd45-xml}
5dcdda0f 196%{?with_doc:BuildRequires: docbook-style-xsl}
10a6d1a6 197%{?with_dxr2:BuildRequires: dxr2-driver-devel}
dd6c659c 198%{?with_dxr3:BuildRequires: em8300-devel}
3c3fdfcc
JB
199%{?with_enca:BuildRequires: enca-devel}
200%{?with_esd:BuildRequires: esound-devel}
30e3739f 201BuildRequires: faac-devel
3c3fdfcc 202%{?with_faad:BuildRequires: faad2-devel >= 2.0}
b1e29978 203%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 4.1}
63bba7db 204BuildRequires: fontconfig-devel >= 1:2.4.2
6bd88460 205BuildRequires: freetype-devel >= 1:2.2.1
30e3739f 206BuildRequires: fribidi-devel
3d17ae18 207%{?with_altivec:BuildRequires: gcc >= 5:4.1}
3c3fdfcc 208%{?with_gif:BuildRequires: giflib-devel}
44d571a0
JB
209%{?with_gui:BuildRequires: glib2-devel >= 1:2.6.0}
210BuildRequires: gnutls-devel
211%{?with_gui:BuildRequires: gtk+2-devel >= 2:2.4.0}
d336e259 212%{?with_jack:BuildRequires: jack-audio-connection-kit-devel}
63bba7db 213%{?with_ladspa:BuildRequires: ladspa-devel}
a8a0c1d1 214BuildRequires: lame-libs-devel
6bd88460 215BuildRequires: libass-devel >= 0.9.10
c3a1256a 216%{?with_bluray:BuildRequires: libbluray-devel}
10a6d1a6 217%{?with_bs2b:BuildRequires: libbs2b-devel >= 3.0.0}
dd6c659c 218%{?with_caca:BuildRequires: libcaca-devel}
63bba7db
JB
219%{?with_cdio:BuildRequires: libcdio-paranoia-devel}
220%{?with_crystalhd:BuildRequires: libcrystalhd-devel}
49aed190 221%{?with_libdts:BuildRequires: libdts-devel}
c521a17c 222%{?with_libdv:BuildRequires: libdv-devel > 0.9.5}
364125e7 223#%{?with_system_dvdcss:BuildRequires: libdvdcss-devel}
759ef2d3 224%{?with_dvdnav:BuildRequires: libdvdnav-devel >= 4.1.3}
63bba7db 225%{?with_system_dvdread:BuildRequires: libdvdread-devel >= 4.1}
dd6c659c 226%{?with_ggi:BuildRequires: libggi-devel}
63bba7db
JB
227%{?with_ggi:BuildRequires: libggiwmh-devel}
228BuildRequires: libgsm-devel
af480c75 229BuildRequires: libjpeg-devel
dd6c659c 230%{?with_mad:BuildRequires: libmad-devel}
c521a17c 231BuildRequires: libmng-devel
63bba7db
JB
232%{?with_musepack:BuildRequires: libmpcdec-devel >= 1.2.1}
233%{?with_system_libmpeg2:BuildRequires: libmpeg2-devel}
234%{?with_mpg123:BuildRequires: libmpg123-devel >= 1.14}
10a6d1a6 235%{?with_nemesi:BuildRequires: libnemesi-devel >= 0.6.3}
62ba71a7 236BuildRequires: libnut-devel
af480c75 237BuildRequires: libpng-devel
63bba7db 238%{?with_rtmp:BuildRequires: librtmp-devel}
a4298e0c 239%{?with_smb:BuildRequires: libsmbclient-devel}
de0c2d91 240%{?with_theora:BuildRequires: libtheora-devel}
5dcdda0f 241%{?with_vdpau:BuildRequires: libvdpau-devel}
44d571a0
JB
242%if %{with vorbis} && %{without tremor}
243BuildRequires: libvorbis-devel
244%endif
0431b837 245BuildRequires: libvpx-devel
44d571a0 246# build >= 118
bbab8eb7 247%{?with_x264:BuildRequires: libx264-devel >= 0.1.3}
ceb01d0e 248BuildRequires: libxslt-progs
44d571a0
JB
249# with v4l2 headers
250BuildRequires: linux-libc-headers >= 7:2.6.22
dd6c659c 251%{?with_lirc:BuildRequires: lirc-devel}
1ee1ef52 252%{?with_live:BuildRequires: live-devel >= 2:2011.01.10}
841cb995 253%{?with_lzo:BuildRequires: lzo-devel >= 2.0}
dd6c659c 254%{?with_nas:BuildRequires: nas-devel}
b458005d 255BuildRequires: ncurses-devel
b69a6f83 256%{?with_amr:BuildRequires: opencore-amr-devel}
4362ee26 257%{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.1.0}
44d571a0 258BuildRequires: opus-devel
e9d22b19 259BuildRequires: pkgconfig
86bc294f 260%{?with_pulseaudio:BuildRequires: pulseaudio-devel >= 0.9}
5dcdda0f 261BuildRequires: rpm >= 4.4.9-56
9accd5e5 262BuildRequires: rpmbuild(macros) >= 1.527
aeb67db6 263BuildRequires: speex-devel >= 1.1
dd6c659c 264%{?with_svga:BuildRequires: svgalib-devel}
3af20979 265BuildRequires: tar >= 1:1.22
44d571a0 266%{?with_tremor:BuildRequires: tremor-devel}
c521a17c 267BuildRequires: twolame-devel
3af20979 268%{?with_vidix:BuildRequires: vidix-devel}
10a6d1a6 269%{?with_vstream:BuildRequires: vstream-client-devel}
44d571a0 270BuildRequires: webrtc-libilbc-devel
c521a17c 271%{?with_xmms:BuildRequires: xmms-devel}
627a7a97 272BuildRequires: xorg-lib-libX11-devel
c521a17c 273BuildRequires: xorg-lib-libXScrnSaver-devel
627a7a97
ER
274BuildRequires: xorg-lib-libXext-devel
275BuildRequires: xorg-lib-libXinerama-devel
276BuildRequires: xorg-lib-libXv-devel
277BuildRequires: xorg-lib-libXvMC-devel
278BuildRequires: xorg-lib-libXxf86dga-devel
279BuildRequires: xorg-lib-libXxf86vm-devel
b57c3c6c
ER
280%{?with_xvid:BuildRequires: xvid-devel >= 1:0.9.0}
281BuildRequires: xz
282%ifarch %{ix86} %{x8664}
283BuildRequires: yasm
284%endif
285BuildRequires: zlib-devel
4d75c49f 286Requires: %{name}-common = %{epoch}:%{version}-%{release}
4362ee26 287%{?with_openjpeg:Requires: openjpeg2 >= 2.1.0}
0f2a502d 288BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
2adea73e 289
bb27cfbd 290%define specflags_ia32 -fomit-frame-pointer
198487b4 291%if %{with altivec}
adfd0023 292%define specflags_ppc -maltivec
20a66bdb 293%endif
2adea73e
AM
294
295%description
c902f7c6 296Movie player. Supported input formats: VCD (VideoCD), MPEG1/2, RIFF
297AVI, ASF 1.0, Quicktime. Supported audio codecs: PCM (uncompressed),
6db4b1ea 298MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Supported video codecs:
299MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX. Supported output
c902f7c6 300devices: Matrox G200/G400 hardware, Matrox G200/G400 overlay, X11
301optionally with SHM extension, X11 using overlays with the Xvideo
302extension, OpenGL renderer, Matrox G400 YUV support on framebuffer
303Voodoo2/3 hardware, SDL v1.1.7 driver etc.
2adea73e 304
8b146837 305If you want to use win32 codecs install w32codec package.
4228a246 306
e011d408 307%description -l de.UTF-8
deba608c 308MPlayer ist ein unter der freien GPL-Lizenz stehender Media-Player.
309Kennzeichnend ist die herausragende Format- und
e011d408 310Plattform-Kompatibilität.
deba608c 311
e011d408
JR
312Es unterstützt eine Vielzahl von Video und Audio-Codecs, darunter auch
313plattformexklusive, wodurch etwa Windows Media auch außerhalb von
314Windows wiedergegeben werden kann. Darüber hinaus unterstützt er DVB.
315Eine besondere Fehlertoleranz ermöglicht es dem mehrfach
deba608c 316ausgezeichneten Player, auch defekte Dateien abzuspielen. Eine weitere
e011d408
JR
317Stärke ist dabei der Wegfall jeglicher Installation, so dass bereits
318installierte Codecs nicht mit MPlayer kollidieren können.
deba608c 319
e011d408 320%description -l es.UTF-8
c902f7c6 321Reproductor video. Formatos de entrada soportados: VCD (VideoCD),
322MPEG1/2, RIFF AVI, ASF 1.0, Quicktime. Codecs de audio soportados: PCM
323(uncompressed), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM. Codecs
324de video soportados: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
325Dispositivos de salida soportados: Matrox G200/G400 hardware, Matrox
e011d408
JR
326G200/G400 overlay, X11 optionalmente con la extensión SHM, X11 usando
327overlays con la extensión Xvideo, plasmador OpenGL, soporte de Matrox
c902f7c6 328G400 YUV en hardware de framebuffer de Voodoo2/3, controlador SDL
329v1.1.7 etc.
33c4efab 330
8b146837 331Si quiere usar codecs Win32, instale el paquete w32codec.
33c4efab 332
e011d408
JR
333%description -l ko.UTF-8
334MPlayer는 리눅스용 무비플레이어입니다. 대부분의 mpeg, avi 그리고 asf
335파일을 재생합니다. VCD, DVD, 심 지어 DivX까지 볼 수 있습니다.
336MPlayer의 또 다른 큰 특징은 출력 드라이버가 다양하다는 것입니다. X11,
337Xv, DGA, OpenGL, SVGAlib, fbdev와 작동하며, SDL이나
338(Matrox/3dfx/Sis등의) 특정 카드에 종속된 로우레 벨 드라이버들도 사용할
339수 있습니다. 대부분의 출력 드라이버들은 소프트웨어 혹은 하드웨어적인
340크기조절 (scaling)을 지원하므로, 전체화면으로 영상을 감상할 수
341있습니다. 뿐만아니라, 한국어, 영어, 헝가리어, 체코어, 러시아어등의
342부드러운(antialiased) 자막폰트도 사용할 수 있습니다.
af480c75 343
e011d408
JR
344%description -l pl.UTF-8
345Odtwarzacz wideo. Wspierane formaty wejściowe: VCD (VideoCD), MPEG1/2,
c902f7c6 346RIFF AVI, ASF 1.0, Quicktime. Wspierane kodeki audio: PCM
347(nieskompresowane), MPEG layer 2/3, AC3, aLaw, MS-GSM, Win32 ACM.
348Wspierane kodeki wideo: MPEG 1 and MPEG 2, Win32 ICM (VfW), OpenDivX.
e011d408 349Wspierane urządzenia wyjściowe: Matrox G200/G400, X11 opcjonalnie z
c902f7c6 350rozszerzeniem SHM, X11 z rozszerzeniem Xvideo, renderer OpenGL, Matrox
e011d408 351G400 używając framebuffera, Voodoo2/3, SDL v1.1.7 itp.
2adea73e 352
e011d408 353Jeśli chcesz używać kodeków win32, zainstaluj pakiet w32codec.
4228a246 354
e011d408
JR
355%description -l pt_BR.UTF-8
356MPlayer é um reprodutor de filmes que suporta vários codecs de vídeo e
357áudio. Diferentes mecanismos de reprodução podem também ser
2abc285c 358escolhidos, incluindo SDL, SVGALib, frame buffer, aalib, X11 e outros.
359
11421384
ER
360%package -n gmplayer
361Summary: MPlayer with GTK+ GUI interface
eeb91a66 362Summary(pl.UTF-8): MPlayer z graficznym interfejsem GTK+
11421384 363Group: X11/Applications/Multimedia
11421384 364Requires: %{name}-common = %{epoch}:%{version}-%{release}
deba608c 365Requires: %{name}-skin
11421384
ER
366
367%description -n gmplayer
368MPlayer with GUI GTK+ interface.
369
e011d408 370%description -n gmplayer -l pl.UTF-8
906bf13b
JB
371MPlayer z graficznym interfejsem GTK+.
372
11421384 373%package common
906bf13b 374Summary: Configuration files and documentation for MPlayer
eeb91a66 375Summary(pl.UTF-8): Pliki konfiguracyjne i dokumentacja dla MPlayera
11421384 376Group: Applications/Multimedia
c521a17c 377Suggests: unrar
1087e996 378Obsoletes: mplayer-vidix
11421384
ER
379
380%description common
906bf13b
JB
381Configuration files, man page and HTML documentation for MPlayer.
382
e011d408 383%description common -l pl.UTF-8
906bf13b 384Pliki konfiguracyjne, strona manuala i dokumentacja HTML dla MPlayera.
11421384 385
dc3c7d77 386%package doc
63bba7db
JB
387Summary: HTML documentation for MPlayer
388Summary(pl.UTF-8): Dokumentacja do MPlayera w formacie HTML
dc3c7d77
ER
389Group: Documentation
390
391%description doc
63bba7db
JB
392HTML Documentation for MPlayer.
393
394%description doc -l pl.UTF-8
395Dokumentacja do MPlayera w formacie HTML.
dc3c7d77 396
11421384 397%package -n mencoder
906bf13b 398Summary: MEncoder - a movie encoder for Linux
eeb91a66 399Summary(pl.UTF-8): MEncoder - koder filmów dla Linuksa
11421384
ER
400Group: Applications/Multimedia
401Requires: %{name}-common = %{epoch}:%{version}-%{release}
402
403%description -n mencoder
906bf13b
JB
404MEncoder is a movie encoder for Linux and is a part of the MPlayer
405package.
406
e011d408
JR
407%description -n mencoder -l pl.UTF-8
408MEncoder to koder filmów dla Linuksa będący częścią pakietu MPlayer.
11421384 409
2adea73e 410%prep
b1e29978
JB
411%if 0%{?snap:1}
412%setup -q -n %{name}-export-%{snap} -a1 -a2 -a3 -a4
413%else
414%setup -q -n MPlayer-%{version} -a2 -a3 -a4
415%endif
833dbe20 416cp -f etc/codecs.conf etc/codecs.win32.conf
79907b07 417
418# build (configure / Makefile) related:
419%patch10 -p1
420%patch11 -p1
421%patch12 -p1
c2bf8f19 422%patch13 -p1
2bb2f3d6 423%patch14 -p1
e2b12b5a 424%patch15 -p1
e156db0d 425
63bba7db 426%patch17 -p1
7eb1aa3e 427
63bba7db 428%{?with_shared:%patch19 -p1}
990687b2 429%patch20 -p1
79907b07 430
431# codecs, outputs, demuxers:
79907b07 432%patch21 -p1
990687b2 433%patch22 -p1
79907b07 434
435# goodies:
436%patch30 -p0
2833f81f 437%patch31 -p1
438#%{with_gnomess:%patch32 -p1}
59ba0205 439
b252aa8a
PS
440%patch101 -p1
441
53f97285 442cat etc/example.conf > etc/mplayer.conf
c521a17c 443cat <<'CONFIGADD' >> etc/mplayer.conf
444
d1f72115 445######################
8b2ed1fb 446# PLD Linux Defaults #
d1f72115 447######################
2833f81f 448[default]
449
450# alternate solution for CP1250-encoded subtitles
451fontconfig = yes
452subcp = cp1250
453
454# ...or if you prefer native bitmap fonts shipped with mplayer
455#fontconfig = no
456#subcp = iso-8859-1
457
458# Standard location
459unrarexec = "%{_bindir}/unrar"
460
993f72f1
ER
461# Joystick input is disabled because of issues on some laptops (thinkpad, macbook pro).
462joystick=no
463
c521a17c 464CONFIGADD
d1732085 465
1f8d8779
ER
466%if %{with system_ffmpeg}
467# using external ffmpeg, but mplayer adds these to includepath
0cd1ec52 468%{__rm} -rf ffmpeg
1f8d8779
ER
469%endif
470
2adea73e 471%build
5dcdda0f 472CFLAGS="%{rpmcflags} %{?with_hidden_visibility:-fvisibility=hidden} %{?with_shared:-fvisibility=default -fPIC}"
b1e29978 473CFLAGS="$CFLAGS -I%{_includedir}/xvid%{?with_directfb: %{_includedir}/directfb} -DHAVE_GSM_H=1"
53f97285 474
63bba7db
JB
475# NOTE:
476# - lircc refers to obsolete liblircc library (used in LIRCCD < 0.9)
477# - toolame is obsolete predecessor of twolame
44d571a0 478# - libcdio-paranoia is preferred over cdparanoia-III libs
11421384 479build() {
c521a17c 480 set -x
53f97285 481
11421384
ER
482 ./configure \
483 %{?debug:--enable-debug=3} \
dd6c659c 484 --prefix=%{_prefix} \
63bba7db 485 --codecsdir=%{_libdir}/codecs \
dd6c659c 486 --confdir=%{_sysconfdir}/mplayer \
53f97285 487 --cc="%{__cc}" \
488 --extra-cflags="$CFLAGS" \
79907b07 489 --real-ldflags="%{rpmldflags}" \
490 --extra-ldflags="%{?_x_libraries:-L%{_x_libraries}}" \
63bba7db 491 --language=all \
1f8d8779 492%if %{with system_ffmpeg}
0cd1ec52 493 --disable-ffmpeg_a \
1f8d8779 494%endif
57f87bc2 495%ifnarch %{ix86} %{x8664}
dd6c659c 496 --disable-3dnow \
a14f4270 497 --disable-3dnowext \
63bba7db
JB
498 --disable-fastmemcpy \
499 --disable-mmx \
500 --disable-mmxext \
dd6c659c
JB
501 --disable-sse \
502 --disable-sse2 \
dfeec30a 503%endif
9accd5e5 504 %{__disable ssse3} \
1837afdf 505%ifarch ppc
9accd5e5 506 %{__disable altivec} \
1837afdf 507%endif
9accd5e5 508 %{__disable aalib aa} \
9accd5e5 509 %{__enable_disable alsa} \
510 %{__disable arts} \
63bba7db 511 %{__disable bluray} \
9accd5e5 512 %{__disable caca} \
513 %{__disable cdparanoia} \
63bba7db
JB
514 --enable-dga1 \
515 --enable-dga2 \
516 %{__enable_disable directfb} \
517 %{__enable_disable dvdnav} \
518 %{__disable system_dvdread dvdread-internal} \
10a6d1a6 519 %{__disable dxr2} \
63bba7db
JB
520 %{__disable dxr3} \
521 --enable-dynamic-plugins \
9accd5e5 522 %{__disable enca} \
523 %{__disable esd} \
9accd5e5 524 %{__disable faad} \
63bba7db 525 --enable-fbdev \
9accd5e5 526 %{__disable gif} \
63bba7db
JB
527 --enable-gl \
528 %{__disable ggi} \
529 %{__disable jack} \
9accd5e5 530 %{__enable joystick} \
63bba7db
JB
531 %{__disable cdio libcdio} \
532 %{__disable ladspa} \
10a6d1a6 533 %{__disable bs2b libbs2b} \
9accd5e5 534 %{__disable libdts libdca} \
63bba7db
JB
535 %{__disable libdv} \
536 %{__disable system_dvdcss libdvdcss-internal} \
537 %{__disable lzo liblzo} \
538 %{__disable system_libmpeg2 libmpeg2-internal} \
10a6d1a6 539 %{__disable nemesi} \
63bba7db
JB
540 %{__enable_disable amr libopencore_amrnb} %{__enable_disable amr libopencore_amrwb} \
541 %{__disable openjpeg} \
542 %{__disable rtmp librtmp} \
543 %{__disable vorbis libvorbis} \
9accd5e5 544 %{__enable_disable lirc} \
63bba7db
JB
545 --disable-lircc \
546 %{__disable live} \
9accd5e5 547 %{__disable mad} \
63bba7db
JB
548 %{__disable mencoder} \
549 %{__enable osd menu} \
550 --enable-mga \
551 %{__disable mpg123} \
552 %{__enable musepack} \
553 %{__disable nas} \
9accd5e5 554 %{__disable pulseaudio pulse} \
555 %{__disable quicktime qtx} \
63bba7db
JB
556 --enable-radio \
557 --enable-radio-capture \
9accd5e5 558 %{__disable real} \
559 %{__enable_disable runtime runtime-cpudetection} \
63bba7db 560 %{__enable_disable sdl} \
9accd5e5 561 %{__disable select} \
10a6d1a6 562 --enable-s3fb \
9accd5e5 563 %{__disable smb} \
63bba7db
JB
564 %{__disable svga} \
565 --enable-tdfxfb \
10a6d1a6 566 --enable-tdfxvid \
9accd5e5 567 %{__disable theora} \
63bba7db 568 --disable-toolame \
44d571a0 569 %{!?with_tremor:--disable-tremor} \
63bba7db 570 --enable-unrarexec \
9accd5e5 571 %{__disable vdpau} \
63bba7db 572 %{__disable vidix} \
10a6d1a6 573 %{__disable vstream} \
dd6c659c 574 --enable-vm \
10a6d1a6
JB
575%ifarch ppc
576 --enable-wii \
577%endif
63bba7db 578 %{__disable win32 win32dll} \
dd6c659c 579 --enable-x11 \
63bba7db 580 %{__disable x264} \
dd6c659c 581 --enable-xmga \
63bba7db 582 %{?with_xmms:--enable-xmms --with-xmmsplugindir=%{_libdir}/xmms/Input --with-xmmslibdir=%{_libdir}} \
dd6c659c 583 --enable-xv \
63bba7db
JB
584 %{__disable xvid} \
585 --enable-xvmc --with-xvmclib=XvMCW \
7016f339 586 %{__enable_disable zr} \
11421384 587 "$@"
eb52750a 588
d53c9a42 589 %{__make} %{?with_verbose:V=1}
11421384 590}
2adea73e 591
11421384
ER
592%if %{with gui}
593# build GUI version
841cb995 594build --enable-gui --disable-mencoder
d6da6cb0 595%{__mv} mplayer gmplayer
aeb67db6 596%{__make} distclean
11421384
ER
597%endif
598
599# now build regular version
600build --disable-gui
601
aab7d90d 602%if %{with doc}
ef1e3931 603%{__make} -j1 doc
11421384 604%endif
ceb01d0e 605
2adea73e
AM
606%install
607rm -rf $RPM_BUILD_ROOT
e0e4b963 608install -d \
d23c171d 609 $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_sysconfdir}/mplayer} \
40ce9ce9 610 $RPM_BUILD_ROOT%{_mandir}/{cs,de,es,fr,hu,it,pl,ru,sv,zh_CN,}/man1 \
9accd5e5 611 $RPM_BUILD_ROOT%{_datadir}/%{name}/skins \
59ba0205 612 $RPM_BUILD_ROOT%{_desktopdir}
2adea73e 613
e0e4b963 614# default config files
c455a752 615install etc/{codecs,mplayer%{?with_osd:,menu},input}.conf $RPM_BUILD_ROOT%{_sysconfdir}/mplayer
e0e4b963 616
617# executables
40ce9ce9
JB
618for prog in mplayer %{?with_mencoder:mencoder} %{?with_gui:gmplayer} ; do
619install $prog $RPM_BUILD_ROOT%{_bindir}/${prog}%{binsuf}
620%if "%{binsuf}" != ""
621ln -sf ${prog}%{binsuf} $RPM_BUILD_ROOT%{_bindir}/$prog
11421384 622%endif
40ce9ce9 623done
e0e4b963 624
c2bf8f19 625%if %{with shared}
626install -d $RPM_BUILD_ROOT%{_libdir}
627install libmplayer.so $RPM_BUILD_ROOT%{_libdir}
628%endif
629
e0e4b963 630# fonts
9d62f689 631cp -r font-* $RPM_BUILD_ROOT%{_datadir}/mplayer
6e933f9c 632ln -sf font-arial-iso-8859-2/font-arial-24-iso-8859-2 $RPM_BUILD_ROOT%{_datadir}/mplayer/font
e0e4b963 633
11421384 634%if %{with gui}
f0d8c47e 635install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
68dd28e8 636%endif
9accd5e5 637touch $RPM_BUILD_ROOT%{_datadir}/%{name}/skins/default
24481cd2 638install %{SOURCE8} $RPM_BUILD_ROOT%{_desktopdir}
11b89ef7 639install %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}
e0e4b963 640
641# man pages
59ba0205 642install DOCS/man/cs/*.1 $RPM_BUILD_ROOT%{_mandir}/cs/man1
aee40e50 643install DOCS/man/de/*.1 $RPM_BUILD_ROOT%{_mandir}/de/man1
644install DOCS/man/en/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
645install DOCS/man/es/*.1 $RPM_BUILD_ROOT%{_mandir}/es/man1
646install DOCS/man/fr/*.1 $RPM_BUILD_ROOT%{_mandir}/fr/man1
647install DOCS/man/hu/*.1 $RPM_BUILD_ROOT%{_mandir}/hu/man1
8cda16b8 648install DOCS/man/it/*.1 $RPM_BUILD_ROOT%{_mandir}/it/man1
aee40e50 649install DOCS/man/pl/*.1 $RPM_BUILD_ROOT%{_mandir}/pl/man1
40ce9ce9 650install DOCS/man/ru/*.1 $RPM_BUILD_ROOT%{_mandir}/ru/man1
841cb995 651#install DOCS/man/sv/*.1 $RPM_BUILD_ROOT%{_mandir}/sv/man1
40ce9ce9 652install DOCS/man/zh_CN/*.1 $RPM_BUILD_ROOT%{_mandir}/zh_CN/man1
6db4b1ea 653
2adea73e
AM
654%clean
655rm -rf $RPM_BUILD_ROOT
656
a69eaaef 657%post -n gmplayer
cd748ae6 658umask 022
cd748ae6 659[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
660
a69eaaef 661%postun -n gmplayer
cd748ae6 662umask 022
75b3147a 663[ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
2ea7d522 664
2adea73e
AM
665%files
666%defattr(644,root,root,755)
1a8df7bd 667%attr(755,root,root) %{_bindir}/mplayer*
11421384
ER
668
669%if %{with gui}
670%files -n gmplayer
671%defattr(644,root,root,755)
1a8df7bd 672%attr(755,root,root) %{_bindir}/gmplayer*
11421384 673%{_desktopdir}/gmplayer.desktop
11421384
ER
674%endif
675
0fb5a7ee 676%if %{with mencoder}
11421384
ER
677%files -n mencoder
678%defattr(644,root,root,755)
aeb67db6 679%doc DOCS/tech/encoding-guide.txt DOCS/tech/encoding-tips.txt
680%doc DOCS/tech/swscaler_filters.txt DOCS/tech/swscaler_methods.txt
681%doc DOCS/tech/colorspaces.txt
1a8df7bd 682%attr(755,root,root) %{_bindir}/mencoder*
0fb5a7ee 683%endif
11421384 684
841cb995 685%if %{with doc}
dc3c7d77 686%files doc
df52db46 687%defattr(644,root,root,755)
dc3c7d77 688%doc DOCS/tech
841cb995
ER
689# HTML and XML-generated docs
690%doc DOCS/HTML/en
0ffd4cd0 691%lang(cs) %doc DOCS/HTML/cs
aeb67db6 692%lang(de) %doc DOCS/HTML/de
aee40e50 693%lang(es) %doc DOCS/HTML/es
694%lang(fr) %doc DOCS/HTML/fr
8cda16b8 695%lang(hu) %doc DOCS/HTML/hu
d6da6cb0 696%lang(it) %doc DOCS/HTML/it
aee40e50 697%lang(pl) %doc DOCS/HTML/pl
698%lang(ru) %doc DOCS/HTML/ru
d6da6cb0 699%lang(zh_CN) %doc DOCS/HTML/zh_CN
841cb995 700%endif
dc3c7d77
ER
701
702%files common
703%defattr(644,root,root,755)
841cb995 704%doc AUTHORS README
dc3c7d77
ER
705%{?with_shared:%attr(755,root,root) %{_libdir}/libmplayer.so}
706%if %{with win32}
707%doc etc/codecs.win32.conf
708%endif
11421384 709
906bf13b
JB
710%dir %{_sysconfdir}/%{name}
711%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
40ce9ce9
JB
712%{_mandir}/man1/mplayer.1*
713%lang(cs) %{_mandir}/cs/man1/mplayer.1*
714%lang(de) %{_mandir}/de/man1/mplayer.1*
715%lang(es) %{_mandir}/es/man1/mplayer.1*
716%lang(fr) %{_mandir}/fr/man1/mplayer.1*
717%lang(hu) %{_mandir}/hu/man1/mplayer.1*
718%lang(it) %{_mandir}/it/man1/mplayer.1*
719%lang(pl) %{_mandir}/pl/man1/mplayer.1*
720%lang(ru) %{_mandir}/ru/man1/mplayer.1*
721#%lang(sv) %{_mandir}/sv/man1/mplayer.1*
722%lang(zh_CN) %{_mandir}/zh_CN/man1/mplayer.1*
24481cd2 723%{_desktopdir}/mplayer.desktop
1087e996 724%{_pixmapsdir}/mplayer.png
11421384
ER
725%dir %{_datadir}/%{name}
726%{_datadir}/%{name}/font*
59ce39fb
ER
727%dir %{_datadir}/%{name}/skins
728%ghost %{_datadir}/%{name}/skins/default
This page took 0.28948 seconds and 4 git commands to generate.