]> git.pld-linux.org Git - packages/microcode-data-intel.git/blob - microcode-data-intel.spec
- rel 2; use ucode format which is directly accessed by kernel module (no need for...
[packages/microcode-data-intel.git] / microcode-data-intel.spec
1 Summary:        Microcode definitions for Intel processors
2 Name:           microcode-data-intel
3 Version:        20111110
4 Release:        2
5 License:        INTEL SOFTWARE LICENSE AGREEMENT
6 Group:          Base
7 # http://downloadcenter.intel.com/, enter "processor microcode data file" to the search
8 Source0:        http://downloadmirror.intel.com/20728/eng/microcode-%{version}.tgz
9 # Source0-md5:  ba288eb9490986513e59c5a035c93a65
10 # Tool for splitting Intel's microcode file. From Fedora
11 Source1:        intel-microcode2ucode.c
12 Provides:       microcode-data
13 ExclusiveArch:  i686 pentium2 pentium3 pentium4 %{x8664}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The microcode data file for Linux contains the latest microcode
18 definitions for all Intel processors.
19
20 %prep
21 %setup -q -c
22
23 %build
24 if ! grep -q 0x00000000 microcode.dat; then
25         echo >&2 microcode.dat contains giberrish
26         exit 1
27 fi
28
29 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode %{SOURCE1}
30 ./intel-microcode2ucode microcode.dat > /dev/null || exit 1
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_sbindir},/lib/firmware}
35
36 install intel-microcode2ucode $RPM_BUILD_ROOT%{_sbindir}
37 mv intel-ucode $RPM_BUILD_ROOT/lib/firmware
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %attr(755,root,root) %{_sbindir}/intel-microcode2ucode
45 /lib/firmware/intel-ucode
This page took 0.029978 seconds and 4 git commands to generate.