]> git.pld-linux.org Git - packages/libskk.git/blob - libskk.spec
- libffi rebuild
[packages/libskk.git] / libskk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  fep             # fep client
6 #
7 Summary:        Library to deal with Japanese kana-to-kanji conversion method
8 Summary(pl.UTF-8):      Biblioteka obsługi metody konwersji tekstu japońskiego kana do kanji
9 Name:           libskk
10 Version:        1.0.0
11 Release:        2
12 License:        GPL v3+
13 Group:          Libraries
14 #Source0Download: https://github.com/ueno/libskk/downloads
15 Source0:        https://github.com/downloads/ueno/libskk/%{name}-%{version}.tar.gz
16 # Source0-md5:  4318fabf49041950cabb0ed1d5bf286a
17 URL:            https://github.com/ueno/libskk/
18 BuildRequires:  gettext-devel
19 BuildRequires:  glib2-devel >= 2.0
20 BuildRequires:  gobject-introspection-devel >= 0.9.0
21 BuildRequires:  json-glib-devel
22 BuildRequires:  libgee0.6-devel
23 BuildRequires:  pkgconfig
24 # not needed for releases
25 #BuildRequires: vala >= 2:0.14.0
26 %{?with_apidocs:BuildRequires:  valadoc >= 0.3.1}
27 %if %{with fep}
28 BuildRequires:  libfep-devel >= 0.0.7
29 BuildRequires:  vala-libfep >= 0.0.7
30 %endif
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 libskk is a library to deal with Japanese kana-to-kanji conversion
35 method.
36
37 %description -l pl.UTF-8
38 libskk to biblioteka do obsługi metody konwersji tekstu japońśkiego
39 kana do kanji.
40
41 %package fep
42 Summary:        skkfep - Japanese SKK input method on text terminal
43 Summary(pl.UTF-8):      skkfep - metoda wprowadzania znaków japońskich SKK z terminala tekstowego
44 Group:          Applications/Text
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libfep >= 0.0.7
47
48 %description fep
49 skkfep is a tool that allows to use Japanese input method called SKK
50 (Simple Kana to Kanji conversion program) on ANSI compliant text
51 terminals.
52
53 %description fep -l pl.UTF-8
54 skkfep to narzędzie pozwalające na używanie metody wprowadzania znaków
55 japońskich SKK (Simple Kana to Kanji - konwersja uproszczonego kana do
56 kanji) na terminalach tekstowych zgodnych z ANSI.
57
58 %package devel
59 Summary:        Header files for libskk library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libskk
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       glib2-devel >= 2.0
64 Requires:       json-glib-devel
65 Requires:       libgee0.6-devel
66
67 %description devel
68 Header files for libskk library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki libskk.
72
73 %package static
74 Summary:        Static libskk library
75 Summary(pl.UTF-8):      Statyczna biblioteka libskk
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libskk library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka libskk.
84
85 %package -n vala-libskk
86 Summary:        Vala API for libskk library
87 Summary(pl.UTF-8):      API języka Vala do biblioteki libskk
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90 Requires:       vala >= 2:0.14.0
91 Requires:       vala-libgee0.6
92
93 %description -n vala-libskk
94 Vala API for libskk library.
95
96 %description -n vala-libskk -l pl.UTF-8
97 API języka Vala do biblioteki libskk.
98
99 %package apidocs
100 Summary:        libskk API documentation
101 Summary(pl.UTF-8):      Dokumentacja API biblioteki libskk
102 Group:          Documentation
103
104 %description apidocs
105 API and internal documentation for libskk library.
106
107 %description apidocs -l pl.UTF-8
108 Dokumentacja API biblioteki libskk.
109
110 %prep
111 %setup -q
112
113 %build
114 # pass fake VALADOC_* args to avoid requiring valadoc-devel
115 # (only utility is needed here, but configure checks for development package)
116 %configure \
117         VALADOC_CFLAGS=fake \
118         VALADOC_LIBS=fake \
119         %{?with_apidocs:--enable-docs} \
120         %{?with_fep:--enable-fep} \
121         %{?with_static_libs:--enable-static}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         libskkgtkdocdir=%{_gtkdocdir}/libskk
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libskk.la
133
134 %find_lang %{name}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc ChangeLog NEWS README
145 %attr(755,root,root) %{_bindir}/skk
146 %attr(755,root,root) %{_libdir}/libskk.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libskk.so.0
148 %{_libdir}/girepository-1.0/Skk-1.0.typelib
149 %{_datadir}/libskk
150 %{_mandir}/man1/skk.1*
151
152 %if %{with fep}
153 %files fep
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/skkfep
156 %attr(755,root,root) %{_libdir}/skkfep-client
157 %{_mandir}/man1/skkfep.1*
158 %endif
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libskk.so
163 %{_datadir}/gir-1.0/Skk-1.0.gir
164 %{_includedir}/libskk
165 %{_pkgconfigdir}/libskk.pc
166
167 %if %{with static_libs}
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libskk.a
171 %endif
172
173 %files -n vala-libskk
174 %defattr(644,root,root,755)
175 %{_datadir}/vala/vapi/skk-1.0.deps
176 %{_datadir}/vala/vapi/skk-1.0.vapi
177
178 %if %{with apidocs}
179 %files apidocs
180 %defattr(644,root,root,755)
181 %{_gtkdocdir}/libskk
182 # should it be here?
183 %{_datadir}/devhelp/references/libskk
184 %endif
This page took 0.119526 seconds and 4 git commands to generate.