]> git.pld-linux.org Git - packages/libparserutils.git/blob - libparserutils.spec
fix install on lib64 systems
[packages/libparserutils.git] / libparserutils.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Library for building efficient parsers
6 Name:           libparserutils
7 Version:        0.1.2
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  11c2b4ff17406b57dcb718d4fad022bb
13 Patch0: lib.patch
14 URL:            http://www.netsurf-browser.org/projects/libparserutils/
15 BuildRequires:  netsurf-buildsystem
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 LibParserUtils is a library for building efficient parsers, written in
20 C. It was developed as part of the NetSurf project and is available
21 for use by other software under the MIT licence.
22
23 Features:
24 - No mandatory dependencies (iconv() implementation optional for
25   enhanced charset support)
26 - A number of built-in character set converters
27 - Mapping of character set names to/from MIB enum values
28 - UTF-8 and UTF-16 (host endian) support functions
29 - Various simple data structures (resizeable buffer, stack, vector)
30 - A UTF-8 input stream
31 - Simple C API
32 - Portable
33
34 %package devel
35 Summary:        libparserutils library headers
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libparserutils
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 This is the libraries, include files and other resources you can use
42 to incorporate libparserutils into applications.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe pozwalające na używanie biblioteki libparserutils w
46 swoich programach.
47
48 %package static
49 Summary:        libparserutils static libraries
50 Summary(pl.UTF-8):      Statyczne biblioteki libparserutils
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 This is package with static libparserutils libraries.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka libparserutils.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63
64 %build
65 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
66         CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
67
68 %if %{with static_libs}
69 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
70         CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install Q='' \
76         lib=%{_lib} \
77         PREFIX=%{_prefix} \
78         COMPONENT_TYPE=lib-shared \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %if %{with static_libs}
82 %{__make} install Q='' \
83         lib=%{_lib} \
84         PREFIX=%{_prefix} \
85         COMPONENT_TYPE=lib-static \
86         DESTDIR=$RPM_BUILD_ROOT
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/lib*.so
102 %{_includedir}/parserutils
103 %{_pkgconfigdir}/*pc
104
105 %if %{with static_libs}
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/lib*.a
109 %endif
This page took 0.093087 seconds and 3 git commands to generate.