]> git.pld-linux.org Git - packages/libffi.git/blob - libffi.spec
- updated to 3.0.9
[packages/libffi.git] / libffi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Foreign Function Interface library
6 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface
7 Name:           libffi
8 Version:        3.0.9
9 Release:        1
10 Epoch:          7
11 License:        MIT-like
12 Group:          Libraries
13 Source0:        ftp://sourceware.org/pub/libffi/%{name}-%{version}.tar.gz
14 # Source0-md5:  1f300a7a7f975d4046f51c3022fa5ff1
15 Patch0:         %{name}-info.patch
16 URL:            http://sources.redhat.com/libffi/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The libffi library provides a portable, high level programming
24 interface to various calling conventions. This allows a programmer to
25 call any function specified by a call interface description at
26 run-time.
27
28 Ffi stands for Foreign Function Interface. A foreign function
29 interface is the popular name for the interface that allows code
30 written in one language to call code written in another language. The
31 libffi library really only provides the lowest, machine dependent
32 layer of a fully featured foreign function interface. A layer must
33 exist above libffi that handles type conversions for values passed
34 between the two languages.
35
36 %description -l pl.UTF-8
37 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
38 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
39 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
40 działania programu.
41
42 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
43 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
44 napisanemu w jednym języku wywoływać kod napisany w innym języku.
45 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
46 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
47 typów dla wartości przekazywanych pomiędzy różnymi językami.
48
49 %package devel
50 Summary:        libffi development package
51 Summary(pl.UTF-8):      libffi - część dla programistów
52 Group:          Development/Libraries
53 Requires:       %{name} = %{epoch}:%{version}-%{release}
54
55 %description devel
56 Header files for libffi.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe do biblioteki libffi.
60
61 %package static
62 Summary:        libffi static library
63 Summary(pl.UTF-8):      Statyczna biblioteka libffi
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
66
67 %description static
68 Static version of libffi.
69
70 %description static -l pl.UTF-8
71 Statyczna wersja biblioteki libffi.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84         %{!?with_static_libs:--disable-static}
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 rm $RPM_BUILD_ROOT%{_infodir}/dir
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %post   devel -p /sbin/postshell
103 -/usr/sbin/fix-info-dir -c %{_infodir}
104
105 %postun devel -p /sbin/postshell
106 -/usr/sbin/fix-info-dir -c %{_infodir}
107
108 %files
109 %defattr(644,root,root,755)
110 %doc ChangeLog* LICENSE README
111 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libffi.so.5
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libffi.so
117 %{_libdir}/libffi.la
118 %{_libdir}/libffi-%{version}
119 %{_pkgconfigdir}/libffi.pc
120 %{_mandir}/man3/ffi*.3*
121 %{_infodir}/libffi.info*
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libffi.a
127 %endif
This page took 0.090267 seconds and 3 git commands to generate.