]> git.pld-linux.org Git - packages/ka5-dolphin.git/blob - ka5-dolphin.spec
- updated to 21.12.0
[packages/ka5-dolphin.git] / ka5-dolphin.spec
1 %define         kdeappsver      21.12.0
2 %define         kframever       5.69.0
3 %define         qtver           5.9.0
4 %define         kaname          dolphin
5 Summary:        File manager
6 Name:           ka5-%{kaname}
7 Version:        21.12.0
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
12 # Source0-md5:  6ab0ed88af299be2680044bc1ab2bb20
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  cmake >= 2.8.12
16 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
17 BuildRequires:  kf5-kbookmarks-devel >= %{kframever}
18 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
19 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
20 BuildRequires:  kf5-kconfig-devel >= %{kframever}
21 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
22 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
23 BuildRequires:  kf5-kdelibs4support-devel >= %{kframever}
24 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
25 BuildRequires:  kf5-kemoticons-devel >= %{kframever}
26 BuildRequires:  kf5-kguiaddons-devel >= %{kframever}
27 BuildRequires:  kf5-ki18n-devel >= %{kframever}
28 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
29 BuildRequires:  kf5-kinit-devel >= %{kframever}
30 BuildRequires:  kf5-kio-devel >= %{kframever}
31 BuildRequires:  kf5-kitemmodels-devel >= %{kframever}
32 BuildRequires:  kf5-knewstuff-devel >= %{kframever}
33 BuildRequires:  kf5-knotifications-devel >= %{kframever}
34 BuildRequires:  kf5-knotifyconfig-devel >= %{kframever}
35 BuildRequires:  kf5-kparts-devel >= %{kframever}
36 BuildRequires:  kf5-kpty-devel >= %{kframever}
37 BuildRequires:  kf5-kservice-devel >= %{kframever}
38 BuildRequires:  kf5-ktextwidgets-devel >= %{kframever}
39 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
40 BuildRequires:  kf5-kwindowsystem-devel >= %{kframever}
41 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
42 BuildRequires:  ninja
43 BuildRequires:  qt5-build >= %{qtver}
44 BuildRequires:  rpmbuild(macros) >= 1.164
45 BuildRequires:  ruby-test-unit
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xz
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Dolphin is a lightweight file manager. It has been designed with ease
52 of use and simplicity in mind, while still allowing flexibility and
53 customisation. This means that you can do your file management exactly
54 the way you want to do it.
55
56 Features
57
58 • Navigation (or breadcrumb) bar for URLs, allowing you to quickly
59 navigate through the hierarchy of files and folders. • Supports
60 several different kinds of view styles and properties and allows you
61 to configure the view exactly how you want it. • Split view, allowing
62 you to easily copy or move files between locations. • Additional
63 information and shortcuts are available as dock-able panels, allowing
64 you to move them around freely and display exactly what you want. •
65 Multiple tab support • Informational dialogues are displayed in an
66 unobtrusive way. • Undo/redo support • Transparent network access
67 through the KIO system.
68
69 %description -l pl.UTF-8
70 Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w użyciu,
71 choć zapewniający elastyczność i możliwości konfiguracji. To znaczy,
72 że możesz go używać dokładnie, tak jakbyś chciał.
73
74 Cechy
75
76 • Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie
77 się wśród hierarchi plików i folderów • Wspiera wiele różnych rodzajów
78 przeglądania plików pozwalając skonfigurować podgląd tak jak sobie
79 tego życzysz • Podzielony widok do łatwego kopiowania i przenoszenia
80 plików między lokacjami • Dodatkowe informacje i skróty klawiszowe są
81 dostępne jako dokowalne panele, pozwalając przemieszczać się do woli i
82 wyświetlać to co chcesz • Wiele kart • Informacyjne okna dialogowe nie
83 drażnią użytkownika • Wsparcie dla Cofnij/Powtórz • Przeźroczysty
84 dostęp do sieci korzystający z systemu KIO.
85
86 %package devel
87 Summary:        Header files for %{kaname} development
88 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
89 Group:          X11/Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       cmake >= 2.6.0
92
93 %description devel
94 Header files for %{kaname} development.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe dla programistów używających %{kaname}.
98
99 %prep
100 %setup -q -n %{kaname}-%{version}
101
102 %build
103 install -d build
104 cd build
105 RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
106 export RUBYLIB
107 %cmake \
108         -G Ninja \
109         -DHTML_INSTALL_DIR=%{_kdedocdir} \
110         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
111         ..
112 %ninja_build
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %ninja_install -C build
117
118 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
119 %find_lang %{kaname} --all-name --with-kde
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files -f %{kaname}.lang
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/dolphin
130 %attr(755,root,root) %{_bindir}/servicemenuinstaller
131 %ghost %{_libdir}/libdolphinprivate.so.5
132 %{_libdir}/libdolphinprivate.so.5.*.*
133 %ghost %{_libdir}/libdolphinvcs.so.5
134 %{_libdir}/libdolphinvcs.so.5.*.*
135 %dir %{_libdir}/qt5/plugins/dolphin
136 %dir %{_libdir}/qt5/plugins/dolphin/kcms
137 %{_libdir}/qt5/plugins/dolphin/kcms/libkcm_dolphingeneral.so
138 %{_libdir}/qt5/plugins/dolphin/kcms/libkcm_dolphinnavigation.so
139 %{_libdir}/qt5/plugins/dolphin/kcms/libkcm_dolphinviewmodes.so
140 %{_desktopdir}/org.kde.dolphin.desktop
141 %{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
142 %{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
143 %{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
144 %{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
145 %{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
146 %{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
147 %{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
148 %{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
149 %{_datadir}/kservices5/dolphinpart.desktop
150 %{_datadir}/kservices5/kcmdolphingeneral.desktop
151 %{_datadir}/kservices5/kcmdolphinnavigation.desktop
152 %{_datadir}/kservices5/kcmdolphinviewmodes.desktop
153 %{_datadir}/kservicetypes5/fileviewversioncontrolplugin.desktop
154 %{_datadir}/metainfo/org.kde.dolphin.appdata.xml
155 %{_datadir}/kglobalaccel/org.kde.dolphin.desktop
156 %{_datadir}/qlogging-categories5/dolphin.categories
157 %{_datadir}/knsrcfiles/servicemenu.knsrc
158 %{systemduserunitdir}/plasma-dolphin.service
159 %{_libdir}/qt5/plugins/kf5/parts/dolphinpart.so
160 %{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
161
162 %files devel
163 %defattr(644,root,root,755)
164 %{_libdir}/libdolphinvcs.so
165 %{_includedir}/Dolphin
166 %{_includedir}/dolphin_export.h
167 %{_includedir}/dolphinvcs_export.h
168 %{_libdir}/cmake/DolphinVcs
This page took 0.041896 seconds and 4 git commands to generate.