]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
- python-ipython package pl description
[packages/ipython.git] / ipython.spec
1 %include        /usr/lib/rpm/macros.python
2
3 #
4 # todo:
5 # 2. %{py_sitedir}/%{pname}/UserConfig/*.py ???
6 #
7
8 %define pname IPython
9
10 Summary:        An enhanced Interactive Python shell
11 Summary(pl):    Interaktywna pow³oka jêzyka Python
12 Name:           ipython
13 Version:        0.2.8
14 Release:        0.3
15 License:        LGPL
16 Group:          Applications/Shells
17 Source0:        http://www-hep.colorado.edu/~fperez/ipython/dist/%{pname}-%{version}.tar.gz
18 URL:            http://www-hep.colorado.edu/~fperez/ipython/
19 %requires_eq    python
20 Requires:       python-%{name} = %{version}
21 BuildRequires:  rpm-pythonprov >= 4.0.2-50
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 IPython is a free software project which tries to:
27
28 1. Provide an interactive interpreter superior to Python's default.
29 IPython has many features for object introspection, shell access, and
30 its own special command system for adding functionality when working
31 interactively.
32
33 2. Serve as an embeddable, ready to use interpreter for your own
34 programs. IPython can be started with a single call from inside
35 another program, providing access to the current namespace. This can
36 be very useful both for debugging purposes and for situations where a
37 blend of batch-processing and interactive exploration are needed.
38
39 3. Offer a flexible framework which can be used as the base
40 environment for other systems with Python as the underlying language.
41 Specifically scientific environments like Mathematica, IDL and Mathcad
42 inspired its design, but similar ideas can be useful in many fields.
43
44 This package contains IPython shell.
45
46 %description -l pl
47 IPython jest wolnym oprogramowaniem, którego celem jest:
48
49 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej jêzyka
50 Python. IPython ma wiele cech takich jak badanie obiektów, dostêp do
51 pow³oki oraz w³asny system poleceñ, który umo¿liwia rozszerzanie
52 funkcjonalno¶ci podczas pracy interaktywnej.
53
54 2. Dostarczenie gotowego interpertera, który mo¿na do³±czaæ do w³asnej
55 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
56 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
57 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
58 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
59 wymagane po³±czenie przetwarzania wsadowego z interaktywnym badaniem.
60
61 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
62 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
63 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
64 Mathematic, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
65 w wielu przypadkach.
66
67 Pakiet ten zawiera pow³okê IPython.
68
69 %package -n python-ipython
70 Summary:        An enhanced Interactive Python shell modules
71 Summary(pl):    Modu³y interaktywnej pow³oki jêzyka Python
72 Group:          Libraries/Python
73 %requires_eq    python-modules
74 %requires_eq    python-pydoc
75
76 %description -n python-ipython
77 IPython is a free software project which tries to:
78
79 1. Provide an interactive interpreter superior to Python's default.
80 IPython has many features for object introspection, shell access, and
81 its own special command system for adding functionality when working
82 interactively.
83
84 2. Serve as an embeddable, ready to use interpreter for your own
85 programs. IPython can be started with a single call from inside
86 another program, providing access to the current namespace. This can
87 be very useful both for debugging purposes and for situations where a
88 blend of batch-processing and interactive exploration are needed.
89
90 3. Offer a flexible framework which can be used as the base
91 environment for other systems with Python as the underlying language.
92 Specifically scientific environments like Mathematica, IDL and Mathcad
93 inspired its design, but similar ideas can be useful in many fields.
94
95 This package contains IPython modules.
96
97 %description -n python-ipython -l pl
98 IPython jest wolnym oprogramowaniem, którego celem jest:
99
100 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej jêzyka
101 Python. IPython ma wiele cech takich jak badanie obiektów, dostêp do
102 pow³oki oraz w³asny system poleceñ, który umo¿liwia rozszerzanie
103 funkcjonalno¶ci podczas pracy interaktywnej.
104
105 2. Dostarczenie gotowego interpertera, który mo¿na do³±czaæ do w³asnej
106 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
107 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
108 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
109 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
110 wymagane po³±czenie przetwarzania wsadowego z interaktywnym badaniem.
111
112 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
113 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
114 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
115 Mathematic, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
116 w wielu przypadkach.
117
118 Pakiet ten zawiera modu³y interaktywnej pow³oki jêzyka Python.
119
120 %prep
121 %setup  -q -n %{pname}-%{version}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
127
128 mv doc/manual/manual.pdf doc/
129 mv doc/manual/ doc/html/
130
131 gzip -9nf *.txt doc/{*.txt,ChangeLog,ToDo,BUGS}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/*
139
140 %files -n python-ipython
141 %defattr(644,root,root,755)
142 %doc *.gz doc/*.gz doc/html doc/*.pdf
143 %dir %{py_sitedir}/%{pname}
144 %dir %{py_sitedir}/%{pname}/Extensions
145 %dir %{py_sitedir}/%{pname}/UserConfig
146 %{py_sitedir}/%{pname}/*.py?
147 %{py_sitedir}/%{pname}/Extensions/*.py?
148 %{py_sitedir}/%{pname}/UserConfig/*.py
This page took 0.080298 seconds and 3 git commands to generate.