]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
- up to 1.2.3
[packages/gtk-webkit.git] / gtk-webkit.spec
1 # TODO: optflags
2 #
3 # Conditional build:
4 %bcond_without  introspection   # disable introspection
5
6 Summary:        Port of WebKit embeddable web component to GTK+
7 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
8 Name:           gtk-webkit
9 Version:        1.2.3
10 Release:        1
11 License:        BSD-like
12 Group:          X11/Libraries
13 Source0:        http://webkitgtk.org/webkit-%{version}.tar.gz
14 # Source0-md5:  0ab5c478a6f5b74a1ae96bf13a456662
15 URL:            http://webkitgtk.org/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake
18 BuildRequires:  bison
19 BuildRequires:  enchant-devel >= 0.22
20 BuildRequires:  flex >= 2.5.33
21 BuildRequires:  fontconfig-devel >= 2.4.0
22 BuildRequires:  geoclue-devel
23 BuildRequires:  gettext-devel
24 %{?with_introspection:BuildRequires:    gir-repository-devel}
25 BuildRequires:  glib2-devel >= 1:2.22.0
26 BuildRequires:  glibc-misc
27 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.6.2}
28 BuildRequires:  gperf
29 BuildRequires:  gstreamer-devel >= 0.10
30 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.25
31 BuildRequires:  gtk+2-devel >= 2:2.20.0
32 BuildRequires:  gtk-doc >= 1.10
33 BuildRequires:  libicu-devel >= 4.2.1
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libsoup-devel >= 2.30.0
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:1.5
39 BuildRequires:  libxml2-devel >= 1:2.6.30
40 BuildRequires:  libxslt-devel
41 BuildRequires:  pkgconfig
42 BuildRequires:  sqlite3-devel
43 BuildRequires:  xorg-lib-libXft-devel >= 2.0.0
44 BuildRequires:  xorg-lib-libXt-devel
45 Requires:       gtk+2 >= 2:2.20.0
46 Requires:       libsoup >= 2.30.0
47 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 webkit is a port of the WebKit embeddable web component to GTK+.
52
53 %description -l pl.UTF-8
54 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
55
56 %package devel
57 Summary:        Development files for WebKit
58 Summary(pl.UTF-8):      Pliki programistyczne WebKit
59 Group:          X11/Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       fontconfig-devel >= 1.0.0
62 Requires:       glib2-devel >= 1:2.22.0
63 Requires:       gtk+2-devel >= 2:2.20.0
64 Requires:       libicu-devel
65 Requires:       libsoup-devel >= 2.30.0
66 Requires:       libstdc++-devel
67 Requires:       xorg-lib-libXft-devel >= 2.0.0
68
69 %description devel
70 Development files for WebKit.
71
72 %description devel -l pl.UTF-8
73 Pliki programistyczne WebKit.
74
75 %prep
76 %setup -q -n webkit-%{version}
77
78 # http://trac.webkit.org/browser/trunk/WebKit/gtk/JSCore.gir.in
79 %{__sed} -i -e 's,repository version="1.0",repository version="1.1",' WebKit/gtk/JSCore-1.0.gir
80
81 %build
82 %{__gtkdocize}
83 %{__aclocal} -I autotools
84 %{__libtoolize}
85 %{__autoheader}
86 %{__automake}
87 %{__autoconf}
88 %configure \
89         --disable-silent-rules \
90         --enable-3D-transforms \
91         --enable-dom-storage \
92         --enable-geolocation \
93         --enable-icon-database \
94         --%{!?with_introspection:dis}%{?with_introspection:en}able-introspection \
95         --enable-video
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %find_lang webkit
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files -f webkit.lang
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/jsc
116 %attr(755,root,root) %{_libdir}/libwebkit-1.0.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libwebkit-1.0.so.2
118 %if %{with introspection}
119 %{_libdir}/girepository-1.0/JSCore-1.0.typelib
120 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
121 %endif
122 %dir %{_datadir}/webkit-1.0
123 %{_datadir}/webkit-1.0/images
124 %{_datadir}/webkit-1.0/resources
125 %{_datadir}/webkit-1.0/webinspector
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libwebkit-1.0.so
130 %{_libdir}/libwebkit-1.0.la
131 %if %{with introspection}
132 %{_datadir}/gir-1.0/JSCore-1.0.gir
133 %{_datadir}/gir-1.0/WebKit-1.0.gir
134 %endif
135 %{_includedir}/webkit-1.0
136 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.038854 seconds and 4 git commands to generate.