]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
- updated to 1.10.1
[packages/gtk-webkit.git] / gtk-webkit.spec
1 #
2 # Conditional build:
3 %bcond_without  introspection   # disable introspection
4 #
5 Summary:        Port of WebKit embeddable web component to GTK+
6 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
7 Name:           gtk-webkit
8 Version:        1.10.1
9 Release:        1
10 License:        BSD-like
11 Group:          X11/Libraries
12 Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
13 # Source0-md5:  28c930cda012391453c476cdacfaca65
14 URL:            http://webkitgtk.org/
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  OpenGL-GLX-devel
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake
19 BuildRequires:  bison >= 1.875
20 BuildRequires:  cairo-devel >= 1.10
21 BuildRequires:  cairo-gobject-devel >= 1.10
22 BuildRequires:  enchant-devel >= 0.22
23 BuildRequires:  flex >= 2.5.33
24 BuildRequires:  fontconfig-devel >= 2.4.0
25 BuildRequires:  freetype-devel >= 1:2.1.8
26 BuildRequires:  geoclue-devel
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= 1:2.32.0
29 BuildRequires:  glibc-misc
30 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.5}
31 BuildRequires:  gperf
32 BuildRequires:  gstreamer-devel >= 1.0.0
33 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
34 BuildRequires:  gtk+2-devel >= 2:2.20.0
35 BuildRequires:  gtk-doc >= 1.10
36 BuildRequires:  libicu-devel >= 4.2.1
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libsoup-devel >= 2.40.0
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool >= 2:1.5
42 BuildRequires:  libxml2-devel >= 1:2.6.30
43 BuildRequires:  libxslt-devel >= 1.1.7
44 BuildRequires:  pango-devel >= 1:1.21
45 BuildRequires:  pkgconfig
46 BuildRequires:  sqlite3-devel >= 3
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  xorg-lib-libXcomposite-devel
49 BuildRequires:  xorg-lib-libXrender-devel
50 BuildRequires:  xorg-lib-libXt-devel
51 BuildRequires:  xz
52 BuildRequires:  zlib-devel
53 Requires:       cairo >= 1.10
54 Requires:       enchant >= 0.22
55 Requires:       glib2 >= 1:2.32.0
56 Requires:       gstreamer >= 1.0.0
57 Requires:       gstreamer-plugins-base >= 1.0.0
58 Requires:       gtk+2 >= 2:2.20.0
59 Requires:       libsoup >= 2.40.0
60 Requires:       libxml2 >= 1:2.6.30
61 Requires:       libxslt >= 1.1.7
62 Requires:       pango >= 1:1.21
63 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 webkit is a port of the WebKit embeddable web component to GTK+.
68
69 %description -l pl.UTF-8
70 webkit to port osadzalnego komponentu WWW WebKit do GTK+.
71
72 %package devel
73 Summary:        Development files for WebKit
74 Summary(pl.UTF-8):      Pliki programistyczne WebKit
75 Group:          X11/Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       cairo-devel >= 1.10
78 Requires:       enchant-devel >= 0.22
79 Requires:       fontconfig-devel >= 2.4.0
80 Requires:       freetype-devel >= 1:2.1.8
81 Requires:       geoclue-devel
82 Requires:       glib2-devel >= 1:2.32.0
83 Requires:       gstreamer-devel >= 1.0.0
84 Requires:       gstreamer-plugins-base-devel >= 1.0.0
85 Requires:       gtk+2-devel >= 2:2.20.0
86 Requires:       libicu-devel >= 4.2.1
87 Requires:       libjpeg-devel
88 Requires:       libpng-devel
89 Requires:       libsoup-devel >= 2.38
90 Requires:       libstdc++-devel
91 Requires:       libxml2-devel >= 1:2.6.30
92 Requires:       libxslt-devel >= 1.1.7
93 Requires:       pango-devel >= 1:1.21
94 Requires:       sqlite3-devel >= 3
95 Requires:       xorg-lib-libXt-devel
96
97 %description devel
98 Development files for WebKit.
99
100 %description devel -l pl.UTF-8
101 Pliki programistyczne WebKit.
102
103 %prep
104 %setup -q -n webkitgtk-%{version}
105 #patch0 -p1
106 #patch1 -p2
107
108 %build
109 %{__gtkdocize}
110 %{__libtoolize}
111 %{__aclocal} -I Source/autotools
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 # replace -g2 with -g1 to not run into 4 GB ar format limit
116 # https://bugs.webkit.org/show_bug.cgi?id=91154
117 # http://sourceware.org/bugzilla/show_bug.cgi?id=14625
118 export CFLAGS="%(echo %{rpmcflags} | sed 's/ -g2/ -g1/g')"
119 export CXXFLAGS="%(echo %{rpmcxxflags} | sed 's/ -g2/ -g1/g')"
120 %configure \
121         --disable-silent-rules \
122         --disable-webkit2 \
123         --enable-geolocation \
124         --enable-gtk-doc \
125         --enable-icon-database \
126         --enable-introspection%{!?with_introspection:=no} \
127         --enable-video \
128         --with-font-backend=freetype \
129         --with-gstreamer=1.0 \
130         --with-gtk=2.0 \
131         --with-html-dir=%{_gtkdocdir}
132
133 %{__make} -j1
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 # obsoleted by pkg-config
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
143 # packaged in gtk-webkit3
144 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/webkitgtk
145
146 %find_lang webkitgtk-2.0
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files -f webkitgtk-2.0.lang
155 %defattr(644,root,root,755)
156 %doc ChangeLog NEWS 
157 %attr(755,root,root) %{_bindir}/jsc-1
158 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-1.0.so.0
160 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-1.0.so.0
162 %if %{with introspection}
163 %{_libdir}/girepository-1.0/JSCore-1.0.typelib
164 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
165 %endif
166 %dir %{_datadir}/webkitgtk-1.0
167 %{_datadir}/webkitgtk-1.0/images
168 %{_datadir}/webkitgtk-1.0/resources
169 %{_datadir}/webkitgtk-1.0/webinspector
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so
174 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so
175 %if %{with introspection}
176 %{_datadir}/gir-1.0/JSCore-1.0.gir
177 %{_datadir}/gir-1.0/WebKit-1.0.gir
178 %endif
179 %{_includedir}/webkitgtk-1.0
180 %{_pkgconfigdir}/javascriptcoregtk-1.0.pc
181 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.092104 seconds and 4 git commands to generate.