]> git.pld-linux.org Git - packages/gtk-webkit.git/blob - gtk-webkit.spec
- updated to 2.4.4
[packages/gtk-webkit.git] / gtk-webkit.spec
1 #
2 # Conditional build:
3 %bcond_without  introspection   # disable introspection
4 #
5 Summary:        Port of WebKit embeddable web component to GTK+
6 Summary(pl.UTF-8):      Port osadzalnego komponentu WWW WebKit do GTK+
7 Name:           gtk-webkit
8 Version:        2.4.4
9 Release:        1
10 License:        BSD-like
11 Group:          X11/Libraries
12 Source0:        http://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
13 # Source0-md5:  79edd28d32172abc17a8861622cc274f
14 URL:            http://webkitgtk.org/
15 BuildRequires:  /usr/bin/ld.gold
16 BuildRequires:  EGL-devel
17 BuildRequires:  OpenGL-GLX-devel
18 BuildRequires:  at-spi2-core-devel >= 2.6.0
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake
21 BuildRequires:  bison >= 1.875
22 BuildRequires:  cairo-devel >= 1.10
23 BuildRequires:  enchant-devel >= 0.22
24 BuildRequires:  flex >= 2.5.33
25 BuildRequires:  fontconfig-devel >= 2.5.0
26 BuildRequires:  freetype-devel >= 1:2.1.8
27 BuildRequires:  gcc-c++ >= 6:4.7
28 BuildRequires:  geoclue2-devel >= 2.1.5
29 BuildRequires:  gettext-devel
30 BuildRequires:  glib2-devel >= 1:2.36.0
31 BuildRequires:  glibc-misc
32 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 1.32.0}
33 BuildRequires:  gperf
34 BuildRequires:  gstreamer-devel >= 1.0.3
35 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.3
36 BuildRequires:  libstdc++-devel >= 6:4.7
37 BuildRequires:  gtk+2-devel >= 2:2.24.10
38 BuildRequires:  gtk-doc >= 1.10
39 BuildRequires:  harfbuzz-devel >= 0.9.7
40 BuildRequires:  harfbuzz-icu-devel >= 0.9.7
41 BuildRequires:  libicu-devel >= 4.2.1
42 BuildRequires:  libjpeg-devel
43 BuildRequires:  libpng-devel
44 BuildRequires:  libsecret-devel
45 BuildRequires:  libsoup-devel >= 2.42.0
46 BuildRequires:  libstdc++-devel
47 # libtool with -fuse-ld= gcc option support
48 BuildRequires:  libtool >= 2:2.4.2-13
49 BuildRequires:  libwebp-devel
50 BuildRequires:  libxml2-devel >= 1:2.6.30
51 BuildRequires:  libxslt-devel >= 1.1.7
52 BuildRequires:  pango-devel >= 1:1.32.0
53 BuildRequires:  perl-base
54 BuildRequires:  pkgconfig
55 BuildRequires:  python
56 BuildRequires:  rpmbuild(macros) >= 1.592
57 BuildRequires:  ruby
58 BuildRequires:  sqlite3-devel >= 3
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  udev-glib-devel
61 BuildRequires:  xorg-lib-libXcomposite-devel
62 BuildRequires:  xorg-lib-libXdamage-devel
63 BuildRequires:  xorg-lib-libXrender-devel
64 BuildRequires:  xorg-lib-libXt-devel
65 BuildRequires:  xz
66 BuildRequires:  zlib-devel
67 Requires:       cairo >= 1.10
68 Requires:       enchant >= 0.22
69 Requires:       fontconfig-libs >= 2.5.0
70 Requires:       freetype >= 1:2.1.8
71 Requires:       glib2 >= 1:2.36.0
72 Requires:       gstreamer >= 1.0.3
73 Requires:       gstreamer-plugins-base >= 1.0.3
74 Requires:       gtk+2 >= 2:2.24.10
75 Requires:       harfbuzz >= 0.9.7
76 Requires:       libsoup >= 2.42.0
77 Requires:       libxml2 >= 1:2.6.30
78 Requires:       libxslt >= 1.1.7
79 Requires:       pango >= 1:1.32.0
80 %{?with_introspection:Conflicts:        gir-repository < 0.6.5-7}
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 # __once_call, __once_called non-function symbols from libstdc++
84 %define         skip_post_check_so      lib.*gtk-1.0.*
85
86 %description
87 gtk-webkit is a port of the WebKit embeddable web component to GTK+.
88
89 %description -l pl.UTF-8
90 gtk-webkit to port osadzalnego komponentu WWW WebKit do GTK+.
91
92 %package devel
93 Summary:        Development files for WebKit for GTK+ 2
94 Summary(pl.UTF-8):      Pliki programistyczne komponentu WebKit dla GTK+ 2
95 Group:          X11/Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       glib2-devel >= 1:2.36.0
98 Requires:       gtk+2-devel >= 2:2.24.10
99 Requires:       libsoup-devel >= 2.42.0
100 Requires:       libstdc++-devel
101
102 %description devel
103 Development files for WebKit for GTK+ 2.
104
105 %description devel -l pl.UTF-8
106 Pliki programistyczne komponentu WebKit dla GTK+ 2.
107
108 %prep
109 %setup -q -n webkitgtk-%{version}
110
111 %build
112 %{__libtoolize}
113 %{__aclocal} -I Source/autotools
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
119         --disable-gtk-doc \
120         --disable-silent-rules \
121         --disable-webkit2 \
122         --enable-geolocation \
123         --enable-glx \
124         %{__enable_disable introspection} \
125         --enable-webgl \
126         --with-gtk=2.0 \
127         --with-html-dir=%{_gtkdocdir}
128
129 %{__make} -j1
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 # obsoleted by pkg-config
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*-1.0.la
139 # packaged in gtk-webkit3
140 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/{webkitgtk,webkitdomgtk}
141
142 %find_lang WebKitGTK-2.0
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files -f WebKitGTK-2.0.lang
151 %defattr(644,root,root,755)
152 %doc ChangeLog NEWS
153 %attr(755,root,root) %{_bindir}/jsc-1
154 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-1.0.so.0
156 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libjavascriptcoregtk-1.0.so.0
158 %if %{with introspection}
159 %{_libdir}/girepository-1.0/JavaScriptCore-1.0.typelib
160 %{_libdir}/girepository-1.0/WebKit-1.0.typelib
161 %endif
162 %dir %{_datadir}/webkitgtk-1.0
163 %{_datadir}/webkitgtk-1.0/images
164 %{_datadir}/webkitgtk-1.0/resources
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libjavascriptcoregtk-1.0.so
169 %attr(755,root,root) %{_libdir}/libwebkitgtk-1.0.so
170 %if %{with introspection}
171 %{_datadir}/gir-1.0/JavaScriptCore-1.0.gir
172 %{_datadir}/gir-1.0/WebKit-1.0.gir
173 %endif
174 %{_includedir}/webkitgtk-1.0
175 %{_pkgconfigdir}/javascriptcoregtk-1.0.pc
176 %{_pkgconfigdir}/webkit-1.0.pc
This page took 0.035701 seconds and 3 git commands to generate.