]> git.pld-linux.org Git - packages/gnome-shell-extensions.git/blob - gnome-shell-extensions.spec
- new
[packages/gnome-shell-extensions.git] / gnome-shell-extensions.spec
1 %define         major_version           3.6
2 # Minimum GNOME Shell version supported
3 %define         global min_gs_version   %{major_version}.0
4
5 Summary:        Modify and extend GNOME Shell functionality and behavior
6 Name:           gnome-shell-extensions
7 Version:        %{major_version}.0
8 Release:        1
9 Group:          X11/Applications
10 # The entire source code is GPLv2+ except lib/convenience.js which is BSD
11 License:        GPLv2+ and BSD
12 URL:            http://live.gnome.org/GnomeShell/Extensions
13 # Using git archive since upstream doesn't publish tarballs on ftp.gnome.org
14 # anymore
15 # $ git clone git://git.gnome.org/gnome-shell-extensions/
16 # $ cd gnome-shell-extensions/
17 # $ git archive --format=tar --prefix=%{name}-%{version}/ %{version} | xz > ../%{name}-%{version}.tar.xz
18 Source0:        %{name}-%{version}.tar.xz
19 # Source0-md5:  849a020b25595b173ce99bac452f7db2
20 BuildRequires:  gnome-common
21 BuildRequires:  intltool
22 BuildRequires:  gnome-desktop-devel
23 BuildRequires:  libgtop-devel
24 Requires:       gnome-shell >= %{min_gs_version}
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 GNOME Shell Extensions is a collection of extensions providing
30 additional and optional functionality to GNOME Shell.
31
32 Enabled extensions:
33   - alternate-tab
34   - alternative-status-menu
35   - apps-menu
36   - auto-move-windows
37   - dock
38   - drive-menu
39   - native-window-placement
40   - places-menu
41   - systemMonitor
42   - user-theme
43   - windowsNavigator
44   - workspace-indicator
45   - xrandr-indicator
46   - gajim
47
48 %package common
49 Summary:        Files common to GNOME Shell Extensions
50 License:        GPL v2+
51 Group:          X11/Applications
52 Requires:       gnome-shell >= %{min_gs_version}
53
54 %description -n gnome-shell-extensions-common
55 GNOME Shell Extensions is a collection of extensions providing
56 additional and optional functionality to GNOME Shell. Common files and
57 directories needed by extensions are provided here.
58
59 %package -n gnome-shell-extension-alternate-tab
60 Summary:        Classic Alt+Tab behavior. Window based instead of app based
61 License:        GPL v2+
62 Group:          X11/Applications
63 Requires:       gnome-shell-extensions-common = %{version}-%{release}
64
65 %description -n gnome-shell-extension-alternate-tab
66 Lets you use classic Alt+Tab (window-based instead of app-based) in
67 GNOME Shell. GNOME Shell groups multiple instances of the same
68 application together. This extension disables grouping.
69
70 %package -n gnome-shell-extension-alternative-status-menu
71 Summary:        For those who want a power off item visible at all the time
72 License:        GPL v2+
73 Group:          X11/Applications
74 Requires:       gnome-shell-extensions-common = %{version}-%{release}
75
76 %description -n gnome-shell-extension-alternative-status-menu
77 For those who want a power off item visible at all the time, replaces
78 GNOME Shell status menu with one featuring separate Suspend and Power
79 Off. Adds the ability to hibernate as well.
80
81 %package -n gnome-shell-extension-apps-menu
82 Summary:        Application menu for GNOME Shell
83 License:        GPL v2+
84 Group:          X11/Applications
85 Requires:       gnome-shell-extensions-common = %{version}-%{release}
86
87 %description  -n gnome-shell-extension-apps-menu
88 Add a GNOME 2.x style menu for applications.
89
90 %package -n gnome-shell-extension-auto-move-windows
91 Summary:        Assign specific workspaces to applications
92 License:        GPL v2+
93 Group:          X11/Applications
94 Requires:       gnome-shell-extensions-common = %{version}-%{release}
95
96 %description -n gnome-shell-extension-auto-move-windows
97 Lets you manage your workspaces more easily, assigning a specific
98 workspace to each application as soon as it creates a window, in a
99 manner configurable with a GSettings key.
100
101 %package -n gnome-shell-extension-dock
102 Summary:        Shows a dock-style task switcher permanently
103 License:        GPL v2+
104 Group:          X11/Applications
105 Requires:       gnome-shell-extensions-common = %{version}-%{release}
106
107 %description -n gnome-shell-extension-dock
108 Shows a dock-style task switcher on the right side of the screen
109 permanently.
110
111 %package -n gnome-shell-extension-drive-menu
112 Summary:        Disk device manager in the system status area
113 License:        GPL v2+
114 Group:          X11/Applications
115 Requires:       gnome-shell-extensions-common = %{version}-%{release}
116
117 %description -n gnome-shell-extension-drive-menu
118 Adds a menu in the system status area that tracks removable disk
119 devices attached and offers to browse them and eject/unmount them.
120
121 %package -n gnome-shell-extension-gajim
122 Summary:        Gajim IM integration
123 License:        GPL v2+
124 Group:          X11/Applications
125 Requires:       gajim
126 Requires:       gnome-shell-extensions-common = %{version}-%{release}
127
128 %description  -n gnome-shell-extension-gajim
129 Display Gajim incoming chats as notifications in the Shell message
130 tray.
131
132 %package -n gnome-shell-extension-native-window-placement
133 Summary:        Arrange windows in overview in a more native way
134 License:        GPL v2+
135 Group:          X11/Applications
136 Requires:       gnome-shell-extensions-common = %{version}-%{release}
137
138 %description  -n gnome-shell-extension-native-window-placement
139 This extension employs an algorithm (taken from KDE) for layouting the
140 thumbnails in the overview that more closely reflects the positions
141 and relative sizes of the actual windows, instead of using a fixed
142 grid.
143
144 %package -n gnome-shell-extension-places-menu
145 Summary:        Places menu indicator in the system status area
146 License:        GPL v2+
147 Group:          X11/Applications
148 Requires:       gnome-shell-extensions-common = %{version}-%{release}
149
150 %description -n gnome-shell-extension-places-menu
151 Adds a menu in the system status area that resembles the Places menu
152 from GNOME 2.x
153
154 %package -n gnome-shell-extension-systemMonitor
155 Summary:        Monitor your system status
156 License:        GPL v2+
157 Group:          X11/Applications
158 Requires:       gnome-shell-extensions-common = %{version}-%{release}
159 Requires:       libgtop
160
161 %description -n gnome-shell-extension-systemMonitor
162 Monitor your system status
163
164 %package -n gnome-shell-extension-user-theme
165 Summary:        Lets the user select a custom theme for the shell
166 License:        GPL v2+
167 Group:          X11/Applications
168 Requires:       gnome-shell-extensions-common = %{version}-%{release}
169
170 %description -n gnome-shell-extension-user-theme
171 Lets the user select a custom theme for the Gnome shell. It will allow
172 you to apply a style from
173 /.themes/[themeName]/gnome-shell/gnome-shell.css
174
175 %package -n gnome-shell-extension-windowsNavigator
176 Summary:        Keyboard selection of windows and work-spaces in overlay mode
177 License:        GPL v2+
178 Group:          X11/Applications
179 Requires:       gnome-shell-extensions-common = %{version}-%{release}
180
181 %description -n gnome-shell-extension-windowsNavigator
182 Allow keyboard selection of windows and work-spaces in overlay mode in
183 GNOME Shell. Switch to overview mode (press the windows or alt+f1 key)
184 and press the alt key to show numbers over windows. Press any number
185 to switch to the corresponding window.
186
187 %package -n gnome-shell-extension-workspace-indicator
188 Summary:        Workspace Indicator
189 License:        GPL v2+
190 Group:          X11/Applications
191 Requires:       gnome-shell-extensions-common = %{version}-%{release}
192
193 %description -n gnome-shell-extension-workspace-indicator
194 Put an indicator on the panel signaling in which workspace you are,
195 and give you the possibility of switching to another one.
196
197 %package -n gnome-shell-extension-xrandr-indicator
198 Summary:        Monitor status indicator
199 License:        GPL v2+
200 Group:          X11/Applications
201 Requires:       gnome-shell-extensions-common = %{version}-%{release}
202
203 %description  -n gnome-shell-extension-xrandr-indicator
204 This extension adds a systems status menu for rotating monitors
205 (overrides what is currently provided by gnome-settings-daemon.
206
207 %prep
208 %setup -q
209 %{__glib_gettextize}
210 %{__intltoolize}
211 %{__libtoolize}
212 %{__aclocal}
213 %{__autoconf}
214 %{__automake}
215
216 %build
217 %configure \
218          \
219         --enable-extensions="alternate-tab \
220         alternative-status-menu \
221         apps-menu \
222         auto-move-windows \
223         dock \
224         drive-menu \
225         native-window-placement \
226         places-menu \
227         systemMonitor \
228         user-theme \
229         windowsNavigator \
230         workspace-indicator \
231         xrandr-indicator
232         gajim" \
233
234 %{__make}
235
236 %install
237 rm -rf $RPM_BUILD_ROOT
238
239 %{__make} install \
240         DESTDIR=$RPM_BUILD_ROOT
241
242 %find_lang %{name}
243
244 %clean
245 rm -rf $RPM_BUILD_ROOT
246
247 %post -n gnome-shell-extension-alternate-tab
248 %glib_compile_schemas
249
250 %postun -n gnome-shell-extension-alternate-tab
251 %glib_compile_schemas
252
253 %post -n gnome-shell-extension-alternative-status-menu
254 %glib_compile_schemas
255
256 %postun -n gnome-shell-extension-alternative-status-menu
257 %glib_compile_schemas
258
259 %post -n gnome-shell-extension-auto-move-windows
260 %glib_compile_schemas
261
262 %postun -n gnome-shell-extension-auto-move-windows
263 %glib_compile_schemas
264
265 %post -n gnome-shell-extension-dock
266 %glib_compile_schemas
267
268 %postun -n gnome-shell-extension-dock
269 %glib_compile_schemas
270
271 %post -n gnome-shell-extension-native-window-placement
272 %glib_compile_schemas
273
274 %postun -n gnome-shell-extension-native-window-placement
275 %glib_compile_schemas
276
277 %post -n gnome-shell-extension-user-theme
278 %glib_compile_schemas
279
280 %postun -n gnome-shell-extension-user-theme
281 %glib_compile_schemas
282
283 %files common -f %{name}.lang
284 %defattr(644,root,root,755)
285 %doc COPYING NEWS README
286 %dir %{_datadir}/gnome-shell/extensions
287
288 %files -n gnome-shell-extension-alternate-tab
289 %defattr(644,root,root,755)
290 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.alternate-tab.gschema.xml
291 %{_datadir}/gnome-shell/extensions/alternate-tab*
292
293 %files -n gnome-shell-extension-alternative-status-menu
294 %defattr(644,root,root,755)
295 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.alternative-status-menu.gschema.xml
296 %{_datadir}/gnome-shell/extensions/alternative-status-menu*
297
298 %files -n gnome-shell-extension-apps-menu
299 %defattr(644,root,root,755)
300 %{_datadir}/gnome-shell/extensions/apps-menu*
301
302 %files -n gnome-shell-extension-auto-move-windows
303 %defattr(644,root,root,755)
304 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.auto-move-windows.gschema.xml
305 %{_datadir}/gnome-shell/extensions/auto-move-windows*
306
307 %files -n gnome-shell-extension-dock
308 %defattr(644,root,root,755)
309 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.dock.gschema.xml
310 %{_datadir}/gnome-shell/extensions/dock*
311
312 %files -n gnome-shell-extension-drive-menu
313 %defattr(644,root,root,755)
314 %{_datadir}/gnome-shell/extensions/drive-menu*
315
316 %files -n gnome-shell-extension-gajim
317 %defattr(644,root,root,755)
318 %{_datadir}/gnome-shell/extensions/gajim*
319
320 %files -n gnome-shell-extension-native-window-placement
321 %defattr(644,root,root,755)
322 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.native-window-placement.gschema.xml
323 %{_datadir}/gnome-shell/extensions/native-window-placement*
324
325 %files -n gnome-shell-extension-places-menu
326 %defattr(644,root,root,755)
327 %{_datadir}/gnome-shell/extensions/places-menu*
328
329 %files -n gnome-shell-extension-systemMonitor
330 %defattr(644,root,root,755)
331 %{_datadir}/gnome-shell/extensions/systemMonitor*
332
333 %files -n gnome-shell-extension-user-theme
334 %defattr(644,root,root,755)
335 %{_datadir}/glib-2.0/schemas/org.gnome.shell.extensions.user-theme.gschema.xml
336 %{_datadir}/gnome-shell/extensions/user-theme*
337
338 %files -n gnome-shell-extension-windowsNavigator
339 %defattr(644,root,root,755)
340 %{_datadir}/gnome-shell/extensions/windowsNavigator*
341
342 %files -n gnome-shell-extension-workspace-indicator
343 %defattr(644,root,root,755)
344 %{_datadir}/gnome-shell/extensions/workspace-indicator*
345
346 %files -n gnome-shell-extension-xrandr-indicator
347 %defattr(644,root,root,755)
348 %{_datadir}/gnome-shell/extensions/xrandr-indicator*
This page took 0.227801 seconds and 4 git commands to generate.