]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- BuildRequires: autoconf >= 2.53, doesn't require automake
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(ru):    óÉÍ×ÏÌÉÞÅÓËÉÊ ÏÔÌÁÄÞÉË ÄÌÑ C É ÄÒÕÇÉÈ ÑÚÙËÏ×
8 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
9 Summary(uk):    óÉÍ×ÏÌØÎÉʠצÄÌÁÄÞÉË ÄÌÑ ó ÔÁ ¦ÎÛÉÈ ÍÏ×
10 Name:           gdb
11 Version:        5.2
12 Release:        1
13 License:        GPL
14 Group:          Development/Debuggers
15 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
16 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
17 Patch0:         %{name}-gettext.patch
18 Patch1:         %{name}-ncurses.patch
19 Patch2:         %{name}-readline.patch
20 Patch3:         %{name}-info.patch
21 Patch4:         %{name}-procfs.patch
22 Patch5:         %{name}-passflags.patch
23 BuildRequires:  ncurses-devel >= 5.2
24 BuildRequires:  readline-devel >= 4.2
25 BuildRequires:  XFree86-devel
26 BuildRequires:  autoconf >= 2.53
27 BuildRequires:  libtool
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Gdb is a full featured, command driven debugger. Gdb allows you to
32 trace the execution of programs and examine their internal state at
33 any time. Gdb works for C and C++ compiled with the GNU C compiler
34 gcc.
35
36 %description -l de
37 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
38 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
39 kompiliertes C++.
40
41 %description -l es
42 Este es un debugger orientado a comandos repleto de características.
43 Te permite rastrear la ejecución de programas y examinar su estado
44 interno a cualquier momento. Funciona para C y C++ compilado con el
45 compilador GNU C.
46
47 %description -l fr
48 Débugger complet, piloté par commandes. Permet de tracer l'exécution
49 des programmes et d'examiner à tout moment leur état interne.
50 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
51 de GNU, gcc.
52
53 %description -l pl
54 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
55 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
56 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
57 przy pomocy kompilatora GNU (gcc).
58
59 %description -l pt_BR
60 Este é um debugger orientado a comandos repleto de características.
61 Ele permite à você rastrear a execução de programas e examinar o seu
62 estado interno a qualquer momento. Ele funciona para para C e C++
63 compilado com o compilador GNU C.
64
65 %description -l ru
66 üÔÏ ÐÏÌÎÏÃÅÎÎÙÊ ÏÔÌÁÄÞÉË, ÕÐÒÁ×ÌÑÅÍÙÊ ËÏÍÁÎÄÁÍÉ. ïΠÐÏÚ×ÏÌÑÅÔ
67 ÔÒÁÓÓÉÒÏ×ÁÔØ ÉÓÐÏÌÎÅÎÉÅ ÐÒÏÇÒÁÍÍ É ÉÚÕÞÁÔØ ÉÈ ×ÎÕÔÒÅÎÎÅÅ ÓÏÓÔÏÑÎÉÅ ×
68 ÌÀÂÏÊ ÍÏÍÅÎÔ ×ÒÅÍÅÎÉ. òÁÂÏÔÁÅÔ Ó ÐÒÏÇÒÁÍÍÁÍÉ ÎÁ C É C++,
69 ÓËÏÍÐÉÌÉÒÏ×ÁÎÎÙÍÉ GNU ËÏÍÐÉÌÑÔÏÒÏÍ C (gcc, egcs, pgcc).
70
71 %description -l tr
72 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
73 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
74 verir.
75
76 %description -l uk
77 ãÅ ÐÏ×ÎÏæÎÎÉʠצÄÌÁÄÞÉË, ÝÏ ËÅÒÕ¤ÔØÓÑ ËÏÍÁÎÄÁÍÉ. ÷¦Î ÄÏÚ×ÏÌѤ
78 ÔÒÁÓÕ×ÁÔÉ ×ÉËÏÎÁÎÎÑ ÐÒÏÇÒÁÍ ÔÁ ×É×ÞÁÔÉ §È ×ÎÕÔÒ¦ÛΦʠÓÔÁΠנÄÏצÌØÎÉÊ
79 ÍÏÍÅÎÔ ÞÁÓÕ. ðÒÁÃÀ¤ Ú ÐÒÏÇÒÁÍÁÍÉ ÎÁ C ÔÁ C++, ÚËÏÍЦÌØÏ×ÁÎÉÍÉ
80 ËÏÍЦÌÑÔÏÒÁÍÉ GNU C (gcc, egcs, pgcc).
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88 %patch4 -p1
89 %patch5 -p1
90
91 %build
92 (cd gdb; autoconf)
93 (cd gdb/doc; autoconf)
94 (cd gdb/testsuite; autoconf)
95 (cd gdb/testsuite/gdb.asm; autoconf)
96 (cd gdb/testsuite/gdb.base; autoconf)
97 (cd gdb/testsuite/gdb.c++; autoconf)
98 (cd gdb/testsuite/gdb.chill; autoconf)
99 (cd gdb/testsuite/gdb.disasm; autoconf)
100 (cd gdb/testsuite/gdb.fortran; autoconf)
101 (cd gdb/testsuite/gdb.java; autoconf)
102 (cd gdb/testsuite/gdb.mi; autoconf)
103 (cd gdb/testsuite/gdb.stabs; autoconf)
104 (cd gdb/testsuite/gdb.threads; autoconf)
105 (cd gdb/testsuite/gdb.trace; autoconf)
106 (cd gdb/gdbserver; autoconf)
107 # !! Don't enable shared here !!
108 # This will cause serious problems --misiek
109 %configure2_13 \
110         --disable-shared \
111         --enable-nls \
112         --without-included-gettext \
113         --without-included-regex \
114         --enable-gdcli \
115         --enable-gdbmi \
116         --enable-multi-ice \
117         --enable-netrom \
118         --with-cpu=%{_target_cpu} \
119         --enable-tui \
120 %ifnarch alpha
121         --with-mmalloc \
122 %endif
123
124 # something is wrong after above - e.g. $exeext=="no" - fix it:
125 (cd gdb
126 %configure
127 )
128
129 %{__make}
130 %{__make} info
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_infodir}
135
136 %{__make} install install-info \
137         prefix=$RPM_BUILD_ROOT%{_prefix} \
138         bindir=$RPM_BUILD_ROOT%{_bindir} \
139         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
140         infodir=$RPM_BUILD_ROOT%{_infodir} \
141         includedir=$RPM_BUILD_ROOT%{_includedir} \
142         libdir=$RPM_BUILD_ROOT%{_libdir} \
143         mandir=$RPM_BUILD_ROOT%{_mandir}
144
145 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
152
153 %postun
154 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
155
156 %files
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/*
159
160 %{_mandir}/man1/*
161 %lang(es) %{_mandir}/es/man1/*
162 %lang(fr) %{_mandir}/fr/man1/*
163 %lang(hu) %{_mandir}/hu/man1/*
164 %lang(ja) %{_mandir}/ja/man1/*
165 %lang(pl) %{_mandir}/pl/man1/*
166 %{_infodir}/gdb*.info*
167 %{_infodir}/stabs*.info*
This page took 0.068826 seconds and 4 git commands to generate.