]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- added passflags patch (should fix ppc build)
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
8 Name:           gdb
9 Version:        5.1.1
10 Release:        2
11 License:        GPL
12 Group:          Development/Debuggers
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
15 Patch0:         %{name}-gettext.patch
16 Patch1:         %{name}-ncurses.patch
17 Patch2:         %{name}-readline.patch
18 Patch3:         %{name}-info.patch
19 Patch4:         %{name}-procfs.patch
20 Patch5:         %{name}-ppc-include.patch
21 Patch6:         %{name}-passflags.patch
22 BuildRequires:  ncurses-devel >= 5.2
23 BuildRequires:  readline-devel >= 4.2
24 BuildRequires:  XFree86-devel
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  libtool
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Gdb is a full featured, command driven debugger. Gdb allows you to
32 trace the execution of programs and examine their internal state at
33 any time. Gdb works for C and C++ compiled with the GNU C compiler
34 gcc.
35
36 %description -l de
37 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
38 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
39 kompiliertes C++.
40
41 %description -l es
42 Este es un debugger orientado a comandos repleto de características.
43 Te permite rastrear la ejecución de programas y examinar su estado
44 interno a cualquier momento. Funciona para C y C++ compilado con el
45 compilador GNU C.
46
47 %description -l fr
48 Débugger complet, piloté par commandes. Permet de tracer l'exécution
49 des programmes et d'examiner à tout moment leur état interne.
50 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
51 de GNU, gcc.
52
53 %description -l pl
54 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
55 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
56 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
57 przy pomocy kompilatora GNU (gcc).
58
59 %description -l pt_BR
60 Este é um debugger orientado a comandos repleto de características.
61 Ele permite à você rastrear a execução de programas e examinar o seu
62 estado interno a qualquer momento. Ele funciona para para C e C++
63 compilado com o compilador GNU C.
64
65 %description -l tr
66 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
67 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
68 verir.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77 %patch5 -p1
78 %patch6 -p1
79
80 %build
81 (cd gdb; autoconf)
82 (cd gdb/doc; autoconf)
83 (cd gdb/testsuite; autoconf)
84 (cd gdb/testsuite/gdb.asm; autoconf)
85 (cd gdb/testsuite/gdb.base; autoconf)
86 (cd gdb/testsuite/gdb.c++; autoconf)
87 (cd gdb/testsuite/gdb.chill; autoconf)
88 (cd gdb/testsuite/gdb.disasm; autoconf)
89 (cd gdb/testsuite/gdb.fortran; autoconf)
90 (cd gdb/testsuite/gdb.java; autoconf)
91 (cd gdb/testsuite/gdb.mi; autoconf)
92 (cd gdb/testsuite/gdb.stabs; autoconf)
93 (cd gdb/testsuite/gdb.threads; autoconf)
94 (cd gdb/testsuite/gdb.trace; autoconf)
95 (cd gdb/gdbserver; autoconf)
96 # !! Don't enable shared here !!
97 # This will cause serious problems --misiek
98 %configure2_13 \
99         --disable-shared \
100         --enable-nls \
101         --without-included-gettext \
102         --enable-multi-ice \
103         --enable-gdbmi \
104         --enable-gdcli \
105         --enable-netrom \
106         --with-cpu=%{_target_cpu} \
107         --with-x \
108         --enable-tui \
109 %ifnarch alpha
110         --with-mmalloc \
111 %endif
112         --with-mmap
113
114 # something is wrong after above - e.g. $exeext=="no" - fix it:
115 (cd gdb
116 %configure
117 )
118
119 %{__make}
120 %{__make} info
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT%{_infodir}
125
126 %{__make} install install-info \
127         prefix=$RPM_BUILD_ROOT%{_prefix} \
128         bindir=$RPM_BUILD_ROOT%{_bindir} \
129         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
130         infodir=$RPM_BUILD_ROOT%{_infodir} \
131         includedir=$RPM_BUILD_ROOT%{_includedir} \
132         libdir=$RPM_BUILD_ROOT%{_libdir} \
133         mandir=$RPM_BUILD_ROOT%{_mandir}
134
135 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
142
143 %postun
144 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
145
146 %files
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/*
149
150 %{_mandir}/man1/*
151 %lang(es) %{_mandir}/es/man1/*
152 %lang(fr) %{_mandir}/fr/man1/*
153 %lang(hu) %{_mandir}/hu/man1/*
154 %lang(ja) %{_mandir}/ja/man1/*
155 %lang(pl) %{_mandir}/pl/man1/*
156 %{_infodir}/gdb*.info*
157 %{_infodir}/stabs*.info*
This page took 0.128359 seconds and 4 git commands to generate.