]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- updated for 5.2
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
8 Name:           gdb
9 Version:        5.2
10 Release:        1
11 License:        GPL
12 Group:          Development/Debuggers
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
15 Patch0:         %{name}-gettext.patch
16 Patch1:         %{name}-ncurses.patch
17 Patch2:         %{name}-readline.patch
18 Patch3:         %{name}-info.patch
19 Patch4:         %{name}-procfs.patch
20 Patch5:         %{name}-passflags.patch
21 BuildRequires:  ncurses-devel >= 5.2
22 BuildRequires:  readline-devel >= 4.2
23 BuildRequires:  XFree86-devel
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  libtool
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Gdb is a full featured, command driven debugger. Gdb allows you to
31 trace the execution of programs and examine their internal state at
32 any time. Gdb works for C and C++ compiled with the GNU C compiler
33 gcc.
34
35 %description -l de
36 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
37 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
38 kompiliertes C++.
39
40 %description -l es
41 Este es un debugger orientado a comandos repleto de características.
42 Te permite rastrear la ejecución de programas y examinar su estado
43 interno a cualquier momento. Funciona para C y C++ compilado con el
44 compilador GNU C.
45
46 %description -l fr
47 Débugger complet, piloté par commandes. Permet de tracer l'exécution
48 des programmes et d'examiner à tout moment leur état interne.
49 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
50 de GNU, gcc.
51
52 %description -l pl
53 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
54 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
55 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
56 przy pomocy kompilatora GNU (gcc).
57
58 %description -l pt_BR
59 Este é um debugger orientado a comandos repleto de características.
60 Ele permite à você rastrear a execução de programas e examinar o seu
61 estado interno a qualquer momento. Ele funciona para para C e C++
62 compilado com o compilador GNU C.
63
64 %description -l tr
65 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
66 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
67 verir.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74 %patch3 -p1
75 %patch4 -p1
76 %patch5 -p1
77
78 %build
79 (cd gdb; autoconf)
80 (cd gdb/doc; autoconf)
81 (cd gdb/testsuite; autoconf)
82 (cd gdb/testsuite/gdb.asm; autoconf)
83 (cd gdb/testsuite/gdb.base; autoconf)
84 (cd gdb/testsuite/gdb.c++; autoconf)
85 (cd gdb/testsuite/gdb.chill; autoconf)
86 (cd gdb/testsuite/gdb.disasm; autoconf)
87 (cd gdb/testsuite/gdb.fortran; autoconf)
88 (cd gdb/testsuite/gdb.java; autoconf)
89 (cd gdb/testsuite/gdb.mi; autoconf)
90 (cd gdb/testsuite/gdb.stabs; autoconf)
91 (cd gdb/testsuite/gdb.threads; autoconf)
92 (cd gdb/testsuite/gdb.trace; autoconf)
93 (cd gdb/gdbserver; autoconf)
94 # !! Don't enable shared here !!
95 # This will cause serious problems --misiek
96 %configure2_13 \
97         --disable-shared \
98         --enable-nls \
99         --without-included-gettext \
100         --without-included-regex \
101         --enable-gdcli \
102         --enable-gdbmi \
103         --enable-multi-ice \
104         --enable-netrom \
105         --with-cpu=%{_target_cpu} \
106         --enable-tui \
107 %ifnarch alpha
108         --with-mmalloc \
109 %endif
110
111 # something is wrong after above - e.g. $exeext=="no" - fix it:
112 (cd gdb
113 %configure
114 )
115
116 %{__make}
117 %{__make} info
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_infodir}
122
123 %{__make} install install-info \
124         prefix=$RPM_BUILD_ROOT%{_prefix} \
125         bindir=$RPM_BUILD_ROOT%{_bindir} \
126         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
127         infodir=$RPM_BUILD_ROOT%{_infodir} \
128         includedir=$RPM_BUILD_ROOT%{_includedir} \
129         libdir=$RPM_BUILD_ROOT%{_libdir} \
130         mandir=$RPM_BUILD_ROOT%{_mandir}
131
132 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
139
140 %postun
141 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
142
143 %files
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/*
146
147 %{_mandir}/man1/*
148 %lang(es) %{_mandir}/es/man1/*
149 %lang(fr) %{_mandir}/fr/man1/*
150 %lang(hu) %{_mandir}/hu/man1/*
151 %lang(ja) %{_mandir}/ja/man1/*
152 %lang(pl) %{_mandir}/pl/man1/*
153 %{_infodir}/gdb*.info*
154 %{_infodir}/stabs*.info*
This page took 0.073869 seconds and 4 git commands to generate.