]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- spec adapterized.
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        4.18
8 Release:        7
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Source0:        ftp://sourceware.cygnus.com/pub/gdb/%{name}-%{version}.tar.bz2
13 Patch0:         gdb-info.patch
14 Patch1:         gdb-sigtramp.patch
15 Patch2:         gdb-sparc.patch
16 Patch3:         gdb-xref.patch
17 Patch4:         gdb-sparcmin.patch
18 Patch5:         gdb-threads.patch
19 Patch6:         gdb-shared-readline.patch
20 BuildRequires:  ncurses-devel >= 5.0
21 BuildRequires:  readline-devel >= 4.1
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Gdb is a full featured, command driven debugger. Gdb allows you to
26 trace the execution of programs and examine their internal state at
27 any time. Gdb works for C and C++ compiled with the GNU C compiler
28 gcc.
29
30 %description -l de
31 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
32 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
33 kompiliertes C++.
34
35 %description -l fr
36 Débugger complet, piloté par commandes. Permet de tracer l'exécution
37 des programmes et d'examiner à tout moment leur état interne.
38 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
39 de GNU, gcc.
40
41 %description -l pl
42 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
43 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
44 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
45 przy pomocy kompilatora GNU (gcc).
46
47 %description -l tr
48 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
49 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
50 verir.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57 %patch3 -p1
58 %patch4 -p1
59 %patch5 -p1
60 %patch6 -p1
61
62 %build
63 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
64 ./configure %{_target_platform} \
65         --prefix=%{_prefix} \
66         --infodir=%{_infodir} \
67         --mandir=%{_mandir} \
68         --enable-shared
69
70 make
71 make info
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_infodir}
76
77 make install \
78         prefix=$RPM_BUILD_ROOT%{_prefix} \
79         infodir=$RPM_BUILD_ROOT%{_infodir} \
80         mandir=$RPM_BUILD_ROOT%{_mandir}
81
82 # install by hand
83 install gdb/doc/*.info* $RPM_BUILD_ROOT%{_infodir}
84
85 strip $RPM_BUILD_ROOT%{_bindir}/*
86
87 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
88
89 %post
90 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
91
92 %postun
93 [ -x /usr/sbin/fix-info-dir ] && /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_bindir}/*
101
102 %{_mandir}/man1/*
103 %{_infodir}/gdb*.info*
104 %{_infodir}/stabs*.info*
This page took 0.071776 seconds and 4 git commands to generate.