]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
8 Name:           gdb
9 Version:        5.1.1
10 Release:        2
11 License:        GPL
12 Group:          Development/Debuggers
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
15 Patch0:         %{name}-gettext.patch
16 Patch1:         %{name}-ncurses.patch
17 Patch2:         %{name}-readline.patch
18 Patch3:         %{name}-info.patch
19 Patch4:         %{name}-procfs.patch
20 BuildRequires:  ncurses-devel >= 5.2
21 BuildRequires:  readline-devel >= 4.2
22 BuildRequires:  XFree86-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  libtool
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Gdb is a full featured, command driven debugger. Gdb allows you to
30 trace the execution of programs and examine their internal state at
31 any time. Gdb works for C and C++ compiled with the GNU C compiler
32 gcc.
33
34 %description -l de
35 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
36 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
37 kompiliertes C++.
38
39 %description -l es
40 Este es un debugger orientado a comandos repleto de características.
41 Te permite rastrear la ejecución de programas y examinar su estado
42 interno a cualquier momento. Funciona para C y C++ compilado con el
43 compilador GNU C.
44
45 %description -l fr
46 Débugger complet, piloté par commandes. Permet de tracer l'exécution
47 des programmes et d'examiner à tout moment leur état interne.
48 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
49 de GNU, gcc.
50
51 %description -l pl
52 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
53 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
54 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
55 przy pomocy kompilatora GNU (gcc).
56
57 %description -l pt_BR
58 Este é um debugger orientado a comandos repleto de características.
59 Ele permite à você rastrear a execução de programas e examinar o seu
60 estado interno a qualquer momento. Ele funciona para para C e C++
61 compilado com o compilador GNU C.
62
63 %description -l tr
64 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
65 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
66 verir.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75
76 %build
77 (cd gdb; autoconf)
78 (cd gdb/doc; autoconf)
79 (cd gdb/testsuite; autoconf)
80 (cd gdb/testsuite/gdb.asm; autoconf)
81 (cd gdb/testsuite/gdb.base; autoconf)
82 (cd gdb/testsuite/gdb.c++; autoconf)
83 (cd gdb/testsuite/gdb.chill; autoconf)
84 (cd gdb/testsuite/gdb.disasm; autoconf)
85 (cd gdb/testsuite/gdb.fortran; autoconf)
86 (cd gdb/testsuite/gdb.java; autoconf)
87 (cd gdb/testsuite/gdb.mi; autoconf)
88 (cd gdb/testsuite/gdb.stabs; autoconf)
89 (cd gdb/testsuite/gdb.threads; autoconf)
90 (cd gdb/testsuite/gdb.trace; autoconf)
91 (cd gdb/gdbserver; autoconf)
92 # !! Don't enable shared here !! 
93 # This will cause serious problems --misiek
94 %configure2_13 \
95         --disable-shared \
96         --enable-nls \
97         --without-included-gettext \
98         --enable-multi-ice \
99         --enable-gdbmi \
100         --enable-gdcli \
101         --enable-netrom \
102         --with-cpu=%{_target_cpu} \
103         --with-x \
104         --enable-tui \
105 %ifnarch alpha
106         --with-mmalloc \
107 %endif
108         --with-mmap
109
110 # something is wrong after above - e.g. $exeext=="no" - fix it:
111 (cd gdb
112 %configure
113 )
114
115 %{__make}
116 %{__make} info
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{_infodir}
121
122 %{__make} install install-info \
123         prefix=$RPM_BUILD_ROOT%{_prefix} \
124         bindir=$RPM_BUILD_ROOT%{_bindir} \
125         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
126         infodir=$RPM_BUILD_ROOT%{_infodir} \
127         includedir=$RPM_BUILD_ROOT%{_includedir} \
128         libdir=$RPM_BUILD_ROOT%{_libdir} \
129         mandir=$RPM_BUILD_ROOT%{_mandir}
130
131 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
138
139 %postun
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
141
142 %files
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/*
145
146 %{_mandir}/man1/*
147 %lang(es) %{_mandir}/es/man1/*
148 %lang(fr) %{_mandir}/fr/man1/*
149 %lang(hu) %{_mandir}/hu/man1/*
150 %lang(ja) %{_mandir}/ja/man1/*
151 %lang(pl) %{_mandir}/pl/man1/*
152 %{_infodir}/gdb*.info*
153 %{_infodir}/stabs*.info*
This page took 0.092153 seconds and 4 git commands to generate.