]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- cosmetic changes for common l&f,
[packages/gdb.git] / gdb.spec
1 Summary:        Symbolic debugger for C and other languages
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny debugger dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        4.18
8 Release:        1
9 Copyright:      GPL
10 Group:          Development/Debuggers
11 Source:         ftp://sourceware.cygnus.com/pub/gdb/%{name}-4.18.tar.bz2
12 Patch0:         gdb-info.patch
13 Prereq:         /sbin/install-info
14 Buildroot:      /tmp/%{name}-%{version}-root
15
16 %description
17 This is a full featured, command driven debugger. It allows you to
18 trace the exectuion of programs and examine their internal state
19 at any time. It works for C and C++ compiled with the GNU C compiler
20 gcc.
21
22 %description -l de
23 dem Sie die Ausführung von Programmen verfolgen und jederzeit den 
24 inneren Zustand überprüfen können. Er funktioniert für C und mit 
25 GNU C kompiliertes C++. 
26
27 %description -l fr
28 Débugger complet, piloté par commandes. Permet de tracer l'exécution
29 des programmes et d'examiner à tout moment leur état interne. Fonctionne
30 avec les binaires C et C++ compilés avec le compilateur C de GNU, gcc.
31
32 %description -l pl
33 Gdb jest rozbudowanym debugerem, pozwalaj±cym ¶ledziæ wykonanie
34 programu i badaæ jego stan wewnêtrzny. gdb umo¿liwia debugowanie
35 programów napisanych w C i C++ i skompilowanych przy pomocy kompilatora
36 C GNU (egcs).
37
38 %description -l tr
39 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme (trace)
40 ve herhangi bir anda programýn durumunu inceleme olanaðý verir.
41
42 %prep
43 %setup -q
44 #%patch0 -p1
45
46 %build
47 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
48 ./configure \
49         --prefix=/usr 
50 make
51 make info
52 # MAKEINFO="makeinfo --force"
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT/usr
57
58 make install install-info prefix=$RPM_BUILD_ROOT/usr 
59
60 strip $RPM_BUILD_ROOT/usr/bin/*
61
62 rm -f $RPM_BUILD_ROOT/usr/info/{bfd*,history*,readline*,standard*,texinfo*}
63 gzip -fn9 $RPM_BUILD_ROOT/usr/info/*info*
64
65 %post
66 /sbin/install-info /usr/info/gdb.info.gz /etc/info-dir
67 /sbin/install-info /usr/info/stabs.info.gz /etc/info-dir
68 /sbin/install-info /usr/info/gdbint.info.gz /etc/info-dir
69
70 %preun
71 if [ "$1" = 0 ]; then
72         /sbin/install-info --delete /usr/info/gdb.info.gz /usr/info-dir
73         /sbin/install-info --delete /usr/info/stabs.info.gz /etc/info-dir
74         /sbin/install-info --delete /usr/info/gdbint.info.gz /etc/info-dir
75 fi
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %attr(755,root,root) /usr/bin/*
83 /usr/man/man1/*
84 /usr/info/*info*
85
86 %changelog
87 * Tue Apr 13 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
88   [4.18-1]
89 - standarized {un}registering info pages (added gdb-info.patch).
90 - removed man group from man pages.
91
92 * Mon Apr 12 1999 Marcin Dalecki <dalecki@cs.net.pl>
93   [4.18]
94 - updated to this fresh new release.
95
96 * Sat Oct 17 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
97   [4.17.0.4-3]
98 - added gdb-readline_ncurses.patch for compiling gdb agains shared
99   libredline and libncurses.
100
101 * Sun Sep 27 1998 Marcin Korzonek <mkorz@shadow.eu.org>
102 - added pl translation.
103
104 * Thu May 07 1998 Prospector System <bugs@redhat.com>
105 - translations modified for de, fr, tr
106
107 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
108 - upgraded to 4.17
109
110 * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
111 - updated to use a buildroot
112 - uses install-info
113
114 * Tue Aug 19 1997 Erik Troan <ewt@redhat.com>
115 - turned off mmalloc() support, which seems to annoy glibc (resulting in
116   a quick core dump inside of getcwd())
117
118 * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
119 - built against glibc
This page took 0.045957 seconds and 3 git commands to generate.