]> git.pld-linux.org Git - packages/farstream.git/blob - farstream.spec
- updated to 0.1.2
[packages/farstream.git] / farstream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 %include        /usr/lib/rpm/macros.gstreamer
7 Summary:        Audio/Video Communications Framework
8 Name:           farstream
9 Version:        0.1.2
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://freedesktop.org/software/farstream/releases/farstream/%{name}-%{version}.tar.gz
14 # Source0-md5:  5d6e561b3688d0d0c8906fec4f356df3
15 URL:            http://www.freedesktop.org/wiki/Software/Farstream
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= 1:2.30.0
19 BuildRequires:  gobject-introspection-devel >= 0.10.1
20 BuildRequires:  gstreamer-devel >= 0.10.33
21 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.33
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  gupnp-igd-devel
24 BuildRequires:  libnice-devel >= 0.1.0
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-devel >= 1:2.4
28 BuildRequires:  python-gstreamer-devel >= 0.10.10
29 BuildRequires:  python-pygobject-devel >= 2.16.0
30 Obsoletes:      farsight2 < 0.0.32
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The Farstream (formerly Farsight) project is an effort to create a
35 framework to deal with all known audio/video conferencing protocols.
36 On one side it offers a generic API that makes it possible to write
37 plugins for different streaming protocols, on the other side it offers
38 an API for clients to use those plugins.
39
40 The main target clients for Farstream are Instant Messaging
41 applications. These applications should be able to use Farstream for
42 all their Audio/Video conferencing needs without having to worry about
43 any of the lower level streaming and NAT traversal issues.
44
45 %package devel
46 Summary:        Header files for Farstream library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Farstream
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       gstreamer-devel >= 0.10.33
51 Requires:       gstreamer-plugins-base-devel >= 0.10.33
52 Obsoletes:      farsight2-devel < 0.0.32
53
54 %description devel
55 Header files for Farstream library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki Farstream.
59
60 %package static
61 Summary:        Static Farstream library
62 Summary(pl.UTF-8):      Statyczna biblioteka Farstream
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65 Obsoletes:      farsight2-static < 0.0.32
66
67 %description static
68 Static Farstream library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka Farstream.
72
73 %package apidocs
74 Summary:        Farstream API documentation
75 Summary(pl.UTF-8):      Dokumentacja API biblioteki Farstream
76 Group:          Documentation
77 Requires:       gtk-doc-common
78 Obsoletes:      farsight2-apidocs < 0.0.32
79
80 %description apidocs
81 API documentation for Farstream library.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API biblioteki Farstream.
85
86 %package -n python-farstream
87 Summary:        Farstream Python bindings
88 Summary(pl.UTF-8):      Wiązania języka Python do Farstream
89 Group:          Libraries/Python
90 Requires:       %{name} = %{version}-%{release}
91 Obsoletes:      python-farsight2 < 0.0.32
92
93 %description -n python-farstream
94 Farstream Python bindings.
95
96 %description -n python-farstream -l pl.UTF-8
97 Wiązania języka Python do Farstream.
98
99 %prep
100 %setup -q
101
102 %build
103 %{__libtoolize}
104 %{__aclocal} -I m4 -I common/m4
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         %{__enable_disable apidocs gtk-doc} \
110         %{__enable_disable static_libs static} \
111         --disable-silent-rules \
112         --with-html-dir=%{_gtkdocdir}
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{farstream-0.1,gstreamer-0.10}/*.{a,la}
122 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README
134 %attr(755,root,root) %{_libdir}/libfarstream-0.1.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libfarstream-0.1.so.0
136 %{_libdir}/girepository-1.0/Farstream-0.1.typelib
137 %dir %{_libdir}/farstream-0.1
138 %attr(755,root,root) %{_libdir}/farstream-0.1/libmulticast-transmitter.so
139 %attr(755,root,root) %{_libdir}/farstream-0.1/libnice-transmitter.so
140 %attr(755,root,root) %{_libdir}/farstream-0.1/librawudp-transmitter.so
141 %attr(755,root,root) %{_libdir}/farstream-0.1/libshm-transmitter.so
142 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsfunnel.so
143 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsmsnconference.so
144 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsrawconference.so
145 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsrtcpfilter.so
146 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsrtpconference.so
147 %attr(755,root,root) %{_libdir}/gstreamer-0.10/libfsvideoanyrate.so
148 %{_datadir}/farstream
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libfarstream-0.1.so
153 %{_datadir}/gir-1.0/Farstream-0.1.gir
154 %{_includedir}/farstream-0.1
155 %{_pkgconfigdir}/farstream-0.1.pc
156
157 %if %{with static_libs}
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libfarstream-0.1.a
161 %endif
162
163 %if %{with apidocs}
164 %files apidocs
165 %defattr(644,root,root,755)
166 %{_gtkdocdir}/farstream-libs-0.10
167 %{_gtkdocdir}/farstream-plugins-0.1
168 %endif
169
170 %files -n python-farstream
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{py_sitedir}/farstream.so
This page took 0.074497 seconds and 4 git commands to generate.