]> git.pld-linux.org Git - packages/farstream.git/blob - farstream.spec
- unconditional noarch subpackage
[packages/farstream.git] / farstream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Audio/Video Communications Framework
7 Summary(pl.UTF-8):      Szkielet komunikacji Audio/Video
8 Name:           farstream
9 Version:        0.2.9
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        https://freedesktop.org/software/farstream/releases/farstream/%{name}-%{version}.tar.gz
14 # Source0-md5:  35ad6b9e0fb52debeaa2d5194bf5153c
15 Patch0:         %{name}-make.patch
16 URL:            https://www.freedesktop.org/wiki/Software/Farstream
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake
19 BuildRequires:  glib2-devel >= 1:2.40
20 BuildRequires:  gobject-introspection-devel >= 0.10.1
21 BuildRequires:  gstreamer-devel >= 1.4
22 BuildRequires:  gstreamer-plugins-base-devel >= 1.4
23 BuildRequires:  gtk-doc >= 1.18
24 BuildRequires:  gupnp-igd-devel >= 0.2
25 BuildRequires:  libnice-devel >= 0.1.8
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 BuildRequires:  python >= 2.1
29 BuildRequires:  rpm-build >= 4.6
30 Requires:       glib2 >= 1:2.40
31 Requires:       gstreamer >= 1.4
32 Requires:       gstreamer-plugins-base >= 1.4
33 Requires:       gupnp-igd >= 0.2
34 Requires:       libnice >= 0.1.8
35 Obsoletes:      farsight2 < 0.0.32
36 Obsoletes:      python-farsight2 < 0.0.32
37 Obsoletes:      python-farstream < 0.2.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The Farstream (formerly Farsight) project is an effort to create a
42 framework to deal with all known audio/video conferencing protocols.
43 On one side it offers a generic API that makes it possible to write
44 plugins for different streaming protocols, on the other side it offers
45 an API for clients to use those plugins.
46
47 The main target clients for Farstream are Instant Messaging
48 applications. These applications should be able to use Farstream for
49 all their Audio/Video conferencing needs without having to worry about
50 any of the lower level streaming and NAT traversal issues.
51
52 %description -l pl.UTF-8
53 Projekt Farstream (dawniej Farsight) to próba stworzenia szkieletu
54 obsługującego wszystkie znane protokoły konferencji audio/video. Z
55 jednej strony oferuje ogólne API umożliwiające pisanie wtyczek dla
56 różnych protokołów strumieniowych, z drugiej strony oferuje API dla
57 klientów, pozwalającyce im używać tych wtyczek.
58
59 Głównymi klientami szkieletu Farstream mają być aplikacje
60 komunikatorów (IM). Powinny być w stanie używać Farstreama do potrzeb
61 konferencji audio/video bez konieczności obsługi niskopoziomowych
62 poziomów strumieni i omijania NAT-u.
63
64 %package devel
65 Summary:        Header files for Farstream library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Farstream
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       glib2-devel >= 1:2.40
70 Requires:       gstreamer-devel >= 1.4
71 Requires:       gstreamer-plugins-base-devel >= 1.4
72 Obsoletes:      farsight2-devel < 0.0.32
73
74 %description devel
75 Header files for Farstream library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki Farstream.
79
80 %package static
81 Summary:        Static Farstream library
82 Summary(pl.UTF-8):      Statyczna biblioteka Farstream
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Obsoletes:      farsight2-static < 0.0.32
86
87 %description static
88 Static Farstream library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka Farstream.
92
93 %package apidocs
94 Summary:        Farstream API documentation
95 Summary(pl.UTF-8):      Dokumentacja API biblioteki Farstream
96 Group:          Documentation
97 Requires:       gtk-doc-common
98 Obsoletes:      farsight2-apidocs < 0.0.32
99 BuildArch:      noarch
100
101 %description apidocs
102 API documentation for Farstream library.
103
104 %description apidocs -l pl.UTF-8
105 Dokumentacja API biblioteki Farstream.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal} -I m4 -I common/m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         %{__enable_disable apidocs gtk-doc} \
119         %{__enable_disable static_libs static} \
120         --disable-silent-rules \
121         --with-html-dir=%{_gtkdocdir}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{farstream-0.2,gstreamer-1.0}/*.la
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README
142 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libfarstream-0.2.so.5
144 %{_libdir}/girepository-1.0/Farstream-0.2.typelib
145 %dir %{_libdir}/farstream-0.2
146 %attr(755,root,root) %{_libdir}/farstream-0.2/libmulticast-transmitter.so
147 %attr(755,root,root) %{_libdir}/farstream-0.2/libnice-transmitter.so
148 %attr(755,root,root) %{_libdir}/farstream-0.2/librawudp-transmitter.so
149 %attr(755,root,root) %{_libdir}/farstream-0.2/libshm-transmitter.so
150 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrawconference.so
151 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpconference.so
152 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpxdata.so
153 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsvideoanyrate.so
154 %{_datadir}/farstream
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so
159 %{_datadir}/gir-1.0/Farstream-0.2.gir
160 %{_includedir}/farstream-0.2
161 %{_pkgconfigdir}/farstream-0.2.pc
162
163 %if %{with static_libs}
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libfarstream-0.2.a
167 %endif
168
169 %if %{with apidocs}
170 %files apidocs
171 %defattr(644,root,root,755)
172 %{_gtkdocdir}/farstream-libs-0.2
173 %{_gtkdocdir}/farstream-plugins-0.2
174 %endif
This page took 0.085419 seconds and 4 git commands to generate.