]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
- updated to 1.16.4.2
[packages/dpkg.git] / dpkg.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Package maintenance system for Debian Linux
3 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
4 Name:           dpkg
5 Version:        1.16.4.2
6 Release:        1
7 License:        GPL v2+
8 Group:          Applications/File
9 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.bz2
10 # Source0-md5:  537b1861b9842ad350f0b64705aa7aaa
11 URL:            http://packages.debian.org/search?keywords=dpkg
12 BuildRequires:  bzip2-devel
13 BuildRequires:  gettext-devel >= 0.18
14 BuildRequires:  libselinux-devel
15 BuildRequires:  perl-tools-pod
16 BuildRequires:  pkgconfig
17 BuildRequires:  rpm-perlprov
18 BuildRequires:  zlib-devel
19 Requires:       perl-base
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # blacklist false positives
23 %define         _noautoreq      'perl(extra)' 'perl(file)' 'perl(in)' 'perl(Tie::ExtraHash)'
24
25 %description
26 This package contains the programs to handle deb packages known from
27 Debian.
28
29 %description -l pl.UTF-8
30 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
31 Debiana.
32
33 %package -n libdpkg-devel
34 Summary:        dpkg library and header files
35 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
36 Group:          Development/Libraries
37
38 %description -n libdpkg-devel
39 dpkg library and header files.
40
41 %description -n libdpkg-devel -l pl.UTF-8
42 Biblioteka i pliki nagłówkowe dpkg.
43
44 %prep
45 %setup -q
46
47 %build
48 %configure \
49         PO4A="true" \
50         --disable-silent-rules \
51         --enable-shared \
52         --without-dselect \
53         --without-install-info \
54         --without-start-stop-daemon \
55         --with-zlib \
56         --with-bz2 \
57         --with-selinux \
58         --with-admindir=/var/lib/%{name}
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
69
70 # dpkg for main part, dpkg-dev for perl-based build script
71 # don't use --all-name to avoid e.g. dselect inclusion
72 %find_lang dpkg
73 %find_lang dpkg-dev
74 cat dpkg-dev.lang >>dpkg.lang
75
76 # dselect is not packaged
77 %{__rm} -r $RPM_BUILD_ROOT%{_bindir}/dselect \
78         $RPM_BUILD_ROOT%{_libdir}/dpkg/methods \
79         $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/dselect.mo \
80         $RPM_BUILD_ROOT%{_mandir}{,/*}/man1/dselect.1 \
81         $RPM_BUILD_ROOT%{_mandir}{,/*}/man5/dselect.cfg.5 \
82         $RPM_BUILD_ROOT%{perl_vendorlib}/Debian/Dselect
83 # part of info package in PLD; anyway, fix-info-dir is used instead
84 %{__rm} $RPM_BUILD_ROOT%{_sbindir}/install-info
85 # merged into rc-scripts in PLD
86 %{__rm} $RPM_BUILD_ROOT%{_sbindir}/start-stop-daemon \
87         $RPM_BUILD_ROOT%{_mandir}{,/*}/man8/start-stop-daemon.8
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files -f dpkg.lang
93 %defattr(644,root,root,755)
94 %doc AUTHORS ChangeLog README THANKS TODO
95 %attr(755,root,root) %{_bindir}/dpkg*
96 %attr(755,root,root) %{_bindir}/update-alternatives
97 %dir %{_sysconfdir}/alternatives
98 %dir %{_sysconfdir}/dpkg
99 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
100
101 %dir %{_libdir}/dpkg
102 %dir %{_libdir}/dpkg/parsechangelog
103 %attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
104 %dir %{_datadir}/dpkg
105 %{_datadir}/dpkg/abitable
106 %{_datadir}/dpkg/cputable
107 %{_datadir}/dpkg/ostable
108 %{_datadir}/dpkg/triplettable
109 %{_datadir}/dpkg/*.mk
110
111 %{perl_vendorlib}/Dpkg.pm
112 %{perl_vendorlib}/Dpkg
113
114 %dir /var/lib/dpkg
115 %dir /var/lib/dpkg/alternatives
116 %dir /var/lib/dpkg/info
117 %dir /var/lib/dpkg/parts
118 %dir /var/lib/dpkg/updates
119
120 %{_mandir}/man1/dpkg*.1*
121 %{_mandir}/man3/Dpkg::*.3*
122 %{_mandir}/man5/deb*.5*
123 %{_mandir}/man5/dpkg.cfg.5*
124 %{_mandir}/man8/dpkg-*.8*
125 %{_mandir}/man8/update-alternatives.8*
126 %lang(de) %{_mandir}/de/man1/dpkg*.1*
127 %lang(de) %{_mandir}/de/man5/deb*.5*
128 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
129 %lang(de) %{_mandir}/de/man8/dpkg-*.8*
130 %lang(de) %{_mandir}/de/man8/update-alternatives.8*
131 %lang(es) %{_mandir}/es/man1/dpkg*.1*
132 %lang(es) %{_mandir}/es/man5/deb*.5*
133 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
134 %lang(es) %{_mandir}/es/man8/dpkg-*.8*
135 %lang(es) %{_mandir}/es/man8/update-alternatives.8*
136 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
137 %lang(fr) %{_mandir}/fr/man5/deb*.5*
138 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
139 %lang(fr) %{_mandir}/fr/man8/dpkg-*.8*
140 %lang(fr) %{_mandir}/fr/man8/update-alternatives.8*
141 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
142 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
143 %lang(ja) %{_mandir}/ja/man5/deb*.5*
144 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
145 %lang(ja) %{_mandir}/ja/man8/dpkg*.8*
146 %lang(ja) %{_mandir}/ja/man8/update-alternatives.8*
147 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
148 %lang(pl) %{_mandir}/pl/man5/deb*.5*
149 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
150 %lang(pl) %{_mandir}/pl/man8/dpkg-*.8*
151 %lang(pl) %{_mandir}/pl/man8/update-alternatives.8*
152 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
153 %lang(sv) %{_mandir}/sv/man5/deb*.5*
154 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
155 %lang(sv) %{_mandir}/sv/man8/dpkg-*.8*
156 %lang(sv) %{_mandir}/sv/man8/update-alternatives.8*
157
158 %files -n libdpkg-devel
159 %defattr(644,root,root,755)
160 %{_libdir}/libdpkg.a
161 %{_includedir}/dpkg
162 %{_pkgconfigdir}/libdpkg.pc
This page took 0.098152 seconds and 4 git commands to generate.