]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
- Xquit patch
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_with     AC
6 %bcond_without  htmldocs        # do not build documentation in HTML
7 %bcond_without  x               # X support
8 %bcond_with     samba           # samba support
9 #
10 %define         smarthogver     0.1.0
11
12 Summary:        A DOS emulator
13 Summary(de.UTF-8):      DOS-Emulator
14 Summary(es.UTF-8):      Emulador DOS
15 Summary(fr.UTF-8):      Emulateur DOS
16 Summary(pl.UTF-8):      Emulator DOS-a
17 Summary(pt_BR.UTF-8):   Emulador DOS
18 Summary(tr.UTF-8):      DOS öykünümcüsü
19 Name:           dosemu
20 Version:        1.4.0
21 Release:        1%{?with_samba:.smb}
22 License:        GPL v2
23 Group:          Applications/Emulators
24 Source0:        http://dl.sourceforge.net/dosemu/%{name}-%{version}.tgz
25 # Source0-md5:  0bba530637266f99d404ba15e3f118d4
26 #Source2:       %{name}-sys.tar.gz
27 Source3:        %{name}-PRZECZYTAJ_TO
28 Source4:        %{name}-README.PLD
29 Source5:        %{name}.desktop
30 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
31 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
32 Source7:        smarthog-%{smarthogver}.tgz
33 Patch0:         %{name}-man-pages.patch
34 Patch1:         %{name}-make-new.patch
35 Patch2:         %{name}-%{name}_conf.patch
36 Patch3:         %{name}-doSgmlTools.patch
37 Patch4:         %{name}-makehtml.patch
38 Patch5:         http://pascalek.pers.pl/files/projects/Samba4DosEmu/%{name}-1.4.0-samba-beta2.patch.gz
39 Patch6:         http://pascalek.pers.pl/files/projects/Samba4DosEmu/s4d-beta2-fix1.patch
40 Patch7:         %{name}-lpt4.patch
41 Patch8:         %{name}-Xquit.patch
42 URL:            http://www.dosemu.org/
43 BuildRequires:  SDL-devel
44 BuildRequires:  alsa-lib-devel >= 0.9
45 BuildRequires:  autoconf >= 2.59-9
46 BuildRequires:  bin86
47 BuildRequires:  bison
48 BuildRequires:  docbook-dtd30-sgml
49 BuildRequires:  docbook-style-dsssl
50 BuildRequires:  flex
51 %{?with_static:BuildRequires:   glibc-static}
52 BuildRequires:  gpm-devel
53 %{?with_samba:BuildRequires:    libcli_smb-devel}
54 BuildRequires:  libsndfile-devel
55 BuildRequires:  lynx
56 %{?with_htmldocs:BuildRequires: openjade}
57 %{?with_htmldocs:BuildRequires: perl-base}
58 %{?with_htmldocs:BuildRequires: sgml-tools}
59 BuildRequires:  slang-devel
60 %{?with_static:BuildRequires:   slang-static}
61 BuildRequires:  unzip
62 BuildRequires:  util-linux
63 %if %{with x}
64 %if !%{with AC}
65 BuildRequires:  xorg-app-bdftopcf
66 BuildRequires:  xorg-lib-libX11-devel
67 BuildRequires:  xorg-lib-libXext-devel
68 BuildRequires:  xorg-lib-libXxf86vm-devel
69 %if %{with static}
70 BuildRequires:  xorg-lib-libX11-static
71 BuildRequires:  xorg-lib-libXext-static
72 BuildRequires:  xorg-lib-libXxf86vm-static
73 %endif
74 %endif
75 %if %{with AC}
76 BuildRequires:  X11-devel
77 %{?with_static:BuildRequires:   X11-static}
78 %endif
79 %endif
80 Obsoletes:      xdosemu
81 Conflicts:      dosemu-freedos-minimal < 2.0.33
82 Conflicts:      kernel < 2.0.28
83 Conflicts:      mtools < 3.6
84 ExclusiveArch:  %{ix86} %{x8664}
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _dosemudir      /var/lib/dosemu
88 %define         specflags       -fomit-frame-pointer
89
90 %description
91 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
92 emulator by typing in the "dos" command.
93
94 You need to install dosemu if you use DOS programs and you want to be
95 able to run them on your GNU/Linux system. You may also need to
96 install the dosemu-freedos-* packages.
97
98 %description -l pl.UTF-8
99 Dosemu to Emulator systemu DOS. Po zainstalowaniu możesz go uruchomić
100 komendą "dos".
101
102 Jeśli korzystasz z dosowych programów i chciałbyś je uruchamiać na
103 twoim linuksowym systemie zainstaluj dosemu. Możesz też potrzebować
104 pakietów dosemu-freedos-*.
105
106 %description -l pt_BR.UTF-8
107 Essa é uma versão do emulador DOS que foi projetada para rodar em
108 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
109 para mouse.
110
111 %package utils
112 Summary:        Utilities for dosemu
113 Summary(pl.UTF-8):      Programy pomocnicze do dosemu
114 Group:          Applications/Emulators
115 Requires:       %{name} = %{version}-%{release}
116
117 %description utils
118 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
119
120 %description utils -l pl.UTF-8
121 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
122 mkfatimage16.
123
124 %package SDL
125 Summary:        SDL plugin for dosemu
126 Summary(pl.UTF-8):      Wtyczka SDL dla dosemu
127 Group:          Libraries
128 Requires:       %{name} = %{version}-%{release}
129
130 %description SDL
131 SDL plugin for dosemu.
132
133 %description SDL -l pl.UTF-8
134 Wtyczka SDL dla dosemu.
135
136 %package X
137 Summary:        X plugin for dosemu
138 Summary(pl.UTF-8):      Wtyczka X dla dosemu
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141
142 %description X
143 X plugin for dosemu.
144
145 %description X -l pl.UTF-8
146 Wtyczka X dla dosemu.
147
148 %prep
149 %setup -q -a6 -a7
150
151 %patch0 -p1
152 %patch1 -p1
153 %patch2 -p1
154 %patch3 -p1
155 %patch4 -p1
156 %{?with_samba:%patch5 -p1}
157 %{?with_samba:%patch6 -p1}
158 %patch7 -p1
159 %patch8 -p1
160
161 %build
162 OPTFLAGS="%{rpmcflags}"; export OPTFLAGS
163
164 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
165 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
166
167 %{__autoconf}
168 # configure2_13 must be used though because of ./default-configure
169
170 # non-X version
171 %configure2_13 \
172         %{?with_static:--enable-linkstatic} \
173         --enable-new-intcode \
174         --enable-aspi \
175         %{!?with_x:--without-x}
176
177 %{__make} \
178         WAIT=no
179
180 %{__make} -C man
181 mv -f man/dosemu.bin.1 man/dosemu.1
182 echo '.so dosemu.1' > man/dos.1
183 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
184 echo '.so dosemu.1' > man/ru/dos.1
185
186 mv -f pl/man1/dos.1 pl/man1/dosemu.1
187 echo '.so dosemu.1' > pl/man1/dos.1
188 echo '.so dosemu.1' > pl/man1/xdosemu.1
189 echo '.so dosemu.1' > pl/man1/dosdebug.1
190
191 %if %{with htmldocs}
192 # documentation
193 %{__make} -C src/doc/DANG html
194 %{__make} -C src/doc/HOWTO html
195 %{__make} -C src/doc/README html
196
197 find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
198 %endif
199
200 %install
201 rm -rf $RPM_BUILD_ROOT
202 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
203         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
204         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
205         $RPM_BUILD_ROOT%{_libdir}/dosemu
206
207 #%%{__make} install \
208 #       DESTDIR=$RPM_BUILD_ROOT
209
210 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
211 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
212 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
213 %if %{with x}
214 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
215 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
216 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
217 %endif
218
219 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
220
221 install bin/{dosdebug,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
222 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage} $RPM_BUILD_ROOT%{_bindir}
223 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
224
225 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
226 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
227 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
228 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
229
230 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
231 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
232 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
233
234 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
235 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
236 install smarthog-%{smarthogver}/*.exe   $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
237 cp %{SOURCE3} PRZECZYTAJ_TO
238 cp %{SOURCE4} README.PLD
239 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
240
241 rm -f doc/{configuration,dosemu.lsm}
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %files
247 %defattr(644,root,root,755)
248 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
249 %lang(pl) %doc PRZECZYTAJ_TO
250 %dir %{_dosemudir}
251 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
252 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
253 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
254 %attr(755,root,root) %{_bindir}/dos
255 %attr(755,root,root) %{_bindir}/dosdebug
256 %attr(755,root,root) %{_bindir}/dosemu
257 %attr(755,root,root) %{_bindir}/dosexec
258 %attr(755,root,root) %{_bindir}/midid
259 %dir %{_libdir}/dosemu
260 %{_libdir}/dosemu/libplugin_alsa.so
261 %{_libdir}/dosemu/libplugin_gpm.so
262 %{_libdir}/dosemu/libplugin_sndfile.so
263 %{_libdir}/dosemu/libplugin_term.so
264 %dir %{_dosemudir}/bootdir
265 %dir %{_dosemudir}/bootdir/dosemu
266 %{_dosemudir}/bootdir/dosemu/*
267 %{_mandir}/man1/d*
268 %lang(pl) %{_mandir}/pl/man1/d*
269 %lang(ru) %{_mandir}/ru/man1/d*
270 %{_pixmapsdir}/dosemu.xpm
271 %if %{with x}
272 %attr(755,root,root) %{_bindir}/xdos*
273 %{_mandir}/man1/xdosemu.1*
274 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
275 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
276 %{_desktopdir}/dosemu.desktop
277 %endif
278
279 %files utils
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_bindir}/dexeconfig
282 %attr(755,root,root) %{_bindir}/hdinfo
283 %attr(755,root,root) %{_bindir}/mkhdimage
284 %attr(755,root,root) %{_bindir}/mkfatimage16
285 %{_mandir}/man1/mkfatimage16.1*
286 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
287
288 %files SDL
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
291
292 %if %{with x}
293 %files X
294 %defattr(644,root,root,755)
295 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
296 %endif
This page took 0.048334 seconds and 3 git commands to generate.