]> git.pld-linux.org Git - packages/conky.git/blob - conky.spec
- BR: sqlite3-devel
[packages/conky.git] / conky.spec
1 #
2 # Conditional build:
3 %bcond_without  lua_cairo       # without lua cairo bindings
4 %bcond_without  lua_imlib2      # without lua imlib2 bindings
5 #
6 Summary:        A light-weight system monitor
7 Summary(pl.UTF-8):      Monitor systemu dla środowiska graficznego
8 Name:           conky
9 Version:        1.8.1
10 Release:        3
11 License:        Distributable (see COPYING doc)
12 Group:          X11/Applications
13 Source0:        http://downloads.sourceforge.net/conky/%{name}-%{version}.tar.bz2
14 # Source0-md5:  366dc6a5c2ebebfbe6f53da25061b5d6
15 URL:            http://conky.sourceforge.net/
16 BuildRequires:  alsa-lib-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_lua_cairo:BuildRequires:        cairo-devel}
20 BuildRequires:  curl-devel
21 BuildRequires:  expat-devel
22 BuildRequires:  freetype-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  imlib2-devel
26 BuildRequires:  libtool
27 BuildRequires:  lua51-devel >= 5.1
28 BuildRequires:  ncurses-devel
29 BuildRequires:  pkgconfig >= 1:0.19
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  sqlite3-devel
32 %if %{with lua_cairo} || %{with lua_imlib2}
33 BuildRequires:  tolua++-devel >= 1.0.90
34 %endif
35 BuildRequires:  xorg-lib-libXdamage-devel
36 BuildRequires:  xorg-lib-libXext-devel
37 BuildRequires:  xorg-lib-libXft-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Conky is a light-weight system monitor based on the torsmo code. Conky
42 can display arbitrary information (such as the date, CPU temperature
43 from i2c, MPD info, and anything else you desire) to the root window
44 in X11.
45
46 %description -l pl.UTF-8
47 Conky jest niewielkim monitorem systemu opartym na kodzie torsmo. Może
48 wyświetlać takie informacje, jak:
49 - data
50 - temperatura CPU
51 - ilość miejsca na dysku itp.
52
53 %package lua-cairo
54 Summary:        Lua Cairo bindings for Conky
55 Summary(pl.UTF-8):      Dowiązania Lua Cairo dla Conky
56 Group:          Development/Languages
57 Requires:       %{name} = %{version}-%{release}
58
59 %description lua-cairo
60 Lua Cairo bindings for Conky.
61
62 %description lua-cairo -l pl.UTF-8
63 Dowiązania Lua Cairo dla Conky.
64
65 %package lua-imlib2
66 Summary:        Lua Imlib2 bindings for Conky
67 Summary(pl.UTF-8):      Dowiązania Lua Imlib2 dla Conky
68 Group:          Development/Languages
69 Requires:       %{name} = %{version}-%{release}
70
71 %description lua-imlib2
72 Lua Imlib2 bindings for Conky.
73
74 %description lua-imlib2 -l pl.UTF-8
75 Dowiązania Lua Imlib2 dla Conky.
76
77 %prep
78 %setup -q
79 %{__sed} -i 's,lua5.1,lua51,' configure.ac
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         CFLAGS="%{rpmcflags} `pkg-config ncurses --cflags`" \
89         LIBS="-ltinfo" \
90         --enable-curl \
91         --enable-imlib2 \
92         --enable-weather-xoap \
93         %{?with_lua_cairo:--enable-lua-cairo} \
94         %{?with_lua_imlib2:--enable-lua-imlib2}
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 # COPYING must be added (see COPYING file)
110 %doc AUTHORS ChangeLog COPYING README TODO
111 %attr(755,root,root) %{_bindir}/%{name}
112 %dir %{_sysconfdir}/conky
113 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}.conf
114 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}_no_x11.conf
115 %dir %{_libdir}/conky
116 %{_mandir}/man1/%{name}.1*
117
118 %if %{with lua_cairo}
119 %files lua-cairo
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/conky/libcairo.so.*.*.*
122 %{_libdir}/conky/libcairo.so
123 %endif
124
125 %if %{with lua_imlib2}
126 %files lua-imlib2
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/conky/libimlib2.so.*.*.*
129 %{_libdir}/conky/libimlib2.so
130 %endif
This page took 0.04328 seconds and 4 git commands to generate.