]> git.pld-linux.org Git - packages/conky.git/blob - conky.spec
- fix files
[packages/conky.git] / conky.spec
1 #
2 # TODO: fix build with lua. Now when lua enabled conky requires tolua++-devel when installing
3 #
4 # Conditional build:
5 %bcond_with     lua_cairo       # without lua cairo bindings
6 %bcond_with     lua_imlib2      # without lua imlib2 bindings
7 #
8 Summary:        A light-weight system monitor
9 Summary(pl.UTF-8):      Monitor systemu dla środowiska graficznego
10 Name:           conky
11 Version:        1.8.1
12 Release:        5
13 License:        Distributable (see COPYING doc)
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/conky/%{name}-%{version}.tar.bz2
16 # Source0-md5:  366dc6a5c2ebebfbe6f53da25061b5d6
17 URL:            http://conky.sourceforge.net/
18 BuildRequires:  alsa-lib-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_lua_cairo:BuildRequires:        cairo-devel}
22 BuildRequires:  curl-devel
23 BuildRequires:  expat-devel
24 BuildRequires:  freetype-devel
25 BuildRequires:  gettext-tools
26 BuildRequires:  glib2-devel >= 2.0
27 BuildRequires:  imlib2-devel
28 BuildRequires:  libtool
29 BuildRequires:  libxml2-devel
30 BuildRequires:  lua51-devel >= 5.1
31 BuildRequires:  ncurses-devel
32 BuildRequires:  pkgconfig >= 1:0.19
33 BuildRequires:  sed >= 4.0
34 BuildRequires:  sqlite3-devel
35 %if %{with lua_cairo} || %{with lua_imlib2}
36 BuildRequires:  tolua++-devel >= 1.0.90
37 %endif
38 BuildRequires:  xorg-lib-libXdamage-devel
39 BuildRequires:  xorg-lib-libXext-devel
40 BuildRequires:  xorg-lib-libXft-devel
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Conky is a light-weight system monitor based on the torsmo code. Conky
45 can display arbitrary information (such as the date, CPU temperature
46 from i2c, MPD info, and anything else you desire) to the root window
47 in X11.
48
49 %description -l pl.UTF-8
50 Conky jest niewielkim monitorem systemu opartym na kodzie torsmo. Może
51 wyświetlać takie informacje, jak:
52 - data
53 - temperatura CPU
54 - ilość miejsca na dysku itp.
55
56 %package lua-cairo
57 Summary:        Lua Cairo bindings for Conky
58 Summary(pl.UTF-8):      Dowiązania Lua Cairo dla Conky
59 Group:          Development/Languages
60 Requires:       %{name} = %{version}-%{release}
61
62 %description lua-cairo
63 Lua Cairo bindings for Conky.
64
65 %description lua-cairo -l pl.UTF-8
66 Dowiązania Lua Cairo dla Conky.
67
68 %package lua-imlib2
69 Summary:        Lua Imlib2 bindings for Conky
70 Summary(pl.UTF-8):      Dowiązania Lua Imlib2 dla Conky
71 Group:          Development/Languages
72 Requires:       %{name} = %{version}-%{release}
73
74 %description lua-imlib2
75 Lua Imlib2 bindings for Conky.
76
77 %description lua-imlib2 -l pl.UTF-8
78 Dowiązania Lua Imlib2 dla Conky.
79
80 %prep
81 %setup -q
82 %{__sed} -i 's,lua5.1,lua51,' configure.ac
83
84 %build
85 %{__libtoolize}
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         CFLAGS="%{rpmcflags} `pkg-config ncurses --cflags`" \
92         --enable-curl \
93         --enable-imlib2 \
94         --enable-weather-xoap \
95         --enable-wlan \
96         --enable-rss \
97         %{?with_lua_cairo:--enable-lua-cairo} \
98         %{?with_lua_imlib2:--enable-lua-imlib2}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 # COPYING must be added (see COPYING file)
114 %doc AUTHORS ChangeLog COPYING README TODO
115 %attr(755,root,root) %{_bindir}/%{name}
116 %dir %{_sysconfdir}/conky
117 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}.conf
118 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}_no_x11.conf
119 %if %{with lua_cairo} || %{with lua_imlib2}
120 %dir %{_libdir}/conky
121 %endif
122 %{_mandir}/man1/%{name}.1*
123
124 %if %{with lua_cairo}
125 %files lua-cairo
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/conky/libcairo.so.*.*.*
128 %{_libdir}/conky/libcairo.so
129 %endif
130
131 %if %{with lua_imlib2}
132 %files lua-imlib2
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/conky/libimlib2.so.*.*.*
135 %{_libdir}/conky/libimlib2.so
136 %endif
This page took 0.069902 seconds and 4 git commands to generate.