]> git.pld-linux.org Git - packages/conky.git/blob - conky.spec
- BR: tolua++-devel will install tolua++ as well
[packages/conky.git] / conky.spec
1 #
2 # Conditional build:
3 %bcond_without  lua_cairo       # without lua cairo bindings
4 #
5 Summary:        A light-weight system monitor
6 Summary(pl.UTF-8):      Monitor systemu dla środowiska graficznego
7 Name:           conky
8 Version:        1.8.1
9 Release:        3
10 License:        Distributable (see COPYING doc)
11 Group:          X11/Applications
12 Source0:        http://downloads.sourceforge.net/conky/%{name}-%{version}.tar.bz2
13 # Source0-md5:  366dc6a5c2ebebfbe6f53da25061b5d6
14 URL:            http://conky.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 %{?with_lua_cairo:BuildRequires:cairo-devel}
18 BuildRequires:  expat-devel
19 BuildRequires:  freetype-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 2.0
22 BuildRequires:  libtool
23 BuildRequires:  lua51-devel >= 5.1
24 BuildRequires:  ncurses-devel
25 BuildRequires:  pkgconfig >= 1:0.19
26 BuildRequires:  sed >= 4.0
27 %{?with_lua_cairo:BuildRequires:tolua++-devel >= 1.0.90}
28 BuildRequires:  xorg-lib-libXdamage-devel
29 BuildRequires:  xorg-lib-libXext-devel
30 BuildRequires:  xorg-lib-libXft-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Conky is a light-weight system monitor based on the torsmo code. Conky
35 can display arbitrary information (such as the date, CPU temperature
36 from i2c, MPD info, and anything else you desire) to the root window
37 in X11.
38
39 %description -l pl.UTF-8
40 Conky jest niewielkim monitorem systemu opartym na kodzie torsmo. Może
41 wyświetlać takie informacje, jak:
42 - data
43 - temperatura CPU
44 - ilość miejsca na dysku itp.
45
46 %package lua-cairo
47 Summary:        Lua Cairo bindings for Conky
48 Summary(pl.UTF-8):      Dowiązania Lua Cairo dla Conky
49 Group:          Development/Languages
50
51 %description lua-cairo
52 Lua Cairo bindings for Conky.
53
54 %description lua-cairo -l pl.UTF-8
55 Dowiązania Lua Cairo dla Conky.
56
57 %prep
58 %setup -q
59 %{__sed} -i 's,lua5.1,lua51,' configure.ac
60
61 %build
62 %{__libtoolize}
63 %{__aclocal} -I m4
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 %configure \
68         CFLAGS="%{rpmcflags} `pkg-config ncurses --cflags`" \
69         LIBS="-ltinfo" \
70         %{?with_lua_cairo:--enable-lua-cairo}
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 # COPYING must be added (see COPYING file)
85 %doc AUTHORS ChangeLog COPYING README TODO
86 %attr(755,root,root) %{_bindir}/%{name}
87 %dir %{_sysconfdir}/conky
88 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}.conf
89 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}_no_x11.conf
90 %dir %{_libdir}/conky
91 %{_mandir}/man1/%{name}.1*
92
93 %if %{with lua_cairo}
94 %files lua-cairo
95 %defattr(644,root,root,755)
96 %{_libdir}/conky/libcairo.so.*.*.*
97 %{_libdir}/conky/libcairo.so
98 %ghost %{_libdir}/conky/libcairo.so.0
99 %endif
This page took 0.039842 seconds and 4 git commands to generate.