]> git.pld-linux.org Git - packages/conky.git/blob - conky.spec
- BR: cairo-devel when building with lua_cairo
[packages/conky.git] / conky.spec
1 #
2 # TODO: create separates subpackages for lua bindings
3 #
4 # Conditional build:
5 %bcond_without  lua_cairo       # without lua cairo bindings
6 #
7 Summary:        A light-weight system monitor
8 Summary(pl.UTF-8):      Monitor systemu dla środowiska graficznego
9 Name:           conky
10 Version:        1.8.1
11 Release:        3
12 License:        Distributable (see COPYING doc)
13 Group:          X11/Applications
14 Source0:        http://downloads.sourceforge.net/conky/%{name}-%{version}.tar.bz2
15 # Source0-md5:  366dc6a5c2ebebfbe6f53da25061b5d6
16 URL:            http://conky.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_lua_cairo:BuildRequires:cairo-devel}
20 BuildRequires:  expat-devel
21 BuildRequires:  freetype-devel
22 BuildRequires:  gettext-devel
23 BuildRequires:  glib2-devel >= 2.0
24 BuildRequires:  libtool
25 BuildRequires:  lua51-devel >= 5.1
26 BuildRequires:  ncurses-devel
27 BuildRequires:  pkgconfig >= 1:0.19
28 BuildRequires:  sed >= 4.0
29 %{?with_lua_cairo:BuildRequires:tolua++-devel >= 1.0.90}
30 BuildRequires:  xorg-lib-libXdamage-devel
31 BuildRequires:  xorg-lib-libXext-devel
32 BuildRequires:  xorg-lib-libXft-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Conky is a light-weight system monitor based on the torsmo code. Conky
37 can display arbitrary information (such as the date, CPU temperature
38 from i2c, MPD info, and anything else you desire) to the root window
39 in X11.
40
41 %description -l pl.UTF-8
42 Conky jest niewielkim monitorem systemu opartym na kodzie torsmo. Może
43 wyświetlać takie informacje, jak:
44 - data
45 - temperatura CPU
46 - ilość miejsca na dysku itp.
47
48 %prep
49 %setup -q
50 %{__sed} -i 's,lua5.1,lua51,' configure.ac
51
52 %build
53 %{__libtoolize}
54 %{__aclocal} -I m4
55 %{__autoconf}
56 %{__autoheader}
57 %{__automake}
58 %configure \
59         CFLAGS="%{rpmcflags} `pkg-config ncurses --cflags`" \
60         LIBS="-ltinfo" \
61         %{?with_lua_cairo:--enable-lua-cairo}
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 # COPYING must be added (see COPYING file)
76 %doc AUTHORS ChangeLog COPYING README TODO
77 %attr(755,root,root) %{_bindir}/%{name}
78 %dir %{_sysconfdir}/conky
79 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}.conf
80 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}_no_x11.conf
81 %dir %{_libdir}/conky
82 # TODO: create separate subapackages for lua bindings
83 %if %{with lua_cairo}
84 %{_libdir}/conky/libcairo.so.*.*.*
85 %{_libdir}/conky/libcairo.so
86 %ghost %{_libdir}/conky/libcairo.so.0
87 %endif
88 %{_mandir}/man1/%{name}.1*
This page took 0.070884 seconds and 4 git commands to generate.