]> git.pld-linux.org Git - packages/conky.git/blob - conky.spec
- release 2
[packages/conky.git] / conky.spec
1 #
2 # TODO: fix build with lua. Now when lua enabled conky requires tolua++-devel when installing
3 #
4 # Conditional build:
5 %bcond_with     lua_cairo       # without lua cairo bindings
6 %bcond_with     lua_imlib2      # without lua imlib2 bindings
7 #
8 Summary:        A light-weight system monitor
9 Summary(pl.UTF-8):      Monitor systemu dla środowiska graficznego
10 Name:           conky
11 Version:        1.8.1
12 Release:        2
13 License:        Distributable (see COPYING doc)
14 Group:          X11/Applications
15 Source0:        http://downloads.sourceforge.net/conky/%{name}-%{version}.tar.bz2
16 # Source0-md5:  366dc6a5c2ebebfbe6f53da25061b5d6
17 URL:            http://conky.sourceforge.net/
18 BuildRequires:  alsa-lib-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_lua_cairo:BuildRequires:        cairo-devel}
22 BuildRequires:  curl-devel
23 BuildRequires:  expat-devel
24 BuildRequires:  freetype-devel
25 BuildRequires:  gettext-devel
26 BuildRequires:  glib2-devel >= 2.0
27 BuildRequires:  imlib2-devel
28 BuildRequires:  libtool
29 BuildRequires:  lua51-devel >= 5.1
30 BuildRequires:  ncurses-devel
31 BuildRequires:  pkgconfig >= 1:0.19
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  sqlite3-devel
34 %if %{with lua_cairo} || %{with lua_imlib2}
35 BuildRequires:  tolua++-devel >= 1.0.90
36 %endif
37 BuildRequires:  xorg-lib-libXdamage-devel
38 BuildRequires:  xorg-lib-libXext-devel
39 BuildRequires:  xorg-lib-libXft-devel
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Conky is a light-weight system monitor based on the torsmo code. Conky
44 can display arbitrary information (such as the date, CPU temperature
45 from i2c, MPD info, and anything else you desire) to the root window
46 in X11.
47
48 %description -l pl.UTF-8
49 Conky jest niewielkim monitorem systemu opartym na kodzie torsmo. Może
50 wyświetlać takie informacje, jak:
51 - data
52 - temperatura CPU
53 - ilość miejsca na dysku itp.
54
55 %package lua-cairo
56 Summary:        Lua Cairo bindings for Conky
57 Summary(pl.UTF-8):      Dowiązania Lua Cairo dla Conky
58 Group:          Development/Languages
59 Requires:       %{name} = %{version}-%{release}
60
61 %description lua-cairo
62 Lua Cairo bindings for Conky.
63
64 %description lua-cairo -l pl.UTF-8
65 Dowiązania Lua Cairo dla Conky.
66
67 %package lua-imlib2
68 Summary:        Lua Imlib2 bindings for Conky
69 Summary(pl.UTF-8):      Dowiązania Lua Imlib2 dla Conky
70 Group:          Development/Languages
71 Requires:       %{name} = %{version}-%{release}
72
73 %description lua-imlib2
74 Lua Imlib2 bindings for Conky.
75
76 %description lua-imlib2 -l pl.UTF-8
77 Dowiązania Lua Imlib2 dla Conky.
78
79 %prep
80 %setup -q
81 %{__sed} -i 's,lua5.1,lua51,' configure.ac
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         CFLAGS="%{rpmcflags} `pkg-config ncurses --cflags`" \
91         LIBS="-ltinfo" \
92         --enable-curl \
93         --enable-imlib2 \
94         --enable-weather-xoap \
95         %{?with_lua_cairo:--enable-lua-cairo} \
96         %{?with_lua_imlib2:--enable-lua-imlib2}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 # COPYING must be added (see COPYING file)
112 %doc AUTHORS ChangeLog COPYING README TODO
113 %attr(755,root,root) %{_bindir}/%{name}
114 %dir %{_sysconfdir}/conky
115 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}.conf
116 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}_no_x11.conf
117 %dir %{_libdir}/conky
118 %{_mandir}/man1/%{name}.1*
119
120 %if %{with lua_cairo}
121 %files lua-cairo
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/conky/libcairo.so.*.*.*
124 %{_libdir}/conky/libcairo.so
125 %endif
126
127 %if %{with lua_imlib2}
128 %files lua-imlib2
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/conky/libimlib2.so.*.*.*
131 %{_libdir}/conky/libimlib2.so
132 %endif
This page took 0.050982 seconds and 4 git commands to generate.