]> git.pld-linux.org Git - packages/conky.git/blob - conky.spec
- lua_imlib2 bcond
[packages/conky.git] / conky.spec
1 #
2 # Conditional build:
3 %bcond_without  lua_cairo       # without lua cairo bindings
4 %bcond_without  lua_imlib2      # without lua imlib2 bindings
5 #
6 Summary:        A light-weight system monitor
7 Summary(pl.UTF-8):      Monitor systemu dla środowiska graficznego
8 Name:           conky
9 Version:        1.8.1
10 Release:        3
11 License:        Distributable (see COPYING doc)
12 Group:          X11/Applications
13 Source0:        http://downloads.sourceforge.net/conky/%{name}-%{version}.tar.bz2
14 # Source0-md5:  366dc6a5c2ebebfbe6f53da25061b5d6
15 URL:            http://conky.sourceforge.net/
16 BuildRequires:  alsa-lib-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_lua_cairo:BuildRequires:        cairo-devel}
20 BuildRequires:  curl-devel
21 BuildRequires:  expat-devel
22 BuildRequires:  freetype-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 2.0
25 BuildRequires:  imlib2-devel
26 BuildRequires:  libtool
27 BuildRequires:  lua51-devel >= 5.1
28 BuildRequires:  ncurses-devel
29 BuildRequires:  pkgconfig >= 1:0.19
30 BuildRequires:  sed >= 4.0
31 %if %{with lua_cairo} || %{with lua_imlib2}
32 BuildRequires:  tolua++-devel >= 1.0.90
33 %endif
34 BuildRequires:  xorg-lib-libXdamage-devel
35 BuildRequires:  xorg-lib-libXext-devel
36 BuildRequires:  xorg-lib-libXft-devel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Conky is a light-weight system monitor based on the torsmo code. Conky
41 can display arbitrary information (such as the date, CPU temperature
42 from i2c, MPD info, and anything else you desire) to the root window
43 in X11.
44
45 %description -l pl.UTF-8
46 Conky jest niewielkim monitorem systemu opartym na kodzie torsmo. Może
47 wyświetlać takie informacje, jak:
48 - data
49 - temperatura CPU
50 - ilość miejsca na dysku itp.
51
52 %package lua-cairo
53 Summary:        Lua Cairo bindings for Conky
54 Summary(pl.UTF-8):      Dowiązania Lua Cairo dla Conky
55 Group:          Development/Languages
56 Requires:       %{name} = %{version}-%{release}
57
58 %description lua-cairo
59 Lua Cairo bindings for Conky.
60
61 %description lua-cairo -l pl.UTF-8
62 Dowiązania Lua Cairo dla Conky.
63
64 %package lua-imlib2
65 Summary:        Lua Imlib2 bindings for Conky
66 Summary(pl.UTF-8):      Dowiązania Lua Imlib2 dla Conky
67 Group:          Development/Languages
68 Requires:       %{name} = %{version}-%{release}
69
70 %description lua-imlib2
71 Lua Imlib2 bindings for Conky.
72
73 %description lua-imlib2 -l pl.UTF-8
74 Dowiązania Lua Imlib2 dla Conky.
75
76 %prep
77 %setup -q
78 %{__sed} -i 's,lua5.1,lua51,' configure.ac
79
80 %build
81 %{__libtoolize}
82 %{__aclocal} -I m4
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         CFLAGS="%{rpmcflags} `pkg-config ncurses --cflags`" \
88         LIBS="-ltinfo" \
89         --enable-curl \
90         --enable-imlib2 \
91         %{?with_lua_cairo:--enable-lua-cairo} \
92         %{?with_lua_imlib2:--enable-lua-imlib2}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 # COPYING must be added (see COPYING file)
108 %doc AUTHORS ChangeLog COPYING README TODO
109 %attr(755,root,root) %{_bindir}/%{name}
110 %dir %{_sysconfdir}/conky
111 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}.conf
112 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conky/%{name}_no_x11.conf
113 %dir %{_libdir}/conky
114 %{_mandir}/man1/%{name}.1*
115
116 %if %{with lua_cairo}
117 %files lua-cairo
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/conky/libcairo.so.*.*.*
120 %{_libdir}/conky/libcairo.so
121 %endif
122
123 %if %{with lua_imlib2}
124 %files lua-imlib2
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/conky/libimlib2.so.*.*.*
127 %{_libdir}/conky/libimlib2.so
128 %endif
This page took 0.067467 seconds and 4 git commands to generate.