]> git.pld-linux.org Git - packages/cloog-isl.git/blob - cloog-isl.spec
- updated to 0.18.5
[packages/cloog-isl.git] / cloog-isl.spec
1 #
2 # Conditional build:
3 %bcond_without  osl     # OpenScop support
4 #
5 %define isl_ver 0.18
6 Summary:        The Chunky Loop Generator
7 Summary(pl.UTF-8):      Chunky Loop Generator - generator pętli cząstkowych
8 Name:           cloog-isl
9 Version:        0.18.5
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Development/Tools
13 # older?
14 #Source0:       http://www.bastoul.net/cloog/pages/download/cloog-%{version}.tar.gz
15 #Source0Download: https://github.com/periscop/cloog/releases
16 Source0:        https://github.com/periscop/cloog/releases/download/cloog-%{version}/cloog-%{version}.tar.gz
17 # Source0-md5:  7e9058076193d8f53aae40cab94ad017
18 URL:            http://www.cloog.org/
19 BuildRequires:  autoconf >= 2.53
20 BuildRequires:  automake
21 BuildRequires:  gmp-devel >= 5.0.2
22 BuildRequires:  gmp-c++-devel >= 5.0.2
23 BuildRequires:  isl-devel >= %{isl_ver}
24 BuildRequires:  libtool
25 %{?with_osl:BuildRequires:      osl-devel >= 0.9.1}
26 BuildRequires:  texinfo-texi2dvi
27 Requires:       %{name}-libs = %{version}-%{release}
28 Provides:       cloog = %{version}
29 Obsoletes:      cloog
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 CLooG is a software which generates loops for scanning Z-polyhedra.
34 That is, CLooG finds the code or pseudo-code where each integral point
35 of one or more parametrized polyhedron or parametrized polyhedra union
36 is reached. CLooG is designed to avoid control overhead and to produce
37 a very efficient code.
38
39 This version is based on isl.
40
41 %description -l pl.UTF-8
42 CLooG to oprogramowanie generujące pętle do przeszukiwania
43 Z-wielościanów (Z-polyhedra). Oznacza to, że CLooG znajduje kod lub
44 pseudokod osiągający każdy punkt całkowity jednego lub większej liczby
45 sparametryzowanych wielościanów lub sum sparametryzowanych
46 wielościanów. CLooG jest zaprojektowany z myślą o zapobieganiu
47 narzutowi na sterowaniu oraz generowaniu bardzo wydajnego kodu.
48
49 Ta wersja jest oparta na bibliotece isl.
50
51 %package libs
52 Summary:        Chunky Loop Generator shared library - isl based version
53 Summary(pl.UTF-8):      Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na isl
54 Group:          Libraries
55 Requires:       isl >= %{isl_ver}
56 %{?with_osl:Requires:   osl >= 0.9.1}
57
58 %description libs
59 Chunky Loop Generator shared library - isl based version.
60
61 %description libs -l pl.UTF-8
62 Biblioteka współdzielona Chunky Loop Generatora - wersja oparta na
63 isl.
64
65 %package devel
66 Summary:        Header files for the isl based version of Chunky Loop Generator
67 Summary(pl.UTF-8):      Pliki nagłówkowe opartej na isl wersji Chunky Loop Generatora
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       gmp-devel >= 5.0.2
71 Requires:       gmp-c++-devel >= 5.0.2
72 Requires:       isl-devel >= %{isl_ver}
73 %{?with_osl:Requires:   osl-devel >= 0.9.1}
74 Provides:       cloog-devel = %{version}
75
76 %description devel
77 The header files for Chunky Loop Generator library.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe biblioteki Chunky Loop Generatora.
81
82 %package static
83 Summary:        Static library of isl based version of Chunky Loop Generator
84 Summary(pl.UTF-8):      Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static library of isl based version of Chunky Loop Generator.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka opartej na isl wersji Chunky Loop Generatora.
93
94 %prep
95 %setup -q -n cloog-%{version}
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__automake}
102 # with_gmp_exec_prefix=yes avoids adding -L/lib to LDFLAGS
103 %configure \
104         --disable-silent-rules \
105         --with-gmp-exec-prefix \
106         --with-isl=system \
107         %{?with_osl:--with-osl=system}
108
109 %{__make}
110
111 %{__make} -C doc cloog.pdf
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   libs -p /sbin/ldconfig
123 %postun libs -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/cloog
128
129 %files libs
130 %defattr(644,root,root,755)
131 %doc ChangeLog README
132 %attr(755,root,root) %{_libdir}/libcloog-isl.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libcloog-isl.so.4
134
135 %files devel
136 %defattr(644,root,root,755)
137 %doc doc/cloog.pdf
138 %attr(755,root,root) %{_libdir}/libcloog-isl.so
139 %{_libdir}/libcloog-isl.la
140 %dir %{_includedir}/cloog
141 %{_includedir}/cloog/*.h
142 %{_includedir}/cloog/isl
143 %{_includedir}/cloog/matrix
144 %dir %{_libdir}/cloog-isl
145 %{_libdir}/cloog-isl/cloog-isl-config.cmake
146 %dir %{_libdir}/isl
147 %{_libdir}/isl/isl-config.cmake
148 %{_pkgconfigdir}/cloog-isl.pc
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libcloog-isl.a
This page took 0.197966 seconds and 3 git commands to generate.