]> git.pld-linux.org Git - packages/cln.git/blob - cln.spec
- BR: texinfo
[packages/cln.git] / cln.spec
1 Summary:        C++ Class Library for Numbers
2 Summary(pl):    Biblioteka klas C++ dla liczb
3 Name:           cln
4 Version:        1.1.9
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  76fbeeeeac1559e482b404b4674915e2
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.ginac.de/CLN/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  gmp-devel >= 3.0
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  texinfo
19 Requires:       gmp >= 3.0
20 Obsoletes:      libcln2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # won't work with -O0 because of static const initialization loops
24 %define         debugcflags     -O1 -g
25
26 %description
27 A GPLed collection of C++ math classes and functions, that will bring
28 efficiency, type safety, algebraic syntax to everyone in a memory and
29 speed efficient library.
30
31 %description -l pl
32 Objêty licencj± GPL zbiór klas i funkcji matematycznych C++ daj±cy
33 wydajno¶æ, bezpieczne typy i sk³adniê algebraiczn±.
34
35 %package devel
36 Summary:        Development files for programs using the CLN library
37 Summary(pl):    Pliki do programowania z u¿yciem biblioteki CLN
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       gmp-devel >= 3.0
41 Requires:       libstdc++-devel
42 Obsoletes:      libcln2-devel
43
44 %description devel
45 This package is necessary if you wish to develop software based on the
46 CLN library.
47
48 %description devel -l pl
49 Ten pakiet jest niezbêdny do tworzenia oprogramowania opartego na
50 bibliotece CLN.
51
52 %package static
53 Summary:        Static CLN library
54 Summary(pl):    Statyczna biblioteka CLN
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static CLN library.
60
61 %description static -l pl
62 Statyczna biblioteka CLN.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68
69 # kill m4/libtool.m4 inclusion
70 head -n 871 autoconf/aclocal.m4 > acinclude.m4
71
72 %build
73 %{__libtoolize}
74 %{__aclocal}
75 %{__autoconf}
76 %configure
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %post devel
95 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
96
97 %postun devel
98 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog NEWS README TODO*
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/cln-config
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %{_libdir}/lib*.la
110 %{_includedir}/cln
111 %{_mandir}/man1/cln-config.1*
112 %{_infodir}/*.info*
113 %{_aclocaldir}/*.m4
114 %{_pkgconfigdir}/*.pc
115 %{_examplesdir}/%{name}-%{version}
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/lib*.a
This page took 0.034269 seconds and 4 git commands to generate.