]> git.pld-linux.org Git - packages/cln.git/blob - cln.spec
- release 2 (by relup.sh)
[packages/cln.git] / cln.spec
1 Summary:        C++ Class Library for Numbers
2 Summary(pl.UTF-8):      Biblioteka klas C++ dla liczb
3 Name:           cln
4 Version:        1.3.3
5 Release:        2
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  9871c401133a12182ad6a3bed89fb3c4
10 Patch0:         %{name}-info.patch
11 URL:            http://www.ginac.de/CLN/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.10
14 BuildRequires:  gmp-devel >= 3.0
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  tetex-dvips
18 BuildRequires:  tetex-fonts-latex
19 BuildRequires:  tetex-format-plain
20 BuildRequires:  tetex-metafont
21 BuildRequires:  texconfig
22 BuildRequires:  texinfo
23 BuildRequires:  texinfo-texi2dvi
24 Requires:       gmp >= 3.0
25 Obsoletes:      libcln2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # won't work with -O0 because of static const initialization loops
29 %define         debugcflags     -O1 -g
30
31 %description
32 A GPLed collection of C++ math classes and functions, that will bring
33 efficiency, type safety, algebraic syntax to everyone in a memory and
34 speed efficient library.
35
36 %description -l pl.UTF-8
37 Objęty licencją GPL zbiór klas i funkcji matematycznych C++ dający
38 wydajność, bezpieczne typy i składnię algebraiczną.
39
40 %package devel
41 Summary:        Development files for programs using the CLN library
42 Summary(pl.UTF-8):      Pliki do programowania z użyciem biblioteki CLN
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       gmp-devel >= 3.0
46 Requires:       libstdc++-devel
47 Obsoletes:      libcln2-devel
48
49 %description devel
50 This package is necessary if you wish to develop software based on the
51 CLN library.
52
53 %description devel -l pl.UTF-8
54 Ten pakiet jest niezbędny do tworzenia oprogramowania opartego na
55 bibliotece CLN.
56
57 %package static
58 Summary:        Static CLN library
59 Summary(pl.UTF-8):      Statyczna biblioteka CLN
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static CLN library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka CLN.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79 %configure
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %post   devel -p /sbin/postshell
98 -/usr/sbin/fix-info-dir -c %{_infodir}
99
100 %postun devel -p /sbin/postshell
101 -/usr/sbin/fix-info-dir -c %{_infodir}
102
103 %files
104 %defattr(644,root,root,755)
105 %doc NEWS README TODO
106 %attr(755,root,root) %{_bindir}/pi
107 %attr(755,root,root) %{_libdir}/libcln.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libcln.so.6
109 %{_mandir}/man1/pi.1*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libcln.so
114 %{_libdir}/libcln.la
115 %{_includedir}/cln
116 %{_infodir}/cln.info*
117 %{_pkgconfigdir}/cln.pc
118 %{_examplesdir}/%{name}-%{version}
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libcln.a
This page took 0.029941 seconds and 4 git commands to generate.