]> git.pld-linux.org Git - packages/cln.git/blob - cln.spec
- updated to 1.1.10 (note: SONAME has changed)
[packages/cln.git] / cln.spec
1 Summary:        C++ Class Library for Numbers
2 Summary(pl):    Biblioteka klas C++ dla liczb
3 Name:           cln
4 Version:        1.1.10
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  f194811dadcd2b1dca5f78a62370eb56
10 Patch0:         %{name}-info.patch
11 #Patch1:                %{name}-link.patch
12 URL:            http://www.ginac.de/CLN/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  gmp-devel >= 3.0
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  tetex-dvips
19 BuildRequires:  tetex-fonts-latex
20 BuildRequires:  tetex-format-plain
21 BuildRequires:  tetex-metafont
22 BuildRequires:  texinfo
23 BuildRequires:  texinfo-texi2dvi
24 Requires:       gmp >= 3.0
25 Obsoletes:      libcln2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # won't work with -O0 because of static const initialization loops
29 %define         debugcflags     -O1 -g
30
31 %description
32 A GPLed collection of C++ math classes and functions, that will bring
33 efficiency, type safety, algebraic syntax to everyone in a memory and
34 speed efficient library.
35
36 %description -l pl
37 Objêty licencj± GPL zbiór klas i funkcji matematycznych C++ daj±cy
38 wydajno¶æ, bezpieczne typy i sk³adniê algebraiczn±.
39
40 %package devel
41 Summary:        Development files for programs using the CLN library
42 Summary(pl):    Pliki do programowania z u¿yciem biblioteki CLN
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       gmp-devel >= 3.0
46 Requires:       libstdc++-devel
47 Obsoletes:      libcln2-devel
48
49 %description devel
50 This package is necessary if you wish to develop software based on the
51 CLN library.
52
53 %description devel -l pl
54 Ten pakiet jest niezbêdny do tworzenia oprogramowania opartego na
55 bibliotece CLN.
56
57 %package static
58 Summary:        Static CLN library
59 Summary(pl):    Statyczna biblioteka CLN
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static CLN library.
65
66 %description static -l pl
67 Statyczna biblioteka CLN.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 rm -f m4/libtool.m4
74
75 %build
76 %{__libtoolize}
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %configure
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %post devel
98 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
99
100 %postun devel
101 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
102
103 %files
104 %defattr(644,root,root,755)
105 %doc ChangeLog NEWS README TODO*
106 %attr(755,root,root) %{_libdir}/libcln.so.*.*.*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_bindir}/cln-config
111 %attr(755,root,root) %{_libdir}/libcln.so
112 %{_libdir}/libcln.la
113 %{_includedir}/cln
114 %{_mandir}/man1/cln-config.1*
115 %{_infodir}/cln.info*
116 %{_aclocaldir}/cln.m4
117 %{_pkgconfigdir}/cln.pc
118 %{_examplesdir}/%{name}-%{version}
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libcln.a
This page took 0.055755 seconds and 4 git commands to generate.