]> git.pld-linux.org Git - packages/cln.git/blob - cln.spec
- BR: tetex-, texinfo-texi2dvi
[packages/cln.git] / cln.spec
1 Summary:        C++ Class Library for Numbers
2 Summary(pl):    Biblioteka klas C++ dla liczb
3 Name:           cln
4 Version:        1.1.9
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  76fbeeeeac1559e482b404b4674915e2
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.ginac.de/CLN/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  gmp-devel >= 3.0
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  tetex-dvips
19 BuildRequires:  tetex-fonts-latex
20 BuildRequires:  tetex-format-plain
21 BuildRequires:  tetex-metafont
22 BuildRequires:  texinfo
23 BuildRequires:  texinfo-texi2dvi
24 Requires:       gmp >= 3.0
25 Obsoletes:      libcln2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # won't work with -O0 because of static const initialization loops
29 %define         debugcflags     -O1 -g
30
31 %description
32 A GPLed collection of C++ math classes and functions, that will bring
33 efficiency, type safety, algebraic syntax to everyone in a memory and
34 speed efficient library.
35
36 %description -l pl
37 Objêty licencj± GPL zbiór klas i funkcji matematycznych C++ daj±cy
38 wydajno¶æ, bezpieczne typy i sk³adniê algebraiczn±.
39
40 %package devel
41 Summary:        Development files for programs using the CLN library
42 Summary(pl):    Pliki do programowania z u¿yciem biblioteki CLN
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       gmp-devel >= 3.0
46 Requires:       libstdc++-devel
47 Obsoletes:      libcln2-devel
48
49 %description devel
50 This package is necessary if you wish to develop software based on the
51 CLN library.
52
53 %description devel -l pl
54 Ten pakiet jest niezbêdny do tworzenia oprogramowania opartego na
55 bibliotece CLN.
56
57 %package static
58 Summary:        Static CLN library
59 Summary(pl):    Statyczna biblioteka CLN
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static CLN library.
65
66 %description static -l pl
67 Statyczna biblioteka CLN.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73
74 # kill m4/libtool.m4 inclusion
75 head -n 871 autoconf/aclocal.m4 > acinclude.m4
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %configure
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %post devel
100 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
101
102 %postun devel
103 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
104
105 %files
106 %defattr(644,root,root,755)
107 %doc ChangeLog NEWS README TODO*
108 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_bindir}/cln-config
113 %attr(755,root,root) %{_libdir}/lib*.so
114 %{_libdir}/lib*.la
115 %{_includedir}/cln
116 %{_mandir}/man1/cln-config.1*
117 %{_infodir}/*.info*
118 %{_aclocaldir}/*.m4
119 %{_pkgconfigdir}/*.pc
120 %{_examplesdir}/%{name}-%{version}
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/lib*.a
This page took 0.057874 seconds and 4 git commands to generate.