]> git.pld-linux.org Git - packages/cln.git/blob - cln.spec
- gmp version
[packages/cln.git] / cln.spec
1 Summary:        C++ Class Library for Numbers
2 Summary(pl):    Biblioteka klas C++ dla liczb
3 Name:           cln
4 Version:        1.1.8
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  490dd0697b3d16b2ba6a843829228cba
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.ginac.de/CLN/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  gmp-devel >= 3.0
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 Requires:       gmp >= 3.0
19 Obsoletes:      libcln2
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # won't work with -O0 because of static const initialization loops
23 %define         debugcflags     -O1 -g
24
25 %description
26 A GPLed collection of C++ math classes and functions, that will bring
27 efficiency, type safety, algebraic syntax to everyone in a memory and
28 speed efficient library.
29
30 %description -l pl
31 Objêty licencj± GPL zbiór klas i funkcji matematycznych C++ daj±cy
32 wydajno¶æ, bezpieczne typy i sk³adniê algebraiczn±.
33
34 %package devel
35 Summary:        Development files for programs using the CLN library
36 Summary(pl):    Pliki do programowania z u¿yciem biblioteki CLN
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       gmp-devel >= 3.0
40 Requires:       libstdc++-devel
41 Obsoletes:      libcln2-devel
42
43 %description devel
44 This package is necessary if you wish to develop software based on the
45 CLN library.
46
47 %description devel -l pl
48 Ten pakiet jest niezbêdny do tworzenia oprogramowania opartego na
49 bibliotece CLN.
50
51 %package static
52 Summary:        Static CLN library
53 Summary(pl):    Statyczna biblioteka CLN
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static CLN library.
59
60 %description static -l pl
61 Statyczna biblioteka CLN.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67
68 # kill AC_PROG_LIBTOOL
69 head -n 423 autoconf/aclocal.m4 > acinclude.m4
70 tail -n +4045 autoconf/aclocal.m4 >> acinclude.m4
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I . -I m4
75 %{__autoconf}
76 %configure
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %post devel
95 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
96
97 %postun devel
98 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
99
100 %files
101 %defattr(644,root,root,755)
102 %doc ChangeLog NEWS README TODO*
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_bindir}/cln-config
108 %attr(755,root,root) %{_libdir}/lib*.so
109 %{_libdir}/lib*.la
110 %{_includedir}/cln
111 %{_mandir}/man1/cln-config.1*
112 %{_infodir}/*.info*
113 %{_aclocaldir}/*.m4
114 %{_pkgconfigdir}/*.pc
115 %{_examplesdir}/%{name}-%{version}
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/lib*.a
This page took 0.071013 seconds and 4 git commands to generate.