]> git.pld-linux.org Git - packages/cln.git/blob - cln.spec
- debugcflags -O1 (crashes if built with -O0)
[packages/cln.git] / cln.spec
1 Summary:        C++ Class Library for Numbers
2 Summary(pl):    Biblioteka klas C++ dla liczb
3 Name:           cln
4 Version:        1.1.8
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  490dd0697b3d16b2ba6a843829228cba
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.ginac.de/CLN/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  gmp-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 Obsoletes:      libcln2
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # won't work with -O0 because of static const initialization loops
22 %define         debugcflags     -O1 -g
23
24 %description
25 A GPLed collection of C++ math classes and functions, that will bring
26 efficiency, type safety, algebraic syntax to everyone in a memory and
27 speed efficient library.
28
29 %description -l pl
30 Objêty licencj± GPL zbiór klas i funkcji matematycznych C++ daj±cy
31 wydajno¶æ, bezpieczne typy i sk³adniê algebraiczn±.
32
33 %package devel
34 Summary:        Development files for programs using the CLN library
35 Summary(pl):    Pliki do programowania z u¿yciem biblioteki CLN
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       gmp-devel
39 Requires:       libstdc++-devel
40 Obsoletes:      libcln2-devel
41
42 %description devel
43 This package is necessary if you wish to develop software based on the
44 CLN library.
45
46 %description devel -l pl
47 Ten pakiet jest niezbêdny do tworzenia oprogramowania opartego na
48 bibliotece CLN.
49
50 %package static
51 Summary:        Static CLN library
52 Summary(pl):    Statyczna biblioteka CLN
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static CLN library.
58
59 %description static -l pl
60 Statyczna biblioteka CLN.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66
67 # kill AC_PROG_LIBTOOL
68 head -n 423 autoconf/aclocal.m4 > acinclude.m4
69 tail -n +4045 autoconf/aclocal.m4 >> acinclude.m4
70
71 %build
72 %{__libtoolize}
73 %{__aclocal} -I . -I m4
74 %{__autoconf}
75 %configure
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %post devel
94 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
95
96 %postun devel
97 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
98
99 %files
100 %defattr(644,root,root,755)
101 %doc ChangeLog NEWS README TODO*
102 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_bindir}/cln-config
107 %attr(755,root,root) %{_libdir}/lib*.so
108 %{_libdir}/lib*.la
109 %{_includedir}/cln
110 %{_mandir}/man1/cln-config.1*
111 %{_infodir}/*.info*
112 %{_aclocaldir}/*.m4
113 %{_pkgconfigdir}/*.pc
114 %{_examplesdir}/%{name}-%{version}
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/lib*.a
This page took 0.057798 seconds and 4 git commands to generate.