]> git.pld-linux.org Git - packages/check.git/blob - check.spec
- pass -fPIC to CFLAGS
[packages/check.git] / check.spec
1 Summary:        Check - unit testing framework for C
2 Summary(pl):    Check - szkielet testów jednostkowych dla C
3 Name:           check
4 Version:        0.9.3
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
9 # Source0-md5:  6e5870f7c9c5414572158d8005e91d68
10 URL:            http://check.sourceforge.net/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Check is a unit test framework for C. It features a simple interface
15 for defining unit tests, putting little in the way of the developer.
16 Tests are run in a separate address space, so Check can catch both
17 assertion failures and code errors that cause segmentation faults or
18 other signals. The output from unit tests can be used within source
19 code editors and IDEs.
20
21 %description -l pl
22 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
23 definiowania testów jednostkowych, nie przeszkadzaj±cy zbytnio
24 programi¶cie. Testy s± uruchamiane w wydzielonej przestrzeni
25 adresowej, dziêki czemu Check mo¿e wy³apaæ zarówno niepowodzenia
26 zapewnieñ (assert), jak i b³êdy w kodzie powoduj±ce naruszenie
27 ochrony pamiêci lub inne sygna³y. Wyj¶cie z testów jednostkowych mo¿e
28 byæ u¿ywane z poziomu edytorów kodu ¼ród³owego i IDE.
29
30 %prep
31 %setup -q
32
33 %build
34 %configure2_13
35 %{__make} \
36     CFLAGS="%{rpmcflags} -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -fPIC"
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc AUTHORS ChangeLog* NEWS README doc/*.html
50 %{_libdir}/libcheck.a
51 %{_includedir}/check.h
52 %{_aclocaldir}/check.m4
This page took 0.050184 seconds and 4 git commands to generate.