]> git.pld-linux.org Git - packages/check.git/blob - check.spec
- ldconfig, .so symlink
[packages/check.git] / check.spec
1 Summary:        Check - unit testing framework for C
2 Summary(pl):    Check - szkielet testów jednostkowych dla C
3 Name:           check
4 Version:        0.9.5
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/check/%{name}-%{version}.tar.gz
9 # Source0-md5:  30143c7974b547a12a7da47809a90951
10 URL:            http://check.sourceforge.net/
11 BuildRequires:  libtool
12 BuildRequires:  texinfo >= 4.2
13 Requires(post,postun):  /sbin/ldconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Check is a unit test framework for C. It features a simple interface
18 for defining unit tests, putting little in the way of the developer.
19 Tests are run in a separate address space, so Check can catch both
20 assertion failures and code errors that cause segmentation faults or
21 other signals. The output from unit tests can be used within source
22 code editors and IDEs.
23
24 %description -l pl
25 Check to szkielet testów jednostkowych dla C. Ma prosty interfejs do
26 definiowania testów jednostkowych, nie przeszkadzaj±cy zbytnio
27 programi¶cie. Testy s± uruchamiane w wydzielonej przestrzeni
28 adresowej, dziêki czemu Check mo¿e wy³apaæ zarówno niepowodzenia
29 zapewnieñ (assert), jak i b³êdy w kodzie powoduj±ce naruszenie
30 ochrony pamiêci lub inne sygna³y. Wyj¶cie z testów jednostkowych mo¿e
31 byæ u¿ywane z poziomu edytorów kodu ¼ród³owego i IDE.
32
33 %prep
34 %setup -q
35
36 %build
37 %configure2_13
38 %{__make} \
39         CFLAGS="%{rpmcflags} -Wall -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -fPIC"
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} install \
45         exampledir=%{_examplesdir}/%{name}-%{version} \
46         examplesrcdir=%{_examplesdir}/%{name}-%{version}/src \
47         exampletestsdir=%{_examplesdir}/%{name}-%{version}/tests \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
51 rm -f $RPM_BUILD_ROOT%{_libdir}/libcheck.la
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /sbin/ldconfig
58 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
59
60 %postun
61 /sbin/ldconfig
62 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
63
64 %files
65 %defattr(644,root,root,755)
66 %doc AUTHORS ChangeLog* NEWS README SVNChangeLog
67 %attr(755,root,root) %{_libdir}/libcheck.so.*.*.*
68 %attr(755,root,root) %{_libdir}/libcheck.so
69 # -static ?
70 %{_libdir}/libcheck.a
71 %{_includedir}/check.h
72 %{_aclocaldir}/check.m4
73 %{_pkgconfigdir}/check.pc
74 %{_infodir}/check.info*
75 %{_examplesdir}/%{name}-%{version}
This page took 0.046297 seconds and 4 git commands to generate.