]> git.pld-linux.org Git - packages/avahi.git/blob - avahi.spec
- updated for 0.6.26
[packages/avahi.git] / avahi.spec
1 #
2 # TODO:
3 #       - finish with_apidocs
4 #       - check BRs for gtk+3
5 #       - make gtk3 bcond enabled by default when gtk+3 will be stable
6 #       - files
7 #
8 # Conditional build:
9 %bcond_with     apidocs         # build API documentation
10 %bcond_without  dotnet          # build without dotnet bindings
11 %bcond_without  gtk             # build without GTK+
12 %bcond_with     gtk3            # build without GTK+3
13 %bcond_without  pygtk           # build without PyGTK
14 %bcond_without  qt              # build without (any) qt bindings
15 %bcond_without  qt3             # build without qt3 bindings
16 %bcond_without  qt4             # build without qt4 bindings
17
18 %ifnarch %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
19 %undefine with_dotnet
20 %endif
21 %ifarch i386
22 %undefine with_dotnet
23 %endif
24
25 %if %{without qt}
26 %undefine       with_qt3
27 %undefine       with_qt4
28 %endif
29
30 %{?with_dotnet:%include /usr/lib/rpm/macros.mono}
31 Summary:        Free mDNS/DNS-SD/Zeroconf implementation
32 Summary(pl.UTF-8):      Wolna implementacja mDNS/DNS-SD/Zeroconf
33 Name:           avahi
34 Version:        0.6.26
35 Release:        0.1
36 License:        LGPL v2.1+
37 Group:          Applications
38 Source0:        http://avahi.org/download/%{name}-%{version}.tar.gz
39 # Source0-md5:  2b2b1899fcec5ae74e92f111598913a1
40 Source1:        %{name}-daemon
41 Source2:        %{name}-dnsconfd
42 Source3:        %{name}.png
43 Source4:        %{name}-daemon.upstart
44 Source5:        %{name}-dnsconfd.upstart
45 Patch0:         %{name}-desktop.patch
46 Patch1:         %{name}-glade.patch
47 Patch2:         %{name}-destdir.patch
48 Patch3:         %{name}-mono-dir.patch
49 Patch4:         nss-mdns-package.patch
50 Patch5:         %{name}-dhclient_hooks.patch
51 Patch6:         %{name}-autoipd-sbin_ip.patch
52 URL:            http://avahi.org/
53 BuildRequires:  autoconf
54 BuildRequires:  automake
55 BuildRequires:  dbus-devel >= 0.92
56 %if %{with apidocs}
57 BuildRequires:  doxygen
58 # for the 'dot' tool used by doxygen
59 BuildRequires:  graphviz
60 %endif
61 BuildRequires:  expat-devel
62 BuildRequires:  gdbm-devel
63 BuildRequires:  gettext-devel
64 %if %{with gtk}
65 BuildRequires:  glib2-devel >= 1:2.12.2
66 BuildRequires:  gtk+2-devel >= 2:2.10.2
67 BuildRequires:  libglade2-devel >= 1:2.6.0
68 %endif
69 %if %{with gtk3}
70 BuildRequires:  glib2-devel
71 BuildRequires:  gtk+3-devel
72 BuildRequires:  libglade2-devel
73 %endif
74 BuildRequires:  intltool >= 0.35
75 BuildRequires:  libcap-devel
76 BuildRequires:  libdaemon-devel >= 0.11
77 BuildRequires:  libtool
78 %if %{with dotnet}
79 BuildRequires:  dotnet-gtk-sharp2-devel >= 2.10
80 BuildRequires:  mono-csharp
81 BuildRequires:  monodoc >= 2.6
82 %endif
83 BuildRequires:  pkgconfig
84 BuildRequires:  python >= 1:2.4
85 BuildRequires:  python-dbus >= 0.71
86 %{?with_pygtk:BuildRequires:    python-pygtk-devel >= 2:2.9.6}
87 %if %{with qt3}
88 BuildRequires:  qt-devel >= 1:3.0
89 %endif
90 %if %{with qt4}
91 BuildRequires:  QtCore-devel
92 BuildRequires:  qt4-build
93 %endif
94 BuildRequires:  rpm-pythonprov
95 BuildRequires:  rpmbuild(macros) >= 1.561
96 Requires(post,preun):   /sbin/chkconfig
97 Requires:       %{name}-libs = %{version}-%{release}
98 Requires:       dbus >= 0.92
99 Requires:       libdaemon >= 0.11
100 Requires:       rc-scripts >= 0.4.3
101 Suggests:       nss_mdns >= 0.10-2
102 Provides:       group(avahi)
103 Provides:       user(avahi)
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %description
107 Avahi is an implementation the DNS Service Discovery and Multicast DNS
108 specifications for Zeroconf Computing. It uses D-BUS for communication
109 between user applications and a system daemon.
110
111 %description -l pl.UTF-8
112 Avahi jest implementacją specyfikacji DNS Service Discovery i
113 Multicast DNS dla Zeroconf Computing. Używa D-BUSa dla komunikacji
114 pomiędzy programami użytkownika a demonem systemowym.
115
116 %package upstart
117 Summary:        Upstart jobs description for Avahi daemons
118 Summary(pl.UTF-8):      Opis zadań Upstart dla demonów Avahi
119 Group:          Daemons
120 Requires:       %{name} = %{version}-%{release}
121 Requires:       upstart >= 0.6
122
123 %description upstart
124 Upstart jobs description for Avahi daemons.
125
126 %description upstart -l pl.UTF-8
127 Opis zadań Upstart dla demonów Avahi.
128
129 %package autoipd
130 Summary:        IPv4LL network address configuration daemon
131 Summary(pl.UTF-8):      Demon configurujący adresy IPv4LL
132 Group:          Networking/Daemons
133 Requires(postun):       /usr/sbin/groupdel
134 Requires(postun):       /usr/sbin/userdel
135 Requires(pre):  /bin/id
136 Requires(pre):  /usr/bin/getgid
137 Requires(pre):  /usr/sbin/groupadd
138 Requires(pre):  /usr/sbin/useradd
139 Provides:       group(avahi)
140 Provides:       user(avahi)
141
142 %description autoipd
143 avahi-autoipd implements IPv4LL, "Dynamic Configuration of IPv4 Link-
144 Local Addresses" (IETF RFC3927), a protocol for automatic IP address
145 configuration from the link-local 169.254.0.0/16 range without the
146 need for a central server. It is primarily intended to be used in
147 ad-hoc networks which lack a DHCP server.
148
149 IPv4LL is part of the Zeroconf stack.
150
151 %description autoipd -l pl.UTF-8
152 avahi-autoipd jest implementacją IPv4LL, protokołu umożliwiającego
153 automatyczną konfigurację adresu z zakresu 169.254.0.0/16 bez potrzeby
154 użycia centralnego serwera. Jego głównym zastosowaniem są sieci
155 ad-hoc, w których brakuje serwera DHCP.
156
157 IPv4LL jest częścią stosu Zeroconf.
158
159 %package libs
160 Summary:        Avahi client, common and core libraries
161 Summary(pl.UTF-8):      Biblioteki Avahi: klienta, wspólna i główna
162 Group:          Libraries
163
164 %description libs
165 Avahi client, common and core libraries.
166
167 %description libs -l pl.UTF-8
168 Biblioteki Avahi: klienta, wspólna i główna.
169
170 %package devel
171 Summary:        Header files for Avahi library
172 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi
173 Group:          Development/Libraries
174 Requires:       %{name}-libs = %{version}-%{release}
175 Requires:       dbus-devel >= 0.92
176 Requires:       expat-devel
177
178 %description devel
179 This is the package containing the header files for Avahi library.
180
181 %description devel -l pl.UTF-8
182 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi.
183
184 %package static
185 Summary:        Static Avahi library
186 Summary(pl.UTF-8):      Statyczna biblioteka Avahi
187 Group:          Development/Libraries
188 Requires:       %{name}-devel = %{version}-%{release}
189
190 %description static
191 Static Avahi library.
192
193 %description static -l pl.UTF-8
194 Statyczna biblioteka Avahi.
195
196 %package ui
197 Summary:        Avahi UI library
198 Summary(pl.UTF-8):      Biblioteka Avahi UI
199 Group:          X11/Libraries
200 Requires:       %{name}-libs = %{version}-%{release}
201 Requires:       gtk+2 >= 2:2.10.2
202
203 %description ui
204 Common GTK+ UI support library for Avahi.
205
206 %description ui -l pl.UTF-8
207 Biblioteka wspólnego interfejsu użytkownika GTK+ dla Avahi.
208
209 %package ui-devel
210 Summary:        Header files for Avahi UI library
211 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Avahi UI
212 Group:          X11/Development/Libraries
213 Requires:       %{name}-devel = %{version}-%{release}
214 Requires:       %{name}-ui = %{version}-%{release}
215 Requires:       gtk+2-devel >= 2:2.10.2
216
217 %description ui-devel
218 Header files for Avahi UI library.
219
220 %description ui-devel -l pl.UTF-8
221 Pliki nagłówkowe biblioteki Avahi UI.
222
223 %package ui-static
224 Summary:        Static Avahi UI library
225 Summary(pl.UTF-8):      Statyczna biblioteka Avahi UI
226 Group:          X11/Development/Libraries
227 Requires:       %{name}-ui-devel = %{version}-%{release}
228
229 %description ui-static
230 Static Avahi UI library.
231
232 %description ui-static -l pl.UTF-8
233 Statyczna biblioteka Avahi UI.
234
235 %package compat-libdns_sd
236 Summary:        Avahi Bonjour compat library
237 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Bonjour
238 Group:          Libraries
239 Provides:       mdns-bonjour
240 Obsoletes:      mDNSResponder-libs
241
242 %description compat-libdns_sd
243 Avahi Bonjour compat library.
244
245 %description compat-libdns_sd -l pl.UTF-8
246 Biblioteka Avahi zgodna z Bonjour.
247
248 %package compat-libdns_sd-devel
249 Summary:        Header files for Avahi Bonjour compat library
250 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour
251 Group:          Development/Libraries
252 Requires:       %{name}-compat-libdns_sd = %{version}-%{release}
253 Requires:       %{name}-devel = %{version}-%{release}
254 Provides:       mdns-bonjour-devel
255 Obsoletes:      mDNSResponder-devel
256
257 %description compat-libdns_sd-devel
258 Header files for Avahi Bonjour compat library.
259
260 %description compat-libdns_sd-devel -l pl.UTF-8
261 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Bonjour.
262
263 %package compat-libdns_sd-static
264 Summary:        Static Avahi Bonjour compat library
265 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Bonjour
266 Group:          Development/Libraries
267 Requires:       %{name}-compat-libdns_sd-devel = %{version}-%{release}
268 Provides:       mdns-bonjour-static
269
270 %description compat-libdns_sd-static
271 Static Avahi Bonjour compat library.
272
273 %description compat-libdns_sd-static -l pl.UTF-8
274 Statyczna biblioteka Avahi zgodna z Bonjour.
275
276 %package compat-howl
277 Summary:        Avahi Howl compat library
278 Summary(pl.UTF-8):      Biblioteka Avahi zgodna z Howl
279 Group:          Libraries
280 Provides:       mdns-howl-libs
281 Obsoletes:      howl-libs
282
283 %description compat-howl
284 Avahi Howl compat library.
285
286 %description compat-howl -l pl.UTF-8
287 Biblioteka Avahi zgodna z Howl.
288
289 %package compat-howl-devel
290 Summary:        Header files for Avahi Howl compat library
291 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl
292 Group:          Development/Libraries
293 Requires:       %{name}-compat-howl = %{version}-%{release}
294 Requires:       %{name}-devel = %{version}-%{release}
295 Provides:       mdns-howl-devel
296 Obsoletes:      howl-devel
297
298 %description compat-howl-devel
299 Header files for Avahi Howl compat library.
300
301 %description compat-howl-devel -l pl.UTF-8
302 Pliki nagłówkowe wiązań Avahi dla biblioteki zgodnej z Howl.
303
304 %package compat-howl-static
305 Summary:        Static Avahi Howl compat library
306 Summary(pl.UTF-8):      Statyczna biblioteka Avahi zgodna z Howl
307 Group:          Development/Libraries
308 Requires:       %{name}-compat-howl-devel = %{version}-%{release}
309 Provides:       mdns-howl-static
310 Obsoletes:      howl-static
311
312 %description compat-howl-static
313 Static Avahi Howl compat library.
314
315 %description compat-howl-static -l pl.UTF-8
316 Statyczna biblioteka Avahi zgodna z Howl.
317
318 %package glib
319 Summary:        Avahi GLib library bindings
320 Summary(pl.UTF-8):      Wiązania Avahi dla bibioteki GLib
321 Group:          Libraries
322
323 %description glib
324 Avahi GLib library bindings.
325
326 %description glib -l pl.UTF-8
327 Wiązania Avahi dla bibioteki GLib.
328
329 %package glib-devel
330 Summary:        Header files for Avahi GLib library bindings
331 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki GLib
332 Group:          Development/Libraries
333 Requires:       %{name}-devel = %{version}-%{release}
334 Requires:       %{name}-glib = %{version}-%{release}
335 Requires:       glib2-devel >= 1:2.12.2
336
337 %description glib-devel
338 This is the package containing the header files for Avahi-glib
339 library.
340
341 %description glib-devel -l pl.UTF-8
342 Ten pakiet zawiera pliki nagłówkowe biblioteki Avahi-glib.
343
344 %package glib-static
345 Summary:        Static Avahi GLib library
346 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GLib
347 Group:          Development/Libraries
348 Requires:       %{name}-glib-devel = %{version}-%{release}
349
350 %description glib-static
351 Static Avahi GLib library.
352
353 %description glib-static -l pl.UTF-8
354 Statyczna biblioteka Avahi GLib.
355
356 %package gobject
357 Summary:        Avahi GObject interface
358 Summary(pl.UTF-8):      Interfejs GObject do Avahi
359 Group:          Libraries
360
361 %description gobject
362 Avahi GObject interface.
363
364 %description gobject -l pl.UTF-8
365 Interfejs GObject do Avahi.
366
367 %package gobject-devel
368 Summary:        Header files for Avahi GObject interface
369 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu GObject do Avahi
370 Group:          Development/Libraries
371 Requires:       %{name}-devel = %{version}-%{release}
372 Requires:       %{name}-gobject = %{version}-%{release}
373 Requires:       glib2-devel >= 1:2.12.2
374
375 %description gobject-devel
376 This is the package containing the header files for Avahi GObject
377 interface.
378
379 %description gobject-devel -l pl.UTF-8
380 Ten pakiet zawiera pliki nagłówkowe interfejsu GObject do Avahi.
381
382 %package gobject-static
383 Summary:        Static Avahi GObject library
384 Summary(pl.UTF-8):      Statyczna biblioteka Avahi GObject
385 Group:          Development/Libraries
386 Requires:       %{name}-gobject-devel = %{version}-%{release}
387
388 %description gobject-static
389 Static Avahi GObject library.
390
391 %description gobject-static -l pl.UTF-8
392 Statyczna biblioteka Avahi GObject.
393
394 %package qt
395 Summary:        Avahi Qt 3 library bindings
396 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 3
397 Group:          Libraries
398 Requires:       %{name}-libs = %{version}-%{release}
399 Obsoletes:      avahi-qt3
400
401 %description qt
402 Avahi Qt 3 library bindings.
403
404 %description qt -l pl.UTF-8
405 Wiązania Avahi dla biblioteki Qt 3.
406
407 %package qt-devel
408 Summary:        Header files for Avahi Qt 3 library bindings
409 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3
410 Group:          Development/Libraries
411 Requires:       %{name}-devel = %{version}-%{release}
412 Requires:       %{name}-qt = %{version}-%{release}
413 Requires:       qt-devel >= 1:3.0
414 Obsoletes:      avahi-qt3-devel
415
416 %description qt-devel
417 Header files for Avahi Qt 3 library bindings.
418
419 %description qt-devel -l pl.UTF-8
420 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 3.
421
422 %package qt-static
423 Summary:        Static Avahi Qt 3 library
424 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 3
425 Group:          Development/Libraries
426 Requires:       %{name}-qt-devel = %{version}-%{release}
427 Obsoletes:      avahi-qt3-static
428
429 %description qt-static
430 Static Avahi Qt 3 library.
431
432 %description qt-static -l pl.UTF-8
433 Statyczna biblioteka Avahi Qt 3.
434
435 %package Qt
436 Summary:        Avahi Qt 4 library bindings
437 Summary(pl.UTF-8):      Wiązania Avahi dla biblioteki Qt 4
438 Group:          Libraries
439 Requires:       %{name}-libs = %{version}-%{release}
440
441 %description Qt
442 Avahi Qt 4 library bindings.
443
444 %description Qt -l pl.UTF-8
445 Wiązania Avahi dla biblioteki Qt 4.
446
447 %package Qt-devel
448 Summary:        Header files for Avahi Qt 4 library bindings
449 Summary(pl.UTF-8):      Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4
450 Group:          Development/Libraries
451 Requires:       %{name}-Qt = %{version}-%{release}
452 Requires:       %{name}-devel = %{version}-%{release}
453
454 %description Qt-devel
455 Header files for Avahi Qt 4 library bindings.
456
457 %description Qt-devel -l pl.UTF-8
458 Pliki nagłówkowe wiązań Avahi dla biblioteki Qt 4.
459
460 %package Qt-static
461 Summary:        Static Avahi Qt 4 library
462 Summary(pl.UTF-8):      Statyczna biblioteka Avahi Qt 4
463 Group:          Development/Libraries
464 Requires:       %{name}-Qt-devel = %{version}-%{release}
465
466 %description Qt-static
467 Static Avahi Qt 4 library.
468
469 %description Qt-static -l pl.UTF-8
470 Statyczna biblioteka Avahi Qt 4.
471
472 %package -n python-avahi
473 Summary:        Avahi Python bindings
474 Summary(pl.UTF-8):      Wiązania Avahi dla Pythona
475 Group:          Development/Languages/Python
476 Requires:       %{name}-libs = %{version}-%{release}
477 Requires:       python-dbus >= 0.71
478
479 %description -n python-avahi
480 Avahi Python bindings.
481
482 %description -n python-avahi -l pl.UTF-8
483 Wiązania Avahi dla Pythona.
484
485 %package -n dotnet-avahi
486 Summary:        Avahi MONO bindings
487 Summary(pl.UTF-8):      Wiązania Avahi dla MONO
488 Group:          Libraries
489 Requires:       %{name}-libs = %{version}-%{release}
490
491 %description -n dotnet-avahi
492 Avahi MONO bindings.
493
494 %description -n dotnet-avahi -l pl.UTF-8
495 Wiązania Avahi dla MONO.
496
497 %package -n dotnet-avahi-devel
498 Summary:        Development files for MONO Avahi bindings
499 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi dla MONO
500 Group:          Development/Libraries
501 Requires:       dotnet-avahi = %{version}-%{release}
502 Requires:       monodoc >= 2.6
503
504 %description -n dotnet-avahi-devel
505 Development files for MONO Avahi bindings.
506
507 %description -n dotnet-avahi-devel -l pl.UTF-8
508 Pliki rozwojowe wiązań Avahi dla MONO.
509
510 %package -n dotnet-avahi-ui
511 Summary:        Avahi UI MONO bindings
512 Summary(pl.UTF-8):      Wiązania Avahi UI dla MONO
513 Group:          X11/Libraries
514 Requires:       %{name}-ui = %{version}-%{release}
515 Requires:       dotnet-avahi = %{version}-%{release}
516
517 %description -n dotnet-avahi-ui
518 Avahi UI MONO bindings.
519
520 %description -n dotnet-avahi-ui -l pl.UTF-8
521 Wiązania Avahi UI dla MONO.
522
523 %package -n dotnet-avahi-ui-devel
524 Summary:        Development files for MONO Avahi UI bindings
525 Summary(pl.UTF-8):      Pliki rozwojowe wiązań Avahi UI dla MONO
526 Group:          X11/Development/Libraries
527 Requires:       dotnet-avahi-ui = %{version}-%{release}
528 Requires:       monodoc >= 2.6
529
530 %description -n dotnet-avahi-ui-devel
531 Development files for MONO Avahi UI bindings.
532
533 %description -n dotnet-avahi-ui-devel -l pl.UTF-8
534 Pliki rozwojowe wiązań Avahi UI dla MONO.
535
536 %package bookmarks
537 Summary:        Miniature web server
538 Summary(pl.UTF-8):      Miniaturowy serwer web
539 Group:          Applications
540
541 %description bookmarks
542 A Python based miniature web server that browses for mDNS/DNS-SD
543 services of type '_http._tcp' (i.e. web sites) and makes them
544 available as HTML links on http://localhost:8080/.
545
546 %description bookmarks -l pl.UTF-8
547 Napisany w Pythonie miniaturowy serwer WWW, pozwalający na
548 przeglądanie usług typu '_http._tcp' (np. stron WWW) i udostępniający
549 je jako odnośniki HTML na http://localhost:8080/.
550
551 %package discover
552 Summary:        Avahi Zeroconf browser
553 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
554 Group:          Applications
555 Requires:       python-avahi = %{version}-%{release}
556 Requires:       python-pygtk-glade >= 2:2.9.6
557
558 %description discover
559 A tool for enumerating all available services on the local LAN
560 (python-pygtk implementation).
561
562 %description discover -l pl.UTF-8
563 Narzędzie wymieniające wszystkie dostępne usługi w sieci lokalnej LAN
564 (implementacja w python-pygtk).
565
566 %package discover-standalone
567 Summary:        Avahi Zeroconf browser
568 Summary(pl.UTF-8):      Przeglądarka Zeroconf Avahi
569 Group:          Applications
570 Requires:       %{name}-glib = %{version}-%{release}
571
572 %description discover-standalone
573 GTK+ tool for enumerating all available services on the local LAN.
574
575 %description discover-standalone -l pl.UTF-8
576 Narzędzie GTK+ wymieniające wszystkie dostępne usługi w sieci lokalnej
577 LAN.
578
579 %package utils
580 Summary:        Avahi CLI utilities
581 Summary(pl.UTF-8):      Narzędzia CLI Avahi
582 Group:          Applications
583
584 %description utils
585 Command line utilities using avahi-client.
586
587 %description utils -l pl.UTF-8
588 Narzędzia linii poleceń korzystające z avahi-client.
589
590 %prep
591 %setup -q
592 %patch0 -p1
593 %patch1 -p1
594 %patch2 -p1
595 %patch3 -p1
596 %patch4 -p1
597 %patch5 -p1
598 %patch6 -p1
599
600 %build
601 %{__intltoolize}
602 %{__libtoolize}
603 %{__aclocal} -I common
604 %{__autoconf}
605 %{__autoheader}
606 %{__automake}
607 %configure \
608         --enable-compat-libdns_sd \
609         --enable-compat-howl \
610         --with-distro=none \
611         %{!?with_apidocs:--disable-doxygen-doc} \
612         %{!?with_gtk:--disable-gtk} \
613         %{!?with_gtk3:--disable-gtk3} \
614         %{!?with_pygtk:--disable-pygtk} \
615         %{!?with_qt3:--disable-qt3} \
616         %{!?with_qt4:--disable-qt4} \
617         %{!?with_dotnet:--disable-mono} \
618         %{!?with_dotnet:--disable-monodoc} \
619         --with-avahi-priv-access-group=adm \
620         --with-autoipd-user=avahi \
621         --with-autoipd-group=avahi
622 %{__make}
623
624 %install
625 rm -rf $RPM_BUILD_ROOT
626 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},/etc/rc.d/init.d,/etc/init}
627
628 %{__make} install \
629         DESTDIR=$RPM_BUILD_ROOT \
630         pythondir=%{py_sitedir}
631
632 install -p %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d
633 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
634
635 install %{SOURCE4} $RPM_BUILD_ROOT/etc/init/avahi-daemon.conf
636 install %{SOURCE5} $RPM_BUILD_ROOT/etc/init/avahi-dnsconfd.conf
637
638 ln -sf %{_includedir}/avahi-compat-libdns_sd/dns_sd.h \
639         $RPM_BUILD_ROOT%{_includedir}/dns_sd.h
640
641 ln -sf %{_pkgconfigdir}/avahi-compat-howl.pc \
642         $RPM_BUILD_ROOT%{_pkgconfigdir}/howl.pc
643
644 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
645 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
646 %py_postclean
647
648 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{avahi-{browse-domains,publish-address,publish-service,resolve-address,resolve-host-name},bvnc}.1
649 echo '.so avahi-browse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-browse-domains.1
650 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-address.1
651 echo '.so avahi-publish.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-publish-service.1
652 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-address.1
653 echo '.so avahi-resolve.1' > $RPM_BUILD_ROOT%{_mandir}/man1/avahi-resolve-host-name.1
654 echo '.so bssh.1' > $RPM_BUILD_ROOT%{_mandir}/man1/bvnc.1
655
656 %find_lang %{name}
657
658 %clean
659 rm -rf $RPM_BUILD_ROOT
660
661 %pre
662 %groupadd -g 165 -r -f avahi
663 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
664
665 %pre autoipd
666 %groupadd -g 165 -r -f avahi
667 %useradd -u 165 -r -d /usr/share/empty -s /bin/false -c "Avahi daemon" -g avahi avahi
668
669 %post
670 /sbin/chkconfig --add %{name}-daemon
671 %service %{name}-daemon restart
672 /sbin/chkconfig --add %{name}-dnsconfd
673 %service %{name}-dnsconfd restart
674
675 %preun
676 if [ "$1" = "0" ]; then
677         %service -q %{name}-dnsconfd stop
678         /sbin/chkconfig --del %{name}-dnsconfd
679         %service -q %{name}-daemon stop
680         /sbin/chkconfig --del %{name}-daemon
681 fi
682
683 %postun
684 if [ "$1" = "0" ]; then
685         %userremove avahi
686         %groupremove avahi
687 fi
688
689 %postun autoipd
690 if [ "$1" = "0" ]; then
691         %userremove avahi
692         %groupremove avahi
693 fi
694
695 %post upstart
696 %upstart_post avahi-daemon
697 %upstart_post avahi-dnsconfd
698
699 %postun upstart
700 %upstart_postun avahi-daemon
701 %upstart_postun avahi-dnsconfd
702
703 %post   libs -p /sbin/ldconfig
704 %postun libs -p /sbin/ldconfig
705
706 %post   ui -p /sbin/ldconfig
707 %postun ui -p /sbin/ldconfig
708
709 %post   compat-libdns_sd -p /sbin/ldconfig
710 %postun compat-libdns_sd -p /sbin/ldconfig
711
712 %post   compat-howl -p /sbin/ldconfig
713 %postun compat-howl -p /sbin/ldconfig
714
715 %post   glib -p /sbin/ldconfig
716 %postun glib -p /sbin/ldconfig
717
718 %post   gobject -p /sbin/ldconfig
719 %postun gobject -p /sbin/ldconfig
720
721 %post   qt -p /sbin/ldconfig
722 %postun qt -p /sbin/ldconfig
723
724 %post   Qt -p /sbin/ldconfig
725 %postun Qt -p /sbin/ldconfig
726
727 %files
728 %defattr(644,root,root,755)
729 %doc docs/AUTHORS docs/COMPAT-LAYERS docs/NEWS docs/README docs/TODO
730
731 %dir %{_sysconfdir}/avahi
732 %dir %{_sysconfdir}/avahi/services
733 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-daemon.conf
734 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/avahi-dnsconfd.action
735 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/hosts
736 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/ssh.service
737 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/sftp-ssh.service
738 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/*
739
740 %attr(755,root,root) %{_bindir}/avahi-set-host-name
741
742 %attr(755,root,root) %{_sbindir}/avahi-daemon
743 %attr(755,root,root) %{_sbindir}/avahi-dnsconfd
744
745 #%%dir %{_datadir}/%{name}/introspection
746 #%%{_datadir}/%{name}/introspection/*.introspect
747 %{_datadir}/%{name}/avahi-service.dtd
748 %{_datadir}/%{name}/service-types
749 %dir %{_libdir}/%{name}
750 %{_libdir}/%{name}/service-types.db
751
752 %{_mandir}/man1/avahi-set-host-name.1*
753 %{_mandir}/man5/avahi-daemon.conf.5*
754 %{_mandir}/man5/avahi.hosts.5*
755 %{_mandir}/man5/avahi.service.5*
756 %{_mandir}/man8/avahi-daemon.8*
757 %{_mandir}/man8/avahi-dnsconfd.8*
758 %{_mandir}/man8/avahi-dnsconfd.action.8*
759
760 %attr(754,root,root) /etc/rc.d/init.d/%{name}-daemon
761 %attr(754,root,root) /etc/rc.d/init.d/%{name}-dnsconfd
762
763 %files upstart
764 %defattr(644,root,root,755)
765 %config(noreplace) %verify(not md5 mtime size) /etc/init/*.conf
766
767 %files autoipd
768 %defattr(644,root,root,755)
769 %dir %{_sysconfdir}/avahi
770 %attr(755,root,root) %{_sysconfdir}/%{name}/avahi-autoipd.action
771 %dir %{_sysconfdir}/dhclient-enter-hooks.d
772 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-enter-hooks.d/avahi-autoipd
773 %dir %{_sysconfdir}/dhclient-exit-hooks.d
774 %config(noreplace) %verify(not md5 mtime size) /etc/dhclient-exit-hooks.d/avahi-autoipd
775 %attr(755,root,root) %{_sbindir}/avahi-autoipd
776 %{_mandir}/man8/avahi-autoipd.8*
777 %{_mandir}/man8/avahi-autoipd.action.8*
778
779 %files libs -f %{name}.lang
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libavahi-client.so.*.*.*
782 %attr(755,root,root) %ghost %{_libdir}/libavahi-client.so.3
783 %attr(755,root,root) %{_libdir}/libavahi-common.so.*.*.*
784 %attr(755,root,root) %ghost %{_libdir}/libavahi-common.so.3
785 %attr(755,root,root) %{_libdir}/libavahi-core.so.*.*.*
786 %attr(755,root,root) %ghost %{_libdir}/libavahi-core.so.7
787 # common for -discover*
788 %dir %{_datadir}/%{name}
789 %dir %{_datadir}/%{name}/interfaces
790
791 %files devel
792 %defattr(644,root,root,755)
793 %doc docs/API-CHANGES-0.6 docs/DBUS-API docs/HACKING docs/MALLOC
794 %attr(755,root,root) %{_libdir}/libavahi-client.so
795 %attr(755,root,root) %{_libdir}/libavahi-common.so
796 %attr(755,root,root) %{_libdir}/libavahi-core.so
797 %{_libdir}/libavahi-client.la
798 %{_libdir}/libavahi-common.la
799 %{_libdir}/libavahi-core.la
800 %{_includedir}/avahi-client
801 %{_includedir}/avahi-common
802 %{_includedir}/avahi-core
803 %{_pkgconfigdir}/avahi-client.pc
804 %{_pkgconfigdir}/avahi-core.pc
805
806 %files static
807 %defattr(644,root,root,755)
808 %{_libdir}/libavahi-client.a
809 %{_libdir}/libavahi-common.a
810 %{_libdir}/libavahi-core.a
811
812 %if %{with gtk}
813 %files ui
814 %defattr(644,root,root,755)
815 #%%attr(755,root,root) %{_bindir}/bshell
816 #%%attr(755,root,root) %{_bindir}/bssh
817 #%%attr(755,root,root) %{_bindir}/bvnc
818 #%%attr(755,root,root) %{_libdir}/libavahi-ui.so.*.*.*
819 #%%attr(755,root,root) %ghost %{_libdir}/libavahi-ui.so.0
820 %{_mandir}/man1/bssh.1*
821 %{_mandir}/man1/bvnc.1*
822 #%%{_desktopdir}/bssh.desktop
823 #%%{_desktopdir}/bvnc.desktop
824
825 %files ui-devel
826 %defattr(644,root,root,755)
827 #%%attr(755,root,root) %{_libdir}/libavahi-ui.so
828 #%%{_libdir}/libavahi-ui.la
829 #%%{_includedir}/avahi-ui
830 %{_pkgconfigdir}/avahi-ui.pc
831
832 %files ui-static
833 %defattr(644,root,root,755)
834 #%%{_libdir}/libavahi-ui.a
835 %endif
836
837 %files compat-libdns_sd
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_libdir}/libdns_sd.so.*.*.*
840 %attr(755,root,root) %ghost %{_libdir}/libdns_sd.so.1
841
842 %files compat-libdns_sd-devel
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_libdir}/libdns_sd.so
845 %{_libdir}/libdns_sd.la
846 %{_includedir}/avahi-compat-libdns_sd
847 %{_includedir}/dns_sd.h
848 %{_pkgconfigdir}/avahi-compat-libdns_sd.pc
849
850 %files compat-libdns_sd-static
851 %defattr(644,root,root,755)
852 %{_libdir}/libdns_sd.a
853
854 %files compat-howl
855 %defattr(644,root,root,755)
856 %attr(755,root,root) %{_libdir}/libhowl.so.*.*.*
857 %attr(755,root,root) %ghost %{_libdir}/libhowl.so.0
858
859 %files compat-howl-devel
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_libdir}/libhowl.so
862 %{_libdir}/libhowl.la
863 %{_includedir}/avahi-compat-howl
864 %{_pkgconfigdir}/avahi-compat-howl.pc
865 %{_pkgconfigdir}/howl.pc
866
867 %files compat-howl-static
868 %defattr(644,root,root,755)
869 %{_libdir}/libhowl.a
870
871 %files -n python-avahi
872 %defattr(644,root,root,755)
873 %{py_sitedir}/avahi
874
875 %if %{with dotnet}
876 %files -n dotnet-avahi
877 %defattr(644,root,root,755)
878 %{_prefix}/lib/mono/gac/avahi-sharp
879
880 %files -n dotnet-avahi-devel
881 %defattr(644,root,root,755)
882 %{_prefix}/lib/mono/avahi-sharp
883 %{_prefix}/lib/monodoc/sources/avahi-sharp-docs.*
884 %{_pkgconfigdir}/avahi-sharp.pc
885
886 %files -n dotnet-avahi-ui
887 %defattr(644,root,root,755)
888 %{_prefix}/lib/mono/gac/avahi-ui-sharp
889
890 %files -n dotnet-avahi-ui-devel
891 %defattr(644,root,root,755)
892 %{_prefix}/lib/mono/avahi-ui-sharp
893 %{_prefix}/lib/monodoc/sources/avahi-ui-sharp-docs.*
894 %{_pkgconfigdir}/avahi-ui-sharp.pc
895 %endif
896
897 %files glib
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/libavahi-glib.so.*.*.*
900 %attr(755,root,root) %ghost %{_libdir}/libavahi-glib.so.1
901
902 %files glib-devel
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/libavahi-glib.so
905 %{_libdir}/libavahi-glib.la
906 %{_includedir}/avahi-glib
907 %{_pkgconfigdir}/avahi-glib.pc
908
909 %files glib-static
910 %defattr(644,root,root,755)
911 %{_libdir}/libavahi-glib.a
912
913 %files gobject
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_libdir}/libavahi-gobject.so.*.*.*
916 %attr(755,root,root) %ghost %{_libdir}/libavahi-gobject.so.0
917
918 %files gobject-devel
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/libavahi-gobject.so
921 %{_libdir}/libavahi-gobject.la
922 %{_includedir}/avahi-gobject
923 %{_pkgconfigdir}/avahi-gobject.pc
924
925 %files gobject-static
926 %defattr(644,root,root,755)
927 %{_libdir}/libavahi-gobject.a
928
929 %if %{with qt3}
930 %files qt
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_libdir}/libavahi-qt3.so.*.*.*
933 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt3.so.1
934
935 %files qt-devel
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/libavahi-qt3.so
938 %{_libdir}/libavahi-qt3.la
939 %{_includedir}/avahi-qt3
940 %{_pkgconfigdir}/avahi-qt3.pc
941
942 %files qt-static
943 %defattr(644,root,root,755)
944 %{_libdir}/libavahi-qt3.a
945 %endif
946
947 %if %{with qt4}
948 %files Qt
949 %defattr(644,root,root,755)
950 %attr(755,root,root) %{_libdir}/libavahi-qt4.so.*.*.*
951 %attr(755,root,root) %ghost %{_libdir}/libavahi-qt4.so.1
952
953 %files Qt-devel
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/libavahi-qt4.so
956 %{_libdir}/libavahi-qt4.la
957 %{_includedir}/avahi-qt4
958 %{_pkgconfigdir}/avahi-qt4.pc
959
960 %files Qt-static
961 %defattr(644,root,root,755)
962 %{_libdir}/libavahi-qt4.a
963 %endif
964
965 %files bookmarks
966 %defattr(644,root,root,755)
967 %attr(755,root,root) %{_bindir}/avahi-bookmarks
968 %{_mandir}/man1/avahi-bookmarks.1*
969
970 %if %{with pygtk}
971 %files discover
972 %defattr(644,root,root,755)
973 %attr(755,root,root) %{_bindir}/avahi-discover
974 %{py_sitedir}/avahi_discover
975 #%%{_datadir}/%{name}/interfaces/avahi-discover.glade
976 %{_desktopdir}/avahi-discover.desktop
977 %{_pixmapsdir}/avahi.png
978 %{_mandir}/man1/avahi-discover.1*
979 %endif
980
981 %if %{with gtk}
982 %files discover-standalone
983 %defattr(644,root,root,755)
984 #%%attr(755,root,root) %{_bindir}/avahi-discover-standalone
985 #%%{_datadir}/%{name}/interfaces/avahi-discover-standalone.glade
986 %endif
987
988 %files utils
989 %defattr(644,root,root,755)
990 %attr(755,root,root) %{_bindir}/avahi-browse
991 %attr(755,root,root) %{_bindir}/avahi-browse-domains
992 %attr(755,root,root) %{_bindir}/avahi-publish
993 %attr(755,root,root) %{_bindir}/avahi-publish-address
994 %attr(755,root,root) %{_bindir}/avahi-publish-service
995 %attr(755,root,root) %{_bindir}/avahi-resolve
996 %attr(755,root,root) %{_bindir}/avahi-resolve-address
997 %attr(755,root,root) %{_bindir}/avahi-resolve-host-name
998 %{_mandir}/man1/avahi-browse.1*
999 %{_mandir}/man1/avahi-browse-domains.1*
1000 %{_mandir}/man1/avahi-publish.1*
1001 %{_mandir}/man1/avahi-publish-address.1*
1002 %{_mandir}/man1/avahi-publish-service.1*
1003 %{_mandir}/man1/avahi-resolve.1*
1004 %{_mandir}/man1/avahi-resolve-address.1*
1005 %{_mandir}/man1/avahi-resolve-host-name.1*
This page took 0.107758 seconds and 3 git commands to generate.