]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- bcond and spare package for OpenGLRenderer
[packages/CEGUI.git] / CEGUI.spec
1 # TODO:
2 # - external tinyxml
3 # - external tolua++
4 # - ogre-renderer (BR: CEGUI-OGRE >= 1.0.0 through pkgconfig)
5 # - maybe we should make subpackages? For example CEGUI-OPENGL (smc.spec)?
6 #
7 # Conditional build:
8 %bcond_without  xercesc         # build XercesParser
9 %bcond_without  ogre            # build without Ogre renderer
10 %bcond_without  opengl          # build without OpenGL renderer
11 %bcond_with     samples         # build samples
12 #
13 Summary:        CEGUI - a free library providing windowing and widgets
14 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
15 Name:           CEGUI
16 Version:        0.7.1
17 Release:        0.1
18 License:        LGPL v2.1+ (with MIT parts)
19 Group:          Libraries
20 Source0:        http://downloads.sourceforge.net/crayzedsgui/%{name}-%{version}.tar.gz
21 # Source0-md5:  0a2815d5204e3c5510884ab62285da97
22 Source1:        http://downloads.sourceforge.net/crayzedsgui/%{name}-DOCS-%{version}.tar.gz
23 # Source1-md5:  b6c1656d6b004c3dc11bf4b887fd5bd3
24 Patch0:         %{name}-link.patch
25 URL:            http://www.cegui.org.uk/
26 BuildRequires:  DevIL-devel
27 BuildRequires:  DirectFB-devel
28 BuildRequires:  FreeImage-devel
29 %if %{with opengl}
30 BuildRequires:  OpenGL-GLU-devel
31 BuildRequires:  OpenGL-glut-devel
32 %endif
33 BuildRequires:  SILLY-devel >= 0.1.0
34 BuildRequires:  autoconf >= 2.59
35 BuildRequires:  automake
36 BuildRequires:  corona-devel >= 1.0.2
37 BuildRequires:  expat-devel
38 BuildRequires:  freetype-devel >= 2.0
39 BuildRequires:  glew-devel
40 BuildRequires:  irrlicht-devel >= 1.4
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool >= 2:1.5
43 BuildRequires:  libxml2-devel >= 1:2.6
44 BuildRequires:  lua51-devel >= 5.1
45 %if %{with ogre}
46 BuildRequires:  ogre-devel >= 1.0.0
47 BuildRequires:  ois-devel
48 %endif
49 BuildRequires:  pcre-devel >= 5.0
50 BuildRequires:  pkgconfig
51 # for irrlicht renderer
52 BuildRequires:  xorg-lib-libXxf86vm-devel
53 %if %{with xercesc}
54 BuildRequires:  xerces-c-devel
55 %endif
56 Requires:       irrlicht >= 1.4
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 CEGUI stands for Crazy Eddie's Gui System; a free library providing
61 windowing and widgets for graphics APIs / engines where such
62 functionality is not natively available, or severely lacking. The
63 library is object orientated, written in C++, and targeted at games
64 developers who should be spending their time creating great games, not
65 building GUI sub-systems!
66
67 %description -l pl.UTF-8
68 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
69 zapewniającą okienka i widgety dla graficznych API i silników tam,
70 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
71 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
72 skierowana dla programistów gier, którzy powinni spędzać czas na
73 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
74
75 %package devel
76 Summary:        Development files for CEGUI
77 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       freetype-devel >= 2.0
81 Requires:       libstdc++-devel
82 Requires:       pcre-devel >= 5.0
83
84 %description devel
85 CEGUI headers.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe CEGUI.
89
90 %package docs
91 Summary:        Documentation files for CEGUI
92 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
93 Group:          Documentation
94 Requires:       %{name} = %{version}-%{release}
95
96 %description docs
97 CEGUI documentation.
98
99 %description docs -l pl.UTF-8
100 Dokumentacja CEGUI.
101
102 %package OPENGL
103 Summary:        OpenGLRenderer library for CEGUI
104 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description OPENGL
109 OpenGLRenderer library for CEGUI.
110
111 %description OPENGL -l pl.UTF-8
112 Biblioteka OpenGLRenderer dla CEGUI.
113
114 %prep
115 %setup -q -a 1
116 %patch0 -p1
117
118 %build
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --with-default-image-codec=FreeImageImageCodec \
126         --with-default-xml-parser=LibxmlParser \
127         %{!?with_samples:--disable-samples} \
128         --%{?with_ogre:en}%{!?with_ogre:dis}able-ogre-renderer \
129         --%{?with_opengl:en}%{!?with_opengl:dis}able-opengl-renderer \
130         --%{?with_xercesc:en}%{!?with_xercesc:dis}able-xerces-c
131
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc doc/README
149 %attr(755,root,root) %{_libdir}/libCEGUIBase-%{version}.so
150 # plugins
151 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec-%{version}.so
152 %attr(755,root,root) %{_libdir}/libCEGUICoronaImageCodec.so
153 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec-%{version}.so
154 %attr(755,root,root) %{_libdir}/libCEGUIDevILImageCodec.so
155 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser-%{version}.so
156 %attr(755,root,root) %{_libdir}/libCEGUIExpatParser.so
157 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase-%{version}.so
158 %attr(755,root,root) %{_libdir}/libCEGUIFalagardWRBase.so
159 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec-%{version}.so
160 %attr(755,root,root) %{_libdir}/libCEGUIFreeImageImageCodec.so
161 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-%{version}.so
162 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer.so
163 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser-%{version}.so
164 %attr(755,root,root) %{_libdir}/libCEGUILibxmlParser.so
165 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-%{version}.so
166 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule.so
167 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec-%{version}.so
168 %attr(755,root,root) %{_libdir}/libCEGUISILLYImageCodec.so
169 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec-%{version}.so
170 %attr(755,root,root) %{_libdir}/libCEGUITGAImageCodec.so
171 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser-%{version}.so
172 %attr(755,root,root) %{_libdir}/libCEGUITinyXMLParser.so
173 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser-%{version}.so
174 %attr(755,root,root) %{_libdir}/libCEGUIXercesParser.so
175 %attr(755,root,root) %{_libdir}/libCEGUItoluapp-%{version}.so
176 %attr(755,root,root) %{_libdir}/libCEGUItoluapp.so
177
178 %files docs
179 %defattr(644,root,root,755)
180 %doc docs/CEGUI-DOCS-%{version}
181 %dir %{_datadir}/%{name}
182 %dir %{_datadir}/%{name}/xml_schemas
183 %{_datadir}/%{name}/xml_schemas/*.xsd
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libCEGUIBase.so
188 %{_libdir}/libCEGUIBase.la
189 # plugins - but as their headers are included...
190 %{_libdir}/libCEGUICoronaImageCodec.la
191 %{_libdir}/libCEGUIDevILImageCodec.la
192 %{_libdir}/libCEGUIExpatParser.la
193 %{_libdir}/libCEGUIFalagardWRBase.la
194 %{_libdir}/libCEGUIFreeImageImageCodec.la
195 %{_libdir}/libCEGUIIrrlichtRenderer.la
196 %{_libdir}/libCEGUILibxmlParser.la
197 %{_libdir}/libCEGUILuaScriptModule.la
198 %{_libdir}/libCEGUISILLYImageCodec.la
199 %{_libdir}/libCEGUITGAImageCodec.la
200 %{_libdir}/libCEGUITinyXMLParser.la
201 %{_libdir}/libCEGUIXercesParser.la
202 %{_libdir}/libCEGUItoluapp.la
203 %{_includedir}/%{name}
204 %{_pkgconfigdir}/CEGUI.pc
205 %{_pkgconfigdir}/CEGUI-OPENGL.pc
206
207 %if %{with opengl}
208 %files OPENGL
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-%{version}.so
211 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer.so
212 %{_libdir}/libCEGUIOpenGLRenderer.la
213 %endif
This page took 0.047613 seconds and 4 git commands to generate.