]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
Release 9 (by relup.sh)
[packages/CEGUI.git] / CEGUI.spec
1 #
2 # Conditional build:
3 %bcond_without  xercesc         # build XercesParser
4 %bcond_with     ogre            # build without Ogre renderer
5 %bcond_without  opengl          # build without OpenGL renderer
6 %bcond_with     directb         # unsupported by upstream
7 %bcond_with     samples         # build samples
8 #
9 Summary:        CEGUI - a free library providing windowing and widgets
10 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
11 Name:           CEGUI
12 Version:        0.8.7
13 Release:        9
14 License:        LGPL v2.1+ (with MIT parts)
15 Group:          Libraries
16 Source0:        http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
17 # Source0-md5:  cebcc95e205b9ad353db0d65b9b2d505
18 Source1:        http://downloads.sourceforge.net/crayzedsgui/cegui-docs.%{version}.zip
19 # Source1-md5:  5f3b19f82cf1e11b4406560b8e809f20
20 Patch0:         pthread.patch
21 Patch1:         %{name}-glfw3.patch
22 Patch3:         x32.patch
23 Patch4:         cxx11.patch
24 Patch5:         python2.patch
25 Patch6:         ogre1.12.patch
26 Patch7:         ogre13.patch
27 URL:            http://www.cegui.org.uk/
28 BuildRequires:  DevIL-devel
29 %{?with_directfb:BuildRequires: DirectFB-devel >= 1.2.0}
30 BuildRequires:  FreeImage-devel
31 BuildRequires:  GLM
32 BuildRequires:  OpenGL-devel
33 BuildRequires:  SDL2-devel
34 BuildRequires:  SDL2_image-devel
35 BuildRequires:  SILLY-devel >= 0.1.0
36 BuildRequires:  boost-devel >= 1.36.0
37 BuildRequires:  boost-python-devel >= 1.36.0
38 BuildRequires:  cmake >= 2.8
39 BuildRequires:  corona-devel
40 BuildRequires:  doxygen
41 BuildRequires:  expat-devel
42 BuildRequires:  fribidi-devel
43 BuildRequires:  freetype-devel >= 2.0
44 BuildRequires:  glew-devel
45 # for SampleFramework
46 BuildRequires:  glfw-devel
47 BuildRequires:  gtk+2-devel >= 2:2.4
48 BuildRequires:  irrlicht-devel >= 1.4
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtool >= 2:1.5
51 BuildRequires:  libxml2-devel >= 1:2.6
52 BuildRequires:  lua51-devel >= 5.1
53 BuildRequires:  minizip-devel
54 %if %{with ogre}
55 BuildRequires:  ogre-devel >= 1.6.0
56 BuildRequires:  ois-devel >= 1.0.0
57 %endif
58 BuildRequires:  pcre-devel >= 5.0
59 BuildRequires:  pkgconfig
60 BuildRequires:  python-devel >= 2
61 BuildRequires:  rapidxml
62 BuildRequires:  sed >= 4.0
63 BuildRequires:  tinyxml-devel
64 BuildRequires:  tolua++-devel
65 %{?with_xercesc:BuildRequires:  xerces-c-devel}
66 # for irrlicht renderer
67 BuildRequires:  xorg-lib-libXxf86vm-devel
68 %if %{with opengl}
69 BuildRequires:  GLM
70 BuildRequires:  OpenGL-GLU-devel
71 BuildRequires:  glew-devel
72 BuildRequires:  glfw-devel
73 %endif
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 CEGUI stands for Crazy Eddie's Gui System; a free library providing
78 windowing and widgets for graphics APIs / engines where such
79 functionality is not natively available, or severely lacking. The
80 library is object orientated, written in C++, and targeted at games
81 developers who should be spending their time creating great games, not
82 building GUI sub-systems!
83
84 %description -l pl.UTF-8
85 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
86 zapewniającą okienka i widgety dla graficznych API i silników tam,
87 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
88 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
89 skierowana dla programistów gier, którzy powinni spędzać czas na
90 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
91
92 %package devel
93 Summary:        Development files for CEGUI
94 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       freetype-devel >= 2.0
98 Requires:       libstdc++-devel
99 Requires:       pcre-devel >= 5.0
100
101 %description devel
102 CEGUI headers.
103
104 %description devel -l pl.UTF-8
105 Pliki nagłówkowe CEGUI.
106
107 %package docs
108 Summary:        Documentation files for CEGUI
109 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
110 Group:          Documentation
111 Requires:       %{name} = %{version}-%{release}
112
113 %description docs
114 CEGUI documentation.
115
116 %description docs -l pl.UTF-8
117 Dokumentacja CEGUI.
118
119 %package ImageCodec-Corona
120 Summary:        CoronaImageCodec library for CEGUI
121 Summary(pl.UTF-8):      Biblioteka CoronaImageCodec dla CEGUI
122 Group:          Libraries
123 Requires:       %{name} = %{version}-%{release}
124
125 %description ImageCodec-Corona
126 CoronaImageCodec library for CEGUI.
127
128 %description ImageCodec-Corona -l pl.UTF-8
129 Biblioteka CoronaImageCodec dla CEGUI
130
131 %package ImageCodec-Corona-devel
132 Summary:        Header files for CEGUI CoronaImageCodec library
133 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec
134 Group:          Development/Libraries
135 Requires:       %{name}-ImageCodec-Corona = %{version}-%{release}
136 Requires:       %{name}-devel = %{version}-%{release}
137 Requires:       corona-devel
138
139 %description ImageCodec-Corona-devel
140 Header files for CEGUI CoronaImageCodec library.
141
142 %description ImageCodec-Corona-devel -l pl.UTF-8
143 Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec.
144
145 %package ImageCodec-DevIL
146 Summary:        DevILImageCodec library for CEGUI
147 Summary(pl.UTF-8):      Biblioteka DevILImageCodec dla CEGUI
148 Group:          Libraries
149 Requires:       %{name} = %{version}-%{release}
150
151 %description ImageCodec-DevIL
152 DevILImageCodec library for CEGUI.
153
154 %description ImageCodec-DevIL -l pl.UTF-8
155 Biblioteka DevILImageCodec dla CEGUI
156
157 %package ImageCodec-DevIL-devel
158 Summary:        Header files for CEGUI DevILImageCodec library
159 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DevILImageCodec
160 Group:          Development/Libraries
161 Requires:       %{name}-ImageCodec-DevIL = %{version}-%{release}
162 Requires:       %{name}-devel = %{version}-%{release}
163 Requires:       DevIL-devel
164
165 %description ImageCodec-DevIL-devel
166 Header files for CEGUI DevILImageCodec library.
167
168 %description ImageCodec-DevIL-devel -l pl.UTF-8
169 Pliki nagłówkowe biblioteki CEGUI DevILImageCodec.
170
171 %package ImageCodec-FreeImage
172 Summary:        FreeImageImageCodec library for CEGUI
173 Summary(pl.UTF-8):      Biblioteka FreeImageImageCodec dla CEGUI
174 Group:          Libraries
175 Requires:       %{name} = %{version}-%{release}
176
177 %description ImageCodec-FreeImage
178 FreeImageImageCodec library for CEGUI.
179
180 %description ImageCodec-FreeImage -l pl.UTF-8
181 Biblioteka FreeImageImageCodec dla CEGUI
182
183 %package ImageCodec-FreeImage-devel
184 Summary:        Header files for CEGUI FreeImageImageCodec library
185 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec
186 Group:          Development/Libraries
187 Requires:       %{name}-ImageCodec-FreeImage = %{version}-%{release}
188 Requires:       %{name}-devel = %{version}-%{release}
189 Requires:       FreeImage-devel
190
191 %description ImageCodec-FreeImage-devel
192 Header files for CEGUI FreeImageImageCodec library.
193
194 %description ImageCodec-FreeImage-devel -l pl.UTF-8
195 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
196
197 %package ImageCodec-SDL2
198 Summary:        SDL2ImageCodec library for CEGUI
199 Summary(pl.UTF-8):      Biblioteka SDL2ImageCodec dla CEGUI
200 Group:          Libraries
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       SDL2
203
204 %description ImageCodec-SDL2
205 SDL2ImageCodec library for CEGUI.
206
207 %description ImageCodec-SDL2 -l pl.UTF-8
208 Biblioteka SDL2ImageCodec dla CEGUI
209
210 %package ImageCodec-SDL2-devel
211 Summary:        Header files for CEGUI SDL2ImageCodec library
212 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SDL2ImageCodec
213 Group:          Development/Libraries
214 Requires:       %{name}-ImageCodec-SDL2 = %{version}-%{release}
215 Requires:       %{name}-devel = %{version}-%{release}
216 Requires:       SDL2-devel >= 0.1.0
217
218 %description ImageCodec-SDL2-devel
219 Header files for CEGUI SDL2ImageCodec library.
220
221 %description ImageCodec-SDL2-devel -l pl.UTF-8
222 Pliki nagłówkowe biblioteki CEGUI SDL2ImageCodec.
223
224 %package ImageCodec-SILLY
225 Summary:        SILLYImageCodec library for CEGUI
226 Summary(pl.UTF-8):      Biblioteka SILLYImageCodec dla CEGUI
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       SILLY >= 0.1.0
230
231 %description ImageCodec-SILLY
232 SILLYImageCodec library for CEGUI.
233
234 %description ImageCodec-SILLY -l pl.UTF-8
235 Biblioteka SILLYImageCodec dla CEGUI
236
237 %package ImageCodec-SILLY-devel
238 Summary:        Header files for CEGUI SILLYImageCodec library
239 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec
240 Group:          Development/Libraries
241 Requires:       %{name}-ImageCodec-SILLY = %{version}-%{release}
242 Requires:       %{name}-devel = %{version}-%{release}
243 Requires:       SILLY-devel >= 0.1.0
244
245 %description ImageCodec-SILLY-devel
246 Header files for CEGUI SILLYImageCodec library.
247
248 %description ImageCodec-SILLY-devel -l pl.UTF-8
249 Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec.
250
251 %package Parser-Expat
252 Summary:        Expat-based XML parser module
253 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Expat
254 Group:          Libraries
255 Requires:       %{name} = %{version}-%{release}
256
257 %description Parser-Expat
258 Expat-based XML parser module.
259
260 %description Parser-Expat -l pl.UTF-8
261 Moduł analizatora XML oparty na bibliotece Expat.
262
263 %package Parser-LibXML
264 Summary:        LibXML-based XML parser module
265 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece LibXML
266 Group:          Libraries
267 Requires:       %{name} = %{version}-%{release}
268 Requires:       libxml2 >= 1:2.6
269
270 %description Parser-LibXML
271 LibXML-based XML parser module.
272
273 %description Parser-LibXML -l pl.UTF-8
274 Moduł analizatora XML oparty na bibliotece LibXML.
275
276 %package Parser-RapidXML
277 Summary:        RapidXML-based XML parser module
278 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece RapidXML
279 Group:          Libraries
280 Requires:       %{name} = %{version}-%{release}
281
282 %description Parser-RapidXML
283 RapidXML-based XML parser module.
284
285 %description Parser-RapidXML -l pl.UTF-8
286 Moduł analizatora XML oparty na bibliotece RapidXML.
287
288 %package Parser-TinyXML
289 Summary:        TinyXML-based XML parser module
290 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece TinyXML
291 Group:          Libraries
292 Requires:       %{name} = %{version}-%{release}
293
294 %description Parser-TinyXML
295 TinyXML-based XML parser module.
296
297 %description Parser-TinyXML -l pl.UTF-8
298 Moduł analizatora XML oparty na bibliotece TinyXML.
299
300 %package Parser-Xerces
301 Summary:        Xerces-based XML parser module
302 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Xerces
303 Group:          Libraries
304 Requires:       %{name} = %{version}-%{release}
305
306 %description Parser-Xerces
307 Xerces-based XML parser module.
308
309 %description Parser-Xerces -l pl.UTF-8
310 Moduł analizatora XML oparty na bibliotece Xerces.
311
312 %package Renderer-DirectFB
313 Summary:        DirectFBRenderer library for CEGUI
314 Summary(pl.UTF-8):      Biblioteka DirectFBRenderer dla CEGUI
315 Group:          Libraries
316 Requires:       %{name} = %{version}-%{release}
317 Requires:       DirectFB >= 1.2.0
318
319 %description Renderer-DirectFB
320 DirectFBRenderer library for CEGUI.
321
322 %description Renderer-DirectFB -l pl.UTF-8
323 Biblioteka DirectFBRenderer dla CEGUI
324
325 %package Renderer-DirectFB-devel
326 Summary:        Header files for CEGUI DirectFBRenderer library
327 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer
328 Group:          Development/Libraries
329 Requires:       %{name}-Renderer-DirectFB = %{version}-%{release}
330 Requires:       %{name}-devel = %{version}-%{release}
331 Requires:       DirectFB-devel >= 1.2.0
332
333 %description Renderer-DirectFB-devel
334 Header files for CEGUI DirectFBRenderer library.
335
336 %description Renderer-DirectFB-devel -l pl.UTF-8
337 Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer.
338
339 %package Renderer-Irrlicht
340 Summary:        IrrlichtRenderer library for CEGUI
341 Summary(pl.UTF-8):      Biblioteka IrrlichtRenderer dla CEGUI
342 Group:          Libraries
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       irrlicht >= 1.4
345
346 %description Renderer-Irrlicht
347 IrrlichtRenderer library for CEGUI.
348
349 %description Renderer-Irrlicht -l pl.UTF-8
350 Biblioteka IrrlichtRenderer dla CEGUI
351
352 %package Renderer-Irrlicht-devel
353 Summary:        Header files for CEGUI IrrlichtRenderer library
354 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer
355 Group:          Development/Libraries
356 Requires:       %{name}-Renderer-Irrlicht = %{version}-%{release}
357 Requires:       %{name}-devel = %{version}-%{release}
358 Requires:       irrlicht-devel >= 1.4
359
360 %description Renderer-Irrlicht-devel
361 Header files for CEGUI IrrlichtRenderer library.
362
363 %description Renderer-Irrlicht-devel -l pl.UTF-8
364 Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer.
365
366 %package Renderer-Ogre
367 Summary:        OgreRenderer library for CEGUI
368 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
369 Group:          Libraries
370 Requires:       %{name} = %{version}-%{release}
371 Obsoletes:      CEGUI-Ogre
372
373 %description Renderer-Ogre
374 OgreRenderer library for CEGUI.
375
376 %description Renderer-Ogre -l pl.UTF-8
377 Biblioteka OgreRenderer dla CEGUI
378
379 %package Renderer-Ogre-devel
380 Summary:        Header files for CEGUI OgreRenderer library
381 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
382 Group:          Development/Libraries
383 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
384 Requires:       %{name}-devel = %{version}-%{release}
385 Requires:       ogre-devel >= 1.6.0
386 Obsoletes:      CEGUI-Ogre-devel
387
388 %description Renderer-Ogre-devel
389 Header files for CEGUI OgreRenderer library.
390
391 %description Renderer-Ogre-devel -l pl.UTF-8
392 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
393
394 %package Renderer-OpenGL
395 Summary:        OpenGLRenderer library for CEGUI
396 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
397 Group:          Libraries
398 Requires:       %{name} = %{version}-%{release}
399 Obsoletes:      CEGUI-OpenGL
400
401 %description Renderer-OpenGL
402 OpenGLRenderer library for CEGUI.
403
404 %description Renderer-OpenGL -l pl.UTF-8
405 Biblioteka OpenGLRenderer dla CEGUI.
406
407 %package Renderer-OpenGL-devel
408 Summary:        Header files for CEGUI OpenGLRenderer library
409 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
410 Group:          Development/Libraries
411 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
412 Requires:       %{name}-devel = %{version}-%{release}
413 Requires:       OpenGL-GLU-devel
414 Requires:       OpenGL-glut-devel
415 Requires:       glew-devel
416 Obsoletes:      CEGUI-OpenGL-devel
417
418 %description Renderer-OpenGL-devel
419 Header files for CEGUI OpenGLRenderer library.
420
421 %description Renderer-OpenGL-devel -l pl.UTF-8
422 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
423
424 %package -n python-CEGUI
425 Summary:        Python binding for CEGUI
426 Summary(pl.UTF-8):      Wiązania Pythona do CEGUI
427 Group:          Libraries/Python
428 Requires:       %{name} = %{version}-%{release}
429
430 %description -n python-CEGUI
431 Python binding for CEGUI.
432
433 %description -n python-CEGUI -l pl.UTF-8
434 Wiązania Pythona do CEGUI.
435
436 %package -n python-CEGUI-Renderer-Ogre
437 Summary:        Python binding for CEGUI OgreRenderer library
438 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OgreRenderer
439 Group:          Libraries/Python
440 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
441 Requires:       python-CEGUI = %{version}-%{release}
442
443 %description -n python-CEGUI-Renderer-Ogre
444 Python binding for CEGUI OgreRenderer library.
445
446 %description -n python-CEGUI-Renderer-Ogre -l pl.UTF-8
447 Wiązania Pythona do biblioteki CEGUI OgreRenderer.
448
449 %package -n python-CEGUI-Renderer-OpenGL
450 Summary:        Python binding for CEGUI OpenGLRenderer library
451 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OpenGLRenderer
452 Group:          Libraries/Python
453 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
454 Requires:       python-CEGUI = %{version}-%{release}
455
456 %description -n python-CEGUI-Renderer-OpenGL
457 Python binding for CEGUI OpenGLRenderer library.
458
459 %description -n python-CEGUI-Renderer-OpenGL -l pl.UTF-8
460 Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
461
462 %prep
463 %setup -q -a 1 -n cegui-%{version}
464 %patch0 -p1
465 %patch1 -p1
466 %patch3 -p1
467 %patch4 -p1
468 %patch5 -p1
469 %patch6 -p1
470 %patch7 -p1
471
472 %build
473 install -d build
474 cd build
475 %cmake .. \
476         -DCEGUI_SAMPLES_ENABLED:BOOL=%{?with_samples:ON}%{!?with_samples:OFF} \
477         -DCEGUI_BUILD_RENDERER_DIRECTFB:BOOL=%{?with_directfb:ON}%{!?with_directfb:OFF} \
478         -DCEGUI_BUILD_RENDERER_OPENGL:BOOL=%{?with_opengl:ON}%{!?with_opengl:OFF} \
479         -DCEGUI_BUILD_RENDERER_OGRE:BOOL=%{?with_ogre:ON}%{!?with_ogre:OFF} \
480         -DCEGUI_BUILD_XMLPARSER_XERCES:BOOL=%{?with_xercesc:ON}%{!?with_xercesc:OFF} \
481         -DCEGUI_OPTION_DEFAULT_IMAGECODEC:STRING=FreeImageImageCodec \
482         -DCEGUI_OPTION_DEFAULT_XMLPARSER:STRING=LibxmlParser \
483         -DCEGUI_PYTHON_INSTALL_DIR=%{py_sitedir}
484
485 %{__make} -j1
486
487 %install
488 rm -rf $RPM_BUILD_ROOT
489
490 %{__make} -C build install/fast \
491         DESTDIR=$RPM_BUILD_ROOT
492
493 %if %{without samples}
494 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cegui-0/{animations,fonts,imagesets,layouts,looknfeel,lua_scripts,schemes,xml_schemas}
495 %endif
496
497 %clean
498 rm -rf $RPM_BUILD_ROOT
499
500 %post   -p /sbin/ldconfig
501 %postun -p /sbin/ldconfig
502
503 %post   Renderer-Irrlicht -p /sbin/ldconfig
504 %postun Renderer-Irrlicht -p /sbin/ldconfig
505 %post   Renderer-Ogre -p /sbin/ldconfig
506 %postun Renderer-Ogre -p /sbin/ldconfig
507 %post   Renderer-OpenGL -p /sbin/ldconfig
508 %postun Renderer-OpenGL -p /sbin/ldconfig
509
510 %files
511 %defattr(644,root,root,755)
512 %doc README.md
513 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase-0.so.2
515 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libCEGUICommonDialogs-0.so.2
517 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule-0.so.2
519 # plugins
520 %dir %{_libdir}/cegui-0.8
521 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoreWindowRendererSet.so
522
523 %files docs
524 %defattr(644,root,root,755)
525 %doc cegui-docs-%{version}/*
526
527 %files devel
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_bindir}/toluappcegui-0.8
530 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so
531 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so
532 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so
533 %dir %{_includedir}/cegui-0
534 %dir %{_includedir}/cegui-0/%{name}
535 %{_includedir}/cegui-0/%{name}/*.h
536 %{_includedir}/cegui-0/%{name}/CommonDialogs
537 %dir %{_includedir}/cegui-0/%{name}/ImageCodecModules
538 %dir %{_includedir}/cegui-0/%{name}/RendererModules
539 %{_includedir}/cegui-0/%{name}/ScriptModules
540 %{_includedir}/cegui-0/%{name}/WindowRendererSets
541 %{_includedir}/cegui-0/%{name}/XMLParserModules
542 %{_includedir}/cegui-0/%{name}/falagard
543 %{_includedir}/cegui-0/%{name}/widgets
544 %{_pkgconfigdir}/CEGUI-0.pc
545 %{_pkgconfigdir}/CEGUI-0-LUA.pc
546
547 %files ImageCodec-Corona
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoronaImageCodec.so
550
551 %files ImageCodec-Corona-devel
552 %defattr(644,root,root,755)
553 %{_includedir}/cegui-0/%{name}/ImageCodecModules/Corona
554
555 %files ImageCodec-DevIL
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIDevILImageCodec.so
558
559 %files ImageCodec-DevIL-devel
560 %defattr(644,root,root,755)
561 %{_includedir}/cegui-0/%{name}/ImageCodecModules/DevIL
562
563 %files ImageCodec-FreeImage
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIFreeImageImageCodec.so
566
567 %files ImageCodec-FreeImage-devel
568 %defattr(644,root,root,755)
569 %{_includedir}/cegui-0/%{name}/ImageCodecModules/FreeImage
570
571 %files ImageCodec-SDL2
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISDL2ImageCodec.so
574
575 %files ImageCodec-SDL2-devel
576 %defattr(644,root,root,755)
577 %{_includedir}/cegui-0/%{name}/ImageCodecModules/SDL2
578
579 %files ImageCodec-SILLY
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISILLYImageCodec.so
582
583 %files ImageCodec-SILLY-devel
584 %defattr(644,root,root,755)
585 %{_includedir}/cegui-0/%{name}/ImageCodecModules/SILLY
586
587 %files Parser-Expat
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIExpatParser.so
590
591 %files Parser-LibXML
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUILibXMLParser.so
594
595 %files Parser-RapidXML
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIRapidXMLParser.so
598
599 %files Parser-TinyXML
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUITinyXMLParser.so
602
603 %files Parser-Xerces
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIXercesParser.so
606
607 %if %{with directfb}
608 %files Renderer-DirectFB
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so.*.*.*
611 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDirectFBRenderer-0.so.2
612
613 %files Renderer-DirectFB-devel
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so
616 %{_includedir}/cegui-0/%{name}/RendererModules/DirectFB
617 %endif
618
619 %files Renderer-Irrlicht
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so.*.*.*
622 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer-0.so.2
623
624 %files Renderer-Irrlicht-devel
625 %defattr(644,root,root,755)
626 %{_includedir}/cegui-0/%{name}/RendererModules/Irrlicht
627 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so
628 %{_pkgconfigdir}/CEGUI-0-IRRLICHT.pc
629
630 %if %{with ogre}
631 %files Renderer-Ogre
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOgreRenderer-0.so.2
635
636 %files Renderer-Ogre-devel
637 %defattr(644,root,root,755)
638 %{_includedir}/cegui-0/%{name}/RendererModules/Ogre
639 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so
640 %{_pkgconfigdir}/CEGUI-0-OGRE.pc
641 %endif
642
643 %if %{with opengl}
644 %files Renderer-OpenGL
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer-0.so.2
648
649 %files Renderer-OpenGL-devel
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so
652 %{_includedir}/cegui-0/%{name}/RendererModules/OpenGL
653 %{_pkgconfigdir}/CEGUI-0-OPENGL.pc
654 %{_pkgconfigdir}/CEGUI-0-OPENGL3.pc
655 %endif
656
657 %files -n python-CEGUI
658 %defattr(644,root,root,755)
659 %dir %{py_sitedir}/cegui-0.8
660 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUI.so
661
662 %if %{with ogre}
663 %files -n python-CEGUI-Renderer-Ogre
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOgreRenderer.so
666 %endif
667
668 %if %{with opengl}
669 %files -n python-CEGUI-Renderer-OpenGL
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOpenGLRenderer.so
672 %endif
This page took 0.167546 seconds and 4 git commands to generate.