]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- unified, missing ldconfig calls
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
1930bef0 5#
bab73684 6# Conditional build:
65c1d4bd
JB
7%bcond_with net_client_only # build only net client
8%bcond_without python # build without python bindings (broken)
9%bcond_without perl # build without perl bindings
d46e45ba 10%bcond_without ruby
65c1d4bd
JB
11%bcond_without apache # build without apache support (webdav, etc)
12%bcond_without javahl # build without javahl support (Java high-level bindings)
13%bcond_without tests # don't perform "make check"
7b27380f 14#
b56474ff 15%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 16%define apxs /usr/sbin/apxs
1f630180
ER
17%define pdir SVN
18%define pnam _Core
12ae68c1 19#
d46e45ba 20%define snap rc7
67cb9518 21Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
22Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
23Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 24Name: subversion
12ae68c1
AM
25Version: 1.5.0
26Release: 0.%{snap}.1
6f88d80e 27License: Apache/BSD-like
93b78127 28Group: Development/Version Control
56724a21 29Source0: http://subversion.tigris.org/downloads/%{name}-%{version}-%{snap}.tar.bz2
d46e45ba 30# Source0-md5: 3145186e3c1a60fbb4dc360da490b841
93b78127 31Source1: %{name}-dav_svn.conf
65318afa 32Source2: %{name}-authz_svn.conf
b56474ff
AM
33Source3: %{name}-svnserve.init
34Source4: %{name}-svnserve.sysconfig
f313e9a9 35Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 36Patch0: %{name}-home_etc.patch
d46e45ba 37Patch1: %{name}-DESTDIR.patch
d2bf70bf 38URL: http://subversion.tigris.org/
4945947e
AM
39%if %{with net_client_only}
40%global apache_modules_api 0
41%else
f2a757d6 42%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 43BuildRequires: automake
3817faf5 44BuildRequires: db-devel >= 4.1.25
e8d9186f 45BuildRequires: rpmbuild(macros) >= 1.268
0905b458 46%if %{with perl}
522a69b4 47BuildRequires: perl-devel >= 1:5.8.0
48BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 49BuildRequires: swig-perl >= 1.3.24
536b3fd3 50%endif
1cc7453a 51%{?with_javahl:BuildRequires: jdk}
0905b458 52%endif
16429189 53BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 54BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 55BuildRequires: autoconf >= 2.59
79d8c53c 56BuildRequires: bison
12ae68c1 57BuildRequires: cyrus-sasl-devel
93b78127 58BuildRequires: expat-devel
86ea8fde 59BuildRequires: gettext-devel
f4e6a380 60BuildRequires: libtool >= 1.4-9
bd3c99a8 61BuildRequires: neon-devel >= 0.26.0
53855fbf 62BuildRequires: python >= 2.2
ed6210a2 63BuildRequires: python-modules >= 2.2
f313e9a9 64%if %{with python}
65BuildRequires: python-devel >= 2.2
1f16145f 66BuildRequires: sed >= 4.0
15f9818d 67BuildRequires: swig-python >= 1.3.24
0905b458 68%endif
93b78127 69BuildRequires: texinfo
7b35d179 70BuildRequires: which
027f8ebe 71Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
f4070f5f 74%define _libexecdir %{_libdir}/svn
1af5e34d
ER
75%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
76%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
77
78%description
79The goal of the Subversion project is to build a version control
80system that is a compelling replacement for CVS in the open source
81community.
82
83Our goals are:
84- All current CVS features.
85- Directories, renames, and file meta-data are versioned.
86- Symbolic links, etc, are supported
87- Commits are truly atomic.
88- Branching and tagging are cheap (constant time) operations
89- Repeated merges are handled gracefully
90- Support for plug-in client side diff programs
91- Natively client/server
92- Client/server protocol sends diffs in both directions
93- Costs are proportional to change size, not project size
94- Internationalization
95- Progressive multi-lingual support
96
aa59005f 97%description -l pl.UTF-8
93b78127
AM
98Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
99zamiennika dla CVS.
100
101Cele projektu to:
aa59005f 102- Wszystkie aktualne możliwości CVS.
24406120
JB
103- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
104- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
105- Commity są w pełni atomowe.
106- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
107- Dobra obsługa powtarzanego łączenia (merge).
108- Obsługa wtyczek diff po stronie klienta.
93b78127 109- Natywny klient/serwer.
aa59005f 110- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
111- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
112- Internacjonalizacja.
aa59005f 113- Postępujące wsparcie dla wielu języków.
93b78127 114
aa59005f
JR
115%description -l pt_BR.UTF-8
116O objetivo do projeto Subversion é construir um sistema de controle de
117versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 118System) na comunidade opensource, fornecendo grandes melhorias.
119
f4e6a380
AM
120%package libs
121Summary: Subversion libraries and modules
abe3c421 122Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 123Group: Libraries
24406120 124Requires: neon >= 0.26.0
53855fbf 125Obsoletes: libsubversion0
f4e6a380
AM
126
127%description libs
128Subversion libraries and modules.
129
aa59005f
JR
130%description libs -l pl.UTF-8
131Biblioteka subversion oraz ładowalne moduły.
f4e6a380 132
93b78127
AM
133%package devel
134Summary: Header files and develpment documentation for subversion
abe3c421
ER
135Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
136Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 137Group: Development/Libraries
9cb7e099 138Requires: %{name}-libs = %{version}-%{release}
c5b1d686 139Requires: apr-util-devel >= 1:1.0.0
24406120 140Requires: neon-devel >= 0.26.0
12cf252c 141Obsoletes: libsubversion0-devel
93b78127
AM
142
143%description devel
144Header files and develpment documentation for subversion.
145
aa59005f
JR
146%description devel -l pl.UTF-8
147Pliki nagłówkowe i dokumetacja do subversion.
93b78127 148
aa59005f
JR
149%description devel -l pt_BR.UTF-8
150Este pacote provê os arquivos necessários para desenvolvedores
92066deb 151interagirem com o Subversion.
152
93b78127
AM
153%package static
154Summary: Static subversion library
abe3c421
ER
155Summary(pl.UTF-8): Biblioteka statyczna subversion
156Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
157Group: Development/Libraries
158Requires: %{name}-devel = %{version}
12cf252c 159Obsoletes: libsubversion0-static-devel
93b78127
AM
160
161%description static
162Static subversion library.
163
aa59005f 164%description static -l pl.UTF-8
93b78127
AM
165Biblioteka statyczna subversion.
166
aa59005f
JR
167%description static -l pt_BR.UTF-8
168Este pacote provê um cliente estático do subversion.
92066deb 169
b56474ff
AM
170%package svnserve
171Summary: Subversion svnserve
abe3c421 172Summary(pl.UTF-8): Subversion svnserve
b56474ff 173Group: Networking/Daemons
3817faf5 174Requires(post,preun): /sbin/chkconfig
93f1d402 175Requires(postun): /usr/sbin/groupdel
176Requires(postun): /usr/sbin/userdel
177Requires(pre): /bin/id
178Requires(pre): /usr/bin/getgid
179Requires(pre): /usr/lib/rpm/user_group.sh
180Requires(pre): /usr/sbin/groupadd
181Requires(pre): /usr/sbin/useradd
182Requires(pre): /usr/sbin/usermod
9cb7e099 183Requires: %{name} = %{version}-%{release}
7b27380f 184Requires: rc-scripts
a1bac09d
185Provides: group(svn)
186Provides: user(svn)
b56474ff
AM
187
188%description svnserve
189Subversion svnserve server.
190
aa59005f 191%description svnserve -l pl.UTF-8
b56474ff
AM
192Serwer subversion svnserve.
193
4bbdbbf8
AM
194%package tools
195Summary: Subversion tools and scripts
abe3c421
ER
196Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
197Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 198Group: Applications
4bbdbbf8 199%pyrequires_eq python
7b27380f 200Requires: %{name} = %{version}-%{release}
1271c9bd 201Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
202Requires: python-subversion = %{version}
203
204%description tools
205Subversion tools and scripts.
206
aa59005f
JR
207%description tools -l pl.UTF-8
208Narzędzia oraz skrypty dla subversion.
4bbdbbf8 209
fe5bb6bb 210%package -n bash-completion-subversion
211Summary: bash completion for subversion
abe3c421 212Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 213Group: Applications/Shells
e30588c4 214Requires: %{name} = %{version}-%{release}
53855fbf 215Requires: bash-completion
e30588c4 216Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 217
218%description -n bash-completion-subversion
219Bash completion for subversion.
220
aa59005f
JR
221%description -n bash-completion-subversion -l pl.UTF-8
222Dopełnienia basha dla subversion.
fe5bb6bb 223
1cc7453a 224%package -n java-subversion
65c1d4bd
JB
225Summary: Subversion Java bindings
226Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 227Group: Development/Languages/Java
228Requires: %{name}-libs = %{version}-%{release}
229
230%description -n java-subversion
231This is a set of Java classes which provide the functionality of
232subversion-libs, the Subversion libraries. It is useful if you want
233to, for example, write a Java class that manipulates a Subversion
234repository or working copy. See the 'subversion' package for more
235information.
236
65c1d4bd
JB
237%description -n java-subversion -l pl.UTF-8
238Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
239subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
240pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
241roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 242
fa3ff1b2 243%package -n python-subversion
65c1d4bd
JB
244Summary: Subversion Python bindings
245Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
246Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 247Group: Development/Languages/Python
f4e6a380 248%pyrequires_eq python
9cb7e099 249Requires: %{name}-libs = %{version}-%{release}
53855fbf 250Obsoletes: subversion-python
f4e6a380 251
fa3ff1b2 252%description -n python-subversion
65c1d4bd 253Subversion Python bindings.
f4e6a380 254
aa59005f 255%description -n python-subversion -l pl.UTF-8
65c1d4bd 256Dowiązania do Subversion dla Pythona.
f4e6a380 257
aa59005f 258%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 259Módulos Python para acessar os recursos do Subversion.
92066deb 260
b56474ff 261%package -n perl-subversion
65c1d4bd
JB
262Summary: Subversion Perl bindings
263Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
264Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 265Group: Development/Languages/Perl
9cb7e099 266Requires: %{name}-libs = %{version}-%{release}
53855fbf 267Obsoletes: subversion-perl
b56474ff
AM
268
269%description -n perl-subversion
65c1d4bd 270Subversion Perl bindings.
b56474ff 271
aa59005f 272%description -n perl-subversion -l pl.UTF-8
65c1d4bd 273Dowiązania do Subversion dla Perla.
b56474ff 274
aa59005f 275%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 276Módulos Perl para acessar os recursos do Subversion.
b56474ff 277
d46e45ba
AM
278%package -n ruby-subversion
279Summary: Subversion Ruby bindings
d2bf70bf 280Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
281Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
282Group: Development/Languages
283Requires: %{name}-libs = %{version}-%{release}
284Obsoletes: subversion-ruby
285
286%description -n ruby-subversion
287Subversion Ruby bindings.
288
289%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 290Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
291
292%description -n ruby-subversion -l pt_BR.UTF-8
293Módulos Ruby para acessar os recursos do Subversion.
294
93b78127
AM
295%package -n apache-mod_dav_svn
296Summary: Apache module: Subversion Server
abe3c421 297Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 298Group: Networking/Daemons
7b27380f 299Requires: %{name} = %{version}-%{release}
53855fbf 300Requires: apache(modules-api) = %apache_modules_api
7887b1ac 301Requires: apache-mod_dav
93b78127
AM
302
303%description -n apache-mod_dav_svn
304Apache module: Subversion Server.
305
aa59005f
JR
306%description -n apache-mod_dav_svn -l pl.UTF-8
307Moduł apache: Serwer Subversion.
93b78127 308
65318afa
AF
309%package -n apache-mod_authz_svn
310Summary: Apache module: Subversion Server - path-based authorization
abe3c421 311Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 312Group: Networking/Daemons
53855fbf 313Requires: apache(modules-api) = %apache_modules_api
9cb7e099 314Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
315
316%description -n apache-mod_authz_svn
317Apache module: Subversion Server - path-based authorization.
318
aa59005f
JR
319%description -n apache-mod_authz_svn -l pl.UTF-8
320Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 321
93b78127 322%prep
12ae68c1 323%setup -q -n %{name}-%{version}-%{snap}
e30588c4 324rm -rf apr apr-util neon
ed6210a2 325%patch0 -p0
d4bccc60 326%patch1 -p1
027f8ebe 327
93b78127 328%build
93f1d402 329rm subversion/bindings/swig/proxy/*.swg
24406120 330cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 331cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 332chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 333
fa3ff1b2 334# don't enable dso - currently it's broken
93b78127 335%configure \
5dfeafd7 336 --with-editor=vi \
12ae68c1 337 --with-zlib=%{_libdir} \
93f1d402 338 --with-python=%{__python} \
339 --with-perl5=%{__perl} \
536b3fd3
AM
340%if %{with net_client_only}
341 --without-apache \
342 --without-swig \
343 --without-apxs \
344 --without-berkeley-db \
345%else
227d7ab4 346 --disable-dso \
86ee97d3 347 --disable-mod-activation \
0905b458 348%if %{with apache}
536b3fd3 349 --with-apxs=%{_sbindir}/apxs \
0905b458 350%else
351 --without-apache \
352 --without-apxs \
536b3fd3 353 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 354%endif
cf353d53 355%if !%{with python} && !%{with perl}
0905b458 356 --without-swig \
357%endif
1cc7453a 358 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 359%endif
1cc7453a 360 --with-jdk="%{java_home}" \
e30588c4 361 --with-neon=%{_prefix} \
78f330c4 362 --disable-neon-version-check \
16429189 363 --with-apr=%{_bindir}/apr-1-config \
364 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 365
1f630180 366%{__make} -j1
536b3fd3 367
cf353d53 368%if !%{with net_client_only}
b56474ff 369# python
0905b458 370%if %{with python}
86a4919e 371%{__make} swig-py \
65318afa
AF
372 swig_pydir=%{py_sitedir}/libsvn \
373 swig_pydir_extra=%{py_sitedir}/svn
0905b458 374%endif
b56474ff 375# perl
0905b458 376%if %{with perl}
bf539998
AM
377%{__make} swig-pl-lib
378odir=$(pwd)
379cd subversion/bindings/swig/perl/native
380%{__perl} Makefile.PL INSTALLDIRS=vendor
381%{__make}
382cd $odir
536b3fd3 383%endif
1cc7453a 384%if %{with javahl}
385%{__make} javahl \
386 javahl_javadir="%{_javadir}"
387%endif
d46e45ba
AM
388# ruby
389%if %{with ruby}
390%{__make} swig-rb
391%endif
12ae68c1
AM
392%endif
393
394%if %{with tests}
395%{__make} check
d46e45ba
AM
396%if %{with python}
397%{__make} check-swig-py
398%endif
399%if %{with perl}
400%{__make} check-swig-pl
401%endif
402%if %{with ruby}
403%{__make} check-swig-rb
404%endif
0905b458 405%endif
93b78127
AM
406
407%install
408rm -rf $RPM_BUILD_ROOT
1326bb99 409install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 410 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 411 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 412 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 413
1f630180 414%{__make} install -j1 \
1cc7453a 415%if %{with javahl}
416 install-javahl \
417 javahl_javadir="%{_javadir}" \
418%endif
d46e45ba
AM
419%if !%{with net_client_only}
420%if %{with python}
0905b458 421 install-swig-py \
d46e45ba
AM
422%endif
423%if %{with ruby}
424 install-swig-rb install-swig-rb-doc \
425%endif
0905b458 426%endif
f2a757d6 427 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 428 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
429 swig_pydir=%{py_sitedir}/libsvn \
430 swig_pydir_extra=%{py_sitedir}/svn
93b78127 431
cf353d53 432%if !%{with net_client_only} && %{with perl}
bf539998
AM
433%{__make} install-swig-pl-lib \
434 DESTDIR=$RPM_BUILD_ROOT
435odir=$(pwd)
436cd subversion/bindings/swig/perl/native
437%{__make} install \
438 DESTDIR=$RPM_BUILD_ROOT \
439 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
440 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
441cd $odir
442%endif
443
0905b458 444%if %{with apache}
1af5e34d
ER
445install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
446install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
447install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
448install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 449%endif
93b78127 450
cf353d53 451%if !%{with net_client_only}
1326bb99 452install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 453%if %{with python}
f4e6a380
AM
454%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
455%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
456find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
457install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 458%endif
0905b458 459%endif
f4e6a380 460
1326bb99
JK
461install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
462install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 463
205a3ddc
AM
464%find_lang %{name}
465
a6ecf312 466rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
467
e23909be
JB
468%clean
469rm -rf $RPM_BUILD_ROOT
470
a1bac09d
471%pre svnserve
472%groupadd -g 86 svn
473%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
474
d2bf70bf
JB
475%post libs -p /sbin/ldconfig
476%postun libs -p /sbin/ldconfig
477
478%post devel -p /sbin/postshell
6f99c3bd 479-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 480
d2bf70bf 481%postun devel -p /sbin/postshell
6f99c3bd 482-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 483
d2bf70bf
JB
484%post -n perl-subversion -p /sbin/ldconfig
485%postun -n perl-subversion -p /sbin/ldconfig
486
487%post -n python-subversion -p /sbin/ldconfig
488%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 489
b56474ff 490%post svnserve
e8d9186f
ER
491/sbin/chkconfig --add svnserve
492%service svnserve restart "svnserve daemon"
493
b56474ff
AM
494%preun svnserve
495if [ "$1" = "0" ]; then
e8d9186f
ER
496 %service svnserve stop
497 /sbin/chkconfig --del svnserve
b56474ff
AM
498fi
499
a1bac09d
500%postun svnserve
501if [ "$1" = "0" ]; then
502 %userremove svn
503 %groupremove svn
504fi
505
93b78127 506%post -n apache-mod_dav_svn
e8d9186f 507%service -q httpd restart
93b78127
AM
508
509%preun -n apache-mod_dav_svn
510if [ "$1" = "0" ]; then
e8d9186f 511 %service -q httpd restart
93b78127
AM
512fi
513
93b78127
AM
514%files
515%defattr(644,root,root,755)
983a49f6 516%doc BUGS CHANGES COPYING INSTALL README
d37298dc 517%doc doc/*/*.html
4bbdbbf8
AM
518%doc tools/hook-scripts/*.{pl,py,example}
519%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 520%doc tools/xslt/*
fa3ff1b2 521%attr(755,root,root) %{_bindir}/svn*
b56474ff 522%exclude %{_bindir}/svnserve
cf353d53 523%if !%{with net_client_only}
9cb7e099 524%exclude %{_bindir}/svn-hot-backup
d62de3c9 525%endif
f4e6a380 526%{_mandir}/man1/*
af654ba5
AM
527%{_mandir}/man5/*
528%{_mandir}/man8/*
b56474ff 529%exclude %{_mandir}/man?/svnserve*
f4e6a380 530
205a3ddc 531%files libs -f %{name}.lang
f4e6a380 532%defattr(644,root,root,755)
227d7ab4 533%attr(755,root,root) %{_libdir}/lib*.so.*
164f681b
AM
534%if %{with perl} || %{with python}
535%exclude %{_libdir}/lib*_swig_*.so.*
536%endif
1cc7453a 537%if %{with javahl}
538%exclude %{_libdir}/libsvnjavahl*.so.*.*.*
539%exclude %{_libdir}/libsvnjavahl*.so.?
540%exclude %{_libdir}/libsvnjavahl*.so
541%endif
93b78127
AM
542
543%files devel
544%defattr(644,root,root,755)
227d7ab4 545%attr(755,root,root) %{_libdir}/lib*.so
b2bcb22a 546%{_libdir}/lib*.la
b72a2fbb 547%if %{with perl} || %{with python}
c00fdf6f 548%exclude %{_libdir}/lib*_swig_*.so
b72a2fbb 549%endif
1cc7453a 550%if %{with javahl}
551%exclude %{_libdir}/libsvnjavahl*.so
552%endif
d2bf70bf 553%{_includedir}/%{name}*
1326bb99 554%{_examplesdir}/%{name}-%{version}
93b78127
AM
555
556%files static
557%defattr(644,root,root,755)
558%{_libdir}/lib*.a
559
cf353d53 560%if !%{with net_client_only}
b56474ff
AM
561%files svnserve
562%defattr(644,root,root,755)
563%attr(755,root,root) %{_bindir}/svnserve
564%{_mandir}/man?/svnserve*
a1bac09d
565%dir %attr(750,svn,svn) /home/services/subversion
566%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 567%if %{with apache}
b56474ff 568%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 569%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 570%endif
b56474ff 571
4bbdbbf8
AM
572%files tools
573%defattr(644,root,root,755)
1326bb99 574%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 575
576%files -n bash-completion-subversion
101e74de 577%defattr(644,root,root,755)
1326bb99 578/etc/bash_completion.d/%{name}
536b3fd3 579
1cc7453a 580%if %{with javahl}
581%files -n java-subversion
582%defattr(644,root,root,755)
583%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.*.*.*
584%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.?
585%attr(755,root,root) %{_libdir}/libsvnjavahl*.so
586%{_javadir}/svn-javahl.jar
587%endif
588
0905b458 589%if %{with python}
fa3ff1b2 590%files -n python-subversion
f4e6a380 591%defattr(644,root,root,755)
4bbdbbf8 592%doc tools/backup/*.py tools/examples/*.py
f4e6a380 593%dir %{py_sitedir}/svn
65318afa 594%dir %{py_sitedir}/libsvn
f4e6a380 595%{py_sitedir}/svn/*.py[co]
65318afa
AF
596%{py_sitedir}/libsvn/*.py[co]
597%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 598%{_examplesdir}/python-%{name}-%{version}
c00fdf6f 599%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
0905b458 600%endif
f4e6a380 601
0905b458 602%if %{with perl}
b56474ff
AM
603%files -n perl-subversion
604%defattr(644,root,root,755)
605%{perl_vendorarch}/SVN
606%dir %{perl_vendorarch}/auto/SVN
607%dir %{perl_vendorarch}/auto/SVN/*
608%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
609%{perl_vendorarch}/auto/SVN/*/*.bs
610%{_mandir}/man3/*.3pm*
c00fdf6f 611%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
0905b458 612%endif
b56474ff 613
d46e45ba
AM
614%if %{with ruby}
615%files -n ruby-subversion
616%defattr(644,root,root,755)
617%{_datadir}/ri/*.*/site/Svn
618%{_datadir}/ri/*.*/site/Time
619%{_datadir}/ri/*.*/site/Uconv
620%{_datadir}/ri/*.*/site/*.rid
621%{_datadir}/ri/*.*/site/Kernel/*
622%{_datadir}/ri/*.*/site/OptionParser/*
623%{_libdir}/ruby/site_ruby/svn
624%endif
625
0905b458 626%if %{with apache}
93b78127
AM
627%files -n apache-mod_dav_svn
628%defattr(644,root,root,755)
1af5e34d
ER
629%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
630%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
631
632%files -n apache-mod_authz_svn
633%defattr(644,root,root,755)
634%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
635%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
636%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 637%endif
7b27380f
ER
638
639%endif # net_client_only
This page took 0.175216 seconds and 4 git commands to generate.