]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- Add backport of Python bindings from 1.5 (trunk) to make bzr_svn
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4#
bab73684 5# Conditional build:
bc526ca4 6%bcond_with net_client_only # build only net client
0905b458 7%bcond_without python # build without python bindings
8%bcond_without perl # build without perl bindings
9%bcond_without apache # build without apache support (webdav, etc)
7b27380f 10#
b56474ff 11%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 12%define apxs /usr/sbin/apxs
1f630180
ER
13%define pdir SVN
14%define pnam _Core
67cb9518 15Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
16Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
17Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 18Name: subversion
0257ce29 19Version: 1.4.4
6f585d10 20Release: 2
93b78127
AM
21License: Apache/BSD Style
22Group: Development/Version Control
e30588c4 23Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
0257ce29 24# Source0-md5: 702655defa418bab8f683f6268b4fd30
93b78127 25Source1: %{name}-dav_svn.conf
65318afa 26Source2: %{name}-authz_svn.conf
b56474ff
AM
27Source3: %{name}-svnserve.init
28Source4: %{name}-svnserve.sysconfig
f313e9a9 29Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 30Patch0: %{name}-home_etc.patch
d4bccc60 31Patch1: %{name}-DESTDIR.patch
3eab78e4 32Patch2: %{name}-neon.patch
f313e9a9 33Patch3: %{name}-python_bindings.patch
93b78127 34URL: http://subversion.tigris.org/
4945947e
AM
35%if %{with net_client_only}
36%global apache_modules_api 0
37%else
f2a757d6 38%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 39BuildRequires: automake
3817faf5 40BuildRequires: db-devel >= 4.1.25
e8d9186f 41BuildRequires: rpmbuild(macros) >= 1.268
0905b458 42%if %{with perl}
522a69b4 43BuildRequires: perl-devel >= 1:5.8.0
44BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 45BuildRequires: swig-perl >= 1.3.24
536b3fd3 46%endif
0905b458 47%endif
16429189 48BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 49BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 50BuildRequires: autoconf >= 2.59
79d8c53c 51BuildRequires: bison
93b78127 52BuildRequires: expat-devel
86ea8fde 53BuildRequires: gettext-devel
f4e6a380 54BuildRequires: libtool >= 1.4-9
bd3c99a8 55BuildRequires: neon-devel >= 0.26.0
53855fbf 56BuildRequires: python >= 2.2
ed6210a2 57BuildRequires: python-modules >= 2.2
f313e9a9 58%if %{with python}
59BuildRequires: python-devel >= 2.2
1f16145f 60BuildRequires: sed >= 4.0
15f9818d 61BuildRequires: swig-python >= 1.3.24
0905b458 62%endif
93b78127 63BuildRequires: texinfo
7b35d179 64BuildRequires: which
93794e7c
JR
65# update -neon patch before messing with this BC
66BuildConflicts: neon-devel > 0.26.3
027f8ebe 67Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
f4070f5f
ER
70%define _apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
71%define _libexecdir %{_libdir}/svn
93b78127
AM
72
73%description
74The goal of the Subversion project is to build a version control
75system that is a compelling replacement for CVS in the open source
76community.
77
78Our goals are:
79- All current CVS features.
80- Directories, renames, and file meta-data are versioned.
81- Symbolic links, etc, are supported
82- Commits are truly atomic.
83- Branching and tagging are cheap (constant time) operations
84- Repeated merges are handled gracefully
85- Support for plug-in client side diff programs
86- Natively client/server
87- Client/server protocol sends diffs in both directions
88- Costs are proportional to change size, not project size
89- Internationalization
90- Progressive multi-lingual support
91
aa59005f 92%description -l pl.UTF-8
93b78127
AM
93Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
94zamiennika dla CVS.
95
96Cele projektu to:
aa59005f
JR
97- Wszystkie aktualne możliwości CVS.
98- Katalogi, zmiany nazw oraz meta-dane plików są wersjonowane.
99- Wsparcie dla linków symbolicznych itp.
100- Commity są w pełni atomowe.
101- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
102- Powtarzające merge.
f313e9a9 103- Wsparcie dla pluginów diff po stronie klienta.
93b78127 104- Natywny klient/serwer.
aa59005f 105- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
106- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
107- Internacjonalizacja.
aa59005f 108- Postępujące wsparcie dla wielu języków.
93b78127 109
aa59005f
JR
110%description -l pt_BR.UTF-8
111O objetivo do projeto Subversion é construir um sistema de controle de
112versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 113System) na comunidade opensource, fornecendo grandes melhorias.
114
f4e6a380
AM
115%package libs
116Summary: Subversion libraries and modules
abe3c421 117Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 118Group: Libraries
e30588c4 119Requires: neon >= 0.24.7
53855fbf 120Obsoletes: libsubversion0
f4e6a380
AM
121
122%description libs
123Subversion libraries and modules.
124
aa59005f
JR
125%description libs -l pl.UTF-8
126Biblioteka subversion oraz ładowalne moduły.
f4e6a380 127
93b78127
AM
128%package devel
129Summary: Header files and develpment documentation for subversion
abe3c421
ER
130Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
131Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 132Group: Development/Libraries
9cb7e099 133Requires: %{name}-libs = %{version}-%{release}
c5b1d686 134Requires: apr-util-devel >= 1:1.0.0
e30588c4 135Requires: neon-devel >= 0.24.7
12cf252c 136Obsoletes: libsubversion0-devel
93b78127
AM
137
138%description devel
139Header files and develpment documentation for subversion.
140
aa59005f
JR
141%description devel -l pl.UTF-8
142Pliki nagłówkowe i dokumetacja do subversion.
93b78127 143
aa59005f
JR
144%description devel -l pt_BR.UTF-8
145Este pacote provê os arquivos necessários para desenvolvedores
92066deb 146interagirem com o Subversion.
147
93b78127
AM
148%package static
149Summary: Static subversion library
abe3c421
ER
150Summary(pl.UTF-8): Biblioteka statyczna subversion
151Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
152Group: Development/Libraries
153Requires: %{name}-devel = %{version}
12cf252c 154Obsoletes: libsubversion0-static-devel
93b78127
AM
155
156%description static
157Static subversion library.
158
aa59005f 159%description static -l pl.UTF-8
93b78127
AM
160Biblioteka statyczna subversion.
161
aa59005f
JR
162%description static -l pt_BR.UTF-8
163Este pacote provê um cliente estático do subversion.
92066deb 164
b56474ff
AM
165%package svnserve
166Summary: Subversion svnserve
abe3c421 167Summary(pl.UTF-8): Subversion svnserve
b56474ff 168Group: Networking/Daemons
3817faf5 169Requires(post,preun): /sbin/chkconfig
9cb7e099 170Requires: %{name} = %{version}-%{release}
7b27380f 171Requires: rc-scripts
b56474ff
AM
172
173%description svnserve
174Subversion svnserve server.
175
aa59005f 176%description svnserve -l pl.UTF-8
b56474ff
AM
177Serwer subversion svnserve.
178
4bbdbbf8
AM
179%package tools
180Summary: Subversion tools and scripts
abe3c421
ER
181Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
182Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 183Group: Applications
4bbdbbf8 184%pyrequires_eq python
7b27380f 185Requires: %{name} = %{version}-%{release}
1271c9bd 186Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
187Requires: python-subversion = %{version}
188
189%description tools
190Subversion tools and scripts.
191
aa59005f
JR
192%description tools -l pl.UTF-8
193Narzędzia oraz skrypty dla subversion.
4bbdbbf8 194
fe5bb6bb 195%package -n bash-completion-subversion
196Summary: bash completion for subversion
abe3c421 197Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 198Group: Applications/Shells
e30588c4 199Requires: %{name} = %{version}-%{release}
53855fbf 200Requires: bash-completion
e30588c4 201Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 202
203%description -n bash-completion-subversion
204Bash completion for subversion.
205
aa59005f
JR
206%description -n bash-completion-subversion -l pl.UTF-8
207Dopełnienia basha dla subversion.
fe5bb6bb 208
fa3ff1b2 209%package -n python-subversion
f4e6a380 210Summary: Subversion python bindings
abe3c421
ER
211Summary(pl.UTF-8): Dowiązania do subversion dla pythona
212Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
f4e6a380 213Group: Development/Languages/Python
f4e6a380 214%pyrequires_eq python
9cb7e099 215Requires: %{name}-libs = %{version}-%{release}
53855fbf 216Obsoletes: subversion-python
f4e6a380 217
fa3ff1b2 218%description -n python-subversion
f4e6a380
AM
219Subversion python bindings.
220
aa59005f
JR
221%description -n python-subversion -l pl.UTF-8
222Dowiązania do subversion dla pythona.
f4e6a380 223
aa59005f
JR
224%description -n python-subversion -l pt_BR.UTF-8
225Módulos python para acessar os recursos do Subversion.
92066deb 226
b56474ff
AM
227%package -n perl-subversion
228Summary: Subversion perl bindings
abe3c421
ER
229Summary(pl.UTF-8): Dowiązania do subversion dla perla
230Summary(pt_BR.UTF-8): Módulos perl para acessar os recursos do Subversion
b56474ff 231Group: Development/Languages/Perl
9cb7e099 232Requires: %{name}-libs = %{version}-%{release}
53855fbf 233Obsoletes: subversion-perl
b56474ff
AM
234
235%description -n perl-subversion
236Subversion perl bindings.
237
aa59005f
JR
238%description -n perl-subversion -l pl.UTF-8
239Dowiązania do subversion dla perl.
b56474ff 240
aa59005f
JR
241%description -n perl-subversion -l pt_BR.UTF-8
242Módulos perl para acessar os recursos do Subversion.
b56474ff 243
93b78127
AM
244%package -n apache-mod_dav_svn
245Summary: Apache module: Subversion Server
abe3c421 246Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 247Group: Networking/Daemons
7b27380f 248Requires: %{name} = %{version}-%{release}
53855fbf 249Requires: apache(modules-api) = %apache_modules_api
7887b1ac 250Requires: apache-mod_dav
93b78127
AM
251
252%description -n apache-mod_dav_svn
253Apache module: Subversion Server.
254
aa59005f
JR
255%description -n apache-mod_dav_svn -l pl.UTF-8
256Moduł apache: Serwer Subversion.
93b78127 257
65318afa
AF
258%package -n apache-mod_authz_svn
259Summary: Apache module: Subversion Server - path-based authorization
abe3c421 260Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 261Group: Networking/Daemons
53855fbf 262Requires: apache(modules-api) = %apache_modules_api
9cb7e099 263Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
264
265%description -n apache-mod_authz_svn
266Apache module: Subversion Server - path-based authorization.
267
aa59005f
JR
268%description -n apache-mod_authz_svn -l pl.UTF-8
269Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 270
93b78127 271%prep
281e2246 272%setup -q
e30588c4 273rm -rf apr apr-util neon
ed6210a2 274%patch0 -p0
d4bccc60 275%patch1 -p1
3eab78e4 276%patch2 -p1
f313e9a9 277%patch3 -p1
027f8ebe 278
93b78127 279%build
f313e9a9 280rm subversion/bindings/swig/proxy/*.swg
281(cd subversion/bindings/swig && python "%{SOURCE5}")
a7bcb345 282cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 283chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 284
fa3ff1b2 285# don't enable dso - currently it's broken
93b78127 286%configure \
5dfeafd7
AM
287 --with-editor=vi \
288 --with-zlib \
497058f9
AM
289 --with-python=%{_bindir}/python \
290 --with-perl5=%{_bindir}/perl \
536b3fd3
AM
291%if %{with net_client_only}
292 --without-apache \
293 --without-swig \
294 --without-apxs \
295 --without-berkeley-db \
296%else
227d7ab4 297 --disable-dso \
86ee97d3 298 --disable-mod-activation \
0905b458 299%if %{with apache}
536b3fd3 300 --with-apxs=%{_sbindir}/apxs \
0905b458 301%else
302 --without-apache \
303 --without-apxs \
536b3fd3 304 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 305%endif
cf353d53 306%if !%{with python} && !%{with perl}
0905b458 307 --without-swig \
308%endif
536b3fd3 309%endif
e30588c4 310 --with-neon=%{_prefix} \
78f330c4 311 --disable-neon-version-check \
16429189 312 --with-apr=%{_bindir}/apr-1-config \
313 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 314
1f630180 315%{__make} -j1
536b3fd3 316
cf353d53 317%if !%{with net_client_only}
b56474ff 318# python
0905b458 319%if %{with python}
86a4919e 320%{__make} swig-py \
65318afa
AF
321 swig_pydir=%{py_sitedir}/libsvn \
322 swig_pydir_extra=%{py_sitedir}/svn
0905b458 323%endif
b56474ff 324# perl
0905b458 325%if %{with perl}
bf539998
AM
326%{__make} swig-pl-lib
327odir=$(pwd)
328cd subversion/bindings/swig/perl/native
329%{__perl} Makefile.PL INSTALLDIRS=vendor
330%{__make}
331cd $odir
536b3fd3 332%endif
0905b458 333%endif
93b78127
AM
334
335%install
336rm -rf $RPM_BUILD_ROOT
1326bb99
JK
337install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
338 $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
afb35189 339 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 340 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 341
1f630180 342%{__make} install -j1 \
cf353d53 343%if !%{with net_client_only} && %{with python}
0905b458 344 install-swig-py \
345%endif
f2a757d6 346 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 347 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
348 swig_pydir=%{py_sitedir}/libsvn \
349 swig_pydir_extra=%{py_sitedir}/svn
93b78127 350
cf353d53 351%if !%{with net_client_only} && %{with perl}
bf539998
AM
352%{__make} install-swig-pl-lib \
353 DESTDIR=$RPM_BUILD_ROOT
354odir=$(pwd)
355cd subversion/bindings/swig/perl/native
356%{__make} install \
357 DESTDIR=$RPM_BUILD_ROOT \
358 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
359 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
360cd $odir
361%endif
362
0905b458 363%if %{with apache}
23bc94fc 364install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
65318afa 365install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
b56474ff
AM
366install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
367install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 368%endif
93b78127 369
cf353d53 370%if !%{with net_client_only}
1326bb99 371install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 372%if %{with python}
f4e6a380
AM
373%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
374%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
375find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
376install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 377%endif
0905b458 378%endif
f4e6a380 379
1326bb99
JK
380install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
381install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 382
205a3ddc
AM
383%find_lang %{name}
384
a6ecf312 385rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
386
e23909be
JB
387%clean
388rm -rf $RPM_BUILD_ROOT
389
65318afa 390%post devel
93b78127
AM
391[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
392
65318afa 393%postun devel
93b78127
AM
394[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
395
e23909be
JB
396%post libs -p /sbin/ldconfig
397%postun libs -p /sbin/ldconfig
164f681b
AM
398%post -n python-subversion -p /sbin/ldconfig
399%postun -n perl-subversion -p /sbin/ldconfig
f4e6a380 400
b56474ff 401%post svnserve
e8d9186f
ER
402/sbin/chkconfig --add svnserve
403%service svnserve restart "svnserve daemon"
404
b56474ff
AM
405%preun svnserve
406if [ "$1" = "0" ]; then
e8d9186f
ER
407 %service svnserve stop
408 /sbin/chkconfig --del svnserve
b56474ff
AM
409fi
410
93b78127 411%post -n apache-mod_dav_svn
e8d9186f 412%service -q httpd restart
93b78127
AM
413
414%preun -n apache-mod_dav_svn
415if [ "$1" = "0" ]; then
e8d9186f 416 %service -q httpd restart
93b78127
AM
417fi
418
93b78127
AM
419%files
420%defattr(644,root,root,755)
983a49f6 421%doc BUGS CHANGES COPYING INSTALL README
d37298dc 422%doc doc/*/*.html
4bbdbbf8
AM
423%doc tools/hook-scripts/*.{pl,py,example}
424%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 425%doc tools/xslt/*
fa3ff1b2 426%attr(755,root,root) %{_bindir}/svn*
b56474ff 427%exclude %{_bindir}/svnserve
cf353d53 428%if !%{with net_client_only}
9cb7e099 429%exclude %{_bindir}/svn-hot-backup
d62de3c9 430%endif
f4e6a380 431%{_mandir}/man1/*
af654ba5
AM
432%{_mandir}/man5/*
433%{_mandir}/man8/*
b56474ff 434%exclude %{_mandir}/man?/svnserve*
f4e6a380 435
205a3ddc 436%files libs -f %{name}.lang
f4e6a380 437%defattr(644,root,root,755)
227d7ab4 438%attr(755,root,root) %{_libdir}/lib*.so.*
164f681b
AM
439%if %{with perl} || %{with python}
440%exclude %{_libdir}/lib*_swig_*.so.*
441%endif
93b78127
AM
442
443%files devel
444%defattr(644,root,root,755)
227d7ab4
AM
445%{_includedir}/%{name}*
446%attr(755,root,root) %{_libdir}/lib*.so
b2bcb22a 447%{_libdir}/lib*.la
b72a2fbb 448%if %{with perl} || %{with python}
c00fdf6f 449%exclude %{_libdir}/lib*_swig_*.so
b72a2fbb 450%endif
1326bb99 451%{_examplesdir}/%{name}-%{version}
93b78127
AM
452
453%files static
454%defattr(644,root,root,755)
455%{_libdir}/lib*.a
456
cf353d53 457%if !%{with net_client_only}
b56474ff
AM
458%files svnserve
459%defattr(644,root,root,755)
460%attr(755,root,root) %{_bindir}/svnserve
461%{_mandir}/man?/svnserve*
afb35189 462%dir /home/services/subversion
a54611db 463%dir /home/services/subversion/repos
0905b458 464%if %{with apache}
b56474ff 465%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 466%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 467%endif
b56474ff 468
4bbdbbf8
AM
469%files tools
470%defattr(644,root,root,755)
1326bb99 471%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 472
473%files -n bash-completion-subversion
101e74de 474%defattr(644,root,root,755)
1326bb99 475/etc/bash_completion.d/%{name}
536b3fd3 476
0905b458 477%if %{with python}
fa3ff1b2 478%files -n python-subversion
f4e6a380 479%defattr(644,root,root,755)
4bbdbbf8 480%doc tools/backup/*.py tools/examples/*.py
f4e6a380 481%dir %{py_sitedir}/svn
65318afa 482%dir %{py_sitedir}/libsvn
f4e6a380 483%{py_sitedir}/svn/*.py[co]
65318afa
AF
484%{py_sitedir}/libsvn/*.py[co]
485%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 486%{_examplesdir}/python-%{name}-%{version}
c00fdf6f 487%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
0905b458 488%endif
f4e6a380 489
0905b458 490%if %{with perl}
b56474ff
AM
491%files -n perl-subversion
492%defattr(644,root,root,755)
493%{perl_vendorarch}/SVN
494%dir %{perl_vendorarch}/auto/SVN
495%dir %{perl_vendorarch}/auto/SVN/*
496%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
497%{perl_vendorarch}/auto/SVN/*/*.bs
498%{_mandir}/man3/*.3pm*
c00fdf6f 499%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
0905b458 500%endif
b56474ff 501
0905b458 502%if %{with apache}
93b78127
AM
503%files -n apache-mod_dav_svn
504%defattr(644,root,root,755)
86ea8fde 505%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
65318afa
AF
506%attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
507
508%files -n apache-mod_authz_svn
509%defattr(644,root,root,755)
510%doc subversion/mod_authz_svn/INSTALL
86ea8fde 511%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
65318afa 512%attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
536b3fd3 513%endif
7b27380f
ER
514
515%endif # net_client_only
This page took 0.243686 seconds and 4 git commands to generate.