]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- updated BRs
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
9688ba4c 5# - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
65f2befa 16%bcond_without kwallet # build without kde4 wallet support
3c200272 17%bcond_without kde # build without kde4 support (alias for kwallet)
bfb248d0 18%bcond_without gnome # build without gnome keyring support
12c96b58 19
b56474ff 20%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 21%define apxs /usr/sbin/apxs
1f630180
ER
22%define pdir SVN
23%define pnam _Core
12c96b58 24
3c200272
JB
25%if !%{with kde}
26%undefine with_kwallet
27%endif
04129f48 28%if %{with neon}
a510fada 29%define webdavlib neon
04129f48
AG
30%else
31%define webdavlib serf
a510fada 32%endif
67cb9518 33Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
34Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
35Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 36Name: subversion
84e0d0fb 37Version: 1.6.15
38Release: 1
6f88d80e 39License: Apache/BSD-like
93b78127 40Group: Development/Version Control
a5c00029 41Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
84e0d0fb 42# Source0-md5: 113fca1d9e4aa389d7dc2b210010fa69
93b78127 43Source1: %{name}-dav_svn.conf
65318afa 44Source2: %{name}-authz_svn.conf
b56474ff
AM
45Source3: %{name}-svnserve.init
46Source4: %{name}-svnserve.sysconfig
a510fada
AM
47# current subversion tarball has correct *.swg files
48# but after regeneration these are broken again, so
49# we still need this script
f313e9a9 50Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 51Patch0: %{name}-home_etc.patch
d46e45ba 52Patch1: %{name}-DESTDIR.patch
00664663 53Patch2: %{name}-ruby-datadir-path.patch
1cfe7af2 54Patch3: %{name}-tests.patch
dc8fcc41 55URL: http://subversion.apache.org/
4945947e
AM
56%if %{with net_client_only}
57%global apache_modules_api 0
58%else
f2a757d6 59%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
1cfe7af2 60BuildRequires: autoconf
7b27380f 61BuildRequires: automake
3817faf5 62BuildRequires: db-devel >= 4.1.25
1cfe7af2 63BuildRequires: libtool
58f4b627 64BuildRequires: rpmbuild(macros) >= 1.583
0905b458 65%if %{with perl}
522a69b4 66BuildRequires: perl-devel >= 1:5.8.0
67BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 68BuildRequires: swig-perl >= 1.3.24
536b3fd3 69%endif
6ac3574b
AM
70%if %{with python}
71BuildRequires: python-ctypesgen
c01720ea 72BuildRequires: python-devel >= 1:2.5
6ac3574b
AM
73BuildRequires: swig-python >= 1.3.24
74%endif
75%if %{with ruby}
76BuildRequires: ruby-devel
77BuildRequires: swig-ruby >= 1.3.24
78%endif
af0d490b 79%if %{with javahl}
20c5f543 80BuildRequires: jdk
af0d490b 81%endif
6ac3574b 82BuildRequires: cyrus-sasl-devel
0905b458 83%endif
16429189 84BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 85BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 86BuildRequires: autoconf >= 2.59
79d8c53c 87BuildRequires: bison
93b78127 88BuildRequires: expat-devel
86ea8fde 89BuildRequires: gettext-devel
7b9fe651 90%{?with_gnome:BuildRequires: libgnome-keyring-devel}
65f2befa 91%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 92BuildRequires: libtool >= 1.4-9
54271075 93BuildRequires: pkgconfig
c01720ea 94BuildRequires: rpm-pythonprov
a562165a 95BuildRequires: sed >= 4.0
c26d84c4 96BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
97BuildRequires: texinfo
98BuildRequires: which
99%if %{with neon}
bd3c99a8 100BuildRequires: neon-devel >= 0.26.0
a562165a
JB
101%else
102BuildRequires: serf-devel
e3ad24ea 103%endif
027f8ebe 104Requires: %{name}-libs = %{version}-%{release}
8b023a9d 105%requires_ge sqlite3
93b78127
AM
106BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
f4070f5f 108%define _libexecdir %{_libdir}/svn
1af5e34d
ER
109%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
110%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127 111
58f4b627
JR
112%define skip_post_check_so libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
113
93b78127
AM
114%description
115The goal of the Subversion project is to build a version control
116system that is a compelling replacement for CVS in the open source
117community.
118
119Our goals are:
120- All current CVS features.
121- Directories, renames, and file meta-data are versioned.
122- Symbolic links, etc, are supported
123- Commits are truly atomic.
124- Branching and tagging are cheap (constant time) operations
125- Repeated merges are handled gracefully
126- Support for plug-in client side diff programs
127- Natively client/server
128- Client/server protocol sends diffs in both directions
129- Costs are proportional to change size, not project size
130- Internationalization
131- Progressive multi-lingual support
132
aa59005f 133%description -l pl.UTF-8
93b78127
AM
134Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
135zamiennika dla CVS.
136
137Cele projektu to:
aa59005f 138- Wszystkie aktualne możliwości CVS.
24406120
JB
139- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
140- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
141- Commity są w pełni atomowe.
142- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
143- Dobra obsługa powtarzanego łączenia (merge).
144- Obsługa wtyczek diff po stronie klienta.
93b78127 145- Natywny klient/serwer.
aa59005f 146- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
147- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
148- Internacjonalizacja.
aa59005f 149- Postępujące wsparcie dla wielu języków.
93b78127 150
aa59005f
JR
151%description -l pt_BR.UTF-8
152O objetivo do projeto Subversion é construir um sistema de controle de
153versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 154System) na comunidade opensource, fornecendo grandes melhorias.
155
f4e6a380
AM
156%package libs
157Summary: Subversion libraries and modules
abe3c421 158Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 159Group: Libraries
04129f48 160%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 161Obsoletes: libsubversion0
f4e6a380
AM
162
163%description libs
164Subversion libraries and modules.
165
aa59005f
JR
166%description libs -l pl.UTF-8
167Biblioteka subversion oraz ładowalne moduły.
f4e6a380 168
93b78127
AM
169%package devel
170Summary: Header files and develpment documentation for subversion
abe3c421
ER
171Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
172Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 173Group: Development/Libraries
9cb7e099 174Requires: %{name}-libs = %{version}-%{release}
c5b1d686 175Requires: apr-util-devel >= 1:1.0.0
04129f48 176%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 177Obsoletes: libsubversion0-devel
93b78127
AM
178
179%description devel
180Header files and develpment documentation for subversion.
181
aa59005f
JR
182%description devel -l pl.UTF-8
183Pliki nagłówkowe i dokumetacja do subversion.
93b78127 184
aa59005f
JR
185%description devel -l pt_BR.UTF-8
186Este pacote provê os arquivos necessários para desenvolvedores
92066deb 187interagirem com o Subversion.
188
93b78127
AM
189%package static
190Summary: Static subversion library
abe3c421
ER
191Summary(pl.UTF-8): Biblioteka statyczna subversion
192Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
193Group: Development/Libraries
194Requires: %{name}-devel = %{version}
12cf252c 195Obsoletes: libsubversion0-static-devel
93b78127
AM
196
197%description static
198Static subversion library.
199
aa59005f 200%description static -l pl.UTF-8
93b78127
AM
201Biblioteka statyczna subversion.
202
aa59005f
JR
203%description static -l pt_BR.UTF-8
204Este pacote provê um cliente estático do subversion.
92066deb 205
b56474ff
AM
206%package svnserve
207Summary: Subversion svnserve
abe3c421 208Summary(pl.UTF-8): Subversion svnserve
b56474ff 209Group: Networking/Daemons
3817faf5 210Requires(post,preun): /sbin/chkconfig
93f1d402 211Requires(postun): /usr/sbin/groupdel
212Requires(postun): /usr/sbin/userdel
213Requires(pre): /bin/id
214Requires(pre): /usr/bin/getgid
215Requires(pre): /usr/lib/rpm/user_group.sh
216Requires(pre): /usr/sbin/groupadd
217Requires(pre): /usr/sbin/useradd
218Requires(pre): /usr/sbin/usermod
9cb7e099 219Requires: %{name} = %{version}-%{release}
7b27380f 220Requires: rc-scripts
a1bac09d
221Provides: group(svn)
222Provides: user(svn)
b56474ff
AM
223
224%description svnserve
225Subversion svnserve server.
226
aa59005f 227%description svnserve -l pl.UTF-8
b56474ff
AM
228Serwer subversion svnserve.
229
4bbdbbf8
AM
230%package tools
231Summary: Subversion tools and scripts
abe3c421
ER
232Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
233Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 234Group: Applications
4bbdbbf8 235%pyrequires_eq python
7b27380f 236Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
237Requires: python-subversion = %{version}
238
239%description tools
240Subversion tools and scripts.
241
aa59005f
JR
242%description tools -l pl.UTF-8
243Narzędzia oraz skrypty dla subversion.
4bbdbbf8 244
fe5bb6bb 245%package -n bash-completion-subversion
246Summary: bash completion for subversion
abe3c421 247Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 248Group: Applications/Shells
e30588c4 249Requires: %{name} = %{version}-%{release}
53855fbf 250Requires: bash-completion
e30588c4 251Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 252
253%description -n bash-completion-subversion
254Bash completion for subversion.
255
aa59005f
JR
256%description -n bash-completion-subversion -l pl.UTF-8
257Dopełnienia basha dla subversion.
fe5bb6bb 258
1cc7453a 259%package -n java-subversion
65c1d4bd
JB
260Summary: Subversion Java bindings
261Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 262Group: Development/Languages/Java
263Requires: %{name}-libs = %{version}-%{release}
264
265%description -n java-subversion
266This is a set of Java classes which provide the functionality of
267subversion-libs, the Subversion libraries. It is useful if you want
268to, for example, write a Java class that manipulates a Subversion
269repository or working copy. See the 'subversion' package for more
270information.
271
65c1d4bd
JB
272%description -n java-subversion -l pl.UTF-8
273Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
274subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
275pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
276roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 277
fa3ff1b2 278%package -n python-subversion
65c1d4bd
JB
279Summary: Subversion Python bindings
280Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
281Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 282Group: Development/Languages/Python
f4e6a380 283%pyrequires_eq python
9cb7e099 284Requires: %{name}-libs = %{version}-%{release}
53855fbf 285Obsoletes: subversion-python
f4e6a380 286
fa3ff1b2 287%description -n python-subversion
65c1d4bd 288Subversion Python bindings.
f4e6a380 289
aa59005f 290%description -n python-subversion -l pl.UTF-8
65c1d4bd 291Dowiązania do Subversion dla Pythona.
f4e6a380 292
aa59005f 293%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 294Módulos Python para acessar os recursos do Subversion.
92066deb 295
137fcafd
AM
296%package -n python-csvn
297Summary: CTypes Subversion Python bindings
298Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
299Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
300Group: Development/Languages/Python
301%pyrequires_eq python
302Requires: %{name}-libs = %{version}-%{release}
303
304%description -n python-csvn
305Subversion CTypes Python bindings.
306
307%description -n python-csvn -l pl.UTF-8
308Dowiązania do Subversion dla Pythona używające CTypes.
309
310%description -n python-csvn -l pt_BR.UTF-8
311Módulos Python para acessar os recursos do Subversion.
312
b56474ff 313%package -n perl-subversion
65c1d4bd
JB
314Summary: Subversion Perl bindings
315Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
316Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 317Group: Development/Languages/Perl
9cb7e099 318Requires: %{name}-libs = %{version}-%{release}
53855fbf 319Obsoletes: subversion-perl
b56474ff
AM
320
321%description -n perl-subversion
65c1d4bd 322Subversion Perl bindings.
b56474ff 323
aa59005f 324%description -n perl-subversion -l pl.UTF-8
65c1d4bd 325Dowiązania do Subversion dla Perla.
b56474ff 326
aa59005f 327%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 328Módulos Perl para acessar os recursos do Subversion.
b56474ff 329
d46e45ba
AM
330%package -n ruby-subversion
331Summary: Subversion Ruby bindings
d2bf70bf 332Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
333Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
334Group: Development/Languages
335Requires: %{name}-libs = %{version}-%{release}
336Obsoletes: subversion-ruby
337
338%description -n ruby-subversion
339Subversion Ruby bindings.
340
341%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 342Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
343
344%description -n ruby-subversion -l pt_BR.UTF-8
345Módulos Ruby para acessar os recursos do Subversion.
346
93b78127
AM
347%package -n apache-mod_dav_svn
348Summary: Apache module: Subversion Server
abe3c421 349Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 350Group: Networking/Daemons
7b27380f 351Requires: %{name} = %{version}-%{release}
53855fbf 352Requires: apache(modules-api) = %apache_modules_api
7887b1ac 353Requires: apache-mod_dav
93b78127
AM
354
355%description -n apache-mod_dav_svn
356Apache module: Subversion Server.
357
aa59005f
JR
358%description -n apache-mod_dav_svn -l pl.UTF-8
359Moduł apache: Serwer Subversion.
93b78127 360
65318afa
AF
361%package -n apache-mod_authz_svn
362Summary: Apache module: Subversion Server - path-based authorization
abe3c421 363Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 364Group: Networking/Daemons
53855fbf 365Requires: apache(modules-api) = %apache_modules_api
9cb7e099 366Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
367
368%description -n apache-mod_authz_svn
369Apache module: Subversion Server - path-based authorization.
370
aa59005f
JR
371%description -n apache-mod_authz_svn -l pl.UTF-8
372Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 373
1429fa1c 374%package -n gnome-keyring-subversion
fe242fac
JB
375Summary: GNOME Keyring authentication provider for Subversion
376Summary(pl.UTF-8): Moduł uwierzytelniający GNOME Keyring dla Subversion
1429fa1c
AM
377Group: X11/Applications
378
379%description -n gnome-keyring-subversion
fe242fac
JB
380Authentication provider module for Subversion which allows SVN client
381to authenticate using GNOME Keyring.
1429fa1c
AM
382
383%description -n gnome-keyring-subversion -l pl.UTF-8
fe242fac
JB
384Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
385uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
1429fa1c
AM
386
387%package -n kde4-kwallet-subversion
fe242fac
JB
388Summary: KDE Wallet authentication provider for Subversion
389Summary(pl.UTF-8): Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
1429fa1c
AM
390Group: X11/Applications
391
392%description -n kde4-kwallet-subversion
fe242fac
JB
393Authentication provider module for Subversion which allows SVN client
394to authenticate using KDE Wallet.
1429fa1c
AM
395
396%description -n kde4-kwallet-subversion -l pl.UTF-8
fe242fac
JB
397Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
398uwierzytelniać się przy użyciu Portfela KDE.
1429fa1c 399
93b78127 400%prep
a5c00029 401%setup -q
ed6210a2 402%patch0 -p0
d4bccc60 403%patch1 -p1
00664663 404%patch2 -p0
1cfe7af2 405%patch3 -p1
a510fada
AM
406
407sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
408
409# serf.m4 macro is broken and ignores --without serf
244bdb04 410%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 411
93b78127 412%build
1cfe7af2
JB
413# disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
414#%{__rm} subversion/bindings/swig/proxy/*.swg
415#cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
67cb9518 416chmod +x ./autogen.sh && ./autogen.sh
1cfe7af2 417%{__libtoolize}
93b78127 418%configure \
5dfeafd7 419 --with-editor=vi \
12ae68c1 420 --with-zlib=%{_libdir} \
536b3fd3
AM
421%if %{with net_client_only}
422 --without-apache \
423 --without-swig \
424 --without-apxs \
425 --without-berkeley-db \
426%else
fa6fa2cf 427 --disable-runtime-module-search \
86ee97d3 428 --disable-mod-activation \
ad5c551e 429 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
0905b458 430%if %{with apache}
536b3fd3 431 --with-apxs=%{_sbindir}/apxs \
0905b458 432%else
433 --without-apache \
434 --without-apxs \
0905b458 435%endif
73ab938a 436%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 437 --without-swig \
438%endif
137fcafd 439 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 440 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 441%endif
1cc7453a 442 --with-jdk="%{java_home}" \
cf2589d0 443 --without-jikes \
04129f48 444%if %{with neon}
e3ad24ea 445 --without-serf \
e30588c4 446 --with-neon=%{_prefix} \
78f330c4 447 --disable-neon-version-check \
04129f48
AG
448%else
449 --with-serf=%{_prefix} \
450 --without-neon \
e3ad24ea 451%endif
16429189 452 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 453 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 454%if %{with kwallet}
1429fa1c 455 --with-kwallet \
65f2befa 456%endif
bfb248d0 457%if %{with gnome}
1429fa1c 458 --with-gnome-keyring
bfb248d0 459%endif
536b3fd3 460
1f630180 461%{__make} -j1
536b3fd3 462
cf353d53 463%if !%{with net_client_only}
b56474ff 464# python
0905b458 465%if %{with python}
137fcafd
AM
466# ctypes bindings
467%{__make} ctypes-python
468# swig bindings
86a4919e 469%{__make} swig-py \
65318afa
AF
470 swig_pydir=%{py_sitedir}/libsvn \
471 swig_pydir_extra=%{py_sitedir}/svn
0905b458 472%endif
b56474ff 473# perl
0905b458 474%if %{with perl}
390bb8f4 475%{__make} -j1 swig-pl-lib
bf539998
AM
476odir=$(pwd)
477cd subversion/bindings/swig/perl/native
478%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 479%{__make} -j1
bf539998 480cd $odir
536b3fd3 481%endif
1cc7453a 482%if %{with javahl}
b445847c 483%{__make} -j1 javahl \
1cc7453a 484 javahl_javadir="%{_javadir}"
485%endif
d46e45ba
AM
486# ruby
487%if %{with ruby}
488%{__make} swig-rb
489%endif
12ae68c1
AM
490%endif
491
492%if %{with tests}
493%{__make} check
d46e45ba 494%if %{with python}
137fcafd 495%{__make} check-ctypes-python
d46e45ba
AM
496%{__make} check-swig-py
497%endif
498%if %{with perl}
499%{__make} check-swig-pl
500%endif
501%if %{with ruby}
502%{__make} check-swig-rb
503%endif
0905b458 504%endif
93b78127
AM
505
506%install
507rm -rf $RPM_BUILD_ROOT
1326bb99 508install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 509 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 510 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 511 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 512
1f630180 513%{__make} install -j1 \
1cc7453a 514%if %{with javahl}
515 install-javahl \
516 javahl_javadir="%{_javadir}" \
517%endif
d46e45ba
AM
518%if !%{with net_client_only}
519%if %{with python}
0905b458 520 install-swig-py \
137fcafd 521 install-ctypes-python \
d46e45ba
AM
522%endif
523%if %{with ruby}
524 install-swig-rb install-swig-rb-doc \
525%endif
0905b458 526%endif
f2a757d6 527 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 528 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
529 swig_pydir=%{py_sitedir}/libsvn \
530 swig_pydir_extra=%{py_sitedir}/svn
93b78127 531
cf353d53 532%if !%{with net_client_only} && %{with perl}
bf539998
AM
533%{__make} install-swig-pl-lib \
534 DESTDIR=$RPM_BUILD_ROOT
b445847c 535%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
536 DESTDIR=$RPM_BUILD_ROOT \
537 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
538 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
539%endif
540
0905b458 541%if %{with apache}
1af5e34d
ER
542install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
543install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
544install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
545install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 546%endif
93b78127 547
cf353d53 548%if !%{with net_client_only}
1326bb99 549install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 550%if %{with python}
f4e6a380
AM
551%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
552%py_comp $RPM_BUILD_ROOT%{py_sitedir}
3c200272
JB
553%py_postclean
554%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
1326bb99 555install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 556%endif
0905b458 557%endif
f4e6a380 558
1326bb99
JK
559install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
560install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 561
fe242fac
JB
562%{?with_javahl:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
563%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
564%{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
565%if %{with gnome} || %{with kwallet}
566# dlopened by soname (libsvn_auth_*-1.so.0)
567%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
568%endif
205a3ddc 569
fe242fac 570%find_lang %{name}
a6ecf312 571
e23909be
JB
572%clean
573rm -rf $RPM_BUILD_ROOT
574
a1bac09d
575%pre svnserve
576%groupadd -g 86 svn
577%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
578
d2bf70bf
JB
579%post libs -p /sbin/ldconfig
580%postun libs -p /sbin/ldconfig
581
582%post devel -p /sbin/postshell
6f99c3bd 583-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 584
d2bf70bf 585%postun devel -p /sbin/postshell
6f99c3bd 586-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 587
12c96b58
ER
588%post -n java-subversion -p /sbin/ldconfig
589%postun -n java-subversion -p /sbin/ldconfig
590
d2bf70bf
JB
591%post -n perl-subversion -p /sbin/ldconfig
592%postun -n perl-subversion -p /sbin/ldconfig
593
594%post -n python-subversion -p /sbin/ldconfig
595%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 596
12c96b58
ER
597%post -n ruby-subversion -p /sbin/ldconfig
598%postun -n ruby-subversion -p /sbin/ldconfig
599
600%post -n gnome-keyring-subversion -p /sbin/ldconfig
601%postun -n gnome-keyring-subversion -p /sbin/ldconfig
602
603%post -n kde4-kwallet-subversion -p /sbin/ldconfig
604%postun -n kde4-kwallet-subversion -p /sbin/ldconfig
605
b56474ff 606%post svnserve
e8d9186f
ER
607/sbin/chkconfig --add svnserve
608%service svnserve restart "svnserve daemon"
609
b56474ff
AM
610%preun svnserve
611if [ "$1" = "0" ]; then
e8d9186f
ER
612 %service svnserve stop
613 /sbin/chkconfig --del svnserve
b56474ff
AM
614fi
615
a1bac09d
616%postun svnserve
617if [ "$1" = "0" ]; then
12c96b58
ER
618 %userremove svn
619 %groupremove svn
a1bac09d
620fi
621
93b78127 622%post -n apache-mod_dav_svn
e8d9186f 623%service -q httpd restart
93b78127 624
ba425c92 625%postun -n apache-mod_dav_svn
93b78127 626if [ "$1" = "0" ]; then
e8d9186f 627 %service -q httpd restart
93b78127
AM
628fi
629
9688ba4c
JR
630%post -n apache-mod_authz_svn
631%service -q httpd restart
632
ba425c92 633%postun -n apache-mod_authz_svn
9688ba4c
JR
634if [ "$1" = "0" ]; then
635 %service -q httpd restart
636fi
637
93b78127
AM
638%files
639%defattr(644,root,root,755)
983a49f6 640%doc BUGS CHANGES COPYING INSTALL README
d37298dc 641%doc doc/*/*.html
4bbdbbf8
AM
642%doc tools/hook-scripts/*.{pl,py,example}
643%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 644%doc tools/xslt/*
b445847c
JB
645%attr(755,root,root) %{_bindir}/svn
646%attr(755,root,root) %{_bindir}/svnadmin
647%attr(755,root,root) %{_bindir}/svndumpfilter
648%attr(755,root,root) %{_bindir}/svnlook
649%attr(755,root,root) %{_bindir}/svnsync
650%attr(755,root,root) %{_bindir}/svnversion
651%{_mandir}/man1/svn.1*
652%{_mandir}/man1/svnadmin.1*
653%{_mandir}/man1/svndumpfilter.1*
654%{_mandir}/man1/svnlook.1*
655%{_mandir}/man1/svnsync.1*
656%{_mandir}/man1/svnversion.1*
f4e6a380 657
205a3ddc 658%files libs -f %{name}.lang
f4e6a380 659%defattr(644,root,root,755)
b445847c
JB
660%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
661%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
662%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
663%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
664%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
665%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
666%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
667%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
668%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
669%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
670%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
671%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
672%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
673%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
674%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
675%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
676%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
677%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
678%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
679%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
680%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
681%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
682%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
683%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
684%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
685%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
686%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
687%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
688
689%files devel
690%defattr(644,root,root,755)
b445847c
JB
691%attr(755,root,root) %{_libdir}/libsvn_client-1.so
692%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
693%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
694%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
695%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
696%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
697%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
698%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
699%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 700%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
701%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
702%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
703%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
704%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
705%{_libdir}/libsvn_client-1.la
706%{_libdir}/libsvn_delta-1.la
707%{_libdir}/libsvn_diff-1.la
708%{_libdir}/libsvn_fs-1.la
709%{_libdir}/libsvn_fs_base-1.la
710%{_libdir}/libsvn_fs_fs-1.la
711%{_libdir}/libsvn_fs_util-1.la
712%{_libdir}/libsvn_ra-1.la
713%{_libdir}/libsvn_ra_local-1.la
a510fada 714%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
715%{_libdir}/libsvn_ra_svn-1.la
716%{_libdir}/libsvn_repos-1.la
717%{_libdir}/libsvn_subr-1.la
718%{_libdir}/libsvn_wc-1.la
719%{_includedir}/%{name}-1
1326bb99 720%{_examplesdir}/%{name}-%{version}
93b78127
AM
721
722%files static
723%defattr(644,root,root,755)
b445847c
JB
724%{_libdir}/libsvn_client-1.a
725%{_libdir}/libsvn_delta-1.a
726%{_libdir}/libsvn_diff-1.a
727%{_libdir}/libsvn_fs-1.a
728%{_libdir}/libsvn_fs_base-1.a
729%{_libdir}/libsvn_fs_fs-1.a
730%{_libdir}/libsvn_fs_util-1.a
731%{_libdir}/libsvn_ra-1.a
732%{_libdir}/libsvn_ra_local-1.a
a510fada 733%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
734%{_libdir}/libsvn_ra_svn-1.a
735%{_libdir}/libsvn_repos-1.a
736%{_libdir}/libsvn_subr-1.a
737%{_libdir}/libsvn_wc-1.a
93b78127 738
bfb248d0 739%if %{with gnome}
1429fa1c
AM
740%files -n gnome-keyring-subversion
741%defattr(644,root,root,755)
742%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
743%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
bfb248d0 744%endif
1429fa1c 745
65f2befa 746%if %{with kwallet}
1429fa1c
AM
747%files -n kde4-kwallet-subversion
748%defattr(644,root,root,755)
749%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
750%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 751%endif
1429fa1c 752
12c96b58 753%if %{without net_client_only}
b56474ff
AM
754%files svnserve
755%defattr(644,root,root,755)
756%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
757%{_mandir}/man5/svnserve.conf.5*
758%{_mandir}/man8/svnserve.8*
a1bac09d
759%dir %attr(750,svn,svn) /home/services/subversion
760%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 761%if %{with apache}
b56474ff 762%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 763%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 764%endif
b56474ff 765
4bbdbbf8
AM
766%files tools
767%defattr(644,root,root,755)
1326bb99 768%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 769
770%files -n bash-completion-subversion
101e74de 771%defattr(644,root,root,755)
1326bb99 772/etc/bash_completion.d/%{name}
536b3fd3 773
1cc7453a 774%if %{with javahl}
775%files -n java-subversion
776%defattr(644,root,root,755)
b445847c
JB
777%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
778%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
779%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 780%{_javadir}/svn-javahl.jar
781%endif
782
0905b458 783%if %{with python}
fa3ff1b2 784%files -n python-subversion
f4e6a380 785%defattr(644,root,root,755)
4bbdbbf8 786%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
787%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
788%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
789%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 790%dir %{py_sitedir}/libsvn
3c200272 791%attr(755,root,root) %{py_sitedir}/libsvn/_*.so
65318afa 792%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
793%dir %{py_sitedir}/svn
794%{py_sitedir}/svn/*.py[co]
1326bb99 795%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
796
797%files -n python-csvn
798%defattr(644,root,root,755)
799%doc subversion/bindings/ctypes-python/{README,TODO}
800%doc subversion/bindings/ctypes-python/examples/*.py
801%dir %{py_sitescriptdir}/csvn
802%{py_sitescriptdir}/csvn/*.py[co]
803%dir %{py_sitescriptdir}/csvn/core
804%{py_sitescriptdir}/csvn/core/*.py[co]
805%dir %{py_sitescriptdir}/csvn/ext
806%{py_sitescriptdir}/csvn/ext/*.py[co]
3c200272 807%{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
0905b458 808%endif
f4e6a380 809
0905b458 810%if %{with perl}
b56474ff
AM
811%files -n perl-subversion
812%defattr(644,root,root,755)
b445847c
JB
813%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
814%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
815%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
816%{perl_vendorarch}/SVN
817%dir %{perl_vendorarch}/auto/SVN
818%dir %{perl_vendorarch}/auto/SVN/*
819%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
820%{perl_vendorarch}/auto/SVN/*/*.bs
821%{_mandir}/man3/*.3pm*
0905b458 822%endif
b56474ff 823
d46e45ba
AM
824%if %{with ruby}
825%files -n ruby-subversion
826%defattr(644,root,root,755)
b445847c
JB
827%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
828%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
829%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
916011ef
JR
830%dir %{ruby_sitelibdir}/svn
831%{ruby_sitelibdir}/svn/*.rb
832%dir %{ruby_sitearchdir}/svn
833%dir %{ruby_sitearchdir}/svn/ext
e2c6dc67 834%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
916011ef 835%{ruby_ridir}/Svn
d46e45ba
AM
836%endif
837
0905b458 838%if %{with apache}
93b78127
AM
839%files -n apache-mod_dav_svn
840%defattr(644,root,root,755)
1af5e34d
ER
841%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
842%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
843
844%files -n apache-mod_authz_svn
845%defattr(644,root,root,755)
846%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
847%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
848%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 849%endif
7b27380f
ER
850
851%endif # net_client_only
This page took 0.222717 seconds and 4 git commands to generate.