]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- adapter
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4#
bab73684 5# Conditional build:
bc526ca4 6%bcond_with net_client_only # build only net client
8f179f02 7%bcond_without python # build without python bindings (broken)
0905b458 8%bcond_without perl # build without perl bindings
9%bcond_without apache # build without apache support (webdav, etc)
1cc7453a 10%bcond_without javahl # build without javahl support (Java high-level bindings)
12ae68c1 11%bcond_without tests
7b27380f 12#
b56474ff 13%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 14%define apxs /usr/sbin/apxs
1f630180
ER
15%define pdir SVN
16%define pnam _Core
12ae68c1
AM
17#
18%define snap rc4
67cb9518 19Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
20Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
21Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 22Name: subversion
12ae68c1
AM
23Version: 1.5.0
24Release: 0.%{snap}.1
6f88d80e 25License: Apache/BSD-like
93b78127 26Group: Development/Version Control
12ae68c1
AM
27# Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.gz
28Source0: http://orac.ece.utexas.edu/pub/svn/%{version}-%{snap}/leander-hackberry/%{name}-%{version}-%{snap}.tar.gz
29# Source0-md5: 905fc5030be179d4d387803b8397668a
93b78127 30Source1: %{name}-dav_svn.conf
65318afa 31Source2: %{name}-authz_svn.conf
b56474ff
AM
32Source3: %{name}-svnserve.init
33Source4: %{name}-svnserve.sysconfig
f313e9a9 34Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 35Patch0: %{name}-home_etc.patch
d4bccc60 36Patch1: %{name}-DESTDIR.patch
93b78127 37URL: http://subversion.tigris.org/
4945947e
AM
38%if %{with net_client_only}
39%global apache_modules_api 0
40%else
f2a757d6 41%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 42BuildRequires: automake
3817faf5 43BuildRequires: db-devel >= 4.1.25
e8d9186f 44BuildRequires: rpmbuild(macros) >= 1.268
0905b458 45%if %{with perl}
522a69b4 46BuildRequires: perl-devel >= 1:5.8.0
47BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 48BuildRequires: swig-perl >= 1.3.24
536b3fd3 49%endif
1cc7453a 50%{?with_javahl:BuildRequires: jdk}
0905b458 51%endif
16429189 52BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 53BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 54BuildRequires: autoconf >= 2.59
79d8c53c 55BuildRequires: bison
12ae68c1 56BuildRequires: cyrus-sasl-devel
93b78127 57BuildRequires: expat-devel
86ea8fde 58BuildRequires: gettext-devel
f4e6a380 59BuildRequires: libtool >= 1.4-9
bd3c99a8 60BuildRequires: neon-devel >= 0.26.0
53855fbf 61BuildRequires: python >= 2.2
ed6210a2 62BuildRequires: python-modules >= 2.2
f313e9a9 63%if %{with python}
64BuildRequires: python-devel >= 2.2
1f16145f 65BuildRequires: sed >= 4.0
15f9818d 66BuildRequires: swig-python >= 1.3.24
0905b458 67%endif
93b78127 68BuildRequires: texinfo
7b35d179 69BuildRequires: which
027f8ebe 70Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
f4070f5f 73%define _libexecdir %{_libdir}/svn
1af5e34d
ER
74%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
75%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
76
77%description
78The goal of the Subversion project is to build a version control
79system that is a compelling replacement for CVS in the open source
80community.
81
82Our goals are:
83- All current CVS features.
84- Directories, renames, and file meta-data are versioned.
85- Symbolic links, etc, are supported
86- Commits are truly atomic.
87- Branching and tagging are cheap (constant time) operations
88- Repeated merges are handled gracefully
89- Support for plug-in client side diff programs
90- Natively client/server
91- Client/server protocol sends diffs in both directions
92- Costs are proportional to change size, not project size
93- Internationalization
94- Progressive multi-lingual support
95
aa59005f 96%description -l pl.UTF-8
93b78127
AM
97Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
98zamiennika dla CVS.
99
100Cele projektu to:
aa59005f 101- Wszystkie aktualne możliwości CVS.
24406120
JB
102- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
103- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
104- Commity są w pełni atomowe.
105- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
106- Dobra obsługa powtarzanego łączenia (merge).
107- Obsługa wtyczek diff po stronie klienta.
93b78127 108- Natywny klient/serwer.
aa59005f 109- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
110- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
111- Internacjonalizacja.
aa59005f 112- Postępujące wsparcie dla wielu języków.
93b78127 113
aa59005f
JR
114%description -l pt_BR.UTF-8
115O objetivo do projeto Subversion é construir um sistema de controle de
116versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 117System) na comunidade opensource, fornecendo grandes melhorias.
118
f4e6a380
AM
119%package libs
120Summary: Subversion libraries and modules
abe3c421 121Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 122Group: Libraries
24406120 123Requires: neon >= 0.26.0
53855fbf 124Obsoletes: libsubversion0
f4e6a380
AM
125
126%description libs
127Subversion libraries and modules.
128
aa59005f
JR
129%description libs -l pl.UTF-8
130Biblioteka subversion oraz ładowalne moduły.
f4e6a380 131
93b78127
AM
132%package devel
133Summary: Header files and develpment documentation for subversion
abe3c421
ER
134Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
135Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 136Group: Development/Libraries
9cb7e099 137Requires: %{name}-libs = %{version}-%{release}
c5b1d686 138Requires: apr-util-devel >= 1:1.0.0
24406120 139Requires: neon-devel >= 0.26.0
12cf252c 140Obsoletes: libsubversion0-devel
93b78127
AM
141
142%description devel
143Header files and develpment documentation for subversion.
144
aa59005f
JR
145%description devel -l pl.UTF-8
146Pliki nagłówkowe i dokumetacja do subversion.
93b78127 147
aa59005f
JR
148%description devel -l pt_BR.UTF-8
149Este pacote provê os arquivos necessários para desenvolvedores
92066deb 150interagirem com o Subversion.
151
93b78127
AM
152%package static
153Summary: Static subversion library
abe3c421
ER
154Summary(pl.UTF-8): Biblioteka statyczna subversion
155Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
156Group: Development/Libraries
157Requires: %{name}-devel = %{version}
12cf252c 158Obsoletes: libsubversion0-static-devel
93b78127
AM
159
160%description static
161Static subversion library.
162
aa59005f 163%description static -l pl.UTF-8
93b78127
AM
164Biblioteka statyczna subversion.
165
aa59005f
JR
166%description static -l pt_BR.UTF-8
167Este pacote provê um cliente estático do subversion.
92066deb 168
b56474ff
AM
169%package svnserve
170Summary: Subversion svnserve
abe3c421 171Summary(pl.UTF-8): Subversion svnserve
b56474ff 172Group: Networking/Daemons
3817faf5 173Requires(post,preun): /sbin/chkconfig
93f1d402 174Requires(postun): /usr/sbin/groupdel
175Requires(postun): /usr/sbin/userdel
176Requires(pre): /bin/id
177Requires(pre): /usr/bin/getgid
178Requires(pre): /usr/lib/rpm/user_group.sh
179Requires(pre): /usr/sbin/groupadd
180Requires(pre): /usr/sbin/useradd
181Requires(pre): /usr/sbin/usermod
9cb7e099 182Requires: %{name} = %{version}-%{release}
7b27380f 183Requires: rc-scripts
a1bac09d
184Provides: group(svn)
185Provides: user(svn)
b56474ff
AM
186
187%description svnserve
188Subversion svnserve server.
189
aa59005f 190%description svnserve -l pl.UTF-8
b56474ff
AM
191Serwer subversion svnserve.
192
4bbdbbf8
AM
193%package tools
194Summary: Subversion tools and scripts
abe3c421
ER
195Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
196Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 197Group: Applications
4bbdbbf8 198%pyrequires_eq python
7b27380f 199Requires: %{name} = %{version}-%{release}
1271c9bd 200Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
201Requires: python-subversion = %{version}
202
203%description tools
204Subversion tools and scripts.
205
aa59005f
JR
206%description tools -l pl.UTF-8
207Narzędzia oraz skrypty dla subversion.
4bbdbbf8 208
fe5bb6bb 209%package -n bash-completion-subversion
210Summary: bash completion for subversion
abe3c421 211Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 212Group: Applications/Shells
e30588c4 213Requires: %{name} = %{version}-%{release}
53855fbf 214Requires: bash-completion
e30588c4 215Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 216
217%description -n bash-completion-subversion
218Bash completion for subversion.
219
aa59005f
JR
220%description -n bash-completion-subversion -l pl.UTF-8
221Dopełnienia basha dla subversion.
fe5bb6bb 222
1cc7453a 223%package -n java-subversion
224Summary: Subversion java bindings
225Group: Development/Languages/Java
226Requires: %{name}-libs = %{version}-%{release}
227
228%description -n java-subversion
229This is a set of Java classes which provide the functionality of
230subversion-libs, the Subversion libraries. It is useful if you want
231to, for example, write a Java class that manipulates a Subversion
232repository or working copy. See the 'subversion' package for more
233information.
234
fa3ff1b2 235%package -n python-subversion
f4e6a380 236Summary: Subversion python bindings
abe3c421
ER
237Summary(pl.UTF-8): Dowiązania do subversion dla pythona
238Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
f4e6a380 239Group: Development/Languages/Python
f4e6a380 240%pyrequires_eq python
9cb7e099 241Requires: %{name}-libs = %{version}-%{release}
53855fbf 242Obsoletes: subversion-python
f4e6a380 243
fa3ff1b2 244%description -n python-subversion
f4e6a380
AM
245Subversion python bindings.
246
aa59005f
JR
247%description -n python-subversion -l pl.UTF-8
248Dowiązania do subversion dla pythona.
f4e6a380 249
aa59005f
JR
250%description -n python-subversion -l pt_BR.UTF-8
251Módulos python para acessar os recursos do Subversion.
92066deb 252
b56474ff
AM
253%package -n perl-subversion
254Summary: Subversion perl bindings
abe3c421
ER
255Summary(pl.UTF-8): Dowiązania do subversion dla perla
256Summary(pt_BR.UTF-8): Módulos perl para acessar os recursos do Subversion
b56474ff 257Group: Development/Languages/Perl
9cb7e099 258Requires: %{name}-libs = %{version}-%{release}
53855fbf 259Obsoletes: subversion-perl
b56474ff
AM
260
261%description -n perl-subversion
262Subversion perl bindings.
263
aa59005f
JR
264%description -n perl-subversion -l pl.UTF-8
265Dowiązania do subversion dla perl.
b56474ff 266
aa59005f
JR
267%description -n perl-subversion -l pt_BR.UTF-8
268Módulos perl para acessar os recursos do Subversion.
b56474ff 269
93b78127
AM
270%package -n apache-mod_dav_svn
271Summary: Apache module: Subversion Server
abe3c421 272Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 273Group: Networking/Daemons
7b27380f 274Requires: %{name} = %{version}-%{release}
53855fbf 275Requires: apache(modules-api) = %apache_modules_api
7887b1ac 276Requires: apache-mod_dav
93b78127
AM
277
278%description -n apache-mod_dav_svn
279Apache module: Subversion Server.
280
aa59005f
JR
281%description -n apache-mod_dav_svn -l pl.UTF-8
282Moduł apache: Serwer Subversion.
93b78127 283
65318afa
AF
284%package -n apache-mod_authz_svn
285Summary: Apache module: Subversion Server - path-based authorization
abe3c421 286Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 287Group: Networking/Daemons
53855fbf 288Requires: apache(modules-api) = %apache_modules_api
9cb7e099 289Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
290
291%description -n apache-mod_authz_svn
292Apache module: Subversion Server - path-based authorization.
293
aa59005f
JR
294%description -n apache-mod_authz_svn -l pl.UTF-8
295Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 296
93b78127 297%prep
12ae68c1 298%setup -q -n %{name}-%{version}-%{snap}
e30588c4 299rm -rf apr apr-util neon
ed6210a2 300%patch0 -p0
d4bccc60 301%patch1 -p1
027f8ebe 302
93b78127 303%build
93f1d402 304rm subversion/bindings/swig/proxy/*.swg
24406120 305cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 306cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 307chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 308
fa3ff1b2 309# don't enable dso - currently it's broken
93b78127 310%configure \
5dfeafd7 311 --with-editor=vi \
12ae68c1 312 --with-zlib=%{_libdir} \
93f1d402 313 --with-python=%{__python} \
314 --with-perl5=%{__perl} \
536b3fd3
AM
315%if %{with net_client_only}
316 --without-apache \
317 --without-swig \
318 --without-apxs \
319 --without-berkeley-db \
320%else
227d7ab4 321 --disable-dso \
86ee97d3 322 --disable-mod-activation \
0905b458 323%if %{with apache}
536b3fd3 324 --with-apxs=%{_sbindir}/apxs \
0905b458 325%else
326 --without-apache \
327 --without-apxs \
536b3fd3 328 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 329%endif
cf353d53 330%if !%{with python} && !%{with perl}
0905b458 331 --without-swig \
332%endif
1cc7453a 333 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 334%endif
1cc7453a 335 --with-jdk="%{java_home}" \
e30588c4 336 --with-neon=%{_prefix} \
78f330c4 337 --disable-neon-version-check \
16429189 338 --with-apr=%{_bindir}/apr-1-config \
339 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 340
1f630180 341%{__make} -j1
536b3fd3 342
cf353d53 343%if !%{with net_client_only}
b56474ff 344# python
0905b458 345%if %{with python}
86a4919e 346%{__make} swig-py \
65318afa
AF
347 swig_pydir=%{py_sitedir}/libsvn \
348 swig_pydir_extra=%{py_sitedir}/svn
0905b458 349%endif
b56474ff 350# perl
0905b458 351%if %{with perl}
bf539998
AM
352%{__make} swig-pl-lib
353odir=$(pwd)
354cd subversion/bindings/swig/perl/native
355%{__perl} Makefile.PL INSTALLDIRS=vendor
356%{__make}
357cd $odir
536b3fd3 358%endif
1cc7453a 359%if %{with javahl}
360%{__make} javahl \
361 javahl_javadir="%{_javadir}"
362%endif
12ae68c1
AM
363%endif
364
365%if %{with tests}
366%{__make} check
0905b458 367%endif
93b78127
AM
368
369%install
370rm -rf $RPM_BUILD_ROOT
1326bb99 371install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 372 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 373 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 374 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 375
1f630180 376%{__make} install -j1 \
1cc7453a 377%if %{with javahl}
378 install-javahl \
379 javahl_javadir="%{_javadir}" \
380%endif
cf353d53 381%if !%{with net_client_only} && %{with python}
0905b458 382 install-swig-py \
383%endif
f2a757d6 384 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 385 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
386 swig_pydir=%{py_sitedir}/libsvn \
387 swig_pydir_extra=%{py_sitedir}/svn
93b78127 388
cf353d53 389%if !%{with net_client_only} && %{with perl}
bf539998
AM
390%{__make} install-swig-pl-lib \
391 DESTDIR=$RPM_BUILD_ROOT
392odir=$(pwd)
393cd subversion/bindings/swig/perl/native
394%{__make} install \
395 DESTDIR=$RPM_BUILD_ROOT \
396 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
397 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
398cd $odir
399%endif
400
0905b458 401%if %{with apache}
1af5e34d
ER
402install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
403install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
404install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
405install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 406%endif
93b78127 407
cf353d53 408%if !%{with net_client_only}
1326bb99 409install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 410%if %{with python}
f4e6a380
AM
411%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
412%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
413find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
414install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 415%endif
0905b458 416%endif
f4e6a380 417
1326bb99
JK
418install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
419install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 420
205a3ddc
AM
421%find_lang %{name}
422
a6ecf312 423rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
424
e23909be
JB
425%clean
426rm -rf $RPM_BUILD_ROOT
427
a1bac09d
428%pre svnserve
429%groupadd -g 86 svn
430%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
431
6f99c3bd
ER
432%post devel -p /sbin/postshell
433-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 434
6f99c3bd
ER
435%postun devel -p /sbin/postshell
436-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 437
e23909be
JB
438%post libs -p /sbin/ldconfig
439%postun libs -p /sbin/ldconfig
164f681b
AM
440%post -n python-subversion -p /sbin/ldconfig
441%postun -n perl-subversion -p /sbin/ldconfig
f4e6a380 442
b56474ff 443%post svnserve
e8d9186f
ER
444/sbin/chkconfig --add svnserve
445%service svnserve restart "svnserve daemon"
446
b56474ff
AM
447%preun svnserve
448if [ "$1" = "0" ]; then
e8d9186f
ER
449 %service svnserve stop
450 /sbin/chkconfig --del svnserve
b56474ff
AM
451fi
452
a1bac09d
453%postun svnserve
454if [ "$1" = "0" ]; then
455 %userremove svn
456 %groupremove svn
457fi
458
93b78127 459%post -n apache-mod_dav_svn
e8d9186f 460%service -q httpd restart
93b78127
AM
461
462%preun -n apache-mod_dav_svn
463if [ "$1" = "0" ]; then
e8d9186f 464 %service -q httpd restart
93b78127
AM
465fi
466
93b78127
AM
467%files
468%defattr(644,root,root,755)
983a49f6 469%doc BUGS CHANGES COPYING INSTALL README
d37298dc 470%doc doc/*/*.html
4bbdbbf8
AM
471%doc tools/hook-scripts/*.{pl,py,example}
472%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 473%doc tools/xslt/*
fa3ff1b2 474%attr(755,root,root) %{_bindir}/svn*
b56474ff 475%exclude %{_bindir}/svnserve
cf353d53 476%if !%{with net_client_only}
9cb7e099 477%exclude %{_bindir}/svn-hot-backup
d62de3c9 478%endif
f4e6a380 479%{_mandir}/man1/*
af654ba5
AM
480%{_mandir}/man5/*
481%{_mandir}/man8/*
b56474ff 482%exclude %{_mandir}/man?/svnserve*
f4e6a380 483
205a3ddc 484%files libs -f %{name}.lang
f4e6a380 485%defattr(644,root,root,755)
227d7ab4 486%attr(755,root,root) %{_libdir}/lib*.so.*
164f681b
AM
487%if %{with perl} || %{with python}
488%exclude %{_libdir}/lib*_swig_*.so.*
489%endif
1cc7453a 490%if %{with javahl}
491%exclude %{_libdir}/libsvnjavahl*.so.*.*.*
492%exclude %{_libdir}/libsvnjavahl*.so.?
493%exclude %{_libdir}/libsvnjavahl*.so
494%endif
93b78127
AM
495
496%files devel
497%defattr(644,root,root,755)
227d7ab4
AM
498%{_includedir}/%{name}*
499%attr(755,root,root) %{_libdir}/lib*.so
b2bcb22a 500%{_libdir}/lib*.la
b72a2fbb 501%if %{with perl} || %{with python}
c00fdf6f 502%exclude %{_libdir}/lib*_swig_*.so
b72a2fbb 503%endif
1cc7453a 504%if %{with javahl}
505%exclude %{_libdir}/libsvnjavahl*.so
506%endif
1326bb99 507%{_examplesdir}/%{name}-%{version}
93b78127
AM
508
509%files static
510%defattr(644,root,root,755)
511%{_libdir}/lib*.a
512
cf353d53 513%if !%{with net_client_only}
b56474ff
AM
514%files svnserve
515%defattr(644,root,root,755)
516%attr(755,root,root) %{_bindir}/svnserve
517%{_mandir}/man?/svnserve*
a1bac09d
518%dir %attr(750,svn,svn) /home/services/subversion
519%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 520%if %{with apache}
b56474ff 521%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 522%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 523%endif
b56474ff 524
4bbdbbf8
AM
525%files tools
526%defattr(644,root,root,755)
1326bb99 527%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 528
529%files -n bash-completion-subversion
101e74de 530%defattr(644,root,root,755)
1326bb99 531/etc/bash_completion.d/%{name}
536b3fd3 532
1cc7453a 533%if %{with javahl}
534%files -n java-subversion
535%defattr(644,root,root,755)
536%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.*.*.*
537%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.?
538%attr(755,root,root) %{_libdir}/libsvnjavahl*.so
539%{_javadir}/svn-javahl.jar
540%endif
541
0905b458 542%if %{with python}
fa3ff1b2 543%files -n python-subversion
f4e6a380 544%defattr(644,root,root,755)
4bbdbbf8 545%doc tools/backup/*.py tools/examples/*.py
f4e6a380 546%dir %{py_sitedir}/svn
65318afa 547%dir %{py_sitedir}/libsvn
f4e6a380 548%{py_sitedir}/svn/*.py[co]
65318afa
AF
549%{py_sitedir}/libsvn/*.py[co]
550%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 551%{_examplesdir}/python-%{name}-%{version}
c00fdf6f 552%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
0905b458 553%endif
f4e6a380 554
0905b458 555%if %{with perl}
b56474ff
AM
556%files -n perl-subversion
557%defattr(644,root,root,755)
558%{perl_vendorarch}/SVN
559%dir %{perl_vendorarch}/auto/SVN
560%dir %{perl_vendorarch}/auto/SVN/*
561%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
562%{perl_vendorarch}/auto/SVN/*/*.bs
563%{_mandir}/man3/*.3pm*
c00fdf6f 564%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
0905b458 565%endif
b56474ff 566
0905b458 567%if %{with apache}
93b78127
AM
568%files -n apache-mod_dav_svn
569%defattr(644,root,root,755)
1af5e34d
ER
570%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
571%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
572
573%files -n apache-mod_authz_svn
574%defattr(644,root,root,755)
575%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
576%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
577%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 578%endif
7b27380f
ER
579
580%endif # net_client_only
This page took 0.152644 seconds and 4 git commands to generate.