]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- rel 3
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
b4d1f957 2# - fix java build with java-gcj-compat and s/java-sun/jdk/
1930bef0 3# - remove net_client_only and add db bcond (then without apache and
4# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 5# - finish ruby
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
65f2befa 16%bcond_without kwallet # build without kde4 wallet support
bfb248d0 17%bcond_without gnome # build without gnome keyring support
7b27380f 18#
bc126282 19%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 20%undefine with_javahl
bc126282
AG
21%endif
22#
b56474ff 23%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 24%define apxs /usr/sbin/apxs
1f630180
ER
25%define pdir SVN
26%define pnam _Core
12ae68c1 27#
04129f48 28%if %{with neon}
a510fada 29%define webdavlib neon
04129f48
AG
30%else
31%define webdavlib serf
a510fada
AM
32%endif
33#
67cb9518 34Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
35Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
36Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 37Name: subversion
dc8fcc41 38Version: 1.6.9
6b5f8c2e 39Release: 3
6f88d80e 40License: Apache/BSD-like
93b78127 41Group: Development/Version Control
a5c00029 42Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
dc8fcc41 43# Source0-md5: 9c30a47b1d48664e7afef68bb4834c53
93b78127 44Source1: %{name}-dav_svn.conf
65318afa 45Source2: %{name}-authz_svn.conf
b56474ff
AM
46Source3: %{name}-svnserve.init
47Source4: %{name}-svnserve.sysconfig
a510fada
AM
48# current subversion tarball has correct *.swg files
49# but after regeneration these are broken again, so
50# we still need this script
f313e9a9 51Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 52Patch0: %{name}-home_etc.patch
d46e45ba 53Patch1: %{name}-DESTDIR.patch
00664663 54Patch2: %{name}-ruby-datadir-path.patch
dc8fcc41 55URL: http://subversion.apache.org/
4945947e
AM
56%if %{with net_client_only}
57%global apache_modules_api 0
58%else
f2a757d6 59%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 60BuildRequires: automake
3817faf5 61BuildRequires: db-devel >= 4.1.25
e8d9186f 62BuildRequires: rpmbuild(macros) >= 1.268
0905b458 63%if %{with perl}
522a69b4 64BuildRequires: perl-devel >= 1:5.8.0
65BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 66BuildRequires: swig-perl >= 1.3.24
536b3fd3 67%endif
6ac3574b
AM
68%if %{with python}
69BuildRequires: python-ctypesgen
70BuildRequires: python-devel >= 2.2
71BuildRequires: swig-python >= 1.3.24
72%endif
73%if %{with ruby}
74BuildRequires: ruby-devel
75BuildRequires: swig-ruby >= 1.3.24
76%endif
af0d490b
AM
77%if %{with javahl}
78BuildRequires: java-sun
79BuildRequires: java-sun-tools
80%endif
6ac3574b 81BuildRequires: cyrus-sasl-devel
0905b458 82%endif
16429189 83BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 84BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 85BuildRequires: autoconf >= 2.59
79d8c53c 86BuildRequires: bison
93b78127 87BuildRequires: expat-devel
86ea8fde 88BuildRequires: gettext-devel
bfb248d0 89%{?with_gnome:BuildRequires: gnome-keyring-devel}
65f2befa 90%{?with_kwallet:BuildRequires: kde4-kdelibs-devel}
f4e6a380 91BuildRequires: libtool >= 1.4-9
54271075 92BuildRequires: pkgconfig
a562165a 93BuildRequires: sed >= 4.0
c26d84c4 94BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
95BuildRequires: texinfo
96BuildRequires: which
97%if %{with neon}
bd3c99a8 98BuildRequires: neon-devel >= 0.26.0
a562165a
JB
99%else
100BuildRequires: serf-devel
e3ad24ea 101%endif
53855fbf 102BuildRequires: python >= 2.2
ed6210a2 103BuildRequires: python-modules >= 2.2
027f8ebe 104Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
f4070f5f 107%define _libexecdir %{_libdir}/svn
1af5e34d
ER
108%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
109%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
110
111%description
112The goal of the Subversion project is to build a version control
113system that is a compelling replacement for CVS in the open source
114community.
115
116Our goals are:
117- All current CVS features.
118- Directories, renames, and file meta-data are versioned.
119- Symbolic links, etc, are supported
120- Commits are truly atomic.
121- Branching and tagging are cheap (constant time) operations
122- Repeated merges are handled gracefully
123- Support for plug-in client side diff programs
124- Natively client/server
125- Client/server protocol sends diffs in both directions
126- Costs are proportional to change size, not project size
127- Internationalization
128- Progressive multi-lingual support
129
aa59005f 130%description -l pl.UTF-8
93b78127
AM
131Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
132zamiennika dla CVS.
133
134Cele projektu to:
aa59005f 135- Wszystkie aktualne możliwości CVS.
24406120
JB
136- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
137- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
138- Commity są w pełni atomowe.
139- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
140- Dobra obsługa powtarzanego łączenia (merge).
141- Obsługa wtyczek diff po stronie klienta.
93b78127 142- Natywny klient/serwer.
aa59005f 143- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
144- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
145- Internacjonalizacja.
aa59005f 146- Postępujące wsparcie dla wielu języków.
93b78127 147
aa59005f
JR
148%description -l pt_BR.UTF-8
149O objetivo do projeto Subversion é construir um sistema de controle de
150versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 151System) na comunidade opensource, fornecendo grandes melhorias.
152
f4e6a380
AM
153%package libs
154Summary: Subversion libraries and modules
abe3c421 155Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 156Group: Libraries
04129f48 157%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 158Obsoletes: libsubversion0
f4e6a380
AM
159
160%description libs
161Subversion libraries and modules.
162
aa59005f
JR
163%description libs -l pl.UTF-8
164Biblioteka subversion oraz ładowalne moduły.
f4e6a380 165
93b78127
AM
166%package devel
167Summary: Header files and develpment documentation for subversion
abe3c421
ER
168Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
169Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 170Group: Development/Libraries
9cb7e099 171Requires: %{name}-libs = %{version}-%{release}
c5b1d686 172Requires: apr-util-devel >= 1:1.0.0
04129f48 173%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 174Obsoletes: libsubversion0-devel
93b78127
AM
175
176%description devel
177Header files and develpment documentation for subversion.
178
aa59005f
JR
179%description devel -l pl.UTF-8
180Pliki nagłówkowe i dokumetacja do subversion.
93b78127 181
aa59005f
JR
182%description devel -l pt_BR.UTF-8
183Este pacote provê os arquivos necessários para desenvolvedores
92066deb 184interagirem com o Subversion.
185
93b78127
AM
186%package static
187Summary: Static subversion library
abe3c421
ER
188Summary(pl.UTF-8): Biblioteka statyczna subversion
189Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
190Group: Development/Libraries
191Requires: %{name}-devel = %{version}
12cf252c 192Obsoletes: libsubversion0-static-devel
93b78127
AM
193
194%description static
195Static subversion library.
196
aa59005f 197%description static -l pl.UTF-8
93b78127
AM
198Biblioteka statyczna subversion.
199
aa59005f
JR
200%description static -l pt_BR.UTF-8
201Este pacote provê um cliente estático do subversion.
92066deb 202
b56474ff
AM
203%package svnserve
204Summary: Subversion svnserve
abe3c421 205Summary(pl.UTF-8): Subversion svnserve
b56474ff 206Group: Networking/Daemons
3817faf5 207Requires(post,preun): /sbin/chkconfig
93f1d402 208Requires(postun): /usr/sbin/groupdel
209Requires(postun): /usr/sbin/userdel
210Requires(pre): /bin/id
211Requires(pre): /usr/bin/getgid
212Requires(pre): /usr/lib/rpm/user_group.sh
213Requires(pre): /usr/sbin/groupadd
214Requires(pre): /usr/sbin/useradd
215Requires(pre): /usr/sbin/usermod
9cb7e099 216Requires: %{name} = %{version}-%{release}
7b27380f 217Requires: rc-scripts
a1bac09d
218Provides: group(svn)
219Provides: user(svn)
b56474ff
AM
220
221%description svnserve
222Subversion svnserve server.
223
aa59005f 224%description svnserve -l pl.UTF-8
b56474ff
AM
225Serwer subversion svnserve.
226
4bbdbbf8
AM
227%package tools
228Summary: Subversion tools and scripts
abe3c421
ER
229Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
230Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 231Group: Applications
4bbdbbf8 232%pyrequires_eq python
7b27380f 233Requires: %{name} = %{version}-%{release}
4bbdbbf8
AM
234Requires: python-subversion = %{version}
235
236%description tools
237Subversion tools and scripts.
238
aa59005f
JR
239%description tools -l pl.UTF-8
240Narzędzia oraz skrypty dla subversion.
4bbdbbf8 241
fe5bb6bb 242%package -n bash-completion-subversion
243Summary: bash completion for subversion
abe3c421 244Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 245Group: Applications/Shells
e30588c4 246Requires: %{name} = %{version}-%{release}
53855fbf 247Requires: bash-completion
e30588c4 248Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 249
250%description -n bash-completion-subversion
251Bash completion for subversion.
252
aa59005f
JR
253%description -n bash-completion-subversion -l pl.UTF-8
254Dopełnienia basha dla subversion.
fe5bb6bb 255
1cc7453a 256%package -n java-subversion
65c1d4bd
JB
257Summary: Subversion Java bindings
258Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 259Group: Development/Languages/Java
260Requires: %{name}-libs = %{version}-%{release}
261
262%description -n java-subversion
263This is a set of Java classes which provide the functionality of
264subversion-libs, the Subversion libraries. It is useful if you want
265to, for example, write a Java class that manipulates a Subversion
266repository or working copy. See the 'subversion' package for more
267information.
268
65c1d4bd
JB
269%description -n java-subversion -l pl.UTF-8
270Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
271subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
272pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
273roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 274
fa3ff1b2 275%package -n python-subversion
65c1d4bd
JB
276Summary: Subversion Python bindings
277Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
278Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 279Group: Development/Languages/Python
f4e6a380 280%pyrequires_eq python
9cb7e099 281Requires: %{name}-libs = %{version}-%{release}
53855fbf 282Obsoletes: subversion-python
f4e6a380 283
fa3ff1b2 284%description -n python-subversion
65c1d4bd 285Subversion Python bindings.
f4e6a380 286
aa59005f 287%description -n python-subversion -l pl.UTF-8
65c1d4bd 288Dowiązania do Subversion dla Pythona.
f4e6a380 289
aa59005f 290%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 291Módulos Python para acessar os recursos do Subversion.
92066deb 292
137fcafd
AM
293%package -n python-csvn
294Summary: CTypes Subversion Python bindings
295Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
296Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
297Group: Development/Languages/Python
298%pyrequires_eq python
299Requires: %{name}-libs = %{version}-%{release}
300
301%description -n python-csvn
302Subversion CTypes Python bindings.
303
304%description -n python-csvn -l pl.UTF-8
305Dowiązania do Subversion dla Pythona używające CTypes.
306
307%description -n python-csvn -l pt_BR.UTF-8
308Módulos Python para acessar os recursos do Subversion.
309
b56474ff 310%package -n perl-subversion
65c1d4bd
JB
311Summary: Subversion Perl bindings
312Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
313Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 314Group: Development/Languages/Perl
9cb7e099 315Requires: %{name}-libs = %{version}-%{release}
53855fbf 316Obsoletes: subversion-perl
b56474ff
AM
317
318%description -n perl-subversion
65c1d4bd 319Subversion Perl bindings.
b56474ff 320
aa59005f 321%description -n perl-subversion -l pl.UTF-8
65c1d4bd 322Dowiązania do Subversion dla Perla.
b56474ff 323
aa59005f 324%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 325Módulos Perl para acessar os recursos do Subversion.
b56474ff 326
d46e45ba
AM
327%package -n ruby-subversion
328Summary: Subversion Ruby bindings
d2bf70bf 329Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
330Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
331Group: Development/Languages
332Requires: %{name}-libs = %{version}-%{release}
333Obsoletes: subversion-ruby
334
335%description -n ruby-subversion
336Subversion Ruby bindings.
337
338%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 339Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
340
341%description -n ruby-subversion -l pt_BR.UTF-8
342Módulos Ruby para acessar os recursos do Subversion.
343
93b78127
AM
344%package -n apache-mod_dav_svn
345Summary: Apache module: Subversion Server
abe3c421 346Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 347Group: Networking/Daemons
7b27380f 348Requires: %{name} = %{version}-%{release}
53855fbf 349Requires: apache(modules-api) = %apache_modules_api
7887b1ac 350Requires: apache-mod_dav
93b78127
AM
351
352%description -n apache-mod_dav_svn
353Apache module: Subversion Server.
354
aa59005f
JR
355%description -n apache-mod_dav_svn -l pl.UTF-8
356Moduł apache: Serwer Subversion.
93b78127 357
65318afa
AF
358%package -n apache-mod_authz_svn
359Summary: Apache module: Subversion Server - path-based authorization
abe3c421 360Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 361Group: Networking/Daemons
53855fbf 362Requires: apache(modules-api) = %apache_modules_api
9cb7e099 363Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
364
365%description -n apache-mod_authz_svn
366Apache module: Subversion Server - path-based authorization.
367
aa59005f
JR
368%description -n apache-mod_authz_svn -l pl.UTF-8
369Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 370
1429fa1c
AM
371%package -n gnome-keyring-subversion
372Summary: Subversion module for Gnome Keyring
373Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
374Group: X11/Applications
375
376%description -n gnome-keyring-subversion
377Subversion module for Gnome Keyring.
378
379%description -n gnome-keyring-subversion -l pl.UTF-8
380Moduł subversion dla zarządcy kluczy Gnome.
381
382%package -n kde4-kwallet-subversion
383Summary: Subversion module for KDE Wallet
384Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
385Group: X11/Applications
386
387%description -n kde4-kwallet-subversion
388Subversion module for KDE Wallet.
389
390%description -n kde4-kwallet-subversion -l pl.UTF-8
391Moduł subversion dla Portfela KDE.
392
93b78127 393%prep
a5c00029 394%setup -q
e30588c4 395rm -rf apr apr-util neon
ed6210a2 396%patch0 -p0
d4bccc60 397%patch1 -p1
00664663 398%patch2 -p0
a510fada
AM
399
400sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
401
402# serf.m4 macro is broken and ignores --without serf
244bdb04 403%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 404
93b78127 405%build
93f1d402 406rm subversion/bindings/swig/proxy/*.swg
24406120 407cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 408cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 409chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 410
93b78127 411%configure \
5dfeafd7 412 --with-editor=vi \
12ae68c1 413 --with-zlib=%{_libdir} \
536b3fd3
AM
414%if %{with net_client_only}
415 --without-apache \
416 --without-swig \
417 --without-apxs \
418 --without-berkeley-db \
419%else
fa6fa2cf 420 --disable-runtime-module-search \
86ee97d3 421 --disable-mod-activation \
ad5c551e 422 --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
0905b458 423%if %{with apache}
536b3fd3 424 --with-apxs=%{_sbindir}/apxs \
0905b458 425%else
426 --without-apache \
427 --without-apxs \
0905b458 428%endif
73ab938a 429%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 430 --without-swig \
431%endif
137fcafd 432 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 433 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 434%endif
1cc7453a 435 --with-jdk="%{java_home}" \
04129f48 436%if %{with neon}
e3ad24ea 437 --without-serf \
e30588c4 438 --with-neon=%{_prefix} \
78f330c4 439 --disable-neon-version-check \
04129f48
AG
440%else
441 --with-serf=%{_prefix} \
442 --without-neon \
e3ad24ea 443%endif
16429189 444 --with-apr=%{_bindir}/apr-1-config \
1429fa1c 445 --with-apr-util=%{_bindir}/apu-1-config \
65f2befa 446%if %{with kwallet}
1429fa1c 447 --with-kwallet \
65f2befa 448%endif
bfb248d0 449%if %{with gnome}
1429fa1c 450 --with-gnome-keyring
bfb248d0 451%endif
536b3fd3 452
1f630180 453%{__make} -j1
536b3fd3 454
cf353d53 455%if !%{with net_client_only}
b56474ff 456# python
0905b458 457%if %{with python}
137fcafd
AM
458# ctypes bindings
459%{__make} ctypes-python
460# swig bindings
86a4919e 461%{__make} swig-py \
65318afa
AF
462 swig_pydir=%{py_sitedir}/libsvn \
463 swig_pydir_extra=%{py_sitedir}/svn
0905b458 464%endif
b56474ff 465# perl
0905b458 466%if %{with perl}
390bb8f4 467%{__make} -j1 swig-pl-lib
bf539998
AM
468odir=$(pwd)
469cd subversion/bindings/swig/perl/native
470%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 471%{__make} -j1
bf539998 472cd $odir
536b3fd3 473%endif
1cc7453a 474%if %{with javahl}
b445847c 475%{__make} -j1 javahl \
1cc7453a 476 javahl_javadir="%{_javadir}"
477%endif
d46e45ba
AM
478# ruby
479%if %{with ruby}
480%{__make} swig-rb
481%endif
12ae68c1
AM
482%endif
483
484%if %{with tests}
485%{__make} check
d46e45ba 486%if %{with python}
137fcafd 487%{__make} check-ctypes-python
d46e45ba
AM
488%{__make} check-swig-py
489%endif
490%if %{with perl}
491%{__make} check-swig-pl
492%endif
493%if %{with ruby}
494%{__make} check-swig-rb
495%endif
0905b458 496%endif
93b78127
AM
497
498%install
499rm -rf $RPM_BUILD_ROOT
1326bb99 500install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 501 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 502 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 503 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 504
1f630180 505%{__make} install -j1 \
1cc7453a 506%if %{with javahl}
507 install-javahl \
508 javahl_javadir="%{_javadir}" \
509%endif
d46e45ba
AM
510%if !%{with net_client_only}
511%if %{with python}
0905b458 512 install-swig-py \
137fcafd 513 install-ctypes-python \
d46e45ba
AM
514%endif
515%if %{with ruby}
516 install-swig-rb install-swig-rb-doc \
517%endif
0905b458 518%endif
f2a757d6 519 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 520 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
521 swig_pydir=%{py_sitedir}/libsvn \
522 swig_pydir_extra=%{py_sitedir}/svn
93b78127 523
cf353d53 524%if !%{with net_client_only} && %{with perl}
bf539998
AM
525%{__make} install-swig-pl-lib \
526 DESTDIR=$RPM_BUILD_ROOT
b445847c 527%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
528 DESTDIR=$RPM_BUILD_ROOT \
529 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
530 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
531%endif
532
0905b458 533%if %{with apache}
1af5e34d
ER
534install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
535install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
536install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
537install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 538%endif
93b78127 539
cf353d53 540%if !%{with net_client_only}
1326bb99 541install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 542%if %{with python}
f4e6a380
AM
543%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
544%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
545find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
546install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 547%endif
0905b458 548%endif
f4e6a380 549
1326bb99
JK
550install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
551install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 552
205a3ddc
AM
553%find_lang %{name}
554
dd73606c 555%{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
c39b6844 556rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
557rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 558
e23909be
JB
559%clean
560rm -rf $RPM_BUILD_ROOT
561
a1bac09d
562%pre svnserve
563%groupadd -g 86 svn
564%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
565
d2bf70bf
JB
566%post libs -p /sbin/ldconfig
567%postun libs -p /sbin/ldconfig
568
569%post devel -p /sbin/postshell
6f99c3bd 570-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 571
d2bf70bf 572%postun devel -p /sbin/postshell
6f99c3bd 573-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 574
d2bf70bf
JB
575%post -n perl-subversion -p /sbin/ldconfig
576%postun -n perl-subversion -p /sbin/ldconfig
577
578%post -n python-subversion -p /sbin/ldconfig
579%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 580
b56474ff 581%post svnserve
e8d9186f
ER
582/sbin/chkconfig --add svnserve
583%service svnserve restart "svnserve daemon"
584
b56474ff
AM
585%preun svnserve
586if [ "$1" = "0" ]; then
e8d9186f
ER
587 %service svnserve stop
588 /sbin/chkconfig --del svnserve
b56474ff
AM
589fi
590
a1bac09d
591%postun svnserve
592if [ "$1" = "0" ]; then
593 %userremove svn
594 %groupremove svn
595fi
596
93b78127 597%post -n apache-mod_dav_svn
e8d9186f 598%service -q httpd restart
93b78127
AM
599
600%preun -n apache-mod_dav_svn
601if [ "$1" = "0" ]; then
e8d9186f 602 %service -q httpd restart
93b78127
AM
603fi
604
93b78127
AM
605%files
606%defattr(644,root,root,755)
983a49f6 607%doc BUGS CHANGES COPYING INSTALL README
d37298dc 608%doc doc/*/*.html
4bbdbbf8
AM
609%doc tools/hook-scripts/*.{pl,py,example}
610%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 611%doc tools/xslt/*
b445847c
JB
612%attr(755,root,root) %{_bindir}/svn
613%attr(755,root,root) %{_bindir}/svnadmin
614%attr(755,root,root) %{_bindir}/svndumpfilter
615%attr(755,root,root) %{_bindir}/svnlook
616%attr(755,root,root) %{_bindir}/svnsync
617%attr(755,root,root) %{_bindir}/svnversion
618%{_mandir}/man1/svn.1*
619%{_mandir}/man1/svnadmin.1*
620%{_mandir}/man1/svndumpfilter.1*
621%{_mandir}/man1/svnlook.1*
622%{_mandir}/man1/svnsync.1*
623%{_mandir}/man1/svnversion.1*
f4e6a380 624
205a3ddc 625%files libs -f %{name}.lang
f4e6a380 626%defattr(644,root,root,755)
b445847c
JB
627%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
628%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
629%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
630%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
631%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
632%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
633%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
634%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
635%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
636%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
637%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
638%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
639%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
640%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
641%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
642%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
643%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
644%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
645%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
646%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
647%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
648%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
649%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
650%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
651%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
652%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
653%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
654%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
655
656%files devel
657%defattr(644,root,root,755)
b445847c
JB
658%attr(755,root,root) %{_libdir}/libsvn_client-1.so
659%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
660%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
661%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
662%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
663%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
664%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
665%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
666%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 667%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
668%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
669%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
670%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
671%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
672%{_libdir}/libsvn_client-1.la
673%{_libdir}/libsvn_delta-1.la
674%{_libdir}/libsvn_diff-1.la
675%{_libdir}/libsvn_fs-1.la
676%{_libdir}/libsvn_fs_base-1.la
677%{_libdir}/libsvn_fs_fs-1.la
678%{_libdir}/libsvn_fs_util-1.la
679%{_libdir}/libsvn_ra-1.la
680%{_libdir}/libsvn_ra_local-1.la
a510fada 681%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
682%{_libdir}/libsvn_ra_svn-1.la
683%{_libdir}/libsvn_repos-1.la
684%{_libdir}/libsvn_subr-1.la
685%{_libdir}/libsvn_wc-1.la
686%{_includedir}/%{name}-1
1326bb99 687%{_examplesdir}/%{name}-%{version}
93b78127
AM
688
689%files static
690%defattr(644,root,root,755)
b445847c
JB
691%{_libdir}/libsvn_client-1.a
692%{_libdir}/libsvn_delta-1.a
693%{_libdir}/libsvn_diff-1.a
694%{_libdir}/libsvn_fs-1.a
695%{_libdir}/libsvn_fs_base-1.a
696%{_libdir}/libsvn_fs_fs-1.a
697%{_libdir}/libsvn_fs_util-1.a
698%{_libdir}/libsvn_ra-1.a
699%{_libdir}/libsvn_ra_local-1.a
a510fada 700%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
701%{_libdir}/libsvn_ra_svn-1.a
702%{_libdir}/libsvn_repos-1.a
703%{_libdir}/libsvn_subr-1.a
704%{_libdir}/libsvn_wc-1.a
93b78127 705
bfb248d0 706%if %{with gnome}
1429fa1c
AM
707%files -n gnome-keyring-subversion
708%defattr(644,root,root,755)
709%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
710%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
bfb248d0 711%endif
1429fa1c 712
65f2befa 713%if %{with kwallet}
1429fa1c
AM
714%files -n kde4-kwallet-subversion
715%defattr(644,root,root,755)
716%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
717%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
65f2befa 718%endif
1429fa1c 719
cf353d53 720%if !%{with net_client_only}
b56474ff
AM
721%files svnserve
722%defattr(644,root,root,755)
723%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
724%{_mandir}/man5/svnserve.conf.5*
725%{_mandir}/man8/svnserve.8*
a1bac09d
726%dir %attr(750,svn,svn) /home/services/subversion
727%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 728%if %{with apache}
b56474ff 729%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 730%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 731%endif
b56474ff 732
4bbdbbf8
AM
733%files tools
734%defattr(644,root,root,755)
1326bb99 735%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 736
737%files -n bash-completion-subversion
101e74de 738%defattr(644,root,root,755)
1326bb99 739/etc/bash_completion.d/%{name}
536b3fd3 740
1cc7453a 741%if %{with javahl}
742%files -n java-subversion
743%defattr(644,root,root,755)
b445847c
JB
744%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
745%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
746%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 747%{_javadir}/svn-javahl.jar
748%endif
749
0905b458 750%if %{with python}
fa3ff1b2 751%files -n python-subversion
f4e6a380 752%defattr(644,root,root,755)
4bbdbbf8 753%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
754%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
755%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
756%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 757%dir %{py_sitedir}/libsvn
65318afa 758%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
759%dir %{py_sitedir}/svn
760%{py_sitedir}/svn/*.py[co]
65318afa 761%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 762%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
763
764%files -n python-csvn
765%defattr(644,root,root,755)
766%doc subversion/bindings/ctypes-python/{README,TODO}
767%doc subversion/bindings/ctypes-python/examples/*.py
768%dir %{py_sitescriptdir}/csvn
769%{py_sitescriptdir}/csvn/*.py[co]
770%dir %{py_sitescriptdir}/csvn/core
771%{py_sitescriptdir}/csvn/core/*.py[co]
772%dir %{py_sitescriptdir}/csvn/ext
773%{py_sitescriptdir}/csvn/ext/*.py[co]
774%{py_sitescriptdir}/*.egg-info
0905b458 775%endif
f4e6a380 776
0905b458 777%if %{with perl}
b56474ff
AM
778%files -n perl-subversion
779%defattr(644,root,root,755)
b445847c
JB
780%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
781%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
782%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
783%{perl_vendorarch}/SVN
784%dir %{perl_vendorarch}/auto/SVN
785%dir %{perl_vendorarch}/auto/SVN/*
786%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
787%{perl_vendorarch}/auto/SVN/*/*.bs
788%{_mandir}/man3/*.3pm*
0905b458 789%endif
b56474ff 790
d46e45ba
AM
791%if %{with ruby}
792%files -n ruby-subversion
793%defattr(644,root,root,755)
b445847c
JB
794%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
795%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
796%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
916011ef
JR
797%dir %{ruby_sitelibdir}/svn
798%{ruby_sitelibdir}/svn/*.rb
799%dir %{ruby_sitearchdir}/svn
800%dir %{ruby_sitearchdir}/svn/ext
e2c6dc67 801%attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
916011ef 802%{ruby_ridir}/Svn
d46e45ba
AM
803%endif
804
0905b458 805%if %{with apache}
93b78127
AM
806%files -n apache-mod_dav_svn
807%defattr(644,root,root,755)
1af5e34d
ER
808%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
809%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
810
811%files -n apache-mod_authz_svn
812%defattr(644,root,root,755)
813%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
814%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
815%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 816%endif
7b27380f
ER
817
818%endif # net_client_only
This page took 0.197089 seconds and 4 git commands to generate.