]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- reorder BuildRequires so net_client_only bcond makes sense again
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
b4d1f957 2# - fix java build with java-gcj-compat and s/java-sun/jdk/
1930bef0 3# - remove net_client_only and add db bcond (then without apache and
4# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 5# - finish ruby
1930bef0 6#
bab73684 7# Conditional build:
65c1d4bd 8%bcond_with net_client_only # build only net client
3fc01170 9%bcond_without neon # use serf instead of neon
65c1d4bd
JB
10%bcond_without python # build without python bindings (broken)
11%bcond_without perl # build without perl bindings
73ab938a 12%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
13%bcond_without apache # build without apache support (webdav, etc)
14%bcond_without javahl # build without javahl support (Java high-level bindings)
15%bcond_without tests # don't perform "make check"
7b27380f 16#
bc126282 17%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 18%undefine with_javahl
bc126282
AG
19%endif
20#
b56474ff 21%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 22%define apxs /usr/sbin/apxs
1f630180
ER
23%define pdir SVN
24%define pnam _Core
12ae68c1 25#
04129f48 26%if %{with neon}
a510fada 27%define webdavlib neon
04129f48
AG
28%else
29%define webdavlib serf
a510fada
AM
30%endif
31#
67cb9518 32Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
33Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
34Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 35Name: subversion
1429fa1c
AM
36Version: 1.6.0
37Release: 0.1
6f88d80e 38License: Apache/BSD-like
93b78127 39Group: Development/Version Control
1429fa1c 40Source0: http://subversion.tigris.org/downloads/%{name}-%{version}-rc3.tar.bz2
82c1228d 41# Source0-md5: 58473cb07611fd7567b6ce99461009e1
93b78127 42Source1: %{name}-dav_svn.conf
65318afa 43Source2: %{name}-authz_svn.conf
b56474ff
AM
44Source3: %{name}-svnserve.init
45Source4: %{name}-svnserve.sysconfig
a510fada
AM
46# current subversion tarball has correct *.swg files
47# but after regeneration these are broken again, so
48# we still need this script
f313e9a9 49Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 50Patch0: %{name}-home_etc.patch
d46e45ba 51Patch1: %{name}-DESTDIR.patch
00664663 52Patch2: %{name}-ruby-datadir-path.patch
d2bf70bf 53URL: http://subversion.tigris.org/
4945947e
AM
54%if %{with net_client_only}
55%global apache_modules_api 0
56%else
f2a757d6 57%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 58BuildRequires: automake
3817faf5 59BuildRequires: db-devel >= 4.1.25
e8d9186f 60BuildRequires: rpmbuild(macros) >= 1.268
0905b458 61%if %{with perl}
522a69b4 62BuildRequires: perl-devel >= 1:5.8.0
63BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 64BuildRequires: swig-perl >= 1.3.24
536b3fd3 65%endif
6ac3574b
AM
66%if %{with python}
67BuildRequires: python-ctypesgen
68BuildRequires: python-devel >= 2.2
69BuildRequires: swig-python >= 1.3.24
70%endif
71%if %{with ruby}
72BuildRequires: ruby-devel
73BuildRequires: swig-ruby >= 1.3.24
74%endif
b4d1f957 75%{?with_javahl:BuildRequires: java-sun}
6ac3574b 76BuildRequires: cyrus-sasl-devel
0905b458 77%endif
16429189 78BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 79BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 80BuildRequires: autoconf >= 2.59
79d8c53c 81BuildRequires: bison
93b78127 82BuildRequires: expat-devel
86ea8fde 83BuildRequires: gettext-devel
1429fa1c
AM
84BuildRequires: gnome-keyring-devel
85BuildRequires: kde4-kdelibs-devel
f4e6a380 86BuildRequires: libtool >= 1.4-9
a562165a 87BuildRequires: sed >= 4.0
c26d84c4 88BuildRequires: sqlite3-devel >= 3.6.11
a562165a
JB
89BuildRequires: texinfo
90BuildRequires: which
91%if %{with neon}
bd3c99a8 92BuildRequires: neon-devel >= 0.26.0
a562165a
JB
93%else
94BuildRequires: serf-devel
e3ad24ea 95%endif
53855fbf 96BuildRequires: python >= 2.2
ed6210a2 97BuildRequires: python-modules >= 2.2
027f8ebe 98Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
99BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
f4070f5f 101%define _libexecdir %{_libdir}/svn
1af5e34d
ER
102%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
103%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
104
105%description
106The goal of the Subversion project is to build a version control
107system that is a compelling replacement for CVS in the open source
108community.
109
110Our goals are:
111- All current CVS features.
112- Directories, renames, and file meta-data are versioned.
113- Symbolic links, etc, are supported
114- Commits are truly atomic.
115- Branching and tagging are cheap (constant time) operations
116- Repeated merges are handled gracefully
117- Support for plug-in client side diff programs
118- Natively client/server
119- Client/server protocol sends diffs in both directions
120- Costs are proportional to change size, not project size
121- Internationalization
122- Progressive multi-lingual support
123
aa59005f 124%description -l pl.UTF-8
93b78127
AM
125Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
126zamiennika dla CVS.
127
128Cele projektu to:
aa59005f 129- Wszystkie aktualne możliwości CVS.
24406120
JB
130- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
131- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
132- Commity są w pełni atomowe.
133- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
134- Dobra obsługa powtarzanego łączenia (merge).
135- Obsługa wtyczek diff po stronie klienta.
93b78127 136- Natywny klient/serwer.
aa59005f 137- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
138- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
139- Internacjonalizacja.
aa59005f 140- Postępujące wsparcie dla wielu języków.
93b78127 141
aa59005f
JR
142%description -l pt_BR.UTF-8
143O objetivo do projeto Subversion é construir um sistema de controle de
144versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 145System) na comunidade opensource, fornecendo grandes melhorias.
146
f4e6a380
AM
147%package libs
148Summary: Subversion libraries and modules
abe3c421 149Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 150Group: Libraries
04129f48 151%{?with_neon:Requires: neon >= 0.26.0}
53855fbf 152Obsoletes: libsubversion0
f4e6a380
AM
153
154%description libs
155Subversion libraries and modules.
156
aa59005f
JR
157%description libs -l pl.UTF-8
158Biblioteka subversion oraz ładowalne moduły.
f4e6a380 159
93b78127
AM
160%package devel
161Summary: Header files and develpment documentation for subversion
abe3c421
ER
162Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
163Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 164Group: Development/Libraries
9cb7e099 165Requires: %{name}-libs = %{version}-%{release}
c5b1d686 166Requires: apr-util-devel >= 1:1.0.0
04129f48 167%{?with_neon:Requires: neon-devel >= 0.26.0}
12cf252c 168Obsoletes: libsubversion0-devel
93b78127
AM
169
170%description devel
171Header files and develpment documentation for subversion.
172
aa59005f
JR
173%description devel -l pl.UTF-8
174Pliki nagłówkowe i dokumetacja do subversion.
93b78127 175
aa59005f
JR
176%description devel -l pt_BR.UTF-8
177Este pacote provê os arquivos necessários para desenvolvedores
92066deb 178interagirem com o Subversion.
179
93b78127
AM
180%package static
181Summary: Static subversion library
abe3c421
ER
182Summary(pl.UTF-8): Biblioteka statyczna subversion
183Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
184Group: Development/Libraries
185Requires: %{name}-devel = %{version}
12cf252c 186Obsoletes: libsubversion0-static-devel
93b78127
AM
187
188%description static
189Static subversion library.
190
aa59005f 191%description static -l pl.UTF-8
93b78127
AM
192Biblioteka statyczna subversion.
193
aa59005f
JR
194%description static -l pt_BR.UTF-8
195Este pacote provê um cliente estático do subversion.
92066deb 196
b56474ff
AM
197%package svnserve
198Summary: Subversion svnserve
abe3c421 199Summary(pl.UTF-8): Subversion svnserve
b56474ff 200Group: Networking/Daemons
3817faf5 201Requires(post,preun): /sbin/chkconfig
93f1d402 202Requires(postun): /usr/sbin/groupdel
203Requires(postun): /usr/sbin/userdel
204Requires(pre): /bin/id
205Requires(pre): /usr/bin/getgid
206Requires(pre): /usr/lib/rpm/user_group.sh
207Requires(pre): /usr/sbin/groupadd
208Requires(pre): /usr/sbin/useradd
209Requires(pre): /usr/sbin/usermod
9cb7e099 210Requires: %{name} = %{version}-%{release}
7b27380f 211Requires: rc-scripts
a1bac09d
212Provides: group(svn)
213Provides: user(svn)
b56474ff
AM
214
215%description svnserve
216Subversion svnserve server.
217
aa59005f 218%description svnserve -l pl.UTF-8
b56474ff
AM
219Serwer subversion svnserve.
220
4bbdbbf8
AM
221%package tools
222Summary: Subversion tools and scripts
abe3c421
ER
223Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
224Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 225Group: Applications
4bbdbbf8 226%pyrequires_eq python
7b27380f 227Requires: %{name} = %{version}-%{release}
1271c9bd 228Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
229Requires: python-subversion = %{version}
230
231%description tools
232Subversion tools and scripts.
233
aa59005f
JR
234%description tools -l pl.UTF-8
235Narzędzia oraz skrypty dla subversion.
4bbdbbf8 236
fe5bb6bb 237%package -n bash-completion-subversion
238Summary: bash completion for subversion
abe3c421 239Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 240Group: Applications/Shells
e30588c4 241Requires: %{name} = %{version}-%{release}
53855fbf 242Requires: bash-completion
e30588c4 243Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 244
245%description -n bash-completion-subversion
246Bash completion for subversion.
247
aa59005f
JR
248%description -n bash-completion-subversion -l pl.UTF-8
249Dopełnienia basha dla subversion.
fe5bb6bb 250
1cc7453a 251%package -n java-subversion
65c1d4bd
JB
252Summary: Subversion Java bindings
253Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 254Group: Development/Languages/Java
255Requires: %{name}-libs = %{version}-%{release}
256
257%description -n java-subversion
258This is a set of Java classes which provide the functionality of
259subversion-libs, the Subversion libraries. It is useful if you want
260to, for example, write a Java class that manipulates a Subversion
261repository or working copy. See the 'subversion' package for more
262information.
263
65c1d4bd
JB
264%description -n java-subversion -l pl.UTF-8
265Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
267pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 269
fa3ff1b2 270%package -n python-subversion
65c1d4bd
JB
271Summary: Subversion Python bindings
272Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
273Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 274Group: Development/Languages/Python
f4e6a380 275%pyrequires_eq python
9cb7e099 276Requires: %{name}-libs = %{version}-%{release}
53855fbf 277Obsoletes: subversion-python
f4e6a380 278
fa3ff1b2 279%description -n python-subversion
65c1d4bd 280Subversion Python bindings.
f4e6a380 281
aa59005f 282%description -n python-subversion -l pl.UTF-8
65c1d4bd 283Dowiązania do Subversion dla Pythona.
f4e6a380 284
aa59005f 285%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 286Módulos Python para acessar os recursos do Subversion.
92066deb 287
137fcafd
AM
288%package -n python-csvn
289Summary: CTypes Subversion Python bindings
290Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
291Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
292Group: Development/Languages/Python
293%pyrequires_eq python
294Requires: %{name}-libs = %{version}-%{release}
295
296%description -n python-csvn
297Subversion CTypes Python bindings.
298
299%description -n python-csvn -l pl.UTF-8
300Dowiązania do Subversion dla Pythona używające CTypes.
301
302%description -n python-csvn -l pt_BR.UTF-8
303Módulos Python para acessar os recursos do Subversion.
304
b56474ff 305%package -n perl-subversion
65c1d4bd
JB
306Summary: Subversion Perl bindings
307Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
308Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 309Group: Development/Languages/Perl
9cb7e099 310Requires: %{name}-libs = %{version}-%{release}
53855fbf 311Obsoletes: subversion-perl
b56474ff
AM
312
313%description -n perl-subversion
65c1d4bd 314Subversion Perl bindings.
b56474ff 315
aa59005f 316%description -n perl-subversion -l pl.UTF-8
65c1d4bd 317Dowiązania do Subversion dla Perla.
b56474ff 318
aa59005f 319%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 320Módulos Perl para acessar os recursos do Subversion.
b56474ff 321
d46e45ba
AM
322%package -n ruby-subversion
323Summary: Subversion Ruby bindings
d2bf70bf 324Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
325Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
326Group: Development/Languages
327Requires: %{name}-libs = %{version}-%{release}
328Obsoletes: subversion-ruby
329
330%description -n ruby-subversion
331Subversion Ruby bindings.
332
333%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 334Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
335
336%description -n ruby-subversion -l pt_BR.UTF-8
337Módulos Ruby para acessar os recursos do Subversion.
338
93b78127
AM
339%package -n apache-mod_dav_svn
340Summary: Apache module: Subversion Server
abe3c421 341Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 342Group: Networking/Daemons
7b27380f 343Requires: %{name} = %{version}-%{release}
53855fbf 344Requires: apache(modules-api) = %apache_modules_api
7887b1ac 345Requires: apache-mod_dav
93b78127
AM
346
347%description -n apache-mod_dav_svn
348Apache module: Subversion Server.
349
aa59005f
JR
350%description -n apache-mod_dav_svn -l pl.UTF-8
351Moduł apache: Serwer Subversion.
93b78127 352
65318afa
AF
353%package -n apache-mod_authz_svn
354Summary: Apache module: Subversion Server - path-based authorization
abe3c421 355Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 356Group: Networking/Daemons
53855fbf 357Requires: apache(modules-api) = %apache_modules_api
9cb7e099 358Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
359
360%description -n apache-mod_authz_svn
361Apache module: Subversion Server - path-based authorization.
362
aa59005f
JR
363%description -n apache-mod_authz_svn -l pl.UTF-8
364Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 365
1429fa1c
AM
366%package -n gnome-keyring-subversion
367Summary: Subversion module for Gnome Keyring
368Summary(pl.UTF-8): Moduł subversion dla zarządcy kluczy Gnome
369Group: X11/Applications
370
371%description -n gnome-keyring-subversion
372Subversion module for Gnome Keyring.
373
374%description -n gnome-keyring-subversion -l pl.UTF-8
375Moduł subversion dla zarządcy kluczy Gnome.
376
377%package -n kde4-kwallet-subversion
378Summary: Subversion module for KDE Wallet
379Summary(pl.UTF-8): Moduł subversion dla Portfela KDE
380Group: X11/Applications
381
382%description -n kde4-kwallet-subversion
383Subversion module for KDE Wallet.
384
385%description -n kde4-kwallet-subversion -l pl.UTF-8
386Moduł subversion dla Portfela KDE.
387
93b78127 388%prep
1429fa1c 389%setup -q -n %{name}-%{version}-rc3
e30588c4 390rm -rf apr apr-util neon
ed6210a2 391%patch0 -p0
d4bccc60 392%patch1 -p1
00664663 393%patch2 -p0
a510fada
AM
394
395sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397# serf.m4 macro is broken and ignores --without serf
244bdb04 398%{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
027f8ebe 399
93b78127 400%build
93f1d402 401rm subversion/bindings/swig/proxy/*.swg
24406120 402cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 403cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 404chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 405
93b78127 406%configure \
5dfeafd7 407 --with-editor=vi \
12ae68c1 408 --with-zlib=%{_libdir} \
536b3fd3
AM
409%if %{with net_client_only}
410 --without-apache \
411 --without-swig \
412 --without-apxs \
413 --without-berkeley-db \
414%else
fa6fa2cf 415 --disable-runtime-module-search \
86ee97d3 416 --disable-mod-activation \
0905b458 417%if %{with apache}
536b3fd3 418 --with-apxs=%{_sbindir}/apxs \
0905b458 419%else
420 --without-apache \
421 --without-apxs \
536b3fd3 422 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 423%endif
73ab938a 424%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 425 --without-swig \
426%endif
137fcafd 427 %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
1cc7453a 428 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 429%endif
1cc7453a 430 --with-jdk="%{java_home}" \
04129f48 431%if %{with neon}
e3ad24ea 432 --without-serf \
e30588c4 433 --with-neon=%{_prefix} \
78f330c4 434 --disable-neon-version-check \
04129f48
AG
435%else
436 --with-serf=%{_prefix} \
437 --without-neon \
e3ad24ea 438%endif
16429189 439 --with-apr=%{_bindir}/apr-1-config \
1429fa1c
AM
440 --with-apr-util=%{_bindir}/apu-1-config \
441 --with-kwallet \
442 --with-gnome-keyring
536b3fd3 443
1f630180 444%{__make} -j1
536b3fd3 445
cf353d53 446%if !%{with net_client_only}
b56474ff 447# python
0905b458 448%if %{with python}
137fcafd
AM
449# ctypes bindings
450%{__make} ctypes-python
451# swig bindings
86a4919e 452%{__make} swig-py \
65318afa
AF
453 swig_pydir=%{py_sitedir}/libsvn \
454 swig_pydir_extra=%{py_sitedir}/svn
0905b458 455%endif
b56474ff 456# perl
0905b458 457%if %{with perl}
390bb8f4 458%{__make} -j1 swig-pl-lib
bf539998
AM
459odir=$(pwd)
460cd subversion/bindings/swig/perl/native
461%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 462%{__make} -j1
bf539998 463cd $odir
536b3fd3 464%endif
1cc7453a 465%if %{with javahl}
b445847c 466%{__make} -j1 javahl \
1cc7453a 467 javahl_javadir="%{_javadir}"
468%endif
d46e45ba
AM
469# ruby
470%if %{with ruby}
471%{__make} swig-rb
472%endif
12ae68c1
AM
473%endif
474
475%if %{with tests}
476%{__make} check
d46e45ba 477%if %{with python}
137fcafd 478%{__make} check-ctypes-python
d46e45ba
AM
479%{__make} check-swig-py
480%endif
481%if %{with perl}
482%{__make} check-swig-pl
483%endif
484%if %{with ruby}
485%{__make} check-swig-rb
486%endif
0905b458 487%endif
93b78127
AM
488
489%install
490rm -rf $RPM_BUILD_ROOT
1326bb99 491install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 492 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 493 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 494 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 495
1f630180 496%{__make} install -j1 \
1cc7453a 497%if %{with javahl}
498 install-javahl \
499 javahl_javadir="%{_javadir}" \
500%endif
d46e45ba
AM
501%if !%{with net_client_only}
502%if %{with python}
0905b458 503 install-swig-py \
137fcafd 504 install-ctypes-python \
d46e45ba
AM
505%endif
506%if %{with ruby}
507 install-swig-rb install-swig-rb-doc \
508%endif
0905b458 509%endif
f2a757d6 510 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 511 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
512 swig_pydir=%{py_sitedir}/libsvn \
513 swig_pydir_extra=%{py_sitedir}/svn
93b78127 514
cf353d53 515%if !%{with net_client_only} && %{with perl}
bf539998
AM
516%{__make} install-swig-pl-lib \
517 DESTDIR=$RPM_BUILD_ROOT
b445847c 518%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
519 DESTDIR=$RPM_BUILD_ROOT \
520 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
521 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
522%endif
523
0905b458 524%if %{with apache}
1af5e34d
ER
525install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
526install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
527install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
528install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 529%endif
93b78127 530
cf353d53 531%if !%{with net_client_only}
1326bb99 532install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 533%if %{with python}
f4e6a380
AM
534%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
535%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
536find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
537install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 538%endif
0905b458 539%endif
f4e6a380 540
1326bb99
JK
541install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
542install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 543
205a3ddc
AM
544%find_lang %{name}
545
1429fa1c
AM
546rm $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
547rm $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
a6ecf312 548
e23909be
JB
549%clean
550rm -rf $RPM_BUILD_ROOT
551
a1bac09d
552%pre svnserve
553%groupadd -g 86 svn
554%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
555
d2bf70bf
JB
556%post libs -p /sbin/ldconfig
557%postun libs -p /sbin/ldconfig
558
559%post devel -p /sbin/postshell
6f99c3bd 560-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 561
d2bf70bf 562%postun devel -p /sbin/postshell
6f99c3bd 563-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 564
d2bf70bf
JB
565%post -n perl-subversion -p /sbin/ldconfig
566%postun -n perl-subversion -p /sbin/ldconfig
567
568%post -n python-subversion -p /sbin/ldconfig
569%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 570
b56474ff 571%post svnserve
e8d9186f
ER
572/sbin/chkconfig --add svnserve
573%service svnserve restart "svnserve daemon"
574
b56474ff
AM
575%preun svnserve
576if [ "$1" = "0" ]; then
e8d9186f
ER
577 %service svnserve stop
578 /sbin/chkconfig --del svnserve
b56474ff
AM
579fi
580
a1bac09d
581%postun svnserve
582if [ "$1" = "0" ]; then
583 %userremove svn
584 %groupremove svn
585fi
586
93b78127 587%post -n apache-mod_dav_svn
e8d9186f 588%service -q httpd restart
93b78127
AM
589
590%preun -n apache-mod_dav_svn
591if [ "$1" = "0" ]; then
e8d9186f 592 %service -q httpd restart
93b78127
AM
593fi
594
93b78127
AM
595%files
596%defattr(644,root,root,755)
983a49f6 597%doc BUGS CHANGES COPYING INSTALL README
d37298dc 598%doc doc/*/*.html
4bbdbbf8
AM
599%doc tools/hook-scripts/*.{pl,py,example}
600%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 601%doc tools/xslt/*
b445847c
JB
602%attr(755,root,root) %{_bindir}/svn
603%attr(755,root,root) %{_bindir}/svnadmin
604%attr(755,root,root) %{_bindir}/svndumpfilter
605%attr(755,root,root) %{_bindir}/svnlook
606%attr(755,root,root) %{_bindir}/svnsync
607%attr(755,root,root) %{_bindir}/svnversion
608%{_mandir}/man1/svn.1*
609%{_mandir}/man1/svnadmin.1*
610%{_mandir}/man1/svndumpfilter.1*
611%{_mandir}/man1/svnlook.1*
612%{_mandir}/man1/svnsync.1*
613%{_mandir}/man1/svnversion.1*
f4e6a380 614
205a3ddc 615%files libs -f %{name}.lang
f4e6a380 616%defattr(644,root,root,755)
b445847c
JB
617%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
618%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
619%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
620%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
621%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
622%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
623%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
624%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
625%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
626%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
627%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
628%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
629%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
630%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
631%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
632%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
633%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
634%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
a510fada
AM
635%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
636%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
b445847c
JB
637%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
638%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
639%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
640%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
641%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
642%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
643%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
644%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
645
646%files devel
647%defattr(644,root,root,755)
b445847c
JB
648%attr(755,root,root) %{_libdir}/libsvn_client-1.so
649%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
650%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
651%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
652%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
653%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
654%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
655%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
656%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
a510fada 657%attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
b445847c
JB
658%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
659%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
660%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
661%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
662%{_libdir}/libsvn_client-1.la
663%{_libdir}/libsvn_delta-1.la
664%{_libdir}/libsvn_diff-1.la
665%{_libdir}/libsvn_fs-1.la
666%{_libdir}/libsvn_fs_base-1.la
667%{_libdir}/libsvn_fs_fs-1.la
668%{_libdir}/libsvn_fs_util-1.la
669%{_libdir}/libsvn_ra-1.la
670%{_libdir}/libsvn_ra_local-1.la
a510fada 671%{_libdir}/libsvn_ra_%{webdavlib}-1.la
b445847c
JB
672%{_libdir}/libsvn_ra_svn-1.la
673%{_libdir}/libsvn_repos-1.la
674%{_libdir}/libsvn_subr-1.la
675%{_libdir}/libsvn_wc-1.la
676%{_includedir}/%{name}-1
1326bb99 677%{_examplesdir}/%{name}-%{version}
93b78127
AM
678
679%files static
680%defattr(644,root,root,755)
b445847c
JB
681%{_libdir}/libsvn_client-1.a
682%{_libdir}/libsvn_delta-1.a
683%{_libdir}/libsvn_diff-1.a
684%{_libdir}/libsvn_fs-1.a
685%{_libdir}/libsvn_fs_base-1.a
686%{_libdir}/libsvn_fs_fs-1.a
687%{_libdir}/libsvn_fs_util-1.a
688%{_libdir}/libsvn_ra-1.a
689%{_libdir}/libsvn_ra_local-1.a
a510fada 690%{_libdir}/libsvn_ra_%{webdavlib}-1.a
b445847c
JB
691%{_libdir}/libsvn_ra_svn-1.a
692%{_libdir}/libsvn_repos-1.a
693%{_libdir}/libsvn_subr-1.a
694%{_libdir}/libsvn_wc-1.a
93b78127 695
1429fa1c
AM
696%files -n gnome-keyring-subversion
697%defattr(644,root,root,755)
698%attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
699%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
700
701%files -n kde4-kwallet-subversion
702%defattr(644,root,root,755)
703%attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
704%attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
705
cf353d53 706%if !%{with net_client_only}
b56474ff
AM
707%files svnserve
708%defattr(644,root,root,755)
709%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
710%{_mandir}/man5/svnserve.conf.5*
711%{_mandir}/man8/svnserve.8*
a1bac09d
712%dir %attr(750,svn,svn) /home/services/subversion
713%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 714%if %{with apache}
b56474ff 715%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 716%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 717%endif
b56474ff 718
4bbdbbf8
AM
719%files tools
720%defattr(644,root,root,755)
1326bb99 721%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 722
723%files -n bash-completion-subversion
101e74de 724%defattr(644,root,root,755)
1326bb99 725/etc/bash_completion.d/%{name}
536b3fd3 726
1cc7453a 727%if %{with javahl}
728%files -n java-subversion
729%defattr(644,root,root,755)
b445847c
JB
730%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
731%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
732%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 733%{_javadir}/svn-javahl.jar
734%endif
735
0905b458 736%if %{with python}
fa3ff1b2 737%files -n python-subversion
f4e6a380 738%defattr(644,root,root,755)
4bbdbbf8 739%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
740%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
741%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
742%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 743%dir %{py_sitedir}/libsvn
65318afa 744%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
745%dir %{py_sitedir}/svn
746%{py_sitedir}/svn/*.py[co]
65318afa 747%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 748%{_examplesdir}/python-%{name}-%{version}
137fcafd
AM
749
750%files -n python-csvn
751%defattr(644,root,root,755)
752%doc subversion/bindings/ctypes-python/{README,TODO}
753%doc subversion/bindings/ctypes-python/examples/*.py
754%dir %{py_sitescriptdir}/csvn
755%{py_sitescriptdir}/csvn/*.py[co]
756%dir %{py_sitescriptdir}/csvn/core
757%{py_sitescriptdir}/csvn/core/*.py[co]
758%dir %{py_sitescriptdir}/csvn/ext
759%{py_sitescriptdir}/csvn/ext/*.py[co]
760%{py_sitescriptdir}/*.egg-info
0905b458 761%endif
f4e6a380 762
0905b458 763%if %{with perl}
b56474ff
AM
764%files -n perl-subversion
765%defattr(644,root,root,755)
b445847c
JB
766%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
767%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
768%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
769%{perl_vendorarch}/SVN
770%dir %{perl_vendorarch}/auto/SVN
771%dir %{perl_vendorarch}/auto/SVN/*
772%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
773%{perl_vendorarch}/auto/SVN/*/*.bs
774%{_mandir}/man3/*.3pm*
0905b458 775%endif
b56474ff 776
d46e45ba
AM
777%if %{with ruby}
778%files -n ruby-subversion
779%defattr(644,root,root,755)
b445847c
JB
780%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
781%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
782%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
1429fa1c
AM
783%dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
784%dir %{_libdir}/ruby/site_ruby/*/svn
785%{_libdir}/ruby/site_ruby/*/svn/*.rb
786%dir %{_libdir}/ruby/site_ruby/*/*-*
787%dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
788%attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
ab6adef9 789%{_datadir}/ri/*.*/system/OptionParser
00664663 790%{_datadir}/ri/*.*/system/Svn
791%{_datadir}/ri/*.*/system/Time
792%{_datadir}/ri/*.*/system/Uconv
793%{_datadir}/ri/*.*/system/*.rid
794%{_datadir}/ri/*.*/system/Kernel/*
d46e45ba
AM
795%endif
796
0905b458 797%if %{with apache}
93b78127
AM
798%files -n apache-mod_dav_svn
799%defattr(644,root,root,755)
1af5e34d
ER
800%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
801%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
802
803%files -n apache-mod_authz_svn
804%defattr(644,root,root,755)
805%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
806%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
807%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 808%endif
7b27380f
ER
809
810%endif # net_client_only
This page took 0.227502 seconds and 4 git commands to generate.