]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- up to 1.5.0-rc5
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
4#
bab73684 5# Conditional build:
65c1d4bd
JB
6%bcond_with net_client_only # build only net client
7%bcond_without python # build without python bindings (broken)
8%bcond_without perl # build without perl bindings
9%bcond_without apache # build without apache support (webdav, etc)
10%bcond_without javahl # build without javahl support (Java high-level bindings)
11%bcond_without tests # don't perform "make check"
7b27380f 12#
b56474ff 13%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 14%define apxs /usr/sbin/apxs
1f630180
ER
15%define pdir SVN
16%define pnam _Core
12ae68c1 17#
56724a21 18%define snap rc5
67cb9518 19Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
20Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
21Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 22Name: subversion
12ae68c1
AM
23Version: 1.5.0
24Release: 0.%{snap}.1
6f88d80e 25License: Apache/BSD-like
93b78127 26Group: Development/Version Control
56724a21 27Source0: http://subversion.tigris.org/downloads/%{name}-%{version}-%{snap}.tar.bz2
28# Source0-md5: 0e87b4f9fa8551a2a71b539564c3bf8f
93b78127 29Source1: %{name}-dav_svn.conf
65318afa 30Source2: %{name}-authz_svn.conf
b56474ff
AM
31Source3: %{name}-svnserve.init
32Source4: %{name}-svnserve.sysconfig
f313e9a9 33Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 34Patch0: %{name}-home_etc.patch
d4bccc60 35Patch1: %{name}-DESTDIR.patch
93b78127 36URL: http://subversion.tigris.org/
4945947e
AM
37%if %{with net_client_only}
38%global apache_modules_api 0
39%else
f2a757d6 40%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 41BuildRequires: automake
3817faf5 42BuildRequires: db-devel >= 4.1.25
e8d9186f 43BuildRequires: rpmbuild(macros) >= 1.268
0905b458 44%if %{with perl}
522a69b4 45BuildRequires: perl-devel >= 1:5.8.0
46BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 47BuildRequires: swig-perl >= 1.3.24
536b3fd3 48%endif
1cc7453a 49%{?with_javahl:BuildRequires: jdk}
0905b458 50%endif
16429189 51BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 52BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 53BuildRequires: autoconf >= 2.59
79d8c53c 54BuildRequires: bison
12ae68c1 55BuildRequires: cyrus-sasl-devel
93b78127 56BuildRequires: expat-devel
86ea8fde 57BuildRequires: gettext-devel
f4e6a380 58BuildRequires: libtool >= 1.4-9
bd3c99a8 59BuildRequires: neon-devel >= 0.26.0
53855fbf 60BuildRequires: python >= 2.2
ed6210a2 61BuildRequires: python-modules >= 2.2
f313e9a9 62%if %{with python}
63BuildRequires: python-devel >= 2.2
1f16145f 64BuildRequires: sed >= 4.0
15f9818d 65BuildRequires: swig-python >= 1.3.24
0905b458 66%endif
93b78127 67BuildRequires: texinfo
7b35d179 68BuildRequires: which
027f8ebe 69Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
f4070f5f 72%define _libexecdir %{_libdir}/svn
1af5e34d
ER
73%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
74%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
75
76%description
77The goal of the Subversion project is to build a version control
78system that is a compelling replacement for CVS in the open source
79community.
80
81Our goals are:
82- All current CVS features.
83- Directories, renames, and file meta-data are versioned.
84- Symbolic links, etc, are supported
85- Commits are truly atomic.
86- Branching and tagging are cheap (constant time) operations
87- Repeated merges are handled gracefully
88- Support for plug-in client side diff programs
89- Natively client/server
90- Client/server protocol sends diffs in both directions
91- Costs are proportional to change size, not project size
92- Internationalization
93- Progressive multi-lingual support
94
aa59005f 95%description -l pl.UTF-8
93b78127
AM
96Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
97zamiennika dla CVS.
98
99Cele projektu to:
aa59005f 100- Wszystkie aktualne możliwości CVS.
24406120
JB
101- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
102- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
103- Commity są w pełni atomowe.
104- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
105- Dobra obsługa powtarzanego łączenia (merge).
106- Obsługa wtyczek diff po stronie klienta.
93b78127 107- Natywny klient/serwer.
aa59005f 108- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
109- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
110- Internacjonalizacja.
aa59005f 111- Postępujące wsparcie dla wielu języków.
93b78127 112
aa59005f
JR
113%description -l pt_BR.UTF-8
114O objetivo do projeto Subversion é construir um sistema de controle de
115versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 116System) na comunidade opensource, fornecendo grandes melhorias.
117
f4e6a380
AM
118%package libs
119Summary: Subversion libraries and modules
abe3c421 120Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 121Group: Libraries
24406120 122Requires: neon >= 0.26.0
53855fbf 123Obsoletes: libsubversion0
f4e6a380
AM
124
125%description libs
126Subversion libraries and modules.
127
aa59005f
JR
128%description libs -l pl.UTF-8
129Biblioteka subversion oraz ładowalne moduły.
f4e6a380 130
93b78127
AM
131%package devel
132Summary: Header files and develpment documentation for subversion
abe3c421
ER
133Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
134Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 135Group: Development/Libraries
9cb7e099 136Requires: %{name}-libs = %{version}-%{release}
c5b1d686 137Requires: apr-util-devel >= 1:1.0.0
24406120 138Requires: neon-devel >= 0.26.0
12cf252c 139Obsoletes: libsubversion0-devel
93b78127
AM
140
141%description devel
142Header files and develpment documentation for subversion.
143
aa59005f
JR
144%description devel -l pl.UTF-8
145Pliki nagłówkowe i dokumetacja do subversion.
93b78127 146
aa59005f
JR
147%description devel -l pt_BR.UTF-8
148Este pacote provê os arquivos necessários para desenvolvedores
92066deb 149interagirem com o Subversion.
150
93b78127
AM
151%package static
152Summary: Static subversion library
abe3c421
ER
153Summary(pl.UTF-8): Biblioteka statyczna subversion
154Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
155Group: Development/Libraries
156Requires: %{name}-devel = %{version}
12cf252c 157Obsoletes: libsubversion0-static-devel
93b78127
AM
158
159%description static
160Static subversion library.
161
aa59005f 162%description static -l pl.UTF-8
93b78127
AM
163Biblioteka statyczna subversion.
164
aa59005f
JR
165%description static -l pt_BR.UTF-8
166Este pacote provê um cliente estático do subversion.
92066deb 167
b56474ff
AM
168%package svnserve
169Summary: Subversion svnserve
abe3c421 170Summary(pl.UTF-8): Subversion svnserve
b56474ff 171Group: Networking/Daemons
3817faf5 172Requires(post,preun): /sbin/chkconfig
93f1d402 173Requires(postun): /usr/sbin/groupdel
174Requires(postun): /usr/sbin/userdel
175Requires(pre): /bin/id
176Requires(pre): /usr/bin/getgid
177Requires(pre): /usr/lib/rpm/user_group.sh
178Requires(pre): /usr/sbin/groupadd
179Requires(pre): /usr/sbin/useradd
180Requires(pre): /usr/sbin/usermod
9cb7e099 181Requires: %{name} = %{version}-%{release}
7b27380f 182Requires: rc-scripts
a1bac09d
183Provides: group(svn)
184Provides: user(svn)
b56474ff
AM
185
186%description svnserve
187Subversion svnserve server.
188
aa59005f 189%description svnserve -l pl.UTF-8
b56474ff
AM
190Serwer subversion svnserve.
191
4bbdbbf8
AM
192%package tools
193Summary: Subversion tools and scripts
abe3c421
ER
194Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
195Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 196Group: Applications
4bbdbbf8 197%pyrequires_eq python
7b27380f 198Requires: %{name} = %{version}-%{release}
1271c9bd 199Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
200Requires: python-subversion = %{version}
201
202%description tools
203Subversion tools and scripts.
204
aa59005f
JR
205%description tools -l pl.UTF-8
206Narzędzia oraz skrypty dla subversion.
4bbdbbf8 207
fe5bb6bb 208%package -n bash-completion-subversion
209Summary: bash completion for subversion
abe3c421 210Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 211Group: Applications/Shells
e30588c4 212Requires: %{name} = %{version}-%{release}
53855fbf 213Requires: bash-completion
e30588c4 214Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 215
216%description -n bash-completion-subversion
217Bash completion for subversion.
218
aa59005f
JR
219%description -n bash-completion-subversion -l pl.UTF-8
220Dopełnienia basha dla subversion.
fe5bb6bb 221
1cc7453a 222%package -n java-subversion
65c1d4bd
JB
223Summary: Subversion Java bindings
224Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 225Group: Development/Languages/Java
226Requires: %{name}-libs = %{version}-%{release}
227
228%description -n java-subversion
229This is a set of Java classes which provide the functionality of
230subversion-libs, the Subversion libraries. It is useful if you want
231to, for example, write a Java class that manipulates a Subversion
232repository or working copy. See the 'subversion' package for more
233information.
234
65c1d4bd
JB
235%description -n java-subversion -l pl.UTF-8
236Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
237subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
238pisaniu klas Javy np. modyfikujących repozytorium Subversion lub
239kopię roboczą. Więcej informacji w pakiecie subversion.
240
fa3ff1b2 241%package -n python-subversion
65c1d4bd
JB
242Summary: Subversion Python bindings
243Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
244Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 245Group: Development/Languages/Python
f4e6a380 246%pyrequires_eq python
9cb7e099 247Requires: %{name}-libs = %{version}-%{release}
53855fbf 248Obsoletes: subversion-python
f4e6a380 249
fa3ff1b2 250%description -n python-subversion
65c1d4bd 251Subversion Python bindings.
f4e6a380 252
aa59005f 253%description -n python-subversion -l pl.UTF-8
65c1d4bd 254Dowiązania do Subversion dla Pythona.
f4e6a380 255
aa59005f 256%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 257Módulos Python para acessar os recursos do Subversion.
92066deb 258
b56474ff 259%package -n perl-subversion
65c1d4bd
JB
260Summary: Subversion Perl bindings
261Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
262Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 263Group: Development/Languages/Perl
9cb7e099 264Requires: %{name}-libs = %{version}-%{release}
53855fbf 265Obsoletes: subversion-perl
b56474ff
AM
266
267%description -n perl-subversion
65c1d4bd 268Subversion Perl bindings.
b56474ff 269
aa59005f 270%description -n perl-subversion -l pl.UTF-8
65c1d4bd 271Dowiązania do Subversion dla Perla.
b56474ff 272
aa59005f 273%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 274Módulos Perl para acessar os recursos do Subversion.
b56474ff 275
93b78127
AM
276%package -n apache-mod_dav_svn
277Summary: Apache module: Subversion Server
abe3c421 278Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 279Group: Networking/Daemons
7b27380f 280Requires: %{name} = %{version}-%{release}
53855fbf 281Requires: apache(modules-api) = %apache_modules_api
7887b1ac 282Requires: apache-mod_dav
93b78127
AM
283
284%description -n apache-mod_dav_svn
285Apache module: Subversion Server.
286
aa59005f
JR
287%description -n apache-mod_dav_svn -l pl.UTF-8
288Moduł apache: Serwer Subversion.
93b78127 289
65318afa
AF
290%package -n apache-mod_authz_svn
291Summary: Apache module: Subversion Server - path-based authorization
abe3c421 292Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 293Group: Networking/Daemons
53855fbf 294Requires: apache(modules-api) = %apache_modules_api
9cb7e099 295Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
296
297%description -n apache-mod_authz_svn
298Apache module: Subversion Server - path-based authorization.
299
aa59005f
JR
300%description -n apache-mod_authz_svn -l pl.UTF-8
301Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 302
93b78127 303%prep
12ae68c1 304%setup -q -n %{name}-%{version}-%{snap}
e30588c4 305rm -rf apr apr-util neon
ed6210a2 306%patch0 -p0
d4bccc60 307%patch1 -p1
027f8ebe 308
93b78127 309%build
93f1d402 310rm subversion/bindings/swig/proxy/*.swg
24406120 311cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 312cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 313chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 314
fa3ff1b2 315# don't enable dso - currently it's broken
93b78127 316%configure \
5dfeafd7 317 --with-editor=vi \
12ae68c1 318 --with-zlib=%{_libdir} \
93f1d402 319 --with-python=%{__python} \
320 --with-perl5=%{__perl} \
536b3fd3
AM
321%if %{with net_client_only}
322 --without-apache \
323 --without-swig \
324 --without-apxs \
325 --without-berkeley-db \
326%else
227d7ab4 327 --disable-dso \
86ee97d3 328 --disable-mod-activation \
0905b458 329%if %{with apache}
536b3fd3 330 --with-apxs=%{_sbindir}/apxs \
0905b458 331%else
332 --without-apache \
333 --without-apxs \
536b3fd3 334 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 335%endif
cf353d53 336%if !%{with python} && !%{with perl}
0905b458 337 --without-swig \
338%endif
1cc7453a 339 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 340%endif
1cc7453a 341 --with-jdk="%{java_home}" \
e30588c4 342 --with-neon=%{_prefix} \
78f330c4 343 --disable-neon-version-check \
16429189 344 --with-apr=%{_bindir}/apr-1-config \
345 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 346
1f630180 347%{__make} -j1
536b3fd3 348
cf353d53 349%if !%{with net_client_only}
b56474ff 350# python
0905b458 351%if %{with python}
86a4919e 352%{__make} swig-py \
65318afa
AF
353 swig_pydir=%{py_sitedir}/libsvn \
354 swig_pydir_extra=%{py_sitedir}/svn
0905b458 355%endif
b56474ff 356# perl
0905b458 357%if %{with perl}
bf539998
AM
358%{__make} swig-pl-lib
359odir=$(pwd)
360cd subversion/bindings/swig/perl/native
361%{__perl} Makefile.PL INSTALLDIRS=vendor
362%{__make}
363cd $odir
536b3fd3 364%endif
1cc7453a 365%if %{with javahl}
366%{__make} javahl \
367 javahl_javadir="%{_javadir}"
368%endif
12ae68c1
AM
369%endif
370
371%if %{with tests}
372%{__make} check
0905b458 373%endif
93b78127
AM
374
375%install
376rm -rf $RPM_BUILD_ROOT
1326bb99 377install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 378 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 379 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 380 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 381
1f630180 382%{__make} install -j1 \
1cc7453a 383%if %{with javahl}
384 install-javahl \
385 javahl_javadir="%{_javadir}" \
386%endif
cf353d53 387%if !%{with net_client_only} && %{with python}
0905b458 388 install-swig-py \
389%endif
f2a757d6 390 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 391 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
392 swig_pydir=%{py_sitedir}/libsvn \
393 swig_pydir_extra=%{py_sitedir}/svn
93b78127 394
cf353d53 395%if !%{with net_client_only} && %{with perl}
bf539998
AM
396%{__make} install-swig-pl-lib \
397 DESTDIR=$RPM_BUILD_ROOT
398odir=$(pwd)
399cd subversion/bindings/swig/perl/native
400%{__make} install \
401 DESTDIR=$RPM_BUILD_ROOT \
402 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
403 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
404cd $odir
405%endif
406
0905b458 407%if %{with apache}
1af5e34d
ER
408install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
409install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
410install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
411install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 412%endif
93b78127 413
cf353d53 414%if !%{with net_client_only}
1326bb99 415install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 416%if %{with python}
f4e6a380
AM
417%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
418%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
419find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
420install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 421%endif
0905b458 422%endif
f4e6a380 423
1326bb99
JK
424install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
425install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 426
205a3ddc
AM
427%find_lang %{name}
428
a6ecf312 429rm -f $RPM_BUILD_ROOT%{_libdir}/lib*swig*.la
430
e23909be
JB
431%clean
432rm -rf $RPM_BUILD_ROOT
433
a1bac09d
434%pre svnserve
435%groupadd -g 86 svn
436%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
437
6f99c3bd
ER
438%post devel -p /sbin/postshell
439-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 440
6f99c3bd
ER
441%postun devel -p /sbin/postshell
442-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 443
e23909be
JB
444%post libs -p /sbin/ldconfig
445%postun libs -p /sbin/ldconfig
164f681b
AM
446%post -n python-subversion -p /sbin/ldconfig
447%postun -n perl-subversion -p /sbin/ldconfig
f4e6a380 448
b56474ff 449%post svnserve
e8d9186f
ER
450/sbin/chkconfig --add svnserve
451%service svnserve restart "svnserve daemon"
452
b56474ff
AM
453%preun svnserve
454if [ "$1" = "0" ]; then
e8d9186f
ER
455 %service svnserve stop
456 /sbin/chkconfig --del svnserve
b56474ff
AM
457fi
458
a1bac09d
459%postun svnserve
460if [ "$1" = "0" ]; then
461 %userremove svn
462 %groupremove svn
463fi
464
93b78127 465%post -n apache-mod_dav_svn
e8d9186f 466%service -q httpd restart
93b78127
AM
467
468%preun -n apache-mod_dav_svn
469if [ "$1" = "0" ]; then
e8d9186f 470 %service -q httpd restart
93b78127
AM
471fi
472
93b78127
AM
473%files
474%defattr(644,root,root,755)
983a49f6 475%doc BUGS CHANGES COPYING INSTALL README
d37298dc 476%doc doc/*/*.html
4bbdbbf8
AM
477%doc tools/hook-scripts/*.{pl,py,example}
478%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 479%doc tools/xslt/*
fa3ff1b2 480%attr(755,root,root) %{_bindir}/svn*
b56474ff 481%exclude %{_bindir}/svnserve
cf353d53 482%if !%{with net_client_only}
9cb7e099 483%exclude %{_bindir}/svn-hot-backup
d62de3c9 484%endif
f4e6a380 485%{_mandir}/man1/*
af654ba5
AM
486%{_mandir}/man5/*
487%{_mandir}/man8/*
b56474ff 488%exclude %{_mandir}/man?/svnserve*
f4e6a380 489
205a3ddc 490%files libs -f %{name}.lang
f4e6a380 491%defattr(644,root,root,755)
227d7ab4 492%attr(755,root,root) %{_libdir}/lib*.so.*
164f681b
AM
493%if %{with perl} || %{with python}
494%exclude %{_libdir}/lib*_swig_*.so.*
495%endif
1cc7453a 496%if %{with javahl}
497%exclude %{_libdir}/libsvnjavahl*.so.*.*.*
498%exclude %{_libdir}/libsvnjavahl*.so.?
499%exclude %{_libdir}/libsvnjavahl*.so
500%endif
93b78127
AM
501
502%files devel
503%defattr(644,root,root,755)
227d7ab4
AM
504%{_includedir}/%{name}*
505%attr(755,root,root) %{_libdir}/lib*.so
b2bcb22a 506%{_libdir}/lib*.la
b72a2fbb 507%if %{with perl} || %{with python}
c00fdf6f 508%exclude %{_libdir}/lib*_swig_*.so
b72a2fbb 509%endif
1cc7453a 510%if %{with javahl}
511%exclude %{_libdir}/libsvnjavahl*.so
512%endif
1326bb99 513%{_examplesdir}/%{name}-%{version}
93b78127
AM
514
515%files static
516%defattr(644,root,root,755)
517%{_libdir}/lib*.a
518
cf353d53 519%if !%{with net_client_only}
b56474ff
AM
520%files svnserve
521%defattr(644,root,root,755)
522%attr(755,root,root) %{_bindir}/svnserve
523%{_mandir}/man?/svnserve*
a1bac09d
524%dir %attr(750,svn,svn) /home/services/subversion
525%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 526%if %{with apache}
b56474ff 527%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 528%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 529%endif
b56474ff 530
4bbdbbf8
AM
531%files tools
532%defattr(644,root,root,755)
1326bb99 533%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 534
535%files -n bash-completion-subversion
101e74de 536%defattr(644,root,root,755)
1326bb99 537/etc/bash_completion.d/%{name}
536b3fd3 538
1cc7453a 539%if %{with javahl}
540%files -n java-subversion
541%defattr(644,root,root,755)
542%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.*.*.*
543%attr(755,root,root) %{_libdir}/libsvnjavahl*.so.?
544%attr(755,root,root) %{_libdir}/libsvnjavahl*.so
545%{_javadir}/svn-javahl.jar
546%endif
547
0905b458 548%if %{with python}
fa3ff1b2 549%files -n python-subversion
f4e6a380 550%defattr(644,root,root,755)
4bbdbbf8 551%doc tools/backup/*.py tools/examples/*.py
f4e6a380 552%dir %{py_sitedir}/svn
65318afa 553%dir %{py_sitedir}/libsvn
f4e6a380 554%{py_sitedir}/svn/*.py[co]
65318afa
AF
555%{py_sitedir}/libsvn/*.py[co]
556%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 557%{_examplesdir}/python-%{name}-%{version}
c00fdf6f 558%attr(755,root,root) %{_libdir}/lib*_swig_py*.so*
0905b458 559%endif
f4e6a380 560
0905b458 561%if %{with perl}
b56474ff
AM
562%files -n perl-subversion
563%defattr(644,root,root,755)
564%{perl_vendorarch}/SVN
565%dir %{perl_vendorarch}/auto/SVN
566%dir %{perl_vendorarch}/auto/SVN/*
567%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
568%{perl_vendorarch}/auto/SVN/*/*.bs
569%{_mandir}/man3/*.3pm*
c00fdf6f 570%attr(755,root,root) %{_libdir}/lib*_swig_perl*.so*
0905b458 571%endif
b56474ff 572
0905b458 573%if %{with apache}
93b78127
AM
574%files -n apache-mod_dav_svn
575%defattr(644,root,root,755)
1af5e34d
ER
576%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
577%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
578
579%files -n apache-mod_authz_svn
580%defattr(644,root,root,755)
581%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
582%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
583%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 584%endif
7b27380f
ER
585
586%endif # net_client_only
This page took 0.232071 seconds and 4 git commands to generate.