]> git.pld-linux.org Git - packages/subversion.git/blame - subversion.spec
- formatting
[packages/subversion.git] / subversion.spec
CommitLineData
1f630180 1# TODO:
1930bef0 2# - remove net_client_only and add db bcond (then without apache and
3# without db => net_client_only - spec will be more simpler, I think)
d46e45ba 4# - finish ruby
1930bef0 5#
bab73684 6# Conditional build:
65c1d4bd
JB
7%bcond_with net_client_only # build only net client
8%bcond_without python # build without python bindings (broken)
9%bcond_without perl # build without perl bindings
73ab938a 10%bcond_without ruby # build without ruby bindings
65c1d4bd
JB
11%bcond_without apache # build without apache support (webdav, etc)
12%bcond_without javahl # build without javahl support (Java high-level bindings)
13%bcond_without tests # don't perform "make check"
7b27380f 14#
bc126282 15%ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
c2f5643d 16%undefine with_javahl
bc126282
AG
17%endif
18#
b56474ff 19%{!?with_net_client_only:%include /usr/lib/rpm/macros.perl}
f4070f5f 20%define apxs /usr/sbin/apxs
1f630180
ER
21%define pdir SVN
22%define pnam _Core
12ae68c1 23#
67cb9518 24Summary: A Concurrent Versioning system similar to but better than CVS
abe3c421
ER
25Summary(pl.UTF-8): System kontroli wersji podobny, ale lepszy, niż CVS
26Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127 27Name: subversion
62e481b4
AM
28Version: 1.5.1
29Release: 1
6f88d80e 30License: Apache/BSD-like
93b78127 31Group: Development/Version Control
af7b0bac 32Source0: http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
62e481b4 33# Source0-md5: 8dbdaa625d6b18887702885df07fc87e
93b78127 34Source1: %{name}-dav_svn.conf
65318afa 35Source2: %{name}-authz_svn.conf
b56474ff
AM
36Source3: %{name}-svnserve.init
37Source4: %{name}-svnserve.sysconfig
f313e9a9 38Source5: %{name}-convert-typemaps-to-ifdef.py
ed6210a2 39Patch0: %{name}-home_etc.patch
d46e45ba 40Patch1: %{name}-DESTDIR.patch
00664663 41Patch2: %{name}-ruby-datadir-path.patch
d2bf70bf 42URL: http://subversion.tigris.org/
4945947e
AM
43%if %{with net_client_only}
44%global apache_modules_api 0
45%else
f2a757d6 46%{?with_apache:BuildRequires: apache-devel >= 2.2.0-8}
7b27380f 47BuildRequires: automake
3817faf5 48BuildRequires: db-devel >= 4.1.25
e8d9186f 49BuildRequires: rpmbuild(macros) >= 1.268
0905b458 50%if %{with perl}
522a69b4 51BuildRequires: perl-devel >= 1:5.8.0
52BuildRequires: rpm-perlprov >= 4.1-13
15f9818d 53BuildRequires: swig-perl >= 1.3.24
536b3fd3 54%endif
1cc7453a 55%{?with_javahl:BuildRequires: jdk}
0905b458 56%endif
16429189 57BuildRequires: apr-devel >= 1:1.0.0
a6ecf312 58BuildRequires: apr-util-devel >= 1:1.2.8-3
b0a7a5b2 59BuildRequires: autoconf >= 2.59
79d8c53c 60BuildRequires: bison
12ae68c1 61BuildRequires: cyrus-sasl-devel
93b78127 62BuildRequires: expat-devel
86ea8fde 63BuildRequires: gettext-devel
f4e6a380 64BuildRequires: libtool >= 1.4-9
bd3c99a8 65BuildRequires: neon-devel >= 0.26.0
53855fbf 66BuildRequires: python >= 2.2
ed6210a2 67BuildRequires: python-modules >= 2.2
f313e9a9 68%if %{with python}
69BuildRequires: python-devel >= 2.2
1f16145f 70BuildRequires: sed >= 4.0
15f9818d 71BuildRequires: swig-python >= 1.3.24
0905b458 72%endif
0baf7ef5 73%{?with_ruby:BuildRequires: ruby-devel}
73ab938a 74%{?with_ruby:BuildRequires: swig-ruby >= 1.3.24}
93b78127 75BuildRequires: texinfo
7b35d179 76BuildRequires: which
027f8ebe 77Requires: %{name}-libs = %{version}-%{release}
93b78127
AM
78BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
f4070f5f 80%define _libexecdir %{_libdir}/svn
1af5e34d
ER
81%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
82%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
93b78127
AM
83
84%description
85The goal of the Subversion project is to build a version control
86system that is a compelling replacement for CVS in the open source
87community.
88
89Our goals are:
90- All current CVS features.
91- Directories, renames, and file meta-data are versioned.
92- Symbolic links, etc, are supported
93- Commits are truly atomic.
94- Branching and tagging are cheap (constant time) operations
95- Repeated merges are handled gracefully
96- Support for plug-in client side diff programs
97- Natively client/server
98- Client/server protocol sends diffs in both directions
99- Costs are proportional to change size, not project size
100- Internationalization
101- Progressive multi-lingual support
102
aa59005f 103%description -l pl.UTF-8
93b78127
AM
104Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
105zamiennika dla CVS.
106
107Cele projektu to:
aa59005f 108- Wszystkie aktualne możliwości CVS.
24406120
JB
109- Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
110- Obsługa dowiązań symbolicznych itp.
aa59005f
JR
111- Commity są w pełni atomowe.
112- Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
24406120
JB
113- Dobra obsługa powtarzanego łączenia (merge).
114- Obsługa wtyczek diff po stronie klienta.
93b78127 115- Natywny klient/serwer.
aa59005f 116- Klient/Serwer przesyłają diffy w obu kierunkach.
93b78127
AM
117- Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
118- Internacjonalizacja.
aa59005f 119- Postępujące wsparcie dla wielu języków.
93b78127 120
aa59005f
JR
121%description -l pt_BR.UTF-8
122O objetivo do projeto Subversion é construir um sistema de controle de
123versões que seja um substituto para o CVS (Concurrent Versioning
92066deb 124System) na comunidade opensource, fornecendo grandes melhorias.
125
f4e6a380
AM
126%package libs
127Summary: Subversion libraries and modules
abe3c421 128Summary(pl.UTF-8): Biblioteka subversion oraz ładowalne moduły
f4e6a380 129Group: Libraries
24406120 130Requires: neon >= 0.26.0
53855fbf 131Obsoletes: libsubversion0
f4e6a380
AM
132
133%description libs
134Subversion libraries and modules.
135
aa59005f
JR
136%description libs -l pl.UTF-8
137Biblioteka subversion oraz ładowalne moduły.
f4e6a380 138
93b78127
AM
139%package devel
140Summary: Header files and develpment documentation for subversion
abe3c421
ER
141Summary(pl.UTF-8): Pliki nagłówkowe i dokumetacja do subversion
142Summary(pt_BR.UTF-8): Arquivos de desenvolvimento para o Subversion
93b78127 143Group: Development/Libraries
9cb7e099 144Requires: %{name}-libs = %{version}-%{release}
c5b1d686 145Requires: apr-util-devel >= 1:1.0.0
24406120 146Requires: neon-devel >= 0.26.0
12cf252c 147Obsoletes: libsubversion0-devel
93b78127
AM
148
149%description devel
150Header files and develpment documentation for subversion.
151
aa59005f
JR
152%description devel -l pl.UTF-8
153Pliki nagłówkowe i dokumetacja do subversion.
93b78127 154
aa59005f
JR
155%description devel -l pt_BR.UTF-8
156Este pacote provê os arquivos necessários para desenvolvedores
92066deb 157interagirem com o Subversion.
158
93b78127
AM
159%package static
160Summary: Static subversion library
abe3c421
ER
161Summary(pl.UTF-8): Biblioteka statyczna subversion
162Summary(pt_BR.UTF-8): Sistema de versionamento concorrente
93b78127
AM
163Group: Development/Libraries
164Requires: %{name}-devel = %{version}
12cf252c 165Obsoletes: libsubversion0-static-devel
93b78127
AM
166
167%description static
168Static subversion library.
169
aa59005f 170%description static -l pl.UTF-8
93b78127
AM
171Biblioteka statyczna subversion.
172
aa59005f
JR
173%description static -l pt_BR.UTF-8
174Este pacote provê um cliente estático do subversion.
92066deb 175
b56474ff
AM
176%package svnserve
177Summary: Subversion svnserve
abe3c421 178Summary(pl.UTF-8): Subversion svnserve
b56474ff 179Group: Networking/Daemons
3817faf5 180Requires(post,preun): /sbin/chkconfig
93f1d402 181Requires(postun): /usr/sbin/groupdel
182Requires(postun): /usr/sbin/userdel
183Requires(pre): /bin/id
184Requires(pre): /usr/bin/getgid
185Requires(pre): /usr/lib/rpm/user_group.sh
186Requires(pre): /usr/sbin/groupadd
187Requires(pre): /usr/sbin/useradd
188Requires(pre): /usr/sbin/usermod
9cb7e099 189Requires: %{name} = %{version}-%{release}
7b27380f 190Requires: rc-scripts
a1bac09d
191Provides: group(svn)
192Provides: user(svn)
b56474ff
AM
193
194%description svnserve
195Subversion svnserve server.
196
aa59005f 197%description svnserve -l pl.UTF-8
b56474ff
AM
198Serwer subversion svnserve.
199
4bbdbbf8
AM
200%package tools
201Summary: Subversion tools and scripts
abe3c421
ER
202Summary(pl.UTF-8): Narzędzia oraz skrypty dla subversion
203Summary(pt_BR.UTF-8): Módulos python para acessar os recursos do Subversion
4bbdbbf8 204Group: Applications
4bbdbbf8 205%pyrequires_eq python
7b27380f 206Requires: %{name} = %{version}-%{release}
1271c9bd 207Requires: python-rcsparse >= 0.1-0.20031026.0
4bbdbbf8
AM
208Requires: python-subversion = %{version}
209
210%description tools
211Subversion tools and scripts.
212
aa59005f
JR
213%description tools -l pl.UTF-8
214Narzędzia oraz skrypty dla subversion.
4bbdbbf8 215
fe5bb6bb 216%package -n bash-completion-subversion
217Summary: bash completion for subversion
abe3c421 218Summary(pl.UTF-8): Dopełnienia basha dla subversion
fe5bb6bb 219Group: Applications/Shells
e30588c4 220Requires: %{name} = %{version}-%{release}
53855fbf 221Requires: bash-completion
e30588c4 222Conflicts: %{name}-tools <= 1.1.0-0.rc6.1
fe5bb6bb 223
224%description -n bash-completion-subversion
225Bash completion for subversion.
226
aa59005f
JR
227%description -n bash-completion-subversion -l pl.UTF-8
228Dopełnienia basha dla subversion.
fe5bb6bb 229
1cc7453a 230%package -n java-subversion
65c1d4bd
JB
231Summary: Subversion Java bindings
232Summary(pl.UTF-8): Dowiązania do Subversion dla Javy
1cc7453a 233Group: Development/Languages/Java
234Requires: %{name}-libs = %{version}-%{release}
235
236%description -n java-subversion
237This is a set of Java classes which provide the functionality of
238subversion-libs, the Subversion libraries. It is useful if you want
239to, for example, write a Java class that manipulates a Subversion
240repository or working copy. See the 'subversion' package for more
241information.
242
65c1d4bd
JB
243%description -n java-subversion -l pl.UTF-8
244Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
245subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
d46e45ba
AM
246pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
247roboczą. Więcej informacji w pakiecie subversion.
65c1d4bd 248
fa3ff1b2 249%package -n python-subversion
65c1d4bd
JB
250Summary: Subversion Python bindings
251Summary(pl.UTF-8): Dowiązania do Subversion dla Pythona
252Summary(pt_BR.UTF-8): Módulos Python para acessar os recursos do Subversion
f4e6a380 253Group: Development/Languages/Python
f4e6a380 254%pyrequires_eq python
9cb7e099 255Requires: %{name}-libs = %{version}-%{release}
53855fbf 256Obsoletes: subversion-python
f4e6a380 257
fa3ff1b2 258%description -n python-subversion
65c1d4bd 259Subversion Python bindings.
f4e6a380 260
aa59005f 261%description -n python-subversion -l pl.UTF-8
65c1d4bd 262Dowiązania do Subversion dla Pythona.
f4e6a380 263
aa59005f 264%description -n python-subversion -l pt_BR.UTF-8
65c1d4bd 265Módulos Python para acessar os recursos do Subversion.
92066deb 266
b56474ff 267%package -n perl-subversion
65c1d4bd
JB
268Summary: Subversion Perl bindings
269Summary(pl.UTF-8): Dowiązania do Subversion dla Perla
270Summary(pt_BR.UTF-8): Módulos Perl para acessar os recursos do Subversion
b56474ff 271Group: Development/Languages/Perl
9cb7e099 272Requires: %{name}-libs = %{version}-%{release}
53855fbf 273Obsoletes: subversion-perl
b56474ff
AM
274
275%description -n perl-subversion
65c1d4bd 276Subversion Perl bindings.
b56474ff 277
aa59005f 278%description -n perl-subversion -l pl.UTF-8
65c1d4bd 279Dowiązania do Subversion dla Perla.
b56474ff 280
aa59005f 281%description -n perl-subversion -l pt_BR.UTF-8
65c1d4bd 282Módulos Perl para acessar os recursos do Subversion.
b56474ff 283
d46e45ba
AM
284%package -n ruby-subversion
285Summary: Subversion Ruby bindings
d2bf70bf 286Summary(pl.UTF-8): Dowiązania do Subversion dla języka Ruby
d46e45ba
AM
287Summary(pt_BR.UTF-8): Módulos Ruby para acessar os recursos do Subversion
288Group: Development/Languages
289Requires: %{name}-libs = %{version}-%{release}
290Obsoletes: subversion-ruby
291
292%description -n ruby-subversion
293Subversion Ruby bindings.
294
295%description -n ruby-subversion -l pl.UTF-8
d2bf70bf 296Dowiązania do Subversion dla języka Ruby.
d46e45ba
AM
297
298%description -n ruby-subversion -l pt_BR.UTF-8
299Módulos Ruby para acessar os recursos do Subversion.
300
93b78127
AM
301%package -n apache-mod_dav_svn
302Summary: Apache module: Subversion Server
abe3c421 303Summary(pl.UTF-8): Moduł apache: Serwer Subversion
93b78127 304Group: Networking/Daemons
7b27380f 305Requires: %{name} = %{version}-%{release}
53855fbf 306Requires: apache(modules-api) = %apache_modules_api
7887b1ac 307Requires: apache-mod_dav
93b78127
AM
308
309%description -n apache-mod_dav_svn
310Apache module: Subversion Server.
311
aa59005f
JR
312%description -n apache-mod_dav_svn -l pl.UTF-8
313Moduł apache: Serwer Subversion.
93b78127 314
65318afa
AF
315%package -n apache-mod_authz_svn
316Summary: Apache module: Subversion Server - path-based authorization
abe3c421 317Summary(pl.UTF-8): Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
65318afa 318Group: Networking/Daemons
53855fbf 319Requires: apache(modules-api) = %apache_modules_api
9cb7e099 320Requires: apache-mod_dav_svn = %{version}-%{release}
65318afa
AF
321
322%description -n apache-mod_authz_svn
323Apache module: Subversion Server - path-based authorization.
324
aa59005f
JR
325%description -n apache-mod_authz_svn -l pl.UTF-8
326Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
e23909be 327
93b78127 328%prep
af7b0bac 329%setup -q
e30588c4 330rm -rf apr apr-util neon
ed6210a2 331%patch0 -p0
d4bccc60 332%patch1 -p1
00664663 333%patch2 -p0
027f8ebe 334
93b78127 335%build
93f1d402 336rm subversion/bindings/swig/proxy/*.swg
24406120 337cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
a7bcb345 338cp -f /usr/share/automake/config.sub ac-helpers
67cb9518 339chmod +x ./autogen.sh && ./autogen.sh
8a3d9172 340
93b78127 341%configure \
5dfeafd7 342 --with-editor=vi \
12ae68c1 343 --with-zlib=%{_libdir} \
536b3fd3
AM
344%if %{with net_client_only}
345 --without-apache \
346 --without-swig \
347 --without-apxs \
348 --without-berkeley-db \
349%else
fa6fa2cf 350 --disable-runtime-module-search \
86ee97d3 351 --disable-mod-activation \
0905b458 352%if %{with apache}
536b3fd3 353 --with-apxs=%{_sbindir}/apxs \
0905b458 354%else
355 --without-apache \
356 --without-apxs \
536b3fd3 357 --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
0905b458 358%endif
73ab938a 359%if !%{with python} && !%{with perl} && !%{with ruby}
0905b458 360 --without-swig \
361%endif
1cc7453a 362 --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
536b3fd3 363%endif
1cc7453a 364 --with-jdk="%{java_home}" \
e30588c4 365 --with-neon=%{_prefix} \
78f330c4 366 --disable-neon-version-check \
16429189 367 --with-apr=%{_bindir}/apr-1-config \
368 --with-apr-util=%{_bindir}/apu-1-config
536b3fd3 369
1f630180 370%{__make} -j1
536b3fd3 371
cf353d53 372%if !%{with net_client_only}
b56474ff 373# python
0905b458 374%if %{with python}
86a4919e 375%{__make} swig-py \
65318afa
AF
376 swig_pydir=%{py_sitedir}/libsvn \
377 swig_pydir_extra=%{py_sitedir}/svn
0905b458 378%endif
b56474ff 379# perl
0905b458 380%if %{with perl}
bf539998
AM
381%{__make} swig-pl-lib
382odir=$(pwd)
383cd subversion/bindings/swig/perl/native
384%{__perl} Makefile.PL INSTALLDIRS=vendor
b445847c 385%{__make} -j1
bf539998 386cd $odir
536b3fd3 387%endif
1cc7453a 388%if %{with javahl}
b445847c 389%{__make} -j1 javahl \
1cc7453a 390 javahl_javadir="%{_javadir}"
391%endif
d46e45ba
AM
392# ruby
393%if %{with ruby}
394%{__make} swig-rb
395%endif
12ae68c1
AM
396%endif
397
398%if %{with tests}
399%{__make} check
d46e45ba
AM
400%if %{with python}
401%{__make} check-swig-py
402%endif
403%if %{with perl}
404%{__make} check-swig-pl
405%endif
406%if %{with ruby}
407%{__make} check-swig-rb
408%endif
0905b458 409%endif
93b78127
AM
410
411%install
412rm -rf $RPM_BUILD_ROOT
1326bb99 413install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
1af5e34d 414 $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
afb35189 415 $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
a54611db 416 $RPM_BUILD_ROOT/home/services/subversion{,/repos}
93b78127 417
1f630180 418%{__make} install -j1 \
1cc7453a 419%if %{with javahl}
420 install-javahl \
421 javahl_javadir="%{_javadir}" \
422%endif
d46e45ba
AM
423%if !%{with net_client_only}
424%if %{with python}
0905b458 425 install-swig-py \
d46e45ba
AM
426%endif
427%if %{with ruby}
428 install-swig-rb install-swig-rb-doc \
429%endif
0905b458 430%endif
f2a757d6 431 APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
86a4919e 432 DESTDIR=$RPM_BUILD_ROOT \
65318afa
AF
433 swig_pydir=%{py_sitedir}/libsvn \
434 swig_pydir_extra=%{py_sitedir}/svn
93b78127 435
cf353d53 436%if !%{with net_client_only} && %{with perl}
bf539998
AM
437%{__make} install-swig-pl-lib \
438 DESTDIR=$RPM_BUILD_ROOT
b445847c 439%{__make} -C subversion/bindings/swig/perl/native install \
bf539998
AM
440 DESTDIR=$RPM_BUILD_ROOT \
441 PREFIX=$RPM_BUILD_ROOT%{_prefix} \
442 LIBDIR=$RPM_BUILD_ROOT%{_libdir}
bf539998
AM
443%endif
444
0905b458 445%if %{with apache}
1af5e34d
ER
446install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
447install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
b56474ff
AM
448install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
449install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
0905b458 450%endif
93b78127 451
cf353d53 452%if !%{with net_client_only}
1326bb99 453install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
0905b458 454%if %{with python}
f4e6a380
AM
455%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
456%py_comp $RPM_BUILD_ROOT%{py_sitedir}
1326bb99
JK
457find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
458install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
536b3fd3 459%endif
0905b458 460%endif
f4e6a380 461
1326bb99
JK
462install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
463install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
1326bb99 464
205a3ddc
AM
465%find_lang %{name}
466
b445847c
JB
467rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn{javahl,_swig}*.{la,a}
468rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/svn/ext/*.la
a6ecf312 469
e23909be
JB
470%clean
471rm -rf $RPM_BUILD_ROOT
472
a1bac09d
473%pre svnserve
474%groupadd -g 86 svn
475%useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
476
d2bf70bf
JB
477%post libs -p /sbin/ldconfig
478%postun libs -p /sbin/ldconfig
479
480%post devel -p /sbin/postshell
6f99c3bd 481-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 482
d2bf70bf 483%postun devel -p /sbin/postshell
6f99c3bd 484-/usr/sbin/fix-info-dir -c %{_infodir}
93b78127 485
d2bf70bf
JB
486%post -n perl-subversion -p /sbin/ldconfig
487%postun -n perl-subversion -p /sbin/ldconfig
488
489%post -n python-subversion -p /sbin/ldconfig
490%postun -n python-subversion -p /sbin/ldconfig
f4e6a380 491
b56474ff 492%post svnserve
e8d9186f
ER
493/sbin/chkconfig --add svnserve
494%service svnserve restart "svnserve daemon"
495
b56474ff
AM
496%preun svnserve
497if [ "$1" = "0" ]; then
e8d9186f
ER
498 %service svnserve stop
499 /sbin/chkconfig --del svnserve
b56474ff
AM
500fi
501
a1bac09d
502%postun svnserve
503if [ "$1" = "0" ]; then
504 %userremove svn
505 %groupremove svn
506fi
507
93b78127 508%post -n apache-mod_dav_svn
e8d9186f 509%service -q httpd restart
93b78127
AM
510
511%preun -n apache-mod_dav_svn
512if [ "$1" = "0" ]; then
e8d9186f 513 %service -q httpd restart
93b78127
AM
514fi
515
93b78127
AM
516%files
517%defattr(644,root,root,755)
983a49f6 518%doc BUGS CHANGES COPYING INSTALL README
d37298dc 519%doc doc/*/*.html
4bbdbbf8
AM
520%doc tools/hook-scripts/*.{pl,py,example}
521%doc tools/hook-scripts/mailer/*.{py,example}
1326bb99 522%doc tools/xslt/*
b445847c
JB
523%attr(755,root,root) %{_bindir}/svn
524%attr(755,root,root) %{_bindir}/svnadmin
525%attr(755,root,root) %{_bindir}/svndumpfilter
526%attr(755,root,root) %{_bindir}/svnlook
527%attr(755,root,root) %{_bindir}/svnsync
528%attr(755,root,root) %{_bindir}/svnversion
529%{_mandir}/man1/svn.1*
530%{_mandir}/man1/svnadmin.1*
531%{_mandir}/man1/svndumpfilter.1*
532%{_mandir}/man1/svnlook.1*
533%{_mandir}/man1/svnsync.1*
534%{_mandir}/man1/svnversion.1*
f4e6a380 535
205a3ddc 536%files libs -f %{name}.lang
f4e6a380 537%defattr(644,root,root,755)
b445847c
JB
538%attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
539%attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
540%attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
541%attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
542%attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
543%attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
544%attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
545%attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
546%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
547%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
548%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
549%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
550%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
551%attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
552%attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
553%attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
554%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
555%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
556%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so.*.*.*
557%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_neon-1.so.0
558%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
559%attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
560%attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
561%attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
562%attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
563%attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
564%attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
565%attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
93b78127
AM
566
567%files devel
568%defattr(644,root,root,755)
b445847c
JB
569%attr(755,root,root) %{_libdir}/libsvn_client-1.so
570%attr(755,root,root) %{_libdir}/libsvn_delta-1.so
571%attr(755,root,root) %{_libdir}/libsvn_diff-1.so
572%attr(755,root,root) %{_libdir}/libsvn_fs-1.so
573%attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
574%attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
575%attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
576%attr(755,root,root) %{_libdir}/libsvn_ra-1.so
577%attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
578%attr(755,root,root) %{_libdir}/libsvn_ra_neon-1.so
579%attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
580%attr(755,root,root) %{_libdir}/libsvn_repos-1.so
581%attr(755,root,root) %{_libdir}/libsvn_subr-1.so
582%attr(755,root,root) %{_libdir}/libsvn_wc-1.so
583%{_libdir}/libsvn_client-1.la
584%{_libdir}/libsvn_delta-1.la
585%{_libdir}/libsvn_diff-1.la
586%{_libdir}/libsvn_fs-1.la
587%{_libdir}/libsvn_fs_base-1.la
588%{_libdir}/libsvn_fs_fs-1.la
589%{_libdir}/libsvn_fs_util-1.la
590%{_libdir}/libsvn_ra-1.la
591%{_libdir}/libsvn_ra_local-1.la
592%{_libdir}/libsvn_ra_neon-1.la
593%{_libdir}/libsvn_ra_svn-1.la
594%{_libdir}/libsvn_repos-1.la
595%{_libdir}/libsvn_subr-1.la
596%{_libdir}/libsvn_wc-1.la
597%{_includedir}/%{name}-1
1326bb99 598%{_examplesdir}/%{name}-%{version}
93b78127
AM
599
600%files static
601%defattr(644,root,root,755)
b445847c
JB
602%{_libdir}/libsvn_client-1.a
603%{_libdir}/libsvn_delta-1.a
604%{_libdir}/libsvn_diff-1.a
605%{_libdir}/libsvn_fs-1.a
606%{_libdir}/libsvn_fs_base-1.a
607%{_libdir}/libsvn_fs_fs-1.a
608%{_libdir}/libsvn_fs_util-1.a
609%{_libdir}/libsvn_ra-1.a
610%{_libdir}/libsvn_ra_local-1.a
611%{_libdir}/libsvn_ra_neon-1.a
612%{_libdir}/libsvn_ra_svn-1.a
613%{_libdir}/libsvn_repos-1.a
614%{_libdir}/libsvn_subr-1.a
615%{_libdir}/libsvn_wc-1.a
93b78127 616
cf353d53 617%if !%{with net_client_only}
b56474ff
AM
618%files svnserve
619%defattr(644,root,root,755)
620%attr(755,root,root) %{_bindir}/svnserve
b445847c
JB
621%{_mandir}/man5/svnserve.conf.5*
622%{_mandir}/man8/svnserve.8*
a1bac09d
623%dir %attr(750,svn,svn) /home/services/subversion
624%dir %attr(750,svn,svn) /home/services/subversion/repos
0905b458 625%if %{with apache}
b56474ff 626%attr(754,root,root) /etc/rc.d/init.d/svnserve
86ea8fde 627%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
0905b458 628%endif
b56474ff 629
4bbdbbf8
AM
630%files tools
631%defattr(644,root,root,755)
1326bb99 632%attr(755,root,root) %{_bindir}/svn-hot-backup
fe5bb6bb 633
634%files -n bash-completion-subversion
101e74de 635%defattr(644,root,root,755)
1326bb99 636/etc/bash_completion.d/%{name}
536b3fd3 637
1cc7453a 638%if %{with javahl}
639%files -n java-subversion
640%defattr(644,root,root,755)
b445847c
JB
641%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
642%attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
643%attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
1cc7453a 644%{_javadir}/svn-javahl.jar
645%endif
646
0905b458 647%if %{with python}
fa3ff1b2 648%files -n python-subversion
f4e6a380 649%defattr(644,root,root,755)
4bbdbbf8 650%doc tools/backup/*.py tools/examples/*.py
b445847c
JB
651%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
652%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
653%attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
65318afa 654%dir %{py_sitedir}/libsvn
65318afa 655%{py_sitedir}/libsvn/*.py[co]
b445847c
JB
656%dir %{py_sitedir}/svn
657%{py_sitedir}/svn/*.py[co]
65318afa 658%attr(755,root,root) %{py_sitedir}/libsvn/*.so
1326bb99 659%{_examplesdir}/python-%{name}-%{version}
0905b458 660%endif
f4e6a380 661
0905b458 662%if %{with perl}
b56474ff
AM
663%files -n perl-subversion
664%defattr(644,root,root,755)
b445847c
JB
665%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
666%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
667%attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
b56474ff
AM
668%{perl_vendorarch}/SVN
669%dir %{perl_vendorarch}/auto/SVN
670%dir %{perl_vendorarch}/auto/SVN/*
671%attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
672%{perl_vendorarch}/auto/SVN/*/*.bs
673%{_mandir}/man3/*.3pm*
0905b458 674%endif
b56474ff 675
d46e45ba
AM
676%if %{with ruby}
677%files -n ruby-subversion
678%defattr(644,root,root,755)
b445847c
JB
679%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
680%attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
681%attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
682%dir %{_libdir}/ruby/site_ruby/svn
683%{_libdir}/ruby/site_ruby/svn/*.rb
684%dir %{_libdir}/ruby/site_ruby/svn/ext
685%attr(755,root,root) %{_libdir}/ruby/site_ruby/svn/ext/*.so
ab6adef9 686%{_datadir}/ri/*.*/system/OptionParser
00664663 687%{_datadir}/ri/*.*/system/Svn
688%{_datadir}/ri/*.*/system/Time
689%{_datadir}/ri/*.*/system/Uconv
690%{_datadir}/ri/*.*/system/*.rid
691%{_datadir}/ri/*.*/system/Kernel/*
d46e45ba
AM
692%endif
693
0905b458 694%if %{with apache}
93b78127
AM
695%files -n apache-mod_dav_svn
696%defattr(644,root,root,755)
1af5e34d
ER
697%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
698%attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
65318afa
AF
699
700%files -n apache-mod_authz_svn
701%defattr(644,root,root,755)
702%doc subversion/mod_authz_svn/INSTALL
1af5e34d
ER
703%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
704%attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
536b3fd3 705%endif
7b27380f
ER
706
707%endif # net_client_only
This page took 0.173509 seconds and 4 git commands to generate.